Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 22 Nov 2014, 07:47
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
gparted 0.5.2 with ext4 support
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 2 of 3 Posts_count   Goto page: Previous 1, 2, 3 Next
Author Message
technosaurus


Joined: 18 May 2008
Posts: 4376

PostPosted: Thu 18 Feb 2010, 22:59    Post_subject:  

Thanks DM,
updated with static libdevmapper from latest stable lvm2

here is the complete list of dependencies:
    libatk-1, libc, libcairo, libdl, libexpat, libfontconfig, libfreetype, libgcc_s, libgdk_pixbuf-2, libgdk-x11-2, libgio-2, libglib-2, libgmodule-2, libgobject-2, libgthread-2, libgtk-x11-2, /lib/ld-linux, libm, libpango-1, libpangocairo-1, libpangoft2-1, libpcre, libpixman-1, libpng12, libpthread, libresolv, librt, libsigc-2, libstdc++, libuuid, libX11, libXau, libXcursor, libXdmcp, libXext, libXfixes, libXi, libXinerama, libXrandr, libXrender, libz, linux-gate
gparted-0.5.1-i486.pet
Description 
pet

 Download 
Filename  gparted-0.5.1-i486.pet 
Filesize  634.38 KB 
Downloaded  990 Time(s) 

_________________
Web Programming - Pet Packaging 100 & 101
Back to top
View user's profile Send_private_message 
Dromeno

Joined: 12 Sep 2008
Posts: 538

PostPosted: Fri 19 Feb 2010, 19:09    Post_subject: O.5.1 does not replace the 0.3.3 automatically  

I installed the 0.5.1 in puppy 4.2.1. All seemed to go well but after starting Gparted it was still the 0.3.3 version without ext4 support

So... how do I get rid of the O.3.3 ?
Back to top
View user's profile Send_private_message 
technosaurus


Joined: 18 May 2008
Posts: 4376

PostPosted: Fri 19 Feb 2010, 19:38    Post_subject:  

you can just run /usr/sbin/gpartedbin or /usr/sbin/gparted_shell

- I'm not running 4.2.1 - maybe it is in /usr/bin in 4.2.1 ... you can use pfind

or delete the older gparted*.desktop file in /usr/share/applications and run refreshmenus

_________________
Web Programming - Pet Packaging 100 & 101
Back to top
View user's profile Send_private_message 
Dromeno

Joined: 12 Sep 2008
Posts: 538

PostPosted: Sat 20 Feb 2010, 04:29    Post_subject: Please give me another option  

I think it must be something else. Refreshing the menu's does not help (I still get the 0.3.3 version)

And when I type

/usr/sbin/gpartedbin

in the console I get:


/usr/sbin/gpartedbin: symbol lookup error: /usr/sbin/gpartedbin: undefined symbol: g_file_io_stream_get_type

Do you have any idea what to do next?
Back to top
View user's profile Send_private_message 
technosaurus


Joined: 18 May 2008
Posts: 4376

PostPosted: Sat 20 Feb 2010, 11:19    Post_subject:  

Edit - did some looking & you will need the updated glib pet
glib-2.22.2-i486.pet
Description 
pet

 Download 
Filename  glib-2.22.2-i486.pet 
Filesize  552.84 KB 
Downloaded  1023 Time(s) 

_________________
Web Programming - Pet Packaging 100 & 101
Back to top
View user's profile Send_private_message 
Dromeno

Joined: 12 Sep 2008
Posts: 538

PostPosted: Mon 22 Feb 2010, 05:53    Post_subject: almost there...
Sub_title: (I hope)
 

I have a feeling that I am almost there... but not yet.

I followed your suggestion but if I type /usr/sbin/gpartedbin now I get:

symbol lookup error: /usr/sbin/gpartedbin: undefined symbol: gtk_widget_get_window

...and starting Gparted via the menu still brings up the 0.3.3 version

(persistent little Thing!!!)
Back to top
View user's profile Send_private_message 
technosaurus


Joined: 18 May 2008
Posts: 4376

PostPosted: Mon 22 Feb 2010, 11:37    Post_subject:  

Use the updated glib pet that I posted - It will be part of 4.4 CE - I have confirmed that this is the only pet you will need for a clean 4.3.1 install.
_________________
Web Programming - Pet Packaging 100 & 101
Back to top
View user's profile Send_private_message 
Dromeno

Joined: 12 Sep 2008
Posts: 538

PostPosted: Tue 23 Feb 2010, 05:10    Post_subject:  

Yes, but unfortunately for puppy 4.2.1(not 4.3.1) , installing

glib-2.22.2-i486.pet

and the new Gparted results in the "lookup errors" I described!
Back to top
View user's profile Send_private_message 
technosaurus


Joined: 18 May 2008
Posts: 4376

PostPosted: Tue 23 Feb 2010, 10:32    Post_subject:  

that means you need to update gtk to at least 2.14
_________________
Web Programming - Pet Packaging 100 & 101
Back to top
View user's profile Send_private_message 
Jim1911

Joined: 19 May 2008
Posts: 2457
Location: Texas, USA

PostPosted: Sun 28 Feb 2010, 17:55    Post_subject:
Sub_title: Gparted-0.5.1 on Stardust
 

I installed your Gparted-0.5.1.pet on Stardust-012 which has Gparted-0.4.5 and it just broke the existing installation. However, I see that it is working fine on your 4.4 pre alpha.

What corrections are needed to get it to work on Stardust?

Thanks,
Jim
Back to top
View user's profile Send_private_message 
technosaurus


Joined: 18 May 2008
Posts: 4376

PostPosted: Sun 28 Feb 2010, 20:21    Post_subject:  

probably just the updated glib
_________________
Web Programming - Pet Packaging 100 & 101
Back to top
View user's profile Send_private_message 
Jim1911

Joined: 19 May 2008
Posts: 2457
Location: Texas, USA

PostPosted: Sun 28 Feb 2010, 21:00    Post_subject:  

Thanks, the updated glib did correct the problem with Gparted-0.5.1.
Back to top
View user's profile Send_private_message 
8-bit


Joined: 03 Apr 2007
Posts: 3393
Location: Oregon

PostPosted: Tue 02 Mar 2010, 03:56    Post_subject:  

I installed both pets aka. gparted-51 and the library pet in Puppy 4.3.1 and I get this from the terminal when I try to start it.
# gpartedbin
gpartedbin: error while loading shared libraries: libdevmapper.so.1.02: cannot open shared object file: No such file or directory

So evidently you are still missing a library file. or a link.
Back to top
View user's profile Send_private_message 
technosaurus


Joined: 18 May 2008
Posts: 4376

PostPosted: Tue 02 Mar 2010, 12:31    Post_subject:  

Quote:
Posted: Thu Feb 18, 2010 10:59 pm Post subject:

--------------------------------------------------------------------------------
Thanks DM,
updated with static libdevmapper from latest stable lvm2


Did you happen to download prior to Thu Feb 18, 2010 10:59 pm?

_________________
Web Programming - Pet Packaging 100 & 101
Back to top
View user's profile Send_private_message 
8-bit


Joined: 03 Apr 2007
Posts: 3393
Location: Oregon

PostPosted: Tue 02 Mar 2010, 15:03    Post_subject:  

technosaurus,

I evidently had the old library pet. I downloaded it again and Gparted 5.1 now works. Embarassed
So I wanted to clarify that my previous problem was due to getting the earlier pet of the library.
Thank you! Smile
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 2 of 3 Posts_count   Goto page: Previous 1, 2, 3 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0662s ][ Queries: 12 (0.0047s) ][ GZIP on ]