Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 20 Nov 2018, 16:21
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Puppy 4.3 pre-beta bug reports
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 5 of 8 [106 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8 Next
Author Message
Jim1911

Joined: 19 May 2008
Posts: 2460
Location: Texas, USA

PostPosted: Fri 07 Aug 2009, 09:53    Post subject:  

This entry is made from the "4.3 pre-beta-reloaded"
1. Clicking on an ext4 partition still results in "Error: Unable to mount sdb3". Same result using the mount icon to run pmount. Possibly fix is the one Jesse did earlier for woof http://puppylinux.com/blog/?viewDetailed=00740
2. Fixed, Gparted now recognizes ext4 partitions.
3. Fixed, "Set global font size" now works.

Again, thanks for creating and continuing to improve Puppy.
Jim Smile
Back to top
View user's profile Send private message 
4-stroke

Joined: 07 Aug 2009
Posts: 114
Location: Sweden

PostPosted: Fri 07 Aug 2009, 10:26    Post subject:  

First post on any internet forum...

Ok, here goes...

Medit, gparted and e3vi segfaults, done this for me
since 416 if i remember correctly.

When i try to run medit from the cli it simply states "segmentation fault", same with e3vi.

gparted states:
======================
libparted : 1.8.8
======================
/usr/sbin/gparted: line 37: 19867 Segmentation fault /usr/sbin/gpartedbin $*

I have a Acer Aspire 1360 with AMD Sempron 2800+
708Mb mem

Frugal install.
Back to top
View user's profile Send private message 
DC


Joined: 30 Apr 2006
Posts: 361
Location: Maidenhead, England

PostPosted: Fri 07 Aug 2009, 12:04    Post subject:  

"4.3 pre-beta-reloaded" live-cd and full install
tried modprobe nfsd
Quote:
# modprobe nfsd
FATAL: Error inserting nfsd (/lib/modules/2.6.29.6/kernel/fs/nfsd/nfsd.ko): Unknown symbol in module, or unknown parameter (see dmesg)
# modinfo nfsd
filename: /lib/modules/2.6.29.6/kernel/fs/nfsd/nfsd.ko
license: GPL
author: Olaf Kirch <okir@monad.swb.de>
depends: auth_rpcgss,sunrpc,lockd,exportfs
vermagic: 2.6.29.6 SMP mod_unload modversions 486

exportfs missing?

And now the good news

kernel NFS client working - even from the live-cd which was never possible before for me.

Pleasant surprise - smp seems to be working
conky shows two cpu's working ok but "top view running processes" only shows one?

Thanks
DC
Back to top
View user's profile Send private message 
Ray MK


Joined: 05 Feb 2008
Posts: 776
Location: UK

PostPosted: Fri 07 Aug 2009, 14:44    Post subject:  

Hi

SMP enabled - very nice - try downloading Htop pet.

That will also show multi-processors and double confirm smp enabled
kernel.

This will get many of the Netbook users with N270 dual-core processors exited - and if the wifi modules work out of the box - nice.

Must see if wifi works OTB with earlier celeron M proc + wifi chip in
EeePc 701SD.

Best regards - Ray
Back to top
View user's profile Send private message 
shinobar


Joined: 28 May 2009
Posts: 2673
Location: Japan

PostPosted: Fri 07 Aug 2009, 18:07    Post subject: Re: vi segfault (Repaired)
Subject description: vi command crashes with segment fault.
 

shinobar wrote:
vi command crashes with segment fault.
same as 4.17alpha, 4.22 pre-beta.


BarryK wrote:
Hmmm, perhaps I didn't upgrade properly and 4.3pbr built with the older e3 pkg. Try this one:

http://distro.ibiblio.org/pub/linux/distributions/puppylinux/pet_packages-woof/e3-2.7.1.pet

I tried, and yes its repaired. Tnx.
Back to top
View user's profile Send private message Visit poster's website 
edoc


Joined: 07 Aug 2005
Posts: 4722
Location: Southeast Georgia, USA

PostPosted: Fri 07 Aug 2009, 20:04    Post subject:  

[quote="Ray MK"]Hi
SMP enabled - very nice - try downloading Htop pet.

Where is Htop.pet located, please?

I didn't see it in the package manager.

Ray MK wrote:

That will also show multi-processors and double confirm smp enabled
kernel.
This will get many of the Netbook users with N270 dual-core processors exited - and if the wifi modules work out of the box - nice.


Fatdog 112 is working well with my Acer Aspire 5535-5452 laptop and handles the Atheros b/g/n wireless so I am excited to see 4.3 coming along - still need support for the integrated Web cam and card reader in this laptop.

Ray MK wrote:

Best regards - Ray

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
TahrPup64 & Lighthouse64-b602 & JL64-603
Back to top
View user's profile Send private message Visit poster's website 
trio


Joined: 21 Dec 2008
Posts: 2083
Location: अनुमोदना

PostPosted: Fri 07 Aug 2009, 20:56    Post subject:  

Hi Barry,

Few brief comments on PBR:

Sound: Who needs to run alsa config? The sound just work without configuring! I tried on 2 laptops

Wallpaper setter: I recommend to put ORIGINAL-xxx.jpg maybe in /root/.Choices/ not in /usr/share/backgrounds as they will be listed in the tree box

GXine: still the -f option not working from commandline. You don't want to revert back to previous working version if this issue is not resolved?

thanks

_________________
My apps
Back to top
View user's profile Send private message 
DC


Joined: 30 Apr 2006
Posts: 361
Location: Maidenhead, England

PostPosted: Sat 08 Aug 2009, 06:06    Post subject:  

Htop confirms two cpu's on my laptop
found
htop-0.8.2-i486-uj.pet
here
http://www.murga-linux.com/puppy/viewtopic.php?t=41937&start=45&sid=3628f98288418f621eb03ddd95655097

DC
Back to top
View user's profile Send private message 
ttuuxxx


Joined: 05 May 2007
Posts: 11193
Location: Ontario Canada,Sydney Australia

PostPosted: Sat 08 Aug 2009, 07:44    Post subject:  

Gposil finished fixing a new to puppy wallpaper setter based on CWallpaper setter, It has a very nice preview feature and a great size, Also it will work on all puppy 2,3,4,5 series, well it works on 2.14X and 5 series so please give it a try, Its a 12.27kb pet package Smile
http://www.murga-linux.com/puppy/viewtopic.php?mode=attach&id=20706
He did an excellent job on this, When I first came across it, it would use a config log, that you manually had to edit and place all your wallpaper names on, Now Gposil has totally automated it Smile, Plus originally it wouldn't actually set/stretch/center a wallpaper and now it does.
Thanks Gposil
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send private message Visit poster's website 
trio


Joined: 21 Dec 2008
Posts: 2083
Location: अनुमोदना

PostPosted: Sat 08 Aug 2009, 08:11    Post subject:  

ttuuxxx wrote:
Gposil finished fixing a new to puppy wallpaper setter based on CWallpaper setter, It has a very nice preview feature and a great size, Also it will work on all puppy 2,3,4,5 series, well it works on 2.14X and 5 series so please give it a try, Its a 12.27kb pet package Smile
http://www.murga-linux.com/puppy/viewtopic.php?mode=attach&id=20706
He did an excellent job on this, When I first came across it, it would use a config log, that you manually had to edit and place all your wallpaper names on, Now Gposil has totally automated it Smile, Plus originally it wouldn't actually set/stretch/center a wallpaper and now it does.
Thanks Gposil
ttuuxxx


Yes, I can confirm that it's great. Barry, you should try, and maybe you'll like it...

_________________
My apps
Back to top
View user's profile Send private message 
nancy reagan

Joined: 22 Jan 2009
Posts: 549

PostPosted: Sat 08 Aug 2009, 13:04    Post subject: No sound
Subject description: where is s-Gmixer
 

I am not a tweaker I might have done something wrong maybe somebody reported it earlier but

I did not get any sound trying Trio's :what's its name ?"m (all those cryptic names in lInux when is it going to change ?).

Then I was looking for the thing I always use in 4.1.2 SGmixer could not find it ... maybe there is something similar ?

In Trio's I did not have screencontrol buttons.

This is just a quick report maybe I did not check careful enough, but you'll never know.
Back to top
View user's profile Send private message 
trio


Joined: 21 Dec 2008
Posts: 2083
Location: अनुमोदना

PostPosted: Sat 08 Aug 2009, 21:18    Post subject:  

nancy reagan,

1. pstreamvid you meant? No sound, it means you have to go to setup -- Alsa sound wizard, and you set up your sound there (sometimes it needs to be rebooted afterwards)
2. sgmixer ==> multimedia -- Alsa mixer

I don't understand the part of in "Trio's I don't have a scrollbuton"

Barry,

Again about wallpaper setter, I incorporate your reshape_background function (tweaked the set_bg file to call your script), and it worked well for me

_________________
My apps
Back to top
View user's profile Send private message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 8710
Location: Perth, Western Australia

PostPosted: Sun 09 Aug 2009, 03:31    Post subject:  

rerwin wrote:
Barry,
I am attempting to compile modem modules in ppa_422, but run into the same problem I had with kernel 2.6.30.1. To do this, I renamed the devx used with p417-k2.6.30.1 to ...422..., since you have not yet provided an appropriately named devx for 422.

The problem is that a critical file is missing from the kernel source, causing any compile to fail. I first tried compiling dgcmodem, but then tried pctel, which I infer you have compiled, since it is in the sources-k2.6.29.6/3rdparty/modems directory. The error log for pctel is smaller, but shows what the problem is:
Quote:
CC vuart.o
LD binary.a
make -C /lib/modules/2.6.29.6/build M=/root/pctel-0.9.7-9-rht-10-patched1/src
make[1]: Entering directory `/usr/src/linux-2.6.29.6'
LD /root/pctel-0.9.7-9-rht-10-patched1/src/built-in.o
CC [M] /root/pctel-0.9.7-9-rht-10-patched1/src/linmodem-2.6.o
In file included from include/linux/gfp.h:4,
from include/linux/kmod.h:22,
from include/linux/module.h:13,
from /root/pctel-0.9.7-9-rht-10-patched1/src/linmodem-2.6.c:31:
include/linux/mmzone.h:18:26: error: linux/bounds.h: No such file or directory
include/linux/mmzone.h:256:5: warning: "MAX_NR_ZONES" is not defined
In file included from include/linux/gfp.h:4,
from include/linux/kmod.h:22,
from include/linux/module.h:13,
from /root/pctel-0.9.7-9-rht-10-patched1/src/linmodem-2.6.c:31:
include/linux/mmzone.h:290: error: 'MAX_NR_ZONES' undeclared here (not in a function)
make[2]: *** [/root/pctel-0.9.7-9-rht-10-patched1/src/linmodem-2.6.o] Error 1
make[1]: *** [_module_/root/pctel-0.9.7-9-rht-10-patched1/src] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.29.6'
make: *** [all] Error 2

Others (not re Puppy, though) have reported this problem, but I find nothing that looks like a resolution. The linux/bounds.h file needed to resolve variables used in include/linux/mmzone.h is apparently expected to be created automatically somehow, but the trail stops there! Is there something that you have done to your copy of the source directory that did not get done for the version you posted in "sources"?

I would like to help by compiling the modem modules, but I am "dead in the water", right now. Could you help me out, here? Thanks.
Richard


rerwin,
bounds.h and some others got created when I ran 'make bzImage'. Later on when I ran 'make clean' prior to creating the kernel source sfs file, they got erased.

Attached is the contents of /usr/src/2.6.29.6/include with some missing files...
include.tar.gz
Description 
gz

 Download 
Filename  include.tar.gz 
Filesize  19.03 KB 
Downloaded  203 Time(s) 

_________________
http://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 8710
Location: Perth, Western Australia

PostPosted: Sun 09 Aug 2009, 03:47    Post subject:  

I think I'll stay with the 2.6.29.6 kernel. It seems basically ok. So far not lots of reports about computers hanging at bootup, usb not working, or it won't shutdown...

I have played with the 2.6.27.29 kernel, main reason is to keep the same 3.3 or 3.4 squashfs for compatibility with earlier kernels. But currently the squashfs 3.3 patch I applied to that kernel doesn't work, and I'm reluctant to go through the whole thing again. There is a squashfs 4.0 backport -- but then what's the point, might as well stay with 2.6.29.6.

_________________
http://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 8710
Location: Perth, Western Australia

PostPosted: Sun 09 Aug 2009, 03:53    Post subject:  

Jim1911 wrote:
This entry is made from the "4.3 pre-beta-reloaded"
1. Clicking on an ext4 partition still results in "Error: Unable to mount sdb3". Same result using the mount icon to run pmount. Possibly fix is the one Jesse did earlier for woof http://puppylinux.com/blog/?viewDetailed=00740
2. Fixed, Gparted now recognizes ext4 partitions.
3. Fixed, "Set global font size" now works.

Again, thanks for creating and continuing to improve Puppy.
Jim Smile


Jim1911,
Could you please do this test, in a terminal:

# guess_fstype /dev/<partititon>

Where <partitition> is your ext4 partititon.
Let me know what it returns.

_________________
http://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 5 of 8 [106 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1916s ][ Queries: 12 (0.0286s) ][ GZIP on ]