Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 01 Oct 2014, 04:30
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Ppup 416alpha bug reports
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 3 of 4 [54 Posts]   Goto page: Previous 1, 2, 3, 4 Next
Author Message
ttuuxxx


Joined: 05 May 2007
Posts: 10757
Location: Ontario Canada,Sydney Australia

PostPosted: Tue 14 Jul 2009, 10:19    Post subject:  

Chris its not surpising mp4 isn't working on 2.14X its based on a 2006 version of puppy Smile All in due time, thats on a list of this that neds updating, The main points are get rid of the errors first, then comes the extras.

As for the latest abiword working on it, yes and no, no its not in by default, but yes there is a package made up. The user technosaurus made a static version in series 4 of the latest release, Then I added a working dictionary, and omitted a couple of the non-functional fonts and packaged up a all-in-one version, but the way technosaurus It works very well in series 2.14x even if it was compiled on 4 series, The only non-functional and removed from abiword fonts are, cursor, linux8x8, linux8x16, micro, but the times fonts and others are now working for the first time in like over 10 release of abiword Smile I personally would use this this version and removed the non functional ones, as long as times and the others are working, this would reduce the font size and still leave some of the needed and still working pcf fonts that rest of system (xorg etc) can still use.
Better yet, If this package was used and Gnumeric/Goffice/The non-functional pcf fonts and keep the working ones was removed, since this version of abiword doesn't need goffice anymore Smile
Then install that other small spreadsheet Barry had before, I forget the name, That would probably reduce the iso by around 3MB compressed, wouldn't that be nice to have a 96MB puppy iso, man we could do some serious damage with almost 4MB of space:)
anyways if people want to test the all in one package here's a link. (Its actually small 3.5MB even with the dictionary included)
http://www.ttuuxxx.gposil.com/2.14X/documents/abiword-2.7.6-214X.pet

Plus there's a 1.17MB addon pack that technosaurus made up, http://www.murga-linux.com/puppy/viewtopic.php?mode=attach&id=19839

ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send private message Visit poster's website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Tue 14 Jul 2009, 10:31    Post subject:  

When you test Aqualung, please do bear in mind that my latest recompile of ffmpeg and aqualung, as reported here:

http://puppylinux.com/blog/?viewDetailed=00883

...did not make it into 416.

For example, .m4a files now play. This will be in 417.

_________________
http://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
01micko


Joined: 11 Oct 2008
Posts: 7805
Location: qld

PostPosted: Tue 14 Jul 2009, 16:37    Post subject:  

The mods made to the wallpaper setter to accommodate widescreens in 416 seem to work fine.

Bit if discussion about the superpup, I made the original and CatDude improved on it. I made it for a collection in big_bass slaxer_pup. It was a bit of fun. Good that it has caused a stir! I tend to agree that it wouldn't be a great default for the official release but this is alpha, and lately Barry has been switching them around for the alphas.

That brushed metal wallpaper, one of zigbert's, created by Raymond Levang, who does a bit of zigbert's artwork can be found at dejan555's puppy artwork site, puppy-look.tk. A very nice backdrop! There are many more great walls and themes there.

Cheers

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
Keef


Joined: 20 Dec 2007
Posts: 629
Location: Staffordshire

PostPosted: Tue 14 Jul 2009, 18:45    Post subject: Drive incorrectly identified as floppy
Subject description: CF card in IDE adapter
 

Internal CF card in IDE adapter is being shown on the desktop as a floppy drive (as sda1). Pmount also lists it under the floppy tab. This is not causing any problems though.
Back to top
View user's profile Send private message 
cthisbear

Joined: 29 Jan 2006
Posts: 3417
Location: Sydney Australia

PostPosted: Tue 14 Jul 2009, 21:55    Post subject:  

Thanks BK and ttuuxxx .

The only code I should contribute is a
Code of Silence.

Chris.
Back to top
View user's profile Send private message 
esmourguit


Joined: 17 Nov 2006
Posts: 1288
Location: Sur l'ile aux oiseaux.

PostPosted: Wed 15 Jul 2009, 04:04    Post subject:  

Bonjour a tous,
Not sure it is realy a bug, but i can't run Abiword neither from desktop icon nor from Menu, Document, Abiword. It runs only typing abiword in console.
Cordialement Wink
console.png
 Description   
 Filesize   6.21 KB
 Viewed   886 Time(s)

console.png


_________________
Toutou Linux - Pets francisés
Back to top
View user's profile Send private message 
zygo

Joined: 08 Apr 2006
Posts: 211
Location: UK

PostPosted: Wed 15 Jul 2009, 19:19    Post subject: bad video  

Barry,

I've tested 416 from live CD on my 2 newer PCs:

emachines: celeron 1.8GHz 256MB RAM no HDD - CRT monitor
- the cd wasn't copied to RAM as it was on all previous versions and the cd could not be removed
- could not get anything but a low very low resolution (and low colour depth) display using xvesa. Xorg wouldn't start. This is the first time that a Puppy has failed to start X (or xvesa) on this PC. Actually, I think I got to a reasonable desktop but I can't remember how. The way in which settings are changed and tested affects the outcome.

acer: intel core 2 duo 2GB RAM no HDD - 1440x900 LCD monitor
- I can get 1024x768 but stretched to fill the whole screen when I change i810 to intel as your announcement blog suggests
- I can start Abiword from the menu

I've been using the xorg video wizard a lot.
- In the new dialogues to change sync ranges could you stipulate "using the digit keys above the letters on your keyboard" pressing the numeric pad (which can not be set to num lock) produces letters.
- There were times when I had got a mode to work then closed X to improve it only to find that I couldn't get any mode to work. So no choice but to reboot. Could you add a "delete config files" option to avoid this and speed up testing. Another idea is to give the dialogues an id and print that in red.

Thanks
Back to top
View user's profile Send private message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Thu 16 Jul 2009, 01:39    Post subject:  

I have responded to some 416 feedback here:

http://puppylinux.com/blog/?viewDetailed=00891

_________________
http://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
charlie6


Joined: 30 Jun 2008
Posts: 1010
Location: South of Belgium

PostPosted: Thu 16 Jul 2009, 02:03    Post subject:  

Hi Barry,
thanks for your time and efforts!
(Ooops! ...late discovered this list...)
about using of Puppy416alpha:
- use from live-cd:

- serial mouse?
I booted 416 on live-cd with serial mouse connected: upon Xorg setup,no mouse setup; the cursor stayed fix - maybe have I confused something?
Does Puppy416 as future 4.3 any longer work with a serial mouse?
Rebooting with a ps/2 mouse ...OK

- Wine
I also boot up puppy416 using a pup4save-wine415A.2fs where Wine1112_415.sfs (411 renamed to 415 !) is installed. My favorite applications on wine are running well (design and beam calculation).
I also noticed that opening winecfg's audio thumbnail and further sound testing gives a beep (i.e. is working on 416! - did not on 413 and 415); whereas it did not on my basis ToutouLinux 4.1.2 which is featured with Timidity++2.13 and some additionnals sound libraries as jack and oss.

- abiword 2.6.3 and .docx format
Abiword 2.6.3 on puppy 4.2.1 has .docx format; whereas abiword 2.6.3 on puppy416 and earlier do not. Receiving mails with .docx attachment it would be nice to have abiword featured with .docx reading capability, would'nt it? That also to avoid installation of the huge OpenOffice archive.

- on puppy 416 installed frugal:
- pup4save.2fs not saved on puppy416 partition
Exit puppy after choice for pup4save.2fs 'save to partition' where puppy416 is installed.
Then, restart as whitout loading the pup4save.2fs and asking again the keyboard setup, etc...
(I have only 392MB free on that partition - maybe not enough?)
OK if 'save to file' - choosen size 256MB - the saved pup4save.2fs is well saved and loaded at upon boot.

- SQLite
Got SQLite started from menu.
It get frozen when selecting 'tools/options'.
Had to kill the process to exit SQLite.

cheers, charlie
Back to top
View user's profile Send private message 
ttuuxxx


Joined: 05 May 2007
Posts: 10757
Location: Ontario Canada,Sydney Australia

PostPosted: Thu 16 Jul 2009, 05:07    Post subject:  

charlie6 wrote:
Hi
- abiword 2.6.3 and .docx format
Abiword 2.6.3 on puppy 4.2.1 has .docx format; whereas abiword 2.6.3 on puppy416 and earlier do not. Receiving mails with .docx attachment it would be nice to have abiword featured with .docx reading capability, would'nt it? That also to avoid installation of the huge OpenOffice archive.

cheers, charlie


The reason why abiword 2.6.3 has docx support in 4.2.1 is because at the time of the build, I compiled 2.6.7 and transfered over the docx extension that worked in 2.6.3, since by norm 2.6.3 did not have docx implemented as of yet, I think it came out 2.6.6. For puppy to have docx support in 2.6.3 again the fature/plugin would have to removed once again from either 4.2.1 or recompiled 4.6.7++ and placed in the 2.6.3 package.
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send private message Visit poster's website 
Minnesota

Joined: 11 Sep 2008
Posts: 313

PostPosted: Thu 16 Jul 2009, 07:18    Post subject: sqllight
Subject description: Help please
 

Please excuse my ignorance, but how do I enter data in a database generated by the new SqlLight?

I was able to create a table...but do we have a front end to this?

Thanks. Please refer me to the correct post location.
Back to top
View user's profile Send private message 
tronkel


Joined: 30 Sep 2005
Posts: 1101
Location: Vienna Austria

PostPosted: Thu 16 Jul 2009, 09:07    Post subject:  

I set up pup4 416 with a pup_save sfs file.

On booting into this, when trying to connect to the internet via ETH0,
no interfaces were detected and no modules could be found that could be manually loaded. This was because the system had lost the path to the network *.ko driver modules. The usual path to this is /lib/modules/ ..... and so on, but this path is non-existent after creating the pup_save for some reason. Something to do with the separate drivers archive?

I then had to create the correct path by creating the missing intermediate folders and copy over the forcedeth driver to the now existing normal puppy location. The driver then loaded OK and ETH0 was then visible. Connected via DHCP OK.

There was no problem with this running from the live-cd using "puppy pfix=ram". This problem only surfaced after creating the pup-save file. Might be a layered fs problem making the modules folder invisible to the system. Will play further with this.

_________________
Life is too short to spend it in front of a computer
Back to top
View user's profile Send private message Visit poster's website AIM Address 
ICPUG

Joined: 24 Jul 2005
Posts: 1290
Location: UK

PostPosted: Fri 17 Jul 2009, 07:54    Post subject:  

Tried out 4.1.6 on my Medion laptop and it booted to the i810 video driver and my chosen resolution (800x600) without me having to do anything. Great - First time since 3.01.

Abiword would not start from the desktop icon or menu (this is a frugal install).

There seem to be more questions in the first bootup now. One that confused was choosing the locale. As it defaulted to US I wanted to change to gb. There were 2 entries (that I found) for Great Britain with no explanation of the differences between the two versions.
Back to top
View user's profile Send private message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Fri 17 Jul 2009, 10:34    Post subject: Re: sqllight
Subject description: Help please
 

Minnesota wrote:
Please excuse my ignorance, but how do I enter data in a database generated by the new SqlLight?

I was able to create a table...but do we have a front end to this?

Thanks. Please refer me to the correct post location.

None of us know anything about SQLiteManager. I put it in so that you guys can try it and report back. You may have to hunt around online -- I think there are some online docs.

_________________
http://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
ttuuxxx


Joined: 05 May 2007
Posts: 10757
Location: Ontario Canada,Sydney Australia

PostPosted: Fri 17 Jul 2009, 10:50    Post subject:  

I don't know if this has been reported yet but 'epdfview' seg faults and also complains about a missing config file located in, /root/.config/epdfview/main.conf I place a dummy config file in that location, and then it didn't complain about it missing, but it still segfaults when opening a pdf file, So I used abiword too view the file, which worked.
ttuuxxx

Ps still working on the icons

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile

Last edited by ttuuxxx on Fri 17 Jul 2009, 11:23; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 3 of 4 [54 Posts]   Goto page: Previous 1, 2, 3, 4 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0955s ][ Queries: 12 (0.0064s) ][ GZIP on ]