Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 26 Nov 2015, 01:04
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
font antialiasing problem (partially solved)
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [1 Post]  
Author Message

Joined: 24 Sep 2005
Posts: 427
Location: Mumbai, India

PostPosted: Wed 07 Dec 2005, 13:41    Post subject:  font antialiasing problem (partially solved)  

BarryK wrote on wiki

A bit of a mystery with font antialiasing in Puppy. Bitmap fonts do not antialiase, only the scalable Type1 and TrueType fonts. Note, Puppy's bitmap fonts are to be found in /usr/X11R6/lib/X11/fonts/misc. The outcome of this is that if a bitmap font is used by an application, it will not display antialiased. For example, for reasons known only to itself, Mozilla renders some web pages with a bitmap font. Bitmap fonts are fixed sizes, and look okay if rendered at those sizes, but if scaled they are jagged. I became acutely aware of this problem when I got font antialising working for GTK1 applications a few days ago. The menu and dialog text is a bitmap font, so not antialiased.
A year or so ago, in a much earlier version of Puppy, I had font antialising working for both GTK1 and GTK2 applications and it worked with all the fonts including bitmapped. So, the great mystery now is why are bitmapped fonts being excluded? This is something to do with the way Xft and Fontconfig works.
I am posing this mystery for anyone interested in font rendering and who would like the challenge.

I never knew about this post by Barry until today, however over the last week I have been trying to get better antialiased fonts in puppy.

What I tried ?
1. I thought it had something to do with the fonts themselves, so I used window$ fonts. Not much improvement.

2. Used MU's Xorg instead of Xvesa - some improvement

3. I tried compiling fontconfig in puppy. Would not compile using usr_devx

3. I recompiled freetype after installing Xorg - cannot say any improvement was there or not

4. I recompiled gdkxft and set the environment variable GDK_USE_XFT="1"

5. Googled on the concepts of font rendering in linux - found that libfreetype, libxrender, libxft2 are the core components for font rendering. So there seems to be some problem with these ?

6. Replaced them with libfreetype, libxrender, libxft2 from debain packages - Voila - instant improvement - sharper and darker fonts with antialiasing.

7. bitmap fonts are still excluded ???

I dont know whether the font problem is solved or not in 1.0.7 (it uses Xorg)

Another perplexing question - Why are Mozilla app fonts SO LARGE ?? How to change them ??


looks very blurred so you can download and see the original image from
Back to top
View user's profile Send private message Yahoo Messenger 
Display posts from previous:   Sort by:   
Page 1 of 1 [1 Post]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0306s ][ Queries: 11 (0.0089s) ][ GZIP on ]