Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 21 Sep 2014, 20:25
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Comix
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
robwoj44

Joined: 08 Aug 2008
Posts: 368
Location: Warsaw

PostPosted: Fri 03 Jul 2009, 17:32    Post_subject:  Comix
Sub_title: GTK Comic Book Viewer
 

http://comix.sourceforge.net/
Comix is a user-friendly, customizable image viewer. It is specifically designed to handle comic books, but also serves as a generic viewer. It reads images in ZIP, RAR or tar archives (also gzip or bzip2 compressed) as well as plain image files. It is written in Python and uses GTK+ through the PyGTK bindings.

The dependencies:
python from devx_xxx.sfs or http://www.dotpups.de/puppy3/dotpups/Programming/python-2.5.1-i486.pet
http://www.puppylinux.asia/tpp/ttuuxxx/programs/GnomeCompiledP4/pygtk-2.12.1-i386.pet
http://www.puppylinux.asia/tpp/ttuuxxx/programs/GnomeCompiledP4/pycairo-1.4.12-i386.pet
http://www.puppylinux.asia/tpp/ttuuxxx/programs/GnomeCompiledP4/pygobject-2.14.2-i386.pet
PIL from http://www.murga-linux.com/puppy/viewtopic.php?t=44202
To use the library you need pysqlite from
http://www.murga-linux.com/puppy/viewtopic.php?t=35311&sid=488c80dcd99e4b90934e382719c15778
comix-4.0.4-i486.pet
Description  Comix
pet

 Download 
Filename  comix-4.0.4-i486.pet 
Filesize  306.17 KB 
Downloaded  1473 Time(s) 

Edited_times_total
Back to top
View user's profile Send_private_message 
Dromeno

Joined: 12 Sep 2008
Posts: 537

PostPosted: Sat 04 Jul 2009, 02:50    Post_subject: Something is missing?  

I installed all the files you suggested but when I try to open comix in a console i get the following message:

"env: python: No such file or directory"

but python is installed (puppy 4.10)
Back to top
View user's profile Send_private_message 
logicjoe

Joined: 04 Jul 2009
Posts: 4

PostPosted: Sat 04 Jul 2009, 05:40    Post_subject:  

Nice work its a killer app only i keep getting asked for a password when I go to download:

pygtk-2.12.1-i386.pet
pycairo-1.4.12-i386.pet

Any clues?

Edited_time_total
Back to top
View user's profile Send_private_message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Sat 04 Jul 2009, 05:41    Post_subject:  

user: puppy
password: linux

Mark

_________________
my recommended links
Back to top
View user's profile Send_private_message Visit_website 
logicjoe

Joined: 04 Jul 2009
Posts: 4

PostPosted: Sat 04 Jul 2009, 05:54    Post_subject:    

ta
Back to top
View user's profile Send_private_message 
Dais

Joined: 02 Jun 2009
Posts: 2

PostPosted: Sat 04 Jul 2009, 08:08    Post_subject: Re: Something is missing?  

Dromeno wrote:
I installed all the files you suggested but when I try to open comix in a console i get the following message:

"env: python: No such file or directory"

but python is installed (puppy 4.10)


I have the same problem.

I'm still quite new to Puppy...exactly how should I be running this program? Via terminal emulator, by dragging the file I want to open onto some other file, what?
Back to top
View user's profile Send_private_message 
robwoj44

Joined: 08 Aug 2008
Posts: 368
Location: Warsaw

PostPosted: Sat 04 Jul 2009, 09:57    Post_subject:  

I repacked. Now it must be ok.
Back to top
View user's profile Send_private_message 
doggiebowwow

Joined: 06 Jan 2009
Posts: 3

PostPosted: Sat 04 Jul 2009, 23:28    Post_subject: libpython2.5.so.1.0 missing  

PIL and psqlite says that "libpython2.5.so.1.0" is missing. How do we get this file loaded? Comix would be a cool app to have.
Back to top
View user's profile Send_private_message 
doggiebowwow

Joined: 06 Jan 2009
Posts: 3

PostPosted: Thu 09 Jul 2009, 17:12    Post_subject: Can't get Comix to launch  

Still can't get it to work. I was able to download a python 2.5 pet. and now using the PetGet package manager, I don't get any missing dependencies in PIL or psqlite (unlike before).

However, clicking Comix from the Gui menu doesn't launch it, it actually does nothing.

Running it from a terminal results in:
"env: python: No such file or directory"

same problem as Dromeno.
Back to top
View user's profile Send_private_message 
linux28

Joined: 05 Apr 2009
Posts: 179

PostPosted: Thu 09 Jul 2009, 21:59    Post_subject:  

Quote:
python from devx_xxx.sfs or http://www.dotpups.de/puppy3/dotpups/Programming/python-2.5.1-i486.pet
http://www.puppylinux.asia/tpp/ttuuxxx/programs/GnomeCompiledP4/pygtk-2.12.1-i386.pet
http://www.puppylinux.asia/tpp/ttuuxxx/programs/GnomeCompiledP4/pycairo-1.4.12-i386.pet
http://www.dotpups.de/puppy3/dotpups/Programming/python-2.5.1-i486.pet
PIL from http://www.murga-linux.com/puppy/viewtopic.php?t=44202
To use the library you need pysqlite from
http://www.murga-linux.com/puppy/viewtopic.php?t=35311&sid=488c80dcd99e4b90934e382719c15778


I have installed, but the lack of prompt

pygtk
Back to top
View user's profile Send_private_message 
robwoj44

Joined: 08 Aug 2008
Posts: 368
Location: Warsaw

PostPosted: Fri 10 Jul 2009, 02:22    Post_subject:  

Let me know what you see after typing in console
python /usr/local/share/comix/src/comix.py
Back to top
View user's profile Send_private_message 
linux28

Joined: 05 Apr 2009
Posts: 179

PostPosted: Fri 10 Jul 2009, 06:40    Post_subject:  

robwoj44 wrote:
Let me know what you see after typing in console
python /usr/local/share/comix/src/comix.py


# python /usr/local/share/comix/src/comix.py
PyGTK version 2.12.0 or higher is required to run Comix.
No version of PyGTK was found on your system.
#



http://www.puppylinux.asia/tpp/ttuuxxx/programs/GnomeCompiledP4/pygtk-2.12.1-i386.pet
I have installed the

I'm using dev412


Quote:
python from devx_xxx.sfs or http://www.dotpups.de/puppy3/dotpups/Programming/python-2.5.1-i486.pet
http://www.puppylinux.asia/tpp/ttuuxxx/programs/GnomeCompiledP4/pygtk-2.12.1-i386.pet
http://www.puppylinux.asia/tpp/ttuuxxx/programs/GnomeCompiledP4/pycairo-1.4.12-i386.pet
http://www.dotpups.de/puppy3/dotpups/Programming/python-2.5.1-i486.pet
PIL from http://www.murga-linux.com/puppy/viewtopic.php?t=44202
To use the library you need pysqlite from
http://www.murga-linux.com/puppy/viewtopic.php?t=35311&sid=488c80dcd99e4b90934e382719c15778


All are still not installed
Back to top
View user's profile Send_private_message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Sat 11 Jul 2009, 02:23    Post_subject:  

comix starts in newyearspup (nyp) after installing the image library from
http://www.murga-linux.com/puppy/viewtopic.php?t=44202

nyp uses a different python, http://dotpups.de/puppy3/dotpups/Programming/python_for_CCSM.pet.
This pet already includes pygtk and so on.
Mark

_________________
my recommended links
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0747s ][ Queries: 12 (0.0050s) ][ GZIP on ]