Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 21 Nov 2017, 06:18
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Usuarios de habla Hispana
Conexión a internet modem usb md300 de sony-ericsson
Moderators: rarsa
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [9 Posts]  
Author Message
g000g1e

Joined: 28 Jun 2009
Posts: 27
Location: here - there (aquí y allí)

PostPosted: Tue 30 Jun 2009, 15:58    Post subject:  Conexión a internet modem usb md300 de sony-ericsson  

Hola:
Soy nuevo en el foro, tambien soy analfabeta en Linux y en Puppy.
La pregunta que propongo ya la hice en inglés "macarrónico" en http://www.murga-linux.com/puppy/viewtopic.php?t=37828&start=210.-

El caso es que por el momento mi unica conexión a internet es a través del modem inalámbrico usb md300 de sony-ercisson, aun cuando el pc tiene incorporados una tarjeta modem ethernet y un modem telefónico antediluviano....-

He estado probando diversas distribuciones de gnu/linux con la intención de migrar desde W. xp.; una de las pocas que he logrado instalar al disco duro ha sido puppy 4.2.1, también he probado el live-cd.
Hasta ahora no me ha sido posible lograr que alguna de las muchas distros de linux que he puesto en prueba se conecte a internet por la vía de ese modem.
En el tópico en inglés que cité antes veo que en puppy han hecho un gran esfuerzo por derrotar el boicot de los fabricantes de hardware contra linux, entre ellos sony-ericsson que no da ningun soporte como no sea para Windows y Mac.

Sin embargo ni aún instalando los paquetes que aparecen en el post inicial del hilo mencionado logro ninguna conexión.

También noto que al utilizar puppy desde el live-cd reconoce el modem en cuestion como un dispositivo de almacenamiento ( ese modem tiene adicionada una memoria usb de 170 mb), pero en la misma versión instalada en el disco duro no reconoce ni ese ni ningún otro dispositivo usb.
Sé que estoy haciendo algo mal pero no sé qué exactamente.
¿¿¿ Alguien pudiera ayudarme ???

Para mi es esencial para hacer la migración Windows ->Linux la conexión a internet, si no la consigo , no habría manera de dejar a un lado a Windows.

A continuación incluyo el resultado que me da la herramienta devcon.exe de windows NT sobre la identificación del dispositivo md300:

Quote:
USB\VID_0FCE&PID_D0CF\3534460211209670 : SEMC WMC Composite Device
USB\VID_0FCE&PID_D0CF&MI_01\3534460211209670_01 : SEMC Reserved Interface
USB\VID_0FCE&PID_D0CF&MI_02\3534460211209670_02 : Dispositivo de almacenamiento masivo USB
USB\VID_0FCE&PID_D0CF&MI_03\3534460211209670_03 : Sony Ericsson MD300 Wireless Modem
USB\VID_0FCE&PID_D0CF&MI_05\3534460211209670_05 : Sony Ericsson MD300 Mobile Broadband Device Management
USB\VID_0FCE&PID_D0CF&MI_06\3534460211209670_06 : Sony Ericsson MD300 Mobile Broadband Ethernet Control
USB\VID_0FCE&PID_D0CF&MI_07\3534460211209670_07 : Sony Ericsson MD300 Mobile Broadband Command Interface (COM5)
USB\VID_0FCE&PID_D0CF&MI_09\3534460211209670_09 : Sony Ericsson MD300 Mobile Broadband Network Adapter (WDM)
8 matching device(s) found.

Gracias de antemano.
Back to top
View user's profile Send private message 
wow

Joined: 29 Jun 2006
Posts: 1035
Location: Peru

PostPosted: Wed 01 Jul 2009, 00:41    Post subject:  

Esto es de:Información acerca de MD300
Quote:
Sistemas operativos admitidos

* Mac OS X (compatible con descarga gratuita de terceros)
* Windows® XP (32/64 bit)
* Windows® 2000 (SP4)
* Windows® Vista (32/64 bit)

Controladores

* Controlador NDIS 5
* Microsoft XP WHQL certified drivers

_________________

Back to top
View user's profile Send private message 
g000g1e

Joined: 28 Jun 2009
Posts: 27
Location: here - there (aquí y allí)

PostPosted: Wed 01 Jul 2009, 11:54    Post subject:  

Gracias por la información Wow.
Quisieras informarme como utilizar esos datos en Puppy ?
Localizo el controlador en Windows y lo copio ? Dónde ( en cuál directorio? )
Cómo lo instalo ?
Te agradecría muchisimo alguna ayuda.
Back to top
View user's profile Send private message 
wow

Joined: 29 Jun 2006
Posts: 1035
Location: Peru

PostPosted: Wed 01 Jul 2009, 14:34    Post subject:  

... lo que queria decir era que no hay soporte para linux.
Aunque puedes intentar con los drivers para WinXP usando ndiswrapper (NetworkWizard>LoadModule>NdisWrapper):




Nota: no tengo hardware similar al tuyo, ni conexiones a redes inalambricas.

_________________

Back to top
View user's profile Send private message 
tataditiditin


Joined: 21 Jun 2009
Posts: 25

PostPosted: Wed 01 Jul 2009, 22:34    Post subject: Envío de mensaje a Sony Ericsson  

Hola,
Ya envié un mensaje a Sony Ericsson preguntando por qué no dan soporte a Linux, y cité el comentario de g000g1e en el mensaje para que sepan que el mundo Linux está necesitado de sporte de los fabricantes líderes del mercado (que como dicen, tienen un boicot contra Linux). Cuando me llegue la respuesta a mi correo les hago saber.

Saludos,

Rubén Mendoza
Back to top
View user's profile Send private message 
g000g1e

Joined: 28 Jun 2009
Posts: 27
Location: here - there (aquí y allí)

PostPosted: Thu 02 Jul 2009, 00:05    Post subject:  

Hola.
Gracias Ruben.
Te cuento que hace algunos días sostuve una "amable" conversación en ingles chapurreado mediante el chat con una asistente o asistonta de Sony-Ericsson. Terminó cuando le dije que sus productos eran "a shit's mountain".-
La situación en mi caso no durará mucho pues solamente estoy esperando a que terminé la suscripción con Comcel, en agosto, para buscar un servicio wireless que parece que no tiene las limitaciones del usb-modem en linux.
Entre tanto he tomado el asunto como un reto y he coleccionado todo (creo) lo que se ha publicado en la web sobre el tema.
Re-instalé puppy a partir de una iso virgen pues entendí que las modificaciones ("saves") del cd que venía utilizando como live interferían con la instalación en el DD.
Así logré inicialmente que reconociera y permitiera montar usbs incluyendo el de md300 que en principio lo reconoce como una unidad de almacenamiento. A continuación instalé un archivo en /etc/udev/rules.d que en muchas webs aparece como la solución (50-md300.rules)y modifique el wvdial.conf.
Ahora reconoce el modem lo detecta y !!! MARCA !!! pero no logra sostener la negociación ppp.
A contuación inserto el log del wvdial:

Quote:
-> WvDial: Internet dialer version 1.53
--> Initializing modem.
--> Sending: AT+CFUN=1
AT+CFUN=1
OK
--> Modem initialized.
--> Sending: ATDT*99***2#
--> Waiting for carrier.
ATDT*99***2#
~[7f]}#@!}!}!} }9}#}%B#}%}(}"}'}"}"}&} } } } }%}&X*}3cD7~
CONNECT
--> Carrier detected. Waiting for prompt.
~[7f]}#@!}!}"} }9}#}%B#}%}(}"}'}"}"}&} } } } }%}&X*}3c[08]Z~
--> PPP negotiation detected.
--> Starting pppd at Wed Jul 1 22:27:18 2009
--> pid of pppd: 9436
--> Disconnecting at Wed Jul 1 22:27:48 2009
--> The PPP daemon has died: PPP negotiation failed (exit code = 10)
--> man pppd explains pppd error codes in more detail.
--> I guess that's it for now, exiting
--> The PPP daemon has died. (exit code = 10)

------------------------------------------------------

Welcome to PupDial, written by Barry Kauler for Puppy Linux.

There is a configuration file, /etc/wvdial.conf, that is read by
PupDial, and changes made to any of the above boxes will be saved
to wvdial.conf when you click the 'Exit' or 'Connect' buttons.
Note, you can also manually edit wvdial.conf with a text editor.

Some computers have two modems, perhaps one on the motherboard,
and Puppy may have detected the wrong one. In that case, click the
'probe' button. If it is still wrong, manually edit wvdial.conf.

Y esto se repite una y otra vez...
Con esa información puede alguien ayudarme a encontrar el error ??
Gracias a todos por la atención que me han prestado y que me seguiran prestando..
g000g1e
Back to top
View user's profile Send private message 
bernard

Joined: 26 Jan 2009
Posts: 24

PostPosted: Thu 02 Jul 2009, 19:47    Post subject:  

Supongo que estarás utilizando un modem 3G. Para este tipo de dispositivos has de realizar una conexión PPP (como la de los antiguos modems). Por lo general con wvdialconf se realiza una configuración automática (busqueda del modem y creación del archivos de configuración) y con 'wvdial' se arranca (conecta). Tu problema parece más bien de identificación con el proveedor que de hardware/incompatibilidad con linux.

Tendrás que saber el APN que utiliza tu compañía proveedora, así como el nombre de usuario y la contraseña para acceder al servicio. Una vez los tengas, y puesto que parece la parte de detección del modem ya la has superado, le das al icono "Connect", eliges conectarte mediante una conexión GPRS (o algo así) y ahí introduces los datos en cuestión que te solicita.

Otra forma es cargar un terminal, escribir "wvdialconf wvdial.conf". Se pondrá a buscar el modem en los distintos puertos y cuando lo tenga te generará al archivo wvdial.conf en la ruta /etc/wvdial.conf. Puedes añadir ahí tanto el APN, como el usuario/contraseña y modificar las distintas opciones.

No tengo un puppy a mano ahora mismo, a si que todo lo que estoy diciendo es "a ojo".
Back to top
View user's profile Send private message 
g000g1e

Joined: 28 Jun 2009
Posts: 27
Location: here - there (aquí y allí)

PostPosted: Thu 02 Jul 2009, 20:39    Post subject: EUREKA ... EUREKA (LO ENCONTRE)  

Aqui me tienen queridos amigos: navegando con el seamonkey; no se imaginan el brinco qe pegue hasta el techo cuando vi que el ping a google respondia.
Todo fue resultado de su ayuda y de la investigacion a fondo en la web, algo de suerte y mucha audacia.
El modem respondia pero no conectaba , primer cambio : añadir el pin ( no tuvo ninguna influencia) , segundo cambiar el numero de telefono al cual marcaba:
En un script obtenido en la web supuestamente para conectar con comcel se incluia en el wvdial.conf el numero *99***2# , pero al observar en windows el archivo de excel anexo al programa wireless manager el numero que alli figura es *99#, asi lo cambie y !!! milagro !!! me conecte.... pero nada de navegacion.. algo faltaba...
en el ifconfig aparece que el modem queda ligado a una direccion remota 10.64.64.64; la investigacion en la web me indicaba que cambiando el contenido de dyn_addr en no se cual directorio se desatascaba de esa direccion que no existe realmente (supuestamente es una direccion reservada para uso interno). Nada.. no funcionaba... en otra web decian que habia que establecer como route default esa direccion: nada no funciono, pero me dio luces...
Navegue hasta etc/ppp y mire todos los archivos; encontre el pppoe.conf encontre las lineas :
# Make the PPPoE connection your default route. Set to_
#DEFAULTROUTE=no if you don't want this.
DEFAULTROUTE=yes
Cambie por DEFAULTROUTE=no y .... nada...
entonces siguiendo la intuicion en el rxvt teclee "route del 10.64.64.64" y a contuacion ping **** y aqui estoy....
Disculpen por la extension de este post pero me pongo habla-mier.. cuando algo me sale bien, ademas quiza le sirva a algun otro novato en el futuro.
Nuevamente gracias y ... "adios Window$ nos vemos en las curvas" (expresion colombiana para decir alcanzame si puedes...)
p.s. Aun no logro dominar el teclado por eso la ausencia de tildes...ustedes perdonaran...
Back to top
View user's profile Send private message 
tataditiditin


Joined: 21 Jun 2009
Posts: 25

PostPosted: Thu 02 Jul 2009, 20:57    Post subject:  

Entonces, problema solucionado.

Aquí está la respuesta al mensaje que envié a Sony Ericsson, quieren que hable a Sony Ericsson Latin America, y no a Sony Ericsson España.

Quote:
Estimado Sr. Mendoza:


Gracias por ponerse en contacto con el Servicio de Atención al Cliente de Sony Ericsson. En relación con su consulta número 73574896 recibida en Sony Ericsson España, le informamos que al tratarse de un cliente situado en un país diferente, nuestra recomendación es que su consulta la dirija a la delegación Sony Ericsson correspondiente a su ubicación.
Debe dirigirse a la página Web de Sony Ericsson seleccionar país y región y realizar su consulta en la sección "Contacte con Nosotros".

Contacte de nuevo con nosotros para cualquier duda o consulta que pudiera surgirle, o visite nuestra web www.sonyericsson.es para mayor información y soporte de nuestros productos y servicios.


Atentamente,



David Seoane

Sony Ericsson Call Center

Email: questions.es@support.sonyericsson.com

Phone : 902 180 576


Saludos,

Rubén Mendoza
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [9 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Usuarios de habla Hispana
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0924s ][ Queries: 13 (0.0167s) ][ GZIP on ]