Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 22 Oct 2014, 01:33
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Trouble w. Open Office SFS - icons link dead mount - SOLVED
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
polocanada

Joined: 21 Mar 2008
Posts: 4

PostPosted: Sun 28 Jun 2009, 11:56    Post_subject:  Trouble w. Open Office SFS - icons link dead mount - SOLVED  

SOLVED

_------------------


Downloaded Open Office to home, mounted fine, created icons on desktop OK, started worked fine. After reboot not working anymore.

Why after rebooting the mount of Open Office is disconnected again. The newly created icons on desktop are dead with exclamation sign.

Clicking on SFS file would mount it but in different folder, so links and icons on desktop still not working. I clicked SFS again to unmount.

Ok, So I went then to the BootManager and saw Open Office again not selected in the right pane, again sitting in left pane. Why did it disappeared from the right pain selection.

Then I saw this note at the bottom about ignoring if file name is 420. I remember reading somewhere in forums somebody added 420 to SFS.

So I went ahead and added 420 to the open office SFS file.

Rebooted. Damn. It didn't reboot. It stopped at loading the SFS modules and something it failed to created Layered file system. And then a few errors and stopped booting.

Bad idea. So I booted from CD and went to change the Open office SFS file name by removing the 420 from file name.

Rebooted. It said something about re-creating layered file system?? Can't remember. Anyway.. everything is OK, can boot into Puppy again.

But what to do with Open Office links/icons on desktop. And why it doesn’t auto mount at boot.

Could it be I have the problems above because i have just about 180 MB free puppy space?

I am personally fine with the amount of space, since I am using Puppy as a secondary system on my machine, now since I am still learning linux.

This is a track, for linux newbies. Takes lots of patience. I can't even properly speak Linux language Smile

Thanks for any word of advice.

----------------

OK solved.

There should be a better explanation for newbies that there is something like Full and Frugal installation of Puppy. When I installed Puppy on my drive, I can't remember there was an option to select.

Anyway, seems like I have full installation, the puppy SFS file is only about 98 MB.

There is not even a clear way of telling if it's frugal or full... according to countless pages I already read about this.

I went to these sites and downloaded the PET package of Open Office 3 and now all works.

http://www.leprichaunproductions.com/evil20071/pet_packages/puppy_4/

http://www.murga-linux.com/puppy/viewtopic.php?t=41985

Cheers.

What a track this linux. But trully fun.
Back to top
View user's profile Send_private_message 
drblock2

Joined: 19 Jan 2009
Posts: 141

PostPosted: Sun 28 Jun 2009, 15:16    Post_subject: Trouble w. Open Office SFS - icons link dead mount - SOLVED
Sub_title: Open Office SFS - printing and desktop icons
 

Installing OO3.1 from the sfs file in /mnt/home trashes CUPS is a problem.

It's unfortunate, but true! OO3.1 is super-fast under Puppy 4.2, but that doesn't help much if you can't print (from OO3.1 or any other application).

As Goxan notes on another thread,

<http://www.murga-linux.com/puppy/viewtopic.php?t=23982>

removing OpenOffice-3.1.sfs from /mnt/home and rebooting allows CUPS to recover. The following solution worked for me:

1. Move the offending sfs file to a new directory. I used /root/openoffice3.1, but any directory should do.

2. Reboot.

3. Set up your network connection and start pnethood to make sure that you can access the printer.

4. In "set up CUPS printing" (click Puppy Setup icon), choose your printer (manage printers), click on it and (under maintenance) cancel all print jobs, pause the printer and "resume" it. Try printing a test page from the CUPS manager. If this is successful, you should now be able to print from other applications, assuming, of course, that they allowed printing before you installed OpenOffice-3.1. Try printing a test document from Leafpad to make sure.

5. Using ROX, open the directory where you put OpenOffice-3.1.sfs (in my case, /root/openoffice3.1). Click on the icon for the .sfs-file and ROX will unsquash it and mount if for you. In the subdirectory, /opt/openoffice.org3/program, you will find the program icons which you can click on directly or drag to the desktop.

Now, you should be able to print from OpenOffice as well.

Note that when you reboot, the desktop icons will be orphaned with the triangle and "!". The regular icons will reappear after the squash file is mounted.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0505s ][ Queries: 11 (0.0052s) ][ GZIP on ]