Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 01 Sep 2014, 10:16
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Request for Gyachi PET
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [14 Posts]  
Author Message
ragaman

Joined: 14 Jan 2007
Posts: 186

PostPosted: Tue 16 Jun 2009, 06:47    Post subject:  Request for Gyachi PET  

Recently, older versions of Gyachi Yahoo Messenger Chat client cannot connect to YM anymore. Gyachi 1.1.71 on Ubuntu however, connects without any problem. Is there a dotPet of the latest Gyachi available for Puppy 4.x? Can kind souls who have the time and the knowledge create a Pet for this application?

Thanks.
Back to top
View user's profile Send private message 
gposil


Joined: 06 Apr 2009
Posts: 1305
Location: Stanthorpe (The Granite Belt), QLD, Australia

PostPosted: Tue 16 Jun 2009, 08:03    Post subject:  

You can get it here ...http://www.gposil.com/pets/gyachi-1.1.7.pet
_________________
Dpup Home
Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
ragaman

Joined: 14 Jan 2007
Posts: 186

PostPosted: Tue 16 Jun 2009, 21:56    Post subject:  

Wow! That was fast! Thanks a million, gposil.

Nice informative website too. Bookmarked!
Back to top
View user's profile Send private message 
ragaman

Joined: 14 Jan 2007
Posts: 186

PostPosted: Tue 16 Jun 2009, 23:43    Post subject:  

Installed the PET you provided. It had three missing dependencies namely: libltdl.so.7; libxcb-render-util.so.0; and libxcb-render-so.0. Solved this by copying those dependencies (more recent versions) from my Ubuntu box and then create symbolic links to above version.

Gyachi is now running well and connected.

Thanks again.
Back to top
View user's profile Send private message 
gposil


Joined: 06 Apr 2009
Posts: 1305
Location: Stanthorpe (The Granite Belt), QLD, Australia

PostPosted: Tue 16 Jun 2009, 23:50    Post subject:  

Great...i'll include those depends in an updated pet and upload it...not everyone's Puppy is the same... Smile
_________________
Dpup Home
Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
Runt

Joined: 23 May 2009
Posts: 7

PostPosted: Wed 24 Jun 2009, 10:20    Post subject: Could not install  

Hi, I installed in Puppy 4.2.1 but was unable to start Gyachi. This is the PetGet dependency log:

These dependencies required by gyachi-1.1.7 package are missing:
File /usr/lib/libgyachi.so has these missing library files:
libgio-2.0.so.0 libxcb-render-util.so.0 libxcb-render.so.0 libltdl.so.7
File /usr/lib/gyachi/plugins/libgyachigtkspell.so has these missing library files:
libgtkspell.so.0 libgio-2.0.so.0 libxcb-render-util.so.0 libxcb-render.so.0
File /usr/lib/gyachi/plugins/libgyachipulseaudio.so has these missing library files:
libgio-2.0.so.0 libxcb-render-util.so.0 libxcb-render.so.0 libpulse-simple.so.0 libpulse.so.0
File /usr/lib/gyachi/plugins/libgyachiblowfish.so has these missing library files:
libgio-2.0.so.0 libxcb-render-util.so.0 libxcb-render.so.0 libltdl.so.7 libgio-2.0.so.0 libxcb-render-util.so.0 libxcb-render.so.0 libltdl.so.7
File /usr/lib/gyachi/plugins/libgyachilibnotify.so has these missing library files:
libnotify.so.1 libdbus-glib-1.so.2 libgio-2.0.so.0 libxcb-render-util.so.0 libxcb-render.so.0 libdbus-1.so.3
File /usr/lib/gyachi/plugins/libgyachimcrypt.so has these missing library files:
libgio-2.0.so.0 libxcb-render-util.so.0 libxcb-render.so.0 libmcrypt.so.4
File /usr/lib/gyachi/plugins/libgyachigpgme.so has these missing library files:
libgio-2.0.so.0 libxcb-render-util.so.0 libxcb-render.so.0 libgpgme.so.11 libgpg-error.so.0
File /usr/lib/gyachi/plugins/libgyachialsa.so has these missing library files:
libgio-2.0.so.0 libxcb-render-util.so.0 libxcb-render.so.0
File /usr/libexec/gyachi/gyachi-webcam has these missing library files:
libltdl.so.7 libgio-2.0.so.0 libxcb-render-util.so.0 libxcb-render.so.0 libjasper.so.1 libgio-2.0.so.0 libxcb-render-util.so.0 libxcb-render.so.0 libltdl.so.7
File /usr/libexec/gyachi/gyachi-upload has these missing library files:
libltdl.so.7 libgio-2.0.so.0 libxcb-render-util.so.0 libxcb-render.so.0 libjasper.so.1 libv4l1.so.0 libv4l2.so.0 libv4lconvert.so.0 libgio-2.0.so.0 libxcb-render-util.so.0 libxcb-render.so.0 libltdl.so.7
File /usr/bin/gyachivoice has these missing library files:
libltdl.so.7 libgio-2.0.so.0 libxcb-render-util.so.0 libxcb-render.so.0 libgio-2.0.so.0 libxcb-render-util.so.0 libxcb-render.so.0 libltdl.so.7
File /usr/bin/gyachi has these missing library files:
libltdl.so.7 libgio-2.0.so.0 libxcb-render-util.so.0 libxcb-render.so.0 libgio-2.0.so.0 libxcb-render-util.so.0 libxcb-render.so.0 libltdl.so.7

The PETget package manager does not know what package/s has/have these libraries.

Is there a md5sum so I can check to make sure it downloaded OK? I know only little about dependencies etc, but is there a way for me to 'repair' the install? Thanks!
Back to top
View user's profile Send private message 
gposil


Joined: 06 Apr 2009
Posts: 1305
Location: Stanthorpe (The Granite Belt), QLD, Australia

PostPosted: Wed 24 Jun 2009, 11:00    Post subject:  

This should be all the dependencies... Smile
gyachi-p421-deps.pet
Description  Gyachi Dependencies
pet

 Download 
Filename  gyachi-p421-deps.pet 
Filesize  1.18 MB 
Downloaded  288 Time(s) 

_________________
Dpup Home
Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
Runt

Joined: 23 May 2009
Posts: 7

PostPosted: Wed 24 Jun 2009, 14:08    Post subject: Dependency dependencies  

Hi gposil.

OK, I installed gyachi-p421-deps.pet, and apparently the dependencies have dependencies! PetGet says this:

These dependencies required by gyachi-p421-deps package are missing:
File /usr/lib/libgio-2.0.so.0.1800.2 has these missing library files:
libselinux.so.1
File /usr/lib/libnotify.so.1.1.3 has these missing library files:
libdbus-1.so.3
File /usr/lib/libdbus-glib-1.so.2.1.0 has these missing library files:
libdbus-1.so.3
File /usr/lib/gio/modules/libgiogconf.so has these missing library files:
libgconf-2.so.4 libselinux.so.1
File /usr/lib/gio/modules/libgvfsdbus.so has these missing library files:
libgvfscommon.so.0 libdbus-1.so.3 libselinux.so.1
File /usr/lib/gio/modules/libgioremote-volume-monitor.so has these missing library files:
libdbus-1.so.3 libgvfscommon.so.0 libselinux.so.1

The PETget package manager does not know what package/s has/have these libraries.

Gyachi still isn't running when clicked. Thanks for your help so far...now, what can I do about this?! Smile
Back to top
View user's profile Send private message 
gposil


Joined: 06 Apr 2009
Posts: 1305
Location: Stanthorpe (The Granite Belt), QLD, Australia

PostPosted: Wed 24 Jun 2009, 18:11    Post subject:  

Lets hope this is it...have you got devx installed...
gyachi-dbus.pet
Description  More deps
pet

 Download 
Filename  gyachi-dbus.pet 
Filesize  323.98 KB 
Downloaded  232 Time(s) 

_________________
Dpup Home
Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
Runt

Joined: 23 May 2009
Posts: 7

PostPosted: Wed 24 Jun 2009, 21:27    Post subject:  

Getting closer Smile Gyachi started up, but didn't connect!

Is devx part of the official Puppy 4.2.1? I didn't install it. I tried Pfind on 'devx' and there were no hits.

PetGet:
These dependencies required by gyachi-dbus package are missing: File /usr/lib/libgconf-2.so.4.1.5 has these missing library files: libORBit-2.so.0

Gyachi had these errors:
** Plugin '/usr/lib/gyachi/plugins/libgyachipulseaudio.so' could not be loaded because of an error:file not found
** Location: /usr/lib/gyachi/plugins/libgyachipulseaudio.so

** Plugin '/usr/lib/gyachi/plugins/libgyachilibnotify.so' could not be loaded because of an error: An error occurred initiating the plugin.
System Requirements: libnotify
** Location: /usr/lib/gyachi/plugins/libgyachilibnotify.so

** Plugin '/usr/lib/gyachi/plugins/libgyachimcrypt.so' could not be loaded because of an error: file not found
** Location: /usr/lib/gyachi/plugins/libgyachimcrypt.so

Connect errors:
** Could not connect to Yahoo! [ CONNECT ERROR: Could not connect to server: scs.msg.yahoo.com, errno: 111 ] **

** Could not connect to Yahoo! [ CONNECT ERROR: Could not connect to server: scs.msg.yahoo.com, errno: 4 ] **

Thanks for all your help, I'm a tough client!
Back to top
View user's profile Send private message 
gposil


Joined: 06 Apr 2009
Posts: 1305
Location: Stanthorpe (The Granite Belt), QLD, Australia

PostPosted: Wed 24 Jun 2009, 23:13    Post subject:  

First off, you can find devx here...http://distro.ibiblio.org/pub/linux/distributions/puppylinux/sfs_modules-4/devx_421.sfs

Secondly...the other depends shouldn't stop gyachi working, the plugins that it is looking for are not in Puppy...

Thirdly the connection problem is not a gyachi problem, it is yahoo...try a different server and it should fix problem

_________________
Dpup Home
Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
Runt

Joined: 23 May 2009
Posts: 7

PostPosted: Thu 25 Jun 2009, 00:35    Post subject:  

It's working! Thanks very much for your patience and expertise Smile
Back to top
View user's profile Send private message 
ragaman

Joined: 14 Jan 2007
Posts: 186

PostPosted: Thu 25 Jun 2009, 03:15    Post subject:  

The right server is cn.scs.msg.yahoo.com. So far it's the only one that works.
Back to top
View user's profile Send private message 
gposil


Joined: 06 Apr 2009
Posts: 1305
Location: Stanthorpe (The Granite Belt), QLD, Australia

PostPosted: Thu 25 Jun 2009, 03:18    Post subject:  

There have been real problems with the yahoo servers, I can only get one to work even with Kubuntu
_________________
Dpup Home
Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
Display posts from previous:   Sort by:   
Page 1 of 1 [14 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0888s ][ Queries: 12 (0.0207s) ][ GZIP on ]