Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 21 Apr 2014, 04:15
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Für deutschsprachige Anhänger
Boot Problem: Kernel Panic - no syncing
Moderators: MU
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [9 Posts]  
Author Message
brin

Joined: 13 Jun 2009
Posts: 15

PostPosted: Sat 13 Jun 2009, 08:16    Post subject:  Boot Problem: Kernel Panic - no syncing
Subject description: Noob bittet Rookies um Hilfe
 

EDIT: Ursache für Kernel Panic gefunden - tritt (leider immer wieder) beim Einlesen des pup_save-files auf!
Eröffne neuen Thread "Boot Problem: pup_save-file crasht boot prozess"


Liebe Rookies,
ich noob hab ein Riesenproblem:
Beschäftige mich schon mehrere Nächte mit Puppy - einfach Klasse!

Hatte es auf meinem alten PIII / 1GHz (ohne USB boot im BIOS) mit wakepup Diskette EINMAL vom USB Stick gestartet, lief alles super, in meinem Übermut hatte ich auch email eingerichtet, das überraschenderweise sofort lief und mir aber ALLE mails der letzen Jahre vom Server gelöscht hat Sad

So weit so gut - leider habe ich dann verschlimmbessert und was anderes auf den USB Stick gespielt, und seit ich dann das ursprüngliche seamonkey.iso oder alternativ meine Backupfiles auf den USB gepackt hab, krieg ich im booten (ca. 4 Zeile) immer:

"Kernel panic - not snycing: Attempted to kill init!"

und CapsLock und ScrollLock blinken und ich muß kalt resetten. Sad

Dachte erst es hätte was mit dem filesystem am USBstick zu tun, weil ich das .iso mit Poweriso (oder war's Isobuster) auf den Stick entpackt hab und der Stick dann für wakepup wie eine CD-Laufwerk ausgesehen hat, aber nach mehrmaligem formatieren, wurde es auch nicht besser.

Außerdem hab ich's dann mit BootCD versucht, gleiche Fehlermeldung!!

Und dadurch schaffe ich es auch nicht, von der HD zu booten. Um HD boot zu installieren, braucht man ja ein lauffähiges Puppy, oder?

Liebe Spezis, bitte denkt mal nach, was bei mir schief laufen könnte und wie man das in Ordnung bringt und sagt es mir! Smile

Mir sind leider die Ideen ausgegangen.... Sad

Danke und l.G

da brin

Last edited by brin on Tue 16 Jun 2009, 18:49; edited 3 times in total
Back to top
View user's profile Send private message 
rhadon


Joined: 27 Mar 2008
Posts: 1291
Location: Germany

PostPosted: Sun 14 Jun 2009, 03:29    Post subject:  

Hallo brin,

der einfachste Weg ist, ein Puppy von CD zu starten (kann auch ein anderer Rechner sein), und über Start/Menü -> Setup -> Puppy universal installer das Ganze auf einen USB-Stick zu installieren.

2 Dinge fallen mir noch dazu ein: zum einen die Bootreihenfolge im BIOS, zum anderen muss beim USB-Stick "Boot flag" gesetzt sein, z.B. mit Start/Menü -> System -> GParted, in der Spalte "Flags" muss "boot" stehen, ansonsten Partition -> Manage Flags, Häkchen bei "Boot".

Zu den Prgs, die du da verwendest, kann ich dir leider nicht viel sagen.

Rolf

Edit: Meinst du mit wakepup das Puppy Derivat oder den Menüpunkt "Wakepup create boot floppy"? Welches Puppy verwendest du genau?

_________________
Ich verwende "frugal", und das ist gut so. Wink
Raspberry Pi without Puppy? No, thanks.
Back to top
View user's profile Send private message 
brin

Joined: 13 Jun 2009
Posts: 15

PostPosted: Sun 14 Jun 2009, 07:31    Post subject:  

Servus, Rolf!

Danke f.d. reply:

rhadon wrote:

der einfachste Weg ist, ein Puppy von CD zu starten


ROTFL Smile
Ja, genau DAS geht eben (auch) nicht <verzweifel>

aber das mit einem anderen Rechner werd ich nochmal probieren.


rhadon wrote:

Edit: Meinst du mit wakepup das Puppy Derivat oder den Menüpunkt "Wakepup create boot floppy"? Welches Puppy verwendest du genau?


Da mir wichtig war, die Möglichkeit (auf dem Rechner OHNE BIOS Untestützung für USB-boot) Puppy von USB zu starten, hab ich mir das wakepup floppy image ausm Forum gezogen (wkpup2x-02.img)

ZUERST hatte ich noch rumgespielt und mit "Live Usb Helper" gparted-live-0.4.5-3.zip auf dem USB Stick bootable installiert.
Evtl. war dadurch der USBstick bootbar, auf den ich dann die puppy-4.2.1-k2.6.25.16-seamonkey.iso mit ultraiso entpackt habe.
Denn SO bootete puppy dann via wakepup diskette vom USB stick.

Dann hab ich wieder blöd rumgespielt, weil mich prinzipiel die Möglichkeit fasziniert, von USB zu booten, obwohl das BIOS das nicht unterstützt.

Und dann hatte ich eben den oben beschriebenen Fehler: Kernel panic!
Wobei der Zugriff auf den USB stick aber stattfand, den die kernel panic kam erst nach 4 mal grünes "Done" (rechts)

Ich hab dann auf meinen nächtlichen Streifzügen nochwas über eine Eigenart von GRUB gefunden, dem werde ich nachgehen, wenn Deine Tipps mit Zweitrechner und flag nix fruchten.


EDIT: ES WAR WAS ANDERES, aber Du hast mich auf die richtige Fährte gestoßen:

Da am neueren Rechner der Start von CD in genau demselben Modus mißlungen ist, fiel mir auf, dass der Bootprozess auf meine pup_save-***.2fs zugreifen wollte, die auf dem schon eingesteckten USB stick war.
Stick ausgesteckt, Boot von CD funzt!
Jetzt hoffe ich bloß, dass meine pup_save-***.2fs nicht hin ist, weil da is meine gesamte email der letzen Jahre drin (hoffentlich!)

Dann hab ich vom laufenden puppy wie von Dir emfohlen, puppy auf dem USB Stick installiert, dabei mußte ich (wie ebenfalls von Dir vermutet) das Bootflag gesetzt werden.

NEUES PROBLEM:

Der andere Rechner bootet direkt von USB, nur bleibt hier jedesmal der bootprozess stehen, weil die Tastatur "abstürzt" (boot von CD ging ja).
d.h. ich kann die geforderten Eingaben nicht quittieren (Wenn ich die powertaste am Rechner drücke, meldet sich puppy mit "shutdown" also dürfte nicht der Prozess abgestürzt sein.

Hast Du dazu auch eine Idee?

Jetzt Erstmal VIELEN Dank für Deine Hilfe und schönen Sonntag (Bei uns is Badewetter Smile

l.G. brin
Back to top
View user's profile Send private message 
rhadon


Joined: 27 Mar 2008
Posts: 1291
Location: Germany

PostPosted: Sun 14 Jun 2009, 15:47    Post subject:  

Hast du evtl. beim/nach dem installieren deine Einstellungen in einer pupsave-Datei gespeichert und der andere Rechner hat eine andere Tastatur?

Rolf

_________________
Ich verwende "frugal", und das ist gut so. Wink
Raspberry Pi without Puppy? No, thanks.
Back to top
View user's profile Send private message 
brin

Joined: 13 Jun 2009
Posts: 15

PostPosted: Sun 14 Jun 2009, 17:07    Post subject:  

hi, Rolf!

rhadon wrote:
Hast du evtl. beim/nach dem installieren deine Einstellungen in einer pupsave-Datei gespeichert und der andere Rechner hat eine andere Tastatur?
Rolf


Hm. Ja und Nein.
Wie gesagt bin ich mit CD und USB stick zum anderen Rechner gegangen und der hat genau wie der erste gezickt. Dann kam mir der Verdacht, das es eben am pusave liegen könnte (das von der alten Installation noch auf dem USB Stick war), hab den Stick abgesteckt, dann ging boot von der CD, dann hab ich auf USB neu installiert, das alte pupsave in *.bak umbehannt und in einem neuen pupsave gespeichert. Und DANN hatte ich beim boot vom USBstick das Tastaturproblem. Wobei der zweite Rechner eh (noch) nicht wichtig ist.

Prinzipiell bin ich einen Schritt (Ursache lokalisiert) weiter und tret dennoch auf der Stelle:
mit der pupsave vom ersten Rechner hab ich am ersten Rechner das Kernel panic Problem....

Apropos pupsave: gibts ein tool, mit dem ich den Inhalt extrahieren kann?

wieder mal Danke und

l.G.

da brin
Back to top
View user's profile Send private message 
rhadon


Joined: 27 Mar 2008
Posts: 1291
Location: Germany

PostPosted: Mon 15 Jun 2009, 02:55    Post subject:  

Hallo da brin,

mein erster, vielleicht völlig überflüssiger Rat, mach als erstes eine Kopie von deiner pup_save-Datei, die wichtige Daten enthält Wink

Beim booten sucht Puppy auf allen angeschlossenen Medien nach pupsave-Dateien.
Bei einer gefundenen Datei wird diese automatisch geladen. Findet es mehrere, bekommst du ein Auswahlmenü, zusätzlich mit der Option "0", d.h.ohne save-Datei zu starten. Du kannst z.B. zusätzlich eine leere Datei (nimmt keinen Platz weg) z.B. mit dem Namen pup_save-dummy.2fs erstellen, (die natürlich bei Aufruf nicht funktioniert (Kernel panic), dafür kannst du nun auswählen, ob booten mit oder ohne save-Datei.

Eine nicht verwendete, unverschlüsselte pup_save-Datei kannst du ganz leicht einsehen, oder Dateien daraus extrahieren: im ROX-Dateimanager einfach mit links anklicken, die Datei wird gemountet. Später nochmal zum unmounten draufklicken.

Ich hoffe, das hilft, dein Problem zu lösen, oder wenigstens noch mehr einzugrenzen.

Rolf

_________________
Ich verwende "frugal", und das ist gut so. Wink
Raspberry Pi without Puppy? No, thanks.

Last edited by rhadon on Tue 07 Jul 2009, 08:11; edited 1 time in total
Back to top
View user's profile Send private message 
brin

Joined: 13 Jun 2009
Posts: 15

PostPosted: Mon 15 Jun 2009, 11:55    Post subject:  

rhadon wrote:
Hallo da brin,

mein erster, vielleicht völlig überflüssiger Rat, mach als erstes eine Kopie von deiner pup_save-Datei, die wichtige Daten enthält Wink

Beim booten sucht Puppy auf allen angeschlossenen Medien nach pupsave-Dateien.
Bei einer gefundenen Datei wird diese automatisch geladen. Findet es mehrere, bekommst du ein Auswahlmenü, zusätzlich mit der Option "0", d.h.ohne save-Datei zu starten. Du kannst z.B. zusätzlich eine leere Datei (nimmt keinen Platz weg) mit dem Namen pup_save-dummy.2fs erstellen, (die natürlich bei Aufruf nicht funktioniert (Kernel panic), dafür kannst du nun auswählen, ob booten mit oder ohne save-Datei.

Eine nicht verwendete pup_save-Datei kannst du ganz leicht einsehen, oder Dateien daraus extrahieren: im ROX-Dateimanager einfach mit links anklicken, die Datei wird gemountet. Später nochmal zum unmounten draufklicken.

Ich hoffe, das hilft, dein Problem zu lösen, oder wenigstens noch mehr einzugrenzen.

Rolf


Servus, Rolf -
bin wieder ein Stück weiter und schreibe schon aus puppy 4.21, von USB gebootet. Very Happy
Inzwischen hab ich Gewissheit, der Übeltäter war/ist meine erste, wichtige (und zum Glück gesicherte) pup_save-Datei!
Die verursacht die kernel panic und den Totalabsturz während des bootVorgangs.
Ich glaube auch zu wissen, wie ich die pupsave in meiner Blödheit beschädigt haben könnte: Anscheindend hab ich sie ursprünlgich mit 4.21 angelegt,
Dann hatte ich irrtümlich mal 4.20 irgendwas auf dem Stick, da kam die kernel panic. Interessanterweise konnte ich mit dem ROX browser hineinschauen (Danke für den Tip!) hab gleich versucht, die Dateien mit der aktuellen pupsav mergen - hat aber nix gebracht, die gemergte pupsave ließ sich auch nicht booten Sad

JETZT hab ich wieder 4.21 drauf und kann mit ROX NICHT mehr auf die "alte" pupsave zugreifen Sad(( "failed mounting or unmounting", evtl. gibt sich das wieder nach einem neustart...

Darf ich Dir bitte noch 2 Fragen stellen:
Wenn ich die pupsave nochmal aufkriege, weißt Du, WOHIN das seamonkey mailprogramm meine mails geschrieben haben kann (evtl könnte ich sie von dort wieder ins mailprogramm importieren.

Und, ist zwar in diesem thread O.T.: was muß ich tun, damit nicht bei jedem booten der Xorg wizard gestartet wird? Der bietet mir mal max 640x480, dann wieder 1280x1024, dann mal andere Auflösungen an.
Auch wenn ich 100 mal den Save Button am Desktop drücke.
Netzwerkeinstellungen, Tastatur, Maus bleiben, aber der Xorg wizard startet jedes Mal.

Wiedermal Riesen DANKE für Deinen support

da brin
Back to top
View user's profile Send private message 
rhadon


Joined: 27 Mar 2008
Posts: 1291
Location: Germany

PostPosted: Tue 16 Jun 2009, 03:32    Post subject:  

Hallo da brin,

ich kenne mich mit Seamonkey nicht so aus, da ich meist Opera verwende, auch für meine mails. Ich denke jedoch, was du suchst liegt unterhalb von /root/.mozilla . Der "." bezeichnet einen verborgenen Ordner. Zum sichtbar machen, in ROX auf das Auge klicken.

Keine Ahnung, was mit deinem Xorgwizard schief läuft.. Der erscheint normalerweise nur, wenn du ohne pup_save-Datei startest, oder wenn du ihn manuell aufrufst. Die entsprechenden Werte (xorg/vesa, Auflösung) werden dann genauso in der pup-save-Datei gespeichert, wie Tastatur, Maus, Netzwerkkarte usw,

Hoffe,das bringt dich wieder ein Stückchen weiter.

Rolf
Back to top
View user's profile Send private message 
brin

Joined: 13 Jun 2009
Posts: 15

PostPosted: Tue 16 Jun 2009, 19:16    Post subject:  

Servus Rolf!

rhadon wrote:
Ich denke jedoch, was du suchst liegt unterhalb von /root/.mozilla


O.K., sollte ich je wieder in die initiale pup_save kommen, such ich nach mozilla - guter Tip!

rhadon wrote:

Keine Ahnung, was mit deinem Xorgwizard schief läuft.. Der erscheint normalerweise nur, wenn du ohne pup_save-Datei startest


Ja, und JETZT beißt sich die Katze in den Schwanz:



Auf Rechner Nr. 1 (mit Matrox Grafik - vielleicht liegts daran) hab ich die geschilderten Probleme. Inzwischen weiß ich: wenn ich die pup_save lösche, wird wider brav gebootet. Dann konigurier ich alles, muß den Xorgwizard mehrmals starten bzw. die .conf editieren, damit ich nicht mit 640x480 bei 60Hz arbeiten muß, kein Problem. Netzwerk etc. kofigurieren, alles bestens, runterfahren, pup_save speichern, zumeist mit eigenem namen (pup_save-bRIn.2fs).

Beim nächsten boot: Hänger, kerne panic, pup_save löschen geht wieder. die ganze Chose von vorn....

Nun kommts aber:
Hab auf einer zweiten, älteren Maschine (P3 500MHz, 256MB RAM, 4GB HD) versucht, Puppy von der live CD auf die frisch ext2 formatierte HD zu installieren. Wie gehabt alles konfiguriert, reboot von HD - KERNEL PANIC!!!

Ich konnte hier das pup_save file nun aber nicht mehr löschen, weil auch beim boot von der live CD IMMER versucht wird, die pup_save zu laden Sad((
In Zukunft werde ich mir wirklich wie von die vorgeschlagen, als erstes einen pup_save dummy ins Verzeichnis kopieren.

Da ich vermute, dass früher oder später auch andere meine Probs haben könnten, eröffne ich jetzt den neuen Thread "Boot Problem: pup_save-file crasht boot prozess"
Falls ich mit Deiner Unterstützung dem Rätsel auf die Schliche komme, wird die Lösung, so hoffe ich, schneller gefunden.

Also bitte - wenn's nicht zuviel verlangt ist, im nächsten Thread antworten!?

Danke, Rolf - bis gleich Smile

brin
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [9 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Für deutschsprachige Anhänger
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0830s ][ Queries: 11 (0.0070s) ][ GZIP on ]