Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Oct 2014, 16:59
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
HP Deskjet 722C
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
elcolto13

Joined: 09 Jun 2009
Posts: 69
Location: Southwest Pennsylvania (USA)

PostPosted: Wed 10 Jun 2009, 00:00    Post_subject:  HP Deskjet 722C
Sub_title: Solved: Now Printing
 

I'm having difficulties trying to install my printer. I just installed Puppy today and would really appreciate some comprehensive help with this.

I went into the CUPS setup and entered my Printer Name, Location, and Description.

I chose the correct device. Along with its make.

I can't find the correct driver (For HP Deskjet 722C) but I did try those closest to it.

Then it says that it was installed successfully, yet every time I try and print, I get zilch.



Thanks in advance.

Edited_time_total
Back to top
View user's profile Send_private_message 
Patriot


Joined: 15 Jan 2009
Posts: 734

PostPosted: Wed 10 Jun 2009, 05:00    Post_subject: Re: HP Deskjet 722C
Sub_title: Need Help Installing
 

Hmmm .....

Get the pnm2ppa tar archive for HP700 series provided by rcrsn51 here.

To better understand CUPS, read here.

Remember:
- Puppy 4.2 comes with CUPS 1.4b2
- Puppy 4.2.1 comes with CUPS 1.3.10
- Previous puppy mostly comes with CUPS 1.1.23

Rgds
Back to top
View user's profile Send_private_message 
disciple

Joined: 20 May 2006
Posts: 6449
Location: Auckland, New Zealand

PostPosted: Wed 10 Jun 2009, 05:25    Post_subject:  

EDIT - beaten to it Smile But surely they don't need to know about the CUPS versions Patriot? Is it that broken in the latest puppies?

You need pnm2ppa. I'm not sure if there is a proper .pet package for it (to install with just one click), as I only did a quick search on the forum for it. Unless there is a .pet you should install it from this thread
this may also help.

_________________
DEATH TO SPREADSHEETS
- - -
Classic Puppy quotes
- - -
Beware the demented serfers!
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9203
Location: Stratford, Ontario

PostPosted: Wed 10 Jun 2009, 08:56    Post_subject:  

Quote:
But surely they don't need to know about the CUPS versions Patriot? Is it that broken in the latest puppies?

Not broken, changed. There have been significant changes to CUPS since 1.1.23. Some drivers like PNM2PPA interact with CUPS in an ad hoc manner that must be modified to work correctly with the new versions.
Back to top
View user's profile Send_private_message 
hondasid


Joined: 31 Oct 2008
Posts: 259
Location: Perry, OK

PostPosted: Wed 10 Jun 2009, 09:30    Post_subject:  

wait a sec patriot. I run 4.2.1 and it only has 1.3.1. Colt had 1.1.23 on his 4.12, but then upgraded to 1.3.3 via the package manager. He then uninstalled cups via the package manager and re-installed 1.1.23 via a .pet on ibilio. how can both of our puppies be one version behind on cups?
_________________
Instead of looking out Windows, I'm playing with my Puppy.
Back to top
View user's profile Send_private_message Visit_website AIM YIM MSNM 
rcrsn51


Joined: 05 Sep 2006
Posts: 9203
Location: Stratford, Ontario

PostPosted: Wed 10 Jun 2009, 12:10    Post_subject:  

@hondasid: Go to a console and type:
Code:
cups-config --version
Back to top
View user's profile Send_private_message 
hondasid


Joined: 31 Oct 2008
Posts: 259
Location: Perry, OK

PostPosted: Wed 10 Jun 2009, 14:42    Post_subject:  

1.3.1 is what it said.

I run 4.2.1 standard kernel, downloaded and burned 2 weeks ago from the main puppy page. I have made 3 installs with this CD and they all run 1.3.1. I have seen something about cups 1.4b2, but it was a .pet somewhere in the forum.

I rarely print anything and my old lexmark all in one is perfect and works great. I really don't mess with cups that much

_________________
Instead of looking out Windows, I'm playing with my Puppy.
Back to top
View user's profile Send_private_message Visit_website AIM YIM MSNM 
rcrsn51


Joined: 05 Sep 2006
Posts: 9203
Location: Stratford, Ontario

PostPosted: Wed 10 Jun 2009, 14:54    Post_subject:  

Then that's a mystery. My version of 4.2.1 says "1.3.10" and to my knowledge, there was never a Puppy that had CUPS 1.3.1.
Back to top
View user's profile Send_private_message 
elcolto13

Joined: 09 Jun 2009
Posts: 69
Location: Southwest Pennsylvania (USA)

PostPosted: Sat 13 Jun 2009, 01:31    Post_subject:  

Bumpity Bump.
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9203
Location: Stratford, Ontario

PostPosted: Sat 13 Jun 2009, 08:02    Post_subject:  

What problem are you still having? Which of Patriot's suggestions have you tried? What error messages are you getting? Please be more specific.

Did you notice the title of the thread under this one? Have you used any of that information?
Back to top
View user's profile Send_private_message 
elcolto13

Joined: 09 Jun 2009
Posts: 69
Location: Southwest Pennsylvania (USA)

PostPosted: Sat 13 Jun 2009, 15:42    Post_subject:  

For some reason I didn't notice Patriot's post. I feel pretty stupid because it worked. Very Happy It's printing now. Thanks a bunch guys!
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0640s ][ Queries: 11 (0.0107s) ][ GZIP on ]