Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 01 Oct 2014, 14:27
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Nvidia drivers not working with Xorg (Quadro NVS 140M)
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
rokafeller

Joined: 26 May 2009
Posts: 2

PostPosted: Wed 27 May 2009, 07:09    Post_subject:  Nvidia drivers not working with Xorg (Quadro NVS 140M)
Sub_title: Lenovo T61 laptop
 

Hello all,
I'm struggling trying to make Xorg work with Nvidia quadro NVS 140M on my laptop, Lenovo T61 on Puppy 4.2.

Given that the native Puppy "nv" driver set in xorg.conf doesn't work at all -it freezes-. I tried to install, one after the other, all the .pet packages I found for nvidia chipset http://www.murga-linux.com/puppy/viewtopic.php?t=22272

By doing this, in xorg.conf the driver is set to "nvidia". It doesn't freeze anymore but X doesn't start, so I'm still forced to use Xvesa (slow refresh rate) or "vesa" driver in Xorg (faster, but no 1440x900 resolution support).

Anyone is aware of how to solve this issue? I don't need fast 3D performances, it would be enough to have decent refresh rate for web browsing and support for my screen resolution.

thanx in advance
Back to top
View user's profile Send_private_message 
rokafeller

Joined: 26 May 2009
Posts: 2

PostPosted: Wed 27 May 2009, 07:39    Post_subject: SOLVED  

Sorry for annoyance, but I now solved the issue. On the link quoted in previous post, 3 .pet packages were suggested for nvidia quadro nvs140m. None of them was working, but on the repository I found another package, that seemed to me the most up to date: NVIDIA-177.82-k2.6.25.16

This is the link to the repository:
http://download.tuxfamily.org/nop/

and this is the link to the package i installed
http://download.tuxfamily.org/nop/NVIDIA-177.82-k2.6.25.16.pet

Procedure: simply install the .pet package, then exit from X server (ctrl+alt+bckspace) and run xorgwizard. Be aware that it could take some seconds in testing step to recognize the card/screen.

Cheers
Back to top
View user's profile Send_private_message 
tempestuous

Joined: 10 Jun 2005
Posts: 5263
Location: Australia

PostPosted: Wed 27 May 2009, 08:46    Post_subject:  

rokafeller wrote:
I tried to install, one after the other, all the .pet packages I found for nvidia chipset http://www.murga-linux.com/puppy/viewtopic.php?t=22272

It's important to take heed of the compatibility listed for drivers contributed on the forum:
gray wrote:
For the new kernel (2.6.21.7) of Puppy 3.0 I have put together the set of three driver packages for nvidia cards.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0426s ][ Queries: 11 (0.0031s) ][ GZIP on ]