Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 30 Aug 2014, 10:33
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Trouble getting OpenOffice .sfs to work -- SOLVED
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 2 Posts_count   Goto page: 1, 2 Next
Author Message
rebbi1

Joined: 03 Dec 2008
Posts: 45

PostPosted: Sat 23 May 2009, 09:28    Post_subject:  Trouble getting OpenOffice .sfs to work -- SOLVED  

Hi,

I've been searching for a version of OpenOffice to run under 4.2. I downloaded and installed the version of OO 3.01 from here

http://puppylover.netsons.org/dokupuppy/programs:office_suite

and installed it. (I'd also tried Oxygen Office 3.01 from the same page, but found the GUI squished and hard to use.)

Anyway, the .sfs file seemed to install fine, and the various OO programs show up at the right places in the menus, but when I select a program from the menu, nothing happens. Also, if I try adding a program to the desktop with the Add Icon tray, there are no icons for those programs in the window that opens.

I'm stumped!

Edited_time_total
Back to top
View user's profile Send_private_message 
G0XAN

Joined: 08 May 2009
Posts: 31
Location: Brighton, UK

PostPosted: Sat 23 May 2009, 12:16    Post_subject:  

I had trouble with OpenOffice 3.0.1 on Puppy 4.2, but I found that OOo 3.0.0 worked better:

http://www.murga-linux.com/puppy/viewtopic.php?t=23982

However, I did find that this sfs seemed to stop CUPS (printing) from working. Haven't solved that one yet, but otherwise everything in OOo seems to work OK.

_________________
Gary
Back to top
View user's profile Send_private_message 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Sat 23 May 2009, 13:33    Post_subject:  

Why is it that people, seeking help, don't report their system configuration like install type?
So please, fill in the blanks.

_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send_private_message 
rebbi1

Joined: 03 Dec 2008
Posts: 45

PostPosted: Sat 23 May 2009, 14:32    Post_subject:  

G0XAN wrote:
I had trouble with OpenOffice 3.0.1 on Puppy 4.2, but I found that OOo 3.0.0 worked better:

http://www.murga-linux.com/puppy/viewtopic.php?t=23982

However, I did find that this sfs seemed to stop CUPS (printing) from working. Haven't solved that one yet, but otherwise everything in OOo seems to work OK.


Gosh, I worked so hard to get CUPS to work on my machine... I even have wireless network printing working. I'd hate to screw that up! Thanks for the tip, though!
Back to top
View user's profile Send_private_message 
rebbi1

Joined: 03 Dec 2008
Posts: 45

PostPosted: Sat 23 May 2009, 14:35    Post_subject:  

Béèm wrote:
Why is it that people, seeking help, don't report their system configuration like install type?
So please, fill in the blanks.


Fair enough:

Puppy 4.20, frugal install, HP N3110 laptop, 256 MB RAM, 5 GB hard disk, 433 MHz Celeron CPU.
Back to top
View user's profile Send_private_message 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Sat 23 May 2009, 17:55    Post_subject:  

In /usr/share/applications you have the different .desktop files for the soffice applications.
In the sfs file symlinks are missing, but I don't know which ones.
I solved this by editing each sxxx.desktop file and have the full path in the Exec= statement to the sxxx applications.
Normally starts in /opt/......

_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send_private_message 
rebbi1

Joined: 03 Dec 2008
Posts: 45

PostPosted: Sat 23 May 2009, 18:14    Post_subject:  

Béèm wrote:
In /usr/share/applications you have the different .desktop files for the soffice applications.
In the sfs file symlinks are missing, but I don't know which ones.
I solved this by editing each sxxx.desktop file and have the full path in the Exec= statement to the sxxx applications.
Normally starts in /opt/......


Thanks for the response. I'm a bit of a newbie to Puppy. Can you give me an example walk-through? Your instructions are a little over my head. Smile

Thanks!!
Back to top
View user's profile Send_private_message 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Sat 23 May 2009, 18:16    Post_subject:  

Do you know how to go to /usr/share/applications?
_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send_private_message 
rebbi1

Joined: 03 Dec 2008
Posts: 45

PostPosted: Sat 23 May 2009, 18:38    Post_subject:  

Béèm wrote:
Do you know how to go to /usr/share/applications?


Yes!
Back to top
View user's profile Send_private_message 
rebbi1

Joined: 03 Dec 2008
Posts: 45

PostPosted: Sun 24 May 2009, 12:03    Post_subject:  SOLVED!!!  

rebbi1 wrote:
Béèm wrote:
Do you know how to go to /usr/share/applications?


Yes!

Thanks very much for your help. I edited the desktop files in Geany and specified the full path to each executable (/opt/openoffice.org3/program/sxxx) and rebooted, and now all those programs will launch from the Menu.

Only thing I still can't figure out is how to access icons to put on my desktop.

Anyway, I'm rolling. Thanks!!!! Very Happy
Back to top
View user's profile Send_private_message 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Sun 24 May 2009, 18:09    Post_subject:  

Glad you managed to do it.

Now for the desktop icons.
Go to /opt/openoffice.org3/program and drag the sxxxx executables you want to the desktop.
Right click on them one by one and select set icon
Drag the corresponding icon from /usr/share/midi-icons to the opened panel for each of them.

_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send_private_message 
didik


Joined: 05 Jan 2009
Posts: 44
Location: Bandung, Indonesia

PostPosted: Mon 25 May 2009, 05:42    Post_subject:  

Nothing problem with OpenOffice-3.0.sfs on Puppy-4.20. It works.

http://edwidianto.wordpress.com/2009/05/25/openoffice-3-0-di-puppy-linux-4-20/

-eko didik widianto
bandung@indonesia[/url]
Back to top
View user's profile Send_private_message Visit_website YIM 
trio


Joined: 21 Dec 2008
Posts: 1788
Location: अनुमोदना

PostPosted: Mon 25 May 2009, 06:05    Post_subject:  

didik wrote:
Nothing problem with OpenOffice-3.0.sfs on Puppy-4.20. It works.

http://edwidianto.wordpress.com/2009/05/25/openoffice-3-0-di-puppy-linux-4-20/

-eko didik widianto
bandung@indonesia[/url]


Hai Kang Didik dari Bandung...salam

_________________
PET Maker|WbarCC|My Website
Back to top
View user's profile Send_private_message 
rebbi1

Joined: 03 Dec 2008
Posts: 45

PostPosted: Mon 25 May 2009, 12:02    Post_subject:  

Béèm wrote:
Glad you managed to do it.

Now for the desktop icons.
Go to /opt/openoffice.org3/program and drag the sxxxx executables you want to the desktop.
Right click on them one by one and select set icon
Drag the corresponding icon from /usr/share/midi-icons to the opened panel for each of them.


This worked great, thanks! Cool
Back to top
View user's profile Send_private_message 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Mon 25 May 2009, 17:49    Post_subject:  

Glad that one worked too.
Now can you do a favor to fellow posters and edit the subject of the initial post by adding [SOLVED]

_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 2 Posts_count   Goto page: 1, 2 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0775s ][ Queries: 11 (0.0071s) ][ GZIP on ]