Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 21 Nov 2017, 04:44
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
How to Install Brother Printers and Scanners
Post new topic   Reply to topic View previous topic :: View next topic
Page 13 of 14 [208 Posts]   Goto page: Previous 1, 2, 3, ..., 11, 12, 13, 14 Next
Author Message
edoc


Joined: 07 Aug 2005
Posts: 4722
Location: Southeast Georgia, USA

PostPosted: Sat 16 May 2015, 22:13    Post subject:  

He;s usually been able to sort things for me in the past.

I'll have to look for any notes I may have kept from when I got printing working in the old Lighthouse64.

Thanks ...

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
TahrPup64 & Lighthouse64-b602 & JL64-603
Back to top
View user's profile Send private message Visit poster's website 
DanielSong39

Joined: 04 Mar 2014
Posts: 34

PostPosted: Sun 17 May 2015, 07:27    Post subject:  

Brother HL-2275DW only has 32-bit support for Debian; you need a Fedora-based distribution to get the 64-bit support.

http://support.brother.com/g/s/id/linux/en/evaluation.html?c=us&lang=en&prod=hl2275dw_us&redirect=on

You may be out of luck.
Back to top
View user's profile Send private message 
edoc


Joined: 07 Aug 2005
Posts: 4722
Location: Southeast Georgia, USA

PostPosted: Sun 17 May 2015, 10:27    Post subject:  

That cannot be correct.

I already have access to the Brother printer from my 64-bit install of the older version of Lighthouse64-602.

I just need to know how to get it to work with this newer version.

Later today I will search in the slight hope that I saved some notes as to how I got it working on the older 64-bit install.

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
TahrPup64 & Lighthouse64-b602 & JL64-603
Back to top
View user's profile Send private message Visit poster's website 
starhawk

Joined: 22 Nov 2010
Posts: 5056
Location: Everybody knows this is nowhere...

PostPosted: Sun 17 May 2015, 12:41    Post subject:  

Somewhere on this forum is a utility called rpm2pet that may be of use. I recall that it needs another utility called unrpm...

If you can't get ahold of it here I have both and can re-up.

But they are 32bit PETs so I cannot guarantee function in a 64bit Pup.

_________________

Back to top
View user's profile Send private message 
edoc


Joined: 07 Aug 2005
Posts: 4722
Location: Southeast Georgia, USA

PostPosted: Sun 17 May 2015, 17:22    Post subject:  

I have the ppd file and it's on this computer.

I've compared the cupsd.conf cupsd.confLPD and printer.confn and they are the same - other than the UUID in printers.conf

Not sure where to look next but the answer has to be somewhere on my old version of Lighthouse64 laptop ...

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
TahrPup64 & Lighthouse64-b602 & JL64-603
Back to top
View user's profile Send private message Visit poster's website 
KEubus

Joined: 14 Jun 2014
Posts: 13

PostPosted: Thu 04 Jun 2015, 18:23    Post subject: brother-MFC 7360N
Subject description: failed to create a working sfs-installer-file
 

Hello rcrsn51,

My old HP-MFC broke down and choose a brotherMFC7360N
My working Puppy was Playdayz's Lucid 511/528
and later on Rerwins's supersulu_x (all frugal installs).
My MFC didnot not -and as I read somewhere will not- work under Lucids.
So I had to go for another puppy capable of printing and scanning on my brotherMFC7360N.

rcrsn51's debbi-1.1.pet, the brother-drivers
and his instructions are working perfectly:
brscan4-0.4.2-1.i386.deb
mfc7360nlpr-2.1.0-1.i386.deb
cupswrapperMFC7360N-2.0.4-2.i386.deb
and sometimes libpoppler3_0.8.7-4_i386.deb

I made 2 mfc.sfs
one with the first 2 deb's and one with all 4
und used 2 methods
1) PADS104 by rsh
2) dir2sfs (by 01micko ?? not sure)

I reported te broken links in PADS here
http://murga-linux.com/puppy/viewtopic.php?p=849288#849288
the dir2sfs-method looked ok
files were at the right places as I installed thed the DEB-files
bur did not print or scan

In the Murga-forum I read
you deliverd a few printer-installer-pets.
You did not choose an installer.sfs-file
You delivered a .pet-file as an installer.
Could you describe a howto ?


I would prefer to modify an noobishly quote (Nooby, 2012) here in full agreement
"I have lots of time and lacks of knowledge."

groetjes, greetings & Grüße
k.eubus
Back to top
View user's profile Send private message 
DanielSong39

Joined: 04 Mar 2014
Posts: 34

PostPosted: Fri 12 Jun 2015, 23:21    Post subject:  

At the end of the day I installed the 32-bit version of Quirky; eventually got the printer working.
Back to top
View user's profile Send private message 
edoc


Joined: 07 Aug 2005
Posts: 4722
Location: Southeast Georgia, USA

PostPosted: Sun 14 Jun 2015, 13:59    Post subject:  

Embarassed
_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
TahrPup64 & Lighthouse64-b602 & JL64-603

Last edited by edoc on Wed 17 Jun 2015, 22:02; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
paule@adam.com.au

Joined: 17 Jun 2015
Posts: 2

PostPosted: Wed 17 Jun 2015, 21:33    Post subject:  

Hi

Have installed cupswrapper and print driver and cups can see printer yet when i print it says " printer not connected"

I am new to puppy and believe it is looking for usb connection??

The printer is a wireless printer , can u help
Back to top
View user's profile Send private message 
starhawk

Joined: 22 Nov 2010
Posts: 5056
Location: Everybody knows this is nowhere...

PostPosted: Wed 17 Jun 2015, 22:06    Post subject:  

I cannot help, and right now, nobody can.

I could help if I knew what Puppy you were using, what printer you were using, and how you attempted to install the printer.

I'm sorry if I sound abrupt. It is simply very frustrating to have someone pop up and say "help me stuff's broken" while simultaneously providing essentially no useful information outside of the fact that something doesn't work where they want/need it.

At least you posted in the right place... well, one of the two posts is. (Posting in multiple places about the same issue is not cool around here, BTW. You won't get sacked, but Flash, our resident moderator, might send you an invoice if he needs to buy ibuprofen for the headache.)

_________________

Back to top
View user's profile Send private message 
RickGT351

Joined: 27 Sep 2011
Posts: 200
Location: Auckland, New Zealand

PostPosted: Sat 04 Jul 2015, 04:31    Post subject: Brother install on FatDog 64 700  

I am trying to install my Brother DCP-J125 on FatDog 64. I have installed the 32bit devx. The catch is that PETs don't work on Fatdog so I can't used Debbi. I have tried using the procedure on the brother help page but dpkg keeps complaining about missing files
Back to top
View user's profile Send private message 
RickGT351

Joined: 27 Sep 2011
Posts: 200
Location: Auckland, New Zealand

PostPosted: Sat 04 Jul 2015, 04:56    Post subject:  

Back to top
View user's profile Send private message 
eowens2

Joined: 27 Aug 2008
Posts: 172

PostPosted: Sun 26 Jul 2015, 22:07    Post subject:  

I would like some advice on how to get my new Brother MFC-L2700DW printer working on Quirky Tahr.

I am using Quirky Tahr 6.0.5 [CUPS 1.7.1] on an Acer c710 laptop. The md5sums for tahr-6.0.5.usfs.xz and install-quirky-to-partition.sh were both correct. I am using debbi from debbi-1.2.pet.

Here is my attempt at lpr install and the response:

Code:
# debbi mfcl2700dwlpr-3.2.0-1.i386.deb
chown: unknown user lp
Post-install script completed!
Done!
#


And here is my attempt at cupswrapper install and the response:

Code:
# debbi mfcl2700dwcupswrapper-3.2.0-1.i386.deb
lpadmin -p MFCL2700DW -E -v usb://dev/usb/lp0 -P /usr/share/ppd/brother/brother-MFCL2700DW-cups-en.ppd
lpadmin: Request Entity Too Large
Post-install script completed!
Done!
#


The process created PPD files in /opt/brother/Printers, /usr/share/cups/model, and /usr/share/ppd, but when I then open CUPS and click on "Adding Printers and Classes" I get "Internal Server Error" and the process halts!

BK's blog says that early versions of Quirky had printing problems due to the non-inclusion of the packages "cups-core-drivers" and "cups-filters-core-drivers" by Ubuntu, but these packages were present in my copy of Quirky Tahr-6.0.5.

Has anyone else encountered this? Any suggestions as to how to get the Brother MFC-L2700DW working?

I should add that the printer works fine under Tahrpup 6.0.5 [CUPS 1.4.8] on the same machine and under Windows 7 on a Dell Laptop.

Any help would be appreciated.
Back to top
View user's profile Send private message 
eowens2

Joined: 27 Aug 2008
Posts: 172

PostPosted: Sun 26 Jul 2015, 22:07    Post subject:  

Duplicate Post - Excuse Me!
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 11721
Location: Stratford, Ontario

PostPosted: Sun 26 Jul 2015, 22:17    Post subject:  

The "internal server error" has nothing to do with the Brother driver and everything to do with the CUPS setup in Quirky. Are you doing this from a clean install? Have you added any other packages like web browsers? Are you using a 32bit Quirky?

You should post your problem in the Quirky thread.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 13 of 14 [208 Posts]   Goto page: Previous 1, 2, 3, ..., 11, 12, 13, 14 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0718s ][ Queries: 14 (0.0113s) ][ GZIP on ]