Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 21 Dec 2014, 10:36
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
[Request] Emulators for Puppy 4.x
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
panzerpuppy

Joined: 02 Oct 2007
Posts: 632

PostPosted: Mon 11 May 2009, 09:25    Post_subject:  [Request] Emulators for Puppy 4.x  

Request (for Puppy 4.x):

Nestopia 1.40
-------------------
" Nestopia is the best and most accurate open-source NES emulator for Linux "

Sources and instructions:
http://rbelmont.mameworld.info/?page_id=200

VBA-M (SVN build 877 with the GTK frontend)
-----------------------------------------------------------
" VBA-M is the next generation successor to the well-known VisualBoy Advance GameBoy/Color/Advance emulator. VBA-M is an order of magnitude better and more accurate than any release of VisualBoy Advance 1.x"

Download the latest source tarball from here:
http://vbam.svn.sourceforge.net/

bsnes 0.46
-----------------
" bsnes is the most accurate SNES emulator for fast PCs (>=2GHz)
Much better than ZSNES or Snes9x if you have the hardware to run it. "

(compiled without PulseAudio and JMA , needs Qt >= 4.5.0)

Source:
http://byuu.org/download.php?file=bsnes_v046.tar.bz2

Outdated compile instructions (some of the dependencies are not needed / have changed):
http://board.byuu.org/viewtopic.php?f=3&t=39

.

Edited_times_total
Back to top
View user's profile Send_private_message 
panzerpuppy

Joined: 02 Oct 2007
Posts: 632

PostPosted: Mon 11 May 2009, 13:42    Post_subject:  

*bump*

(updated)
Back to top
View user's profile Send_private_message 
dom_b

Joined: 14 May 2009
Posts: 24

PostPosted: Sat 16 May 2009, 13:03    Post_subject:  

bump and epsxe!

http://www.epsxe.com/download.php
Back to top
View user's profile Send_private_message 
panzerpuppy

Joined: 02 Oct 2007
Posts: 632

PostPosted: Sun 17 May 2009, 02:46    Post_subject:  

dom_b wrote:
epsxe!

http://www.epsxe.com/download.php


This one is much better than ePSXe :

http://psxemulator.gazaxian.com/

pSX is the most accurate PlayStation One emulator for Linux Smile
Doesn't need any plugins, looks and feels like the real thing.

Just grab the precompiled Linux version:
http://psxemulator.gazaxian.com/pSX_linux_1_13.tar.bz2
and have some good old-school 3D fun Smile
Back to top
View user's profile Send_private_message 
dom_b

Joined: 14 May 2009
Posts: 24

PostPosted: Sun 17 May 2009, 11:42    Post_subject:  

ive used psx too, but the graphics plugins for epsxe look far better than the software one on psx.

but i do agree it works very well with no problems.

if somebody could make a pet of psx that would be great!
Back to top
View user's profile Send_private_message 
plaguedogs


Joined: 18 Oct 2008
Posts: 60

PostPosted: Sun 17 May 2009, 18:54    Post_subject:  

mupen n64 emulator

http://mupen64plus.googlecode.com/files/Mupen64Plus-1-5-bin-32.tar.gz

runs good on most puppies for me. sorry no pet, im in slax today
depends on sdl-1.2.9 (see attachment)

ill post the old mupen.pet too.


http://www.pcsx2.net/files/18428

is for ps2. it doesn't play games for me very well yet but its fun to hack at.
to be honest ive had better luck with wine, directx, and the win32 pcsx2.

actually, if you have wine you can run nocash, gba/nds emulator.
http://nocash.emubase.de/no$gba-w.zip

almost forgot, qjoypad, to get game pad support. it depends on qt that most puppies have. its kinda sketchy but is good enough.

with wine you can try xpadder
http://download.softpedia.com/dl/f63ac2ca1da674af8f1c0ce904bed466/4a10915f/100045445/software/system/Xpadder5-3.zip
qjoypad-3.4-1-i486.pet
Description  linux native gamepad support depends on qt. only seems to be a problem in pup_301.
pet

 Download 
Filename  qjoypad-3.4-1-i486.pet 
Filesize  79.48 KB 
Downloaded  520 Time(s) 
zsnes-1.51.pet
Description  super nintendo emulator
pet

 Download 
Filename  zsnes-1.51.pet 
Filesize  595.76 KB 
Downloaded  598 Time(s) 
sdl-1.2.9.pet
Description  mupen64plus depends on this
pet

 Download 
Filename  sdl-1.2.9.pet 
Filesize  463.01 KB 
Downloaded  525 Time(s) 
mupen64-0.5.pet
Description  this is old and unmaintained. mupen64plus 1.5 is (more)current
pet

 Download 
Filename  mupen64-0.5.pet 
Filesize  1.71 MB 
Downloaded  508 Time(s) 
Back to top
View user's profile Send_private_message 
rmdnet

Joined: 04 Nov 2008
Posts: 5

PostPosted: Wed 12 Aug 2009, 08:28    Post_subject:  

Hi,

Also, did somebody compile any emulator for ZX spectrum on Puppy?
If not, somebody has the knowledge and feels like compiling one?.

See a list here: http://www.worldofspectrum.org/emulators.html#unix

Thanks!
Back to top
View user's profile Send_private_message 
cat


Joined: 09 Apr 2008
Posts: 52
Location: out of place

PostPosted: Fri 16 Oct 2009, 10:35    Post_subject: re: Spectrum emu  

Hi there
for the spectrum emu you might want to try the .pet over here.
Regards, displaced pet Wink
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0591s ][ Queries: 12 (0.0037s) ][ GZIP on ]