Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 13 Dec 2017, 17:06
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Usuarios de habla Hispana
Problema driver nVidia
Moderators: rarsa
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [5 Posts]  
Author Message
Antuank

Joined: 17 Apr 2009
Posts: 5

PostPosted: Sat 18 Apr 2009, 07:51    Post subject:  Problema driver nVidia
Subject description: Instalación de driver satisfactoria pero sin que inicien las X's
 

Bueno, ante todo saludos a todos. Este es mi primer thread y post, sinceramente empezé ayer a usar Puppy Linux aunque ya hace un par de años que soy usuario de GNU/Linux.

Bien, la verdad es que he pasado más de 10 horas en este foro (literalmente hablando) y no pude encontrar la solución a esto.
Tengo Puppy Linux 4.2 k2.6.21.7 y estoy intentando de darle aceleración a mi placa de video (nVidia Aladdin TNT2) que usa los drivers legacy 71.86 (los últimos son los 71.86.09). Ok, sinceramente no sé que versión de Xorg usa Puppy 4.2 ni por qué no vienen los linux-headers y todo lo relacionado con build-essential y module-assistant ya instalados (quien haya usado debian, sabe lo privilegiado que es aptitude). Al margen, intenté instalar el pet de acá: http://download.tuxfamily.org/nop/ (un link que encontré en varios posts) y... logré hacerlo, es decir, se instaló correctamente. Me dispuse a modificar xorg.conf y a reiniciar las X's, pero para mi sorprendimiento, éstas no iniciaban!. Me dije a mi mismo: "No debe haber cargado el módulo por alguna razón, entonces xorg no lo reconoce...". Acto seguido hice modprobe nvidia y la verdad que no tengo el error (y estoy en otra PC), pero era algo de que no podía cargar nvidia.ko porque era un módulo incorrecto o algo por el estilo.
Sinceramente no entiendo qué sucede. De compilar paquetes ni hablar porque como ya dije, no tengo los accesorios adecuados. Además, teniendo la facilidad de un paquete instalable (léase pet) en mis manos, sería una pena tener que hacer el trabajo duro yo mismo Razz (aunque con este grado de desesperación no tengo problema en hacerlo).

La verdad, quedé acá trabado. A quien me ayude le agradeceré infinitamente y me verán por acá posteando dudas y haciendo algún que otro tutorial si continuo con esta velocisima distro. (Creo que hay mucha info sobre Puppy, pero muy mal distribuida, y ni hablar del idioma. Entre ayer y hoy aprendí más inglés que en años de estudio... Razz).

Bueno, si necesitan información adicional me avisan, pero creo que con eso es suficiente.

Muchas gracias de antemano y saludos!.
Back to top
View user's profile Send private message 
Antuank

Joined: 17 Apr 2009
Posts: 5

PostPosted: Sun 19 Apr 2009, 12:25    Post subject:  

Please!, nadie sabe qué puede estar ocurriendo? intenté compilar el módulo yo mismo pero no tengo make. No quiero tener una distro que para instalar un programa o driver tenga que pasar 1 semana sin dormir buscando información, aunque tampoco quiero dejarla debido a su increíble velocidad... qué dilema!.

Espero alguien me ayude, gracias nuevamente.
Back to top
View user's profile Send private message 
droope


Joined: 31 Jul 2008
Posts: 811
Location: Uruguay, Mercedes

PostPosted: Sun 19 Apr 2009, 16:17    Post subject:  

Antuank wrote:
Please!, nadie sabe qué puede estar ocurriendo? intenté compilar el módulo yo mismo pero no tengo make. No quiero tener una distro que para instalar un programa o driver tenga que pasar 1 semana sin dormir buscando información, aunque tampoco quiero dejarla debido a su increíble velocidad... qué dilema!.

Espero alguien me ayude, gracias nuevamente.


Hola antuank,

Lamento no tener una respuesta a tu pregunta, en lo único que te puedo asistir es en, si me envias un MP, y si querés, es traducir tu post y ponerlo en el subforo ayuda en ingles.

Un saludo
Pedro
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13648
Location: Karlsruhe, Germany

PostPosted: Sun 19 Apr 2009, 16:50    Post subject:  

Hello,

Para leer este mensaje en español, haga clic aquí

There are pets for k2.6.21.7, but I think they do not work.
They were made for Puppy 3. It had the same kernelversion, but that kernel was compiled different.
http://www.murga-linux.com/puppy/viewtopic.php?t=22272

The easiest way to use the TNT 2 would be:
Use Puppy 4.x with Kernel 2.6.25.16.
Then install the NVIDIA-71.86.06-k2.6.25.16.pet from:
http://www.murga-linux.com/puppy/viewtopic.php?t=34001

If you must stick with 2.6.21.7, you had to compile the Nvidia driver on your own.
http://www.nvidia.com/object/linux_display_x86_71.86.09.html

Download, then right click to make it executable.
Then exit X and type:
cd /where you downloaded
./NVIDIA-Linux-x86-71.86.09-pkg1.run


This requires to have:
http://ftp.nluug.nl/ftp/pub/os/Linux/distr/puppylinux/sfs_modules-4/devx_412.sfs
http://ftp.nluug.nl/ftp/pub/os/Linux/distr/puppylinux/sfs_modules-4/kernel-src-2.6.21.7-patched-puppy4.1retro.sfs

If you get any errors then, write them down, and post them here.
Maybe there is just missing a symbolic link or so, I had such issues back in Puppy 3.

Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
Antuank

Joined: 17 Apr 2009
Posts: 5

PostPosted: Mon 20 Apr 2009, 00:01    Post subject:  

Simplemente MUCHÍSIMAS GRACIAS!
Thank you!!
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [5 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Usuarios de habla Hispana
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0708s ][ Queries: 11 (0.0070s) ][ GZIP on ]