Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 23 Apr 2014, 13:02
All times are UTC - 4
 Forum index » House Training » HOWTO ( Solutions )
The sometimes necessary modem dial-up pppd fix for when:
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [1 Post]  
Author Message
mcewanw

Joined: 16 Aug 2007
Posts: 2017
Location: New Zealand

PostPosted: Fri 03 Apr 2009, 08:54    Post subject:  The sometimes necessary modem dial-up pppd fix for when:
Subject description: modem found, carrier detected, but pppd dies under Linux.
 

[Note that I feel that the following is critically important information, because without it some and perhaps many potential Linux users, who only have dial-up connections, may find that they can only connect to their ISPs using that "other operating system"..., and hence turn away from using Puppy and Linux more generally. I would request therefore that this information is made sticky or easily accessible somewhere and born in mind for future new Puppy releases]

Do you have a dial-up connection, but find that you cannot connect via Puppy Linux (or most any Linux distribution) but can connect via Microsoft windows OS-based machines? Is is a diabolical plot by your ISP perhaps, who says they don't support Linux machines? Perhaps.

For those suffering the above problem, the following may be the solution or at least a try (it worked for me; I was using old Puppy version 2.17.1) [thanks to P.McGavin (and dcheesem) of Slingshot ISP forum, NZ: http://forum.slingshot.co.nz/viewtopic.php?f=13&p=22687&sid=2c21732ae459e6d07f88b6568cbf47df#p22687] .

It appears that Microsoft Windows does not by default negotiate what is called pppd asyncmap values, but most Linux pppd dialup configurations attempt to do so automatically (which causes the above failure for the unlucky few or many who have an ISP with a poor or inflexible dial-up configuration). The solution for such a case is to force the Linux pppd daemon to use a default asyncmap value of 0. To do that simply:

1. Start your favourite text editor (for example, Geany or Leafpad) and open the file /etc/ppp/options for editing.

2. At the top of that file, add the following two lines and save the file:

Code:

asyncmap 0
-am


The above two lines instruct the pppd daemon to use the default asyncmap given, which is what these dodgy ISP servers need. Dialing in via wvdial or gt dial or Xeznet or whatever should now work fine, assuming your modem has been detected correctly and you've entered the correct ISP details and so on.
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 1 [1 Post]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » HOWTO ( Solutions )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0393s ][ Queries: 11 (0.0062s) ][ GZIP on ]