Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 18 Sep 2014, 08:02
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Puppies 4.2-v1 Deeper Thought :) UpDated Version
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 3 [34 Posts]   Goto page: Previous 1, 2, 3 Next
Author Message
tunyawat

Joined: 02 Nov 2008
Posts: 103
Location: Bangkok, Thailand and London, UK

PostPosted: Sat 04 Apr 2009, 09:32    Post subject:  

ttuuxxx - the mt-Paint screencapture is also not working. I captured the following screen by getting into mtPaint and used Actions->Time Delayed Screenshot. Actually, it should be the same command as the one in Puppy, but the screencapture in Puppy doesn't work. (however, there is no problem in the normal 4.2)

The following error occurred just before the dialog "Frugal or Full" came up. I did md5 checksum on your iso but could not find any error.
error.png
 Description   
 Filesize   244.93 KB
 Viewed   520 Time(s)

error.png

Back to top
View user's profile Send private message 
ttuuxxx


Joined: 05 May 2007
Posts: 10750
Location: Ontario Canada,Sydney Australia

PostPosted: Sat 04 Apr 2009, 10:31    Post subject:  

Thanks it sounds like I'll have one more update to do, Glad I kept the first release handy:) plus It needs the non gimp xsane installed also. Its ashame the xsane package only works with gimp and tiff5 installed, It should of been designed as a plugin and not part of the actual program, then it would of worked right. Thanks for everything, did you try the first release and if so did that one have the install rename error ?
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile

Back to top
View user's profile Send private message Visit poster's website 
dawnsboy


Joined: 03 Dec 2008
Posts: 248
Location: Indiana - Republic of New Canada

PostPosted: Sat 04 Apr 2009, 12:26    Post subject:  

@ttuuxxx

I thought I would weigh in on the topic regarding the install/rename error in 4.2 v1. I had originally installed 4.2 and had no problems with it at all. I decided to check out your upgrade in part because it had updates/patches already applied and to be honest in part because of the ridiculous controversy surrounding abiword 2.66 (I have had no problems with 2.66) in the original 4.2 final release.

It appears that the install/rename error is limited to your 4.2-v1 update. It seems that .sfs files must follow the convention of being named with 3 characters in Puppy. IE, pup_420.sfs, devx-4.20.sfs, etc. I was unable to do a full install because the universal installer would not recognize pup_420.sfs. I received a dialogue box stating that pup_42.sfs could not be found. When I renamed pup_420.sfs to pup_42.sfs the installer reported file not found ( I assume because it now violates the Puppy naming convention for .sfs files).

I did you use the pup_420.sfs file from 4.2-v1 to upgrade my usb flash drive install of 4.2 final. I then created a new pup_save file for use with your updated version. I was unable to use the boot manager to load *.sfs files after the upgrade.

In any event I would like to say that I have been the beneficiary of your hard work on numerous occasions and would like to thank you for sharing your work with all of us. I am able to compile most software that I need for everyday use but I am not a programmer or developer and therefore rely on people like you to make my world a better place to compute in.

Regards,
dawnsboy
Back to top
View user's profile Send private message 
ttuuxxx


Joined: 05 May 2007
Posts: 10750
Location: Ontario Canada,Sydney Australia

PostPosted: Sat 04 Apr 2009, 12:40    Post subject:  

dawnsboy wrote:
@ttuuxxx

I thought I would weigh in on the topic regarding the install/rename error in 4.2 v1. I had originally installed 4.2 and had no problems with it at all. I decided to check out your upgrade in part because it had updates/patches already applied and to be honest in part because of the ridiculous controversy surrounding abiword 2.66 (I have had no problems with 2.66) in the original 4.2 final release.

It appears that the install/rename error is limited to your 4.2-v1 update. It seems that .sfs files must follow the convention of being named with 3 characters in Puppy. IE, pup_420.sfs, devx-4.20.sfs, etc. I was unable to do a full install because the universal installer would not recognize pup_420.sfs. I received a dialogue box stating that pup_42.sfs could not be found. When I renamed pup_420.sfs to pup_42.sfs the installer reported file not found ( I assume because it now violates the Puppy naming convention for .sfs files).

I did you use the pup_420.sfs file from 4.2-v1 to upgrade my usb flash drive install of 4.2 final. I then created a new pup_save file for use with your updated version. I was unable to use the boot manager to load *.sfs files after the upgrade.

In any event I would like to say that I have been the beneficiary of your hard work on numerous occasions and would like to thank you for sharing your work with all of us. I am able to compile most software that I need for everyday use but I am not a programmer or developer and therefore rely on people like you to make my world a better place to compute in.

Regards,
dawnsboy

well tomorrow I'll try again, if possible could you test my first release and make sure that it installs ok? That would save me a lot, because the way I have everything setup its a bit complicated for installs, one the swap file on my hard drive never works, maybe because its a sata2 etc.
Thanks for everything Smile
ttuuxxx

ps here's the link to the first one Smile
http://www.puppylinux.asia/tpp/ttuuxxx/puppy420/release/puppies-4.2-k2.6.25.16-seamonkey.iso

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile

Back to top
View user's profile Send private message Visit poster's website 
rjbrewer


Joined: 22 Jan 2008
Posts: 4422
Location: merriam, kansas

PostPosted: Sat 04 Apr 2009, 13:35    Post subject:  

Ttuuxxx:

Having the same problem as Dawnsboy and Tunyawat.

I don't use cds' to install; just download iso and do a manual
frugal. Then use the univ.-installer to make a full install on
another partition.

Worked on all the 420rc and your first "no bling" just fine.

Think I had it installed okay last night by changing pup420
to pup_4.2; but then couldn't create a a name in grub that
would allow it to boot. (should have kept notes).

edit:

I did burn a cd of the first "no-bling" for a friends laptop, and
it would install frugal and full just fine using installer.

rjb

rjb

_________________

Inspiron 700m, Pent.M 1.6Ghz, 1Gb ram.
Msi Wind U100, N270 1.6>2.0Ghz, 1.5Gb ram.
Eeepc 8g 701, 900Mhz, 1Gb ram.
Full installs


Last edited by rjbrewer on Sat 04 Apr 2009, 16:41; edited 1 time in total
Back to top
View user's profile Send private message 
dawnsboy


Joined: 03 Dec 2008
Posts: 248
Location: Indiana - Republic of New Canada

PostPosted: Sat 04 Apr 2009, 15:52    Post subject:  

Quote:
well tomorrow I'll try again, if possible could you test my first release and make sure that it installs ok? That would save me a lot, because the way I have everything setup its a bit complicated for installs, one the swap file on my hard drive never works, maybe because its a sata2 etc.
Thanks for everything Smile
ttuuxxx


Your welcome ttuuxxx!

I downloaded the 4.2-v1 iso image from puppylinux.ca again just to make sure that I have a clean copy. I burned it to cd on on my daughters pc. I inserted the cd into an external drive and boot my Eeepc 701 with a live cd session. I then invoked the universal installer from the menu. I received an error message regarding sanity check file not found as shown in the first of the two attached screen shots.

Failing install from the 4.2-v1 CD I shutdown my system then rebooted with the standard release CD of Deep Thought 4.2 Final. Once the session loaded I removed the CD from the drive and replaced it with your 4.2-v1 CD. I then invoked the universal installer from the menu. When prompted to provide the location of the install files I selected CD. The installer proceeded with a Frugal Install per my selections during the process. The second attached screen shot shows that I have successfully booted into 4.2-v1 Frugal (hdd) desktop.

I hope that you find this to be of some help. I will be running it through its paces. If i note thing worth mentioning I will post it on this thread.
42v1cdinstall.png
 Description   Puppy Linux Live CD 4.2-v1 universal installer error message
 Filesize   141.02 KB
 Viewed   501 Time(s)

42v1cdinstall.png

42v1hddfrugal.png
 Description   Desktop shot of Puppy Linux 4.12-v1 Frugal install on Eeepc 701
 Filesize   137.09 KB
 Viewed   496 Time(s)

42v1hddfrugal.png

Back to top
View user's profile Send private message 
dawnsboy


Joined: 03 Dec 2008
Posts: 248
Location: Indiana - Republic of New Canada

PostPosted: Sat 04 Apr 2009, 16:28    Post subject: SFS Boot Manager Error
Subject description: Boot Manager cannot find /mnt/home/devx_420.sfs
 

@ttuuxxx

I have attached 3 screen shots of the 4.2-v1 desktop to this post. The first is simply of my desktop showing the theming changes that I implemented. The seconded shows that devx_420.sfs is located at /mnt/home. The third screen shot shows an error message that appears when attempting to use the Boot Manager to load devx_420.sfs.

I hope this helps identify the issue for you.

Regards,
dawnsboy

EDIT:

In this case renaming devx_420.sfs to devx_42.sfs does work. I have successfully used the Boot Manager to load devx_42.sfs.
desktopscreen.png
 Description   Updated desktop screen shot
 Filesize   335.65 KB
 Viewed   520 Time(s)

desktopscreen.png

mnthomedevx.png
 Description   Screen shot displaying location of devx_420.sfs @ /mnt/home
 Filesize   317.29 KB
 Viewed   486 Time(s)

mnthomedevx.png

bootmanager.png
 Description   Boot Manager error message when attempting to load devx_420.sfs
 Filesize   218.42 KB
 Viewed   496 Time(s)

bootmanager.png

Back to top
View user's profile Send private message 
tunyawat

Joined: 02 Nov 2008
Posts: 103
Location: Bangkok, Thailand and London, UK

PostPosted: Sat 04 Apr 2009, 21:59    Post subject:  

ttuuxxx - the earlier version works well on the installation process.
Back to top
View user's profile Send private message 
ttuuxxx


Joined: 05 May 2007
Posts: 10750
Location: Ontario Canada,Sydney Australia

PostPosted: Sun 05 Apr 2009, 01:57    Post subject:  

ok guys I'll revert back to the first base and start the second over and add a few new updates/fixes:)
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile

Back to top
View user's profile Send private message Visit poster's website 
shand

Joined: 30 Oct 2008
Posts: 28
Location: China

PostPosted: Sun 05 Apr 2009, 04:18    Post subject:  

Hey ttuuxxx
I found that mtpaint snapshot NOT Running in puppies4.2 v1(USB install),but earlier version(puppies4.2) works well.

B Rgds
shand
Back to top
View user's profile Send private message 
ttuuxxx


Joined: 05 May 2007
Posts: 10750
Location: Ontario Canada,Sydney Australia

PostPosted: Sun 05 Apr 2009, 05:15    Post subject:  

Hi guys I've made a new blinky, I used the gnome images this time instead of my own like the icewm version, but I changed the monitor screens, I found that there wasn't enough contrast in shades of blue. Looks very nice now:) I used the sources for JWM that I finally found so it should be more sticky to the taskbar than the icewm version, below is a image of it off. ttuuxxx
blinky.png
 Description   
 Filesize   2.5 KB
 Viewed   1322 Time(s)

blinky.png


_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile

Back to top
View user's profile Send private message Visit poster's website 
ttuuxxx


Joined: 05 May 2007
Posts: 10750
Location: Ontario Canada,Sydney Australia

PostPosted: Sun 05 Apr 2009, 05:17    Post subject:  

shand wrote:
Hey ttuuxxx
I found that mtpaint snapshot NOT Running in puppies4.2 v1(USB install),but earlier version(puppies4.2) works well.

B Rgds
shand


also another way to do a snapshot is via the terminal just type the following and hit the 'Enter' key
mtpaint -s
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile

Back to top
View user's profile Send private message Visit poster's website 
dawnsboy


Joined: 03 Dec 2008
Posts: 248
Location: Indiana - Republic of New Canada

PostPosted: Sun 05 Apr 2009, 09:30    Post subject:  

Quote:
also another way to do a snapshot is via the terminal just type the following and hit the 'Enter' key
mtpaint -s
ttuuxxx

I changed the .desktop file in /usr/share/applications for the mtpaint screen shot to read:

exec=mtpaint -s

That worked just fine. It had pointed at a .sh script file initially.
Back to top
View user's profile Send private message 
gabe

Joined: 03 Apr 2009
Posts: 85
Location: Minnesota, USA

PostPosted: Sun 05 Apr 2009, 11:42    Post subject:    

"Abiword I downgraded due to issues with .doc"

Oh no, what do you mean? What's wrong with 4.2 working with .doc? I'm very worried now, since I used 4.2 to create and edit some .doc files...
Back to top
View user's profile Send private message 
ttuuxxx


Joined: 05 May 2007
Posts: 10750
Location: Ontario Canada,Sydney Australia

PostPosted: Sun 05 Apr 2009, 11:50    Post subject:  

gabe wrote:
"Abiword I downgraded due to issues with .doc"

Oh no, what do you mean? What's wrong with 4.2 working with .doc? I'm very worried now, since I used 4.2 to create and edit some .doc files...

In 4.2 we didn't have much time to test every part of it so some little things happened, Like abiword change the default font for .doc .rtf etc from 'times new roman' to 'Tymes' they didn't tell us that, So after 4.2 was released we found out that if you open a .doc or rtf the words are all mangled up, plus 2.6.6 wasn't really all that great to start with, we found about 3 bugs before that and fixed them, but this other bug we had no clue about until it was too late. So I quickly took 2.6.3 from the repo which was stable added the new docx plugin plus the templates from 2.6.6 and upgraded it to a better version then the latest, due to the fact it uses our fonts and has all the options as the latest model and is actually more stable:) Thats what I included in the above release, Which I'll be updating maybe tonight but probably tomorrow, its getting late now.
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile

Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 2 of 3 [34 Posts]   Goto page: Previous 1, 2, 3 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0914s ][ Queries: 12 (0.0043s) ][ GZIP on ]