Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 01 Oct 2014, 12:31
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
How to save and execute Bash scripts in Geany?
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
Umren

Joined: 29 Mar 2009
Posts: 5

PostPosted: Wed 01 Apr 2009, 14:26    Post_subject:  How to save and execute Bash scripts in Geany?  

how to save and execute bash scripts in geany? let's say i got some script and i press "execute!"

and that's what happen here... what im doing wrong? just black screen every time
2feb8f9eb594.jpg
 Description   geany won't load!
 Filesize   29.59 KB
 Viewed   2475 Time(s)

2feb8f9eb594.jpg

Back to top
View user's profile Send_private_message 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Wed 01 Apr 2009, 14:41    Post_subject:  

Verify that the script you save is executable.
_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send_private_message 
Umren

Joined: 29 Mar 2009
Posts: 5

PostPosted: Wed 01 Apr 2009, 15:15    Post_subject:    

Béèm wrote:
Verify that the script you save is executable.

It is, on properties it is executable. And i can execute it from terminal, but geany just won't execute it! WTF! Mad
Back to top
View user's profile Send_private_message 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Wed 01 Apr 2009, 16:04    Post_subject:  

OK then. Never tried to execute a script from within Geany.
_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send_private_message 
potong

Joined: 06 Mar 2009
Posts: 88

PostPosted: Fri 03 Apr 2009, 05:56    Post_subject:  

Hi Umren

Have you tried setting the terminal?

Go to Edit/Preferences/Tools and set Tool Paths: Terminal to /usr/bin/rxvt

You must save the script first and chmod +x <scriptname>

Hope this helps

Potong
Back to top
View user's profile Send_private_message 
Umren

Joined: 29 Mar 2009
Posts: 5

PostPosted: Sun 05 Apr 2009, 15:57    Post_subject:  

potong wrote:
Hi Umren

Have you tried setting the terminal?

Go to Edit/Preferences/Tools and set Tool Paths: Terminal to /usr/bin/rxvt

You must save the script first and chmod +x <scriptname>

Hope this helps

Potong

Yeah, terminal is setted just like u tell me. File chmod'ed -x too.

Still same screen, very sad! have to go to terminal for execute file Smile

but i want 1 button exec from geany! lol
Back to top
View user's profile Send_private_message 
hillside


Joined: 02 Sep 2007
Posts: 642
Location: Minnesota, USA. The frozen north.

PostPosted: Sun 05 Apr 2009, 16:27    Post_subject:  

My terminal is set to:

/usr/X11R7/bin/xterm

If my file has been correctly saved as executable, it operates in Geany perfectly.
Back to top
View user's profile Send_private_message 
muggins

Joined: 20 Jan 2006
Posts: 6687
Location: lisbon

PostPosted: Sun 05 Apr 2009, 20:27    Post_subject:  

Same settings as hillside. I opened geany, entered your "Hello World" script, and it ran as expected. So not sure why it's not working for you?
Back to top
View user's profile Send_private_message 
Master_wrong

Joined: 19 Mar 2008
Posts: 456

PostPosted: Tue 07 Apr 2009, 07:52    Post_subject:  

try run them on puppy 301...

I find that in 301 the script will run fine but in 4.2 will not run.
Back to top
View user's profile Send_private_message 
gposil


Joined: 06 Apr 2009
Posts: 1305
Location: Stanthorpe (The Granite Belt), QLD, Australia

PostPosted: Sun 10 May 2009, 04:41    Post_subject:  

Change your terminal setting to /usr/X11R7/bin/xterm -e bash -c.

Then it works...geany has changed.

_________________
Dpup Home
Back to top
View user's profile Send_private_message Visit_website MSNM 
ecomoney


Joined: 25 Nov 2005
Posts: 2183
Location: Lincolnshire, England

PostPosted: Sun 10 May 2009, 13:31    Post_subject:  

Master_Wrong,

Please will you file a bug report in this section as you are familiar with the problem. We can hopefully clear it up for the next 4.2.1 release

Many thanks

_________________
Puppy Linux's Mission

Sorry, my server is down atm!
Back to top
View user's profile Send_private_message Visit_website MSNM 
Master_wrong

Joined: 19 Mar 2008
Posts: 456

PostPosted: Wed 27 May 2009, 00:55    Post_subject:  

Quote:

Please will you file a bug report in this section as you are familiar with the problem. We can hopefully clear it up for the next 4.2.1 release


but the solution is available already...

Quote:


Change your terminal setting to /usr/X11R7/bin/xterm -e bash -c.


clue ----> geany , preference, tool
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0626s ][ Queries: 12 (0.0044s) ][ GZIP on ]