Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 21 Oct 2014, 13:03
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Unnamed puplet 1.1 (puppy411 kernel-2.6.28.5 Xorg-7.4 LXDE)
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 2 of 10 Posts_count   Goto page: Previous 1, 2, 3, 4, ..., 8, 9, 10 Next
Author Message
wow

Joined: 29 Jun 2006
Posts: 988
Location: Peru

PostPosted: Sun 08 Mar 2009, 17:56    Post_subject:  

This was requested by some users, it's the same pcmanfm-0.5 executable but without the "My Documents" icon on the desktop.

Warning reported by techtype
Quote:
Using this pcmanfm, if you right click on the desktop - it sends the processor use to %100 and locks up pcmanfm.
pcmanfm-0.5-x-exe-without_My_Documents_icon.tar.bz2
Description  Close all pcmanfm windows and extract to /usr/bin
bz2

 Download 
Filename  pcmanfm-0.5-x-exe-without_My_Documents_icon.tar.bz2 
Filesize  149.23 KB 
Downloaded  465 Time(s) 

_________________


Edited_time_total
Back to top
View user's profile Send_private_message 
wow

Joined: 29 Jun 2006
Posts: 988
Location: Peru

PostPosted: Sun 08 Mar 2009, 18:07    Post_subject:  

EDIT: It'll fail if the swap file is in a vfat partion.

Bug: Can't load or unload swap files in vfat partitions.
Severity: High
Description: This puplet (ver 1.1) is unable to load swap files with the 'swapon' command, no matter its size if they are located in a vfat partition.
There's no problem if you want to use a swap partition or a swap file inside an EXT partition.

_________________


Edited_time_total
Back to top
View user's profile Send_private_message 
techtype

Joined: 16 Nov 2008
Posts: 181

PostPosted: Sun 08 Mar 2009, 18:09    Post_subject:  Thanks  

wow wrote:
This was requested by some users, it's the same pcmanfm-0.5 executable but without the "My Documents" icon on the desktop.


Thank you, thank you!!!! ('Very Happy')
Back to top
View user's profile Send_private_message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Sun 08 Mar 2009, 18:16    Post_subject:  

wow wrote:
Bug: Can't load or unload swap files.
Severity: High
Description: This puplet (ver 1.1) is unable to load swap files with the 'swapon' command, no matter its size nor where are they located(ext2, vfat partitions).


Hm, NYP uses the same kernel, and almost the same initrd.gz, and the mesa related xorg-files.
I had no time yet, to copy over other files.
So the error must be in the remaining things you modified.
Maybe you altered settings for HAL?

Thanks so much for your work, it helped me a lot to update NYP to newer libs Exclamation

try:
dmesg
to see driver related errors.

Must sleep now, else I would investigate this on my own now.
I can try to look at it tomorrow during my course Smile

Mark

_________________
my recommended links
Back to top
View user's profile Send_private_message Visit_website 
techtype

Joined: 16 Nov 2008
Posts: 181

PostPosted: Sun 08 Mar 2009, 20:15    Post_subject: A bug  

wow wrote:
This was requested by some users, it's the same pcmanfm-0.5 executable but without the "My Documents" icon on the desktop.


Using this pcmanfm, if you right click on the desktop - it sends the processor use to %100 and locks up pcmanfm.

By the way, I reported the swapfile problem on the thread for your first pup.
Back to top
View user's profile Send_private_message 
MUguest

Joined: 09 Dec 2006
Posts: 73

PostPosted: Mon 09 Mar 2009, 07:37    Post_subject:  

I currently run Ultrapup 1.1 in Virtualbox in Windows XP.

It is booted from an iso-image, that was assigned as CD drive.
The harddisk image was partitioned with gparted:
sda1: ext3
sda2: swap

At startup (from the "CD"), the swap is recognized and used.
I can switch it off/on with:
swapoff /dev/sda2
swapon /dev/sda2

This becomes visible in conky 2 seconds later.
Just pmount does not list it.

I would be curious, if your swap is located on a USB-drive?
Maybe the required module like ehci_hcd was not loaded in initrd.gz or rc.sysinit?

Mark
Back to top
View user's profile Send_private_message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Mon 09 Mar 2009, 16:12    Post_subject:  

I don't know how far this concerns Ultrapup.
In NYP I use in .xinitrc:
setxkbmap -layout `cat /etc/keymap | cut -f1 -d.`

Not:
XkbApplyNow

This does not work with british keyboards, as etc/keymap contains "uk.map".
But in /etc/X11/xkb/symbols/ you just have "gb".

Solution: create a symlink:

cd /etc/X11/xkb/symbols
ln -s gb uk


Mark

_________________
my recommended links
Back to top
View user's profile Send_private_message Visit_website 
wow

Joined: 29 Jun 2006
Posts: 988
Location: Peru

PostPosted: Tue 10 Mar 2009, 21:55    Post_subject:  

More info about the "swap file" bug.

@Mark: it also happens in newyearspup-MU-02-rc7 (kernel 2.6.28.5)
@techtype: I can't find your bug report, can you post a link to it?

It only happen when you try to load a "swap file" (not a linux swap partition) stored in a FAT partition. There is no problem with swap partitions and swap files in Ext partitions.

Examples:

1. The 'swapon' command get stuck trying to load the swap file
2. It even works if the swap file is inside an Ext2 file which is in a FAT partition.

_________________

Back to top
View user's profile Send_private_message 
wow

Joined: 29 Jun 2006
Posts: 988
Location: Peru

PostPosted: Tue 10 Mar 2009, 22:11    Post_subject:  

Bug: .conkyrc file is reset every time you start lxde.
Severity: Low
Description: /usr/bin/startlxde will create a fresh copy from /etc/conky/conky.conf to /root/.conkyrc every time you start X.

To solve it, open '/usr/bin/startlxde' with a text editor and replace:
    Code:
    # Ensure the existance of conky config file
    cp /etc/conky/conky.conf "$HOME/.conkyrc"

    with:
    Code:
    # Ensure the existance of conky config file
    if [ ! -f "$HOME/.conkyrc" ]; then
        cp /etc/conky/conky.conf "$HOME/.conkyrc"
    fi

_________________

Back to top
View user's profile Send_private_message 
wow

Joined: 29 Jun 2006
Posts: 988
Location: Peru

PostPosted: Tue 10 Mar 2009, 22:23    Post_subject:  

Bug: Keyboard layouts are not readed from the xorg.conf file.
Severity: Low
Description: I forgot to change a line in '/root/.xinitrc', to run the XkbApplyNow (XkbConfigManager) command every time X is started to read and apply keyboard settings from the xorg.conf file. Without this change you wont be able to use the "Keyboard layout switcher"(LXPanel plugin) properly.

    Replace:
    Code:
    #wow: (custom 4.11 puplet)fix keyboard layout (Xorg 7.4)
    setxkbmap -layout `cat /etc/keymap | cut -f1 -d.`

    with:
    Code:
    #wow: (custom 4.11 puplet)fix keyboard layout (Xorg 7.4)
    XkbApplyNow

_________________

Back to top
View user's profile Send_private_message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Wed 11 Mar 2009, 03:24    Post_subject:  

bug:
drm.ko does not work, but drm.bak does:
http://www.murga-linux.com/puppy/viewtopic.php?p=282939#282939
Mark

_________________
my recommended links
Back to top
View user's profile Send_private_message Visit_website 
techtype

Joined: 16 Nov 2008
Posts: 181

PostPosted: Wed 11 Mar 2009, 06:49    Post_subject:  

wow wrote:
More info about the "swap file" bug.

@techtype: I can't find your bug report, can you post a link to it?

It only happen when you try to load a "swap file" (not a linux swap partition) stored in a FAT partition. There is no problem with swap partitions and swap files in Ext partitions.



Oh, I see -- my report was that I could not load a swap partition. I did not realize you were focusing on a swapfile.

http://www.murga-linux.com/puppy/viewtopic.php?p=277914#277914
Back to top
View user's profile Send_private_message 
sue


Joined: 09 May 2008
Posts: 23
Location: Anaheim, CA, USA

PostPosted: Thu 12 Mar 2009, 00:51    Post_subject: intel xvesa works; xorg goes black  

xvesa works out of the box with my laptop's intel 4500 chipset. I've tried at least 10 other 4.x puppies, and they all go into an infinite loop hunting for a valid mode.

xorg displays the "If you can see this, X is working." but goes black on exit. I think this is fixed in 2.6.2.

_________________
Puppy: Because I want speed!
Back to top
View user's profile Send_private_message 
wow

Joined: 29 Jun 2006
Posts: 988
Location: Peru

PostPosted: Thu 12 Mar 2009, 18:39    Post_subject:  

Bug: SDL-1.2.13 without OpenGL support
Severity: Medium
Description: Plinej's sdl-1.2.13,pet package was compiled without OpenGL support, so you wont be able to play certain games such as FretsOnFire, GridWars, Titanion, Torus Trooper, etc.

This is the error message:


To fix it please install the pet package attached below.
sdl-1.2.13-i686.pet
Description  Latest SDL, compiled in this puplet. May not be compatible with other puplets
pet

 Download 
Filename  sdl-1.2.13-i686.pet 
Filesize  197.79 KB 
Downloaded  607 Time(s) 
sdl_DEV-1.2.13-i686.pet
Description  Use this if you want to compile SDL stuff
pet

 Download 
Filename  sdl_DEV-1.2.13-i686.pet 
Filesize  1.22 MB 
Downloaded  490 Time(s) 

_________________

Back to top
View user's profile Send_private_message 
wow

Joined: 29 Jun 2006
Posts: 988
Location: Peru

PostPosted: Thu 12 Mar 2009, 19:02    Post_subject: oh my . . .
Sub_title: Can this puplet be compared with Vista? just eye candy and many bugs
 

Seems that I'll need to make a service pack or something like that. Perhaps another ISO.

@MU: thanks, I will fix it soon.
@techtype: Have you tried to reformat that swap patition? (gparted, or mkswap /dev/<device node>)
@sue: It worked in Puppy-3? try to replace your current /etc/X11/xorg.conf file with a working copy. They run these commands to switch to Xorg:
Code:
cp /usr/X11R7/bin/
rm X
cp -s Xorg X
xwin

_________________

Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 2 of 10 Posts_count   Goto page: Previous 1, 2, 3, 4, ..., 8, 9, 10 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0920s ][ Queries: 12 (0.0110s) ][ GZIP on ]