Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 28 Jul 2014, 10:59
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Google translator (standalone) updated
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post new topic   Reply to topic View previous topic :: View next topic
Page 3 of 3 [44 Posts]   Goto page: Previous 1, 2, 3
Author Message
Thor

Joined: 21 Feb 2007
Posts: 38

PostPosted: Mon 09 Mar 2009, 16:00    Post subject:  

Greetings:
Using Translator090302 in Puppy-4.2.0-RC2 frugal install and works perfect, thanks for your effort.
How do I change the size of the text to be translated and translated in translator090302?

Thor

(translation with Translator090302)
Back to top
View user's profile Send private message 
trapster


Joined: 28 Nov 2005
Posts: 1999
Location: Maine, USA

PostPosted: Mon 09 Mar 2009, 19:42    Post subject:  

Ok, ok...
Lets break this down to simplicity.
Since we need to be online anyway...
Paste this into a console, or make it a script.

Code:
gtkmoz http://www.translate.google.com/translate_t#


Can't get much smaller than that Very Happy

_________________
trapster
Maine, USA

Asus eeepc 1005HA PU1X-BK
Frugal install: Puppeee4.31 + 1.0, Puppy4.10 + Lupu52
Currently using Slacko AND lupu52 w/ fluxbox
Back to top
View user's profile Send private message Visit poster's website 
vovchik


Joined: 23 Oct 2006
Posts: 1285
Location: Ukraine

PostPosted: Mon 09 Mar 2009, 19:50    Post subject:  

Dear Thor,

Without checking the code (which i will do), I think I can say the following:

The font for QT4 apps/widgets (i.e. the two display windows in translator) is determined by the style settings of QT4. I use the GTK style, so that my QT apps look like my GTK apps. In this configuration, QT simply looks at my GTK settings and mirrors them. So, if you are using the GTK style for QT, adjust your GTK settings, where such text must also appear small.

If you are not certain what style your QT4 apps are using, navigate to /opt/qt4/bin and run qtconfig. Select a style. Use the fonts tab to select your default font and font size.

I hope that this explanation solves your font problem. The styles setting will aslo affect the appearance of ther QT4 apps, such as the latest Opera, if you are using shared libraries.

With kind regards,
vovchik
Back to top
View user's profile Send private message 
Thor

Joined: 21 Feb 2007
Posts: 38

PostPosted: Wed 11 Mar 2009, 08:50    Post subject:  

Sincerely:

Thanks for your indication trapster, but that is not what we wanted to achieve what I want is to see the text larger in windows translator090302.

vovchik:
stardust is the GTK theme and the path "/ opt/qt4/bin" does not appear qtconfig or bin in the path "~ / .config / AlexSnet is Translator.conf, which, if I am not mistaken, the languages selected .

Although not currently able to fix it, you appreciate the help, I will strive to see.

See you soon.

Thor
Back to top
View user's profile Send private message 
trapster


Joined: 28 Nov 2005
Posts: 1999
Location: Maine, USA

PostPosted: Wed 11 Mar 2009, 09:43    Post subject:  

Thor:
Sorry, that post was not meant to address your font issue. It was just another suggestion for translating.

_________________
trapster
Maine, USA

Asus eeepc 1005HA PU1X-BK
Frugal install: Puppeee4.31 + 1.0, Puppy4.10 + Lupu52
Currently using Slacko AND lupu52 w/ fluxbox
Back to top
View user's profile Send private message Visit poster's website 
vovchik


Joined: 23 Oct 2006
Posts: 1285
Location: Ukraine

PostPosted: Wed 11 Mar 2009, 12:33    Post subject:  

Dear Thor,

Here is qtconfig and the GTK QT4 style. Copy the file libgtkstyle.so into your /opt/qt4/plugins/styles folder and run qtconfig (for qt4). It is usually in /opt/qt4/bin. If you don't have it, I have attached it. Select GTK as the style and say "save" in the file menu. Both files are in the archived attachment. You may have to copy these files into /usr/lib/qt4, depending on your build of qt4.

With kind regards,
vovchik
qt-styles.tar.bz2
Description 
bz2

 Download 
Filename  qt-styles.tar.bz2 
Filesize  141.36 KB 
Downloaded  290 Time(s) 
Back to top
View user's profile Send private message 
Thor

Joined: 21 Feb 2007
Posts: 38

PostPosted: Thu 12 Mar 2009, 07:40    Post subject:  

Vovchik Hey, thanks again:

I followed your directions, but when I save the changes, it does not, the console returns
the following message "Segmentation fault", I do dmesg in the console and a long list (I think it is system information)
at the end of this list makes:

qtconfig [3912]: segfault at c ip b79a148d sp bfff8620 error 4 in libQtGui.so.4.3.2 [b77db000 519000]
qtconfig.0 [5988]: segfault at c ip b795448d sp bfda9830 error 4 in libQtGui.so.4.3.2 [b778e000 519000]
qtconfig [6322]: segfault at c ip b78db48d sp bfc30650 error 4 in libQtGui.so.4.3.2 [b7715000 519000]
qtconfig.0 [9699]: segfault at c ip b791048d sp bfe680d0 error 4 in libQtGui.so.4.3.2 [b774a000 519000]
qtconfig [10139]: segfault at c ip b78cf48d sp bfd26f40 error 4 in libQtGui.so.4.3.2 [b7709000 519000]
qtconfig [15199]: segfault at c ip b799648d sp bfcebf10 error 4 in libQtGui.so.4.3.2 [b77d0000 519000]

I ldd / opt/qt4/bin/qtconfig console and returns this:

linux-gate.so.1 => (0xffffe000)
libQt3Support.so.4 => / opt/qt4/lib/libQt3Support.so.4 (0xb7d20000)
libQtSql.so.4 => / opt/qt4/lib/libQtSql.so.4 (0xb7cf6000)
libQtXml.so.4 => / opt/qt4/lib/libQtXml.so.4 (0xb7cb6000)
libQtNetwork.so.4 => / opt/qt4/lib/libQtNetwork.so.4 (0xb7c44000)
libQtGui.so.4 => / opt/qt4/lib/libQtGui.so.4 (0xb7709000)
libpng.so.3 => / usr/lib/libpng.so.3 (0xb76e1000)
libSM.so.6 => / usr/X11R7/lib/libSM.so.6 (0xb76d9000)
libICE.so.6 => / usr/X11R7/lib/libICE.so.6 (0xb76c5000)
libXi.so.6 => / usr/X11R7/lib/libXi.so.6 (0xb76bd000)
libXrender.so.1 => / usr/X11R7/lib/libXrender.so.1 (0xb76b6000)
libXrandr.so.2 => / usr/X11R7/lib/libXrandr.so.2 (0xb76b0000)
libfreetype.so.6 => / usr/lib/libfreetype.so.6 (0xb764f000)
libfontconfig.so.1 => / usr/X11R7/lib/libfontconfig.so.1 (0xb7628000)
libXext.so.6 => / usr/X11R7/lib/libXext.so.6 (0xb761c000)
libX11.so.6 => / usr/X11R7/lib/libX11.so.6 (0xb754b000)
libQtCore.so.4 => / opt/qt4/lib/libQtCore.so.4 (0xb7430000)
libz.so.1 => / lib/libz.so.1 (0xb7421000)
libgthread-2.0.so.0 => / usr/lib/libgthread-2.0.so.0 (0xb741d000)
librt.so.1 => / lib/librt.so.1 (0xb7409000)
libglib-2.0.so.0 => / usr/lib/libglib-2.0.so.0 (0xb737c000)
libpthread.so.0 => / lib/libpthread.so.0 (0xb7367000)
libdl.so.2 => / lib/libdl.so.2 (0xb7363000)
libstdc. so.6 => / usr / lib / libstdc. so.6 (0xb727c000)
libm.so.6 => / lib/libm.so.6 (0xb725a000)
libgcc_s.so.1 => / usr/lib/libgcc_s.so.1 (0xb724e000)
libc.so.6 => / lib/libc.so.6 (0xb7153000)
libsqlite3.so.0 => / usr/lib/libsqlite3.so.0 (0xb70f5000)
libpng12.so.0 => / usr/lib/libpng12.so.0 (0xb70d0000)
libXfixes.so.3 => / usr/X11R7/lib/libXfixes.so.3 (0xb70cc000)
libXcursor.so.1 => / usr/X11R7/lib/libXcursor.so.1 (0xb70c4000)
libexpat.so.1 => / usr/lib/libexpat.so.1 (0xb70a7000)
libXau.so.6 => / usr/X11R7/lib/libXau.so.6 (0xb70a4000)
libXdmcp.so.6 => / usr/X11R7/lib/libXdmcp.so.6 (0xb709f000)
/ lib/ld-linux.so.2 (0xb7f12000)

I see that the library gives libQtGui.so.4.3.2 errors but not to do.

Best regards.

Thor
Back to top
View user's profile Send private message 
vovchik


Joined: 23 Oct 2006
Posts: 1285
Location: Ukraine

PostPosted: Thu 12 Mar 2009, 08:00    Post subject:  

Dear Thor,

I am sorry you are having problems. It could be that my newer version of QT4 is acting up on your system. Here are QT4.3.1 versions of the two files. Please try them and report the results.

With kind regards,
vovchik
qtconfig-4.3.1.tar.gz
Description 
gz

 Download 
Filename  qtconfig-4.3.1.tar.gz 
Filesize  118.65 KB 
Downloaded  278 Time(s) 
Back to top
View user's profile Send private message 
Thor

Joined: 21 Feb 2007
Posts: 38

PostPosted: Thu 12 Mar 2009, 08:54    Post subject:  

Hello vovchik:

Indeed, you're right, putting the "QT4.3.1" works perfectly.

My eyes and I appreciate the help offered.

Best regards.

Thor
Back to top
View user's profile Send private message 
Alex Snet


Joined: 01 Mar 2009
Posts: 3
Location: Russia, Moscow

PostPosted: Thu 19 Mar 2009, 06:24    Post subject:  New version is coming  

Hi 2 all.

New version with more dictionaries and offline mode is coming.
But I need your help!
Can U draw for me a new icon ( 512, 256, 128, 64, 32, 24 and 16 pixels).
Icon must be in PNG.

Also I can say, that in the new version will be two authors: me and lexnewton. ( http://qt-apps.org/content/show.php/Google+Translate?content=100039 and http://qt-apps.org/content/show.php/QGoogleTranslate?content=100713 )

Some features of new version:
1. Support more dictionaries (e.g. Yandex, DICT, PROMT, Google, etc. )
2. Improved dictionary.
3. Offline mode and caching.
4. Proxy, fonts and more settings.
5. Tray icon.
6. Rich text translations.
7. and more, and more, and more...

Please, send icon to my mail: me [at] alexsnet.ru

Big thx!
Back to top
View user's profile Send private message Visit poster's website 
ICQ Number 
vovchik


Joined: 23 Oct 2006
Posts: 1285
Location: Ukraine

PostPosted: Thu 19 Mar 2009, 17:24    Post subject:  

Dear Puppians,

Good news from Alex (see preceding post). As soon as he has some new sources, I'll compile and post the binary. In the meantime, please help him come up with an icon. He is thinking of something that might have a book/dictionary image, since flags would be impossible if the application is to remain "neutral" with regard to languages. The best book image I have is attached. I also have a multi-flag orb, but it would be hard to see detail in small verions, I think.

With kind regards,
vovchik
flags-world-but1.png
 Description   
 Filesize   35.84 KB
 Viewed   948 Time(s)

flags-world-but1.png

Book-128x128.png
 Description   
 Filesize   23.9 KB
 Viewed   955 Time(s)

Book-128x128.png

Back to top
View user's profile Send private message 
Alex Snet


Joined: 01 Mar 2009
Posts: 3
Location: Russia, Moscow

PostPosted: Mon 01 Jun 2009, 11:43    Post subject: New version is avaible
Subject description: Translator 0.9.6.01
 

See at: http://alexsnet.ru/opensource/translator/ and http://qt-apps.org/content/show.php/Google+Translator?content=100039

Changes:
01 June 2009 Translator (src) 0.9.6.01
    Completely reworked the code.
    Ability to set Proxy (beta)
    Added About Qt
    Added About App
    Added Settings
    Class interpreter is now separated from the GUI
    Restored icon for Windows


28 May 2009:
    Tray icon
    Some fixes
Back to top
View user's profile Send private message Visit poster's website 
ICQ Number 
trapster


Joined: 28 Nov 2005
Posts: 1999
Location: Maine, USA

PostPosted: Mon 01 Jun 2009, 12:21    Post subject:  

I will try it soon.

Thank you!!

_________________
trapster
Maine, USA

Asus eeepc 1005HA PU1X-BK
Frugal install: Puppeee4.31 + 1.0, Puppy4.10 + Lupu52
Currently using Slacko AND lupu52 w/ fluxbox
Back to top
View user's profile Send private message Visit poster's website 
vovchik


Joined: 23 Oct 2006
Posts: 1285
Location: Ukraine

PostPosted: Mon 01 Jun 2009, 13:06    Post subject:  

Dear Puppians,

Here is Alex's latest Translator, compiled in Puppy 3.01 using QT 4.4.0. It runs in my Puppy 4.12.

With kind regards,
vovchik

Ps. Unpack the archive and copy into /usr/local/bin.
Translator.tar.gz
Description 
gz

 Download 
Filename  Translator.tar.gz 
Filesize  129.05 KB 
Downloaded  271 Time(s) 
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 3 of 3 [44 Posts]   Goto page: Previous 1, 2, 3
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0792s ][ Queries: 12 (0.0046s) ][ GZIP on ]