Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 02 Sep 2014, 16:03
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Lighthouse Pup 4.4.2 Final SMP 194M
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 21 of 23 [345 Posts]   Goto page: Previous 1, 2, 3, ..., 19, 20, 21, 22, 23 Next
Author Message
juergen

Joined: 11 Sep 2009
Posts: 2

PostPosted: Fri 11 Sep 2009, 13:30    Post subject: no kezboard locatiyation - need help! :-)
Subject description: only us-keyboard in lhp 442 final?
 

@tazoc:

first thanks for all your efforts with lhp442!

I have tried several other attempts with smp-support plus CF
but all still have some problems - none worked so smooth like lhp ...

But one problem still exists for me (and maybe others too):

I can not get any intl keyboard-layout (german for me) to work.
On 07.August you wrote:

-------------------------------------------------------------------------
@hartiberlin,
Open /etc/keymap, should read 'de.map'. Maybe reboot would help?
I think MU fixed that bug in Newyearspup, but I don't remember how.
Or maybe try 'Regional & Language | Keyboard Layout' in KDE
System Settings (in System Menu).
-------------------------------------------------------------------------

- I installed LHP442 frugal to a SATA-drive and have chosen DE locale like usual.
(also tried installing to USB-stick - same result)
- using mariner-sfs, kde and compiz.
- opening LHP-LookNFeelMariner, Keyboard Layout only shows US as Active layouts ...
no other choice is availlable there Sad

Also ... EDITing /etc/keymap, should read 'de.map' ... doesnt change anything
for me (after a reboot).

Btw: NYP 02 RC10 did NOT have that problem when I tested it. So I assume that
MUs fix for the keyboard-problem might not have found its way into LHP?

It would be nice, if you/we could sort that out. Shall I contact MU or do you
know him already (what I guess)?

Juergen
Back to top
View user's profile Send private message 
tazoc


Joined: 11 Dec 2006
Posts: 1157
Location: Lower Columbia Basin WA US

PostPosted: Fri 11 Sep 2009, 16:20    Post subject: International keyboard layout fix  

juergen,
Can you modify the file /root/.xinitrc.
Add there after the line "#!/bin/sh" a new line, so that it looks like:
Code:
#!/bin/sh
setxkbmap -layout `cat /etc/keymap | cut -f1 -d.`
Then restart X.
-TazOC

_________________
lhpup.org Lighthouse 64 6.02

Last edited by tazoc on Sat 12 Sep 2009, 11:55; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
Bruce_n_Duane

Joined: 01 Nov 2005
Posts: 68
Location: Washington State

PostPosted: Sat 12 Sep 2009, 00:32    Post subject: vala and genie programming
Subject description: devx files needed for programming
 

tazoc:

What devx_xxxxx.sfs files do I need to do vala and genie development?
I have devx_412.sfs but the bootloader does not see it.

I see two development files on your website. Do I need these?

Do they replace the puppy 412 devx or need to be used in addition to it?

Have not had the mime problems since I deleted the pup_save.2fs and started over.

I am experiencing on interesting thing --- sometimes when I press the scrollwheel on my usb logitech bluetooth mouse the application disappears on the desktop. It is still in the task bar and running. I have to resize or move the app using the rightclick menu on the taskbar entry to get the screen back. This is a particular problem with seamonkey browser when I middle click on a link and the browser disappears. I need to "unshade" the browser to see it again. I don't know what is causing this but it happens with conkey sysmon and the console window as well.

This is new with seamonkey and puppy 4.1.2 in the experimenting I have been doing in the last two months. It is not unique to Lighthouse.

I am very impressed with your distribution of Puppy. How close is it to Barry's 4.1.2 puppy? What is different? Can I use the official puppy repository and test directory for apps for Lighthouse?

Does anyone know where I can get a gnucash 2.2.4 or greater sfs file for lighthouse. That is the only piece missing for me to convert to this from Ubuntu 8.0.4.

Also, how do I change the default for the apps on the top icon menus? Change the icons shown on this menu? Add or remove apps/icons?

I would also like to automount some partitions/drives and not others. In Ubuntu I edit mtab and fstab, but they use other apps than puppy does.

I am still very very impressed with Lighthouse Puppy 442d!!!!!
Great work!!!!

-bruce.
Back to top
View user's profile Send private message 
Barburo


Joined: 14 Jun 2007
Posts: 283

PostPosted: Sat 12 Sep 2009, 03:18    Post subject: 442f feedback  

Hi TazOC,
Thanks for 442f Smile
I've been testing out the KDE implementation on the Sony Vaio.

With desktop effects disabled KDE works fine as a window manager. With them enabled transparency and some of the other visuals also seem to work OK but it's a bit jerky. (This Vaio only has the onboard intel graphics).

I messed things up by trying to attach an external wide-screen monitor. My previous Viewsonic 19" got detected correctly by xorg in 412f and earlier 442 LHPs, but I now have a 21" Proview model and the maximum resolution that xorg detects is 800x600. I know it's capable of much higher resolution.

Eventually KDE stopped loading even without the monitor attached, (KDE would start to load and then quit straight to the logout options).
I had to do a pfix=nox restart and rerun xorgwizard to rebuild xorg.conf to get KDE back again.

My quick query is this: "Is it the new monitor or Xorg"? I ask because I can configure things to work in Win XP with this monitor (I have a dual boot set-up) but not in puppy (or at least not 412f or 442f).
B.
Back to top
View user's profile Send private message 
juergen

Joined: 11 Sep 2009
Posts: 2

PostPosted: Sat 12 Sep 2009, 05:57    Post subject: Intl keyboard working now
Subject description: German keyboard working now wit LHP442f
 

Ref: Intl keyboard not working with LHP442f

tazoc,

thx a lot for your fast response, it solved the issue fast and easy. Very Happy
Maybe a short info at the info- (start) page of lhpup.org would help
others with intl keyboards to save some time and frustration.

Thx again for your help!

Juergen

[quote="tazoc"]juergen,
Can you modify the file /root/.xinitrc.
Add there after the line "#!/bin/sh" a new line, so that it looks like:[code]#!/bin/sh
setxkbmap -layout `cat /etc/keymap | cut -f1 -d.`[/code]Then restart X.
-TazOC[/quote]
Back to top
View user's profile Send private message 
tazoc


Joined: 11 Dec 2006
Posts: 1157
Location: Lower Columbia Basin WA US

PostPosted: Sat 12 Sep 2009, 12:14    Post subject: Re: Intl keyboard working now
Subject description: German keyboard working now wit LHP442f
 

juergen wrote:
Ref: Intl keyboard not working with LHP442f

tazoc,

thx a lot for your fast response, it solved the issue fast and easy. Very Happy
Maybe a short info at the info- (start) page of lhpup.org would help
others with intl keyboards to save some time and frustration.

Thx again for your help!

Juergen
Hi Juergen,
Thank you for testing this fix. I have added a link to the fix at beginning of thread and at www.lhpup.org. I plan to include this in the next release, and hopefully KDE internationalization also.
-TazOC

_________________
lhpup.org Lighthouse 64 6.02
Back to top
View user's profile Send private message Visit poster's website 
tazoc


Joined: 11 Dec 2006
Posts: 1157
Location: Lower Columbia Basin WA US

PostPosted: Sat 12 Sep 2009, 12:34    Post subject: Re: 442f feedback  

Barburo wrote:
Hi TazOC,
Thanks for 442f Smile
I've been testing out the KDE implementation on the Sony Vaio.

With desktop effects disabled KDE works fine as a window manager. With them enabled transparency and some of the other visuals also seem to work OK but it's a bit jerky. (This Vaio only has the onboard intel graphics).
I don't think LHP has support for Intel graphics acceleration, so desktop effects and C-F probably won't work well, if at all.
Quote:
I messed things up by trying to attach an external wide-screen monitor. My previous Viewsonic 19" got detected correctly by xorg in 412f and earlier 442 LHPs, but I now have a 21" Proview model and the maximum resolution that xorg detects is 800x600. I know it's capable of much higher resolution.
I would try editing /etc/X11/xorg.conf.Intel or similar with correct monitor refresh rates and desired resolution. I don't know why xorgwizard/Xorg doesn't detect it properly. Maybe it is using the specs from your Vaio's display?
Quote:
Eventually KDE stopped loading even without the monitor attached, (KDE would start to load and then quit straight to the logout options).
I had to do a pfix=nox restart and rerun xorgwizard to rebuild xorg.conf to get KDE back again.

My quick query is this: "Is it the new monitor or Xorg"? I ask because I can configure things to work in Win XP with this monitor (I have a dual boot set-up) but not in puppy (or at least not 412f or 442f).
B.
Maybe you'll need to power-off, boot to CL and re-run xorgwizard, deleting the previous xorg.conf whenever connecting / disconnecting the external monitor.
-TazOC

_________________
lhpup.org Lighthouse 64 6.02
Back to top
View user's profile Send private message Visit poster's website 
tazoc


Joined: 11 Dec 2006
Posts: 1157
Location: Lower Columbia Basin WA US

PostPosted: Sat 12 Sep 2009, 13:49    Post subject: Re: vala and genie programming
Subject description: devx files needed for programming
 

Bruce_n_Duane wrote:
tazoc:

What devx_xxxxx.sfs files do I need to do vala and genie development?
I have devx_412.sfs but the bootloader does not see it.

I see two development files on your website. Do I need these?

Do they replace the puppy 412 devx or need to be used in addition to it?
Yes, they replace devx_412.sfs. Use only one devx at a time. You'll need devx-Xorg7.4-gtk2.14.4-r1.sfs (for 4.1.2-rc2 or later or 4.4.2) Then you can install vala and gnucash with Gslapt. I haven't tried vala or genie myself and I don't think they are in that devx.
Quote:
Have not had the mime problems since I deleted the pup_save.2fs and started over.

I am experiencing on interesting thing --- sometimes when I press the scrollwheel on my usb logitech bluetooth mouse the application disappears on the desktop. It is still in the task bar and running. I have to resize or move the app using the rightclick menu on the taskbar entry to get the screen back. This is a particular problem with seamonkey browser when I middle click on a link and the browser disappears. I need to "unshade" the browser to see it again. I don't know what is causing this but it happens with conkey sysmon and the console window as well.

This is new with seamonkey and puppy 4.1.2 in the experimenting I have been doing in the last two months. It is not unique to Lighthouse.
Which window manager exhibits the behavior? If KDE, check the System Settings | Window Behavior.
Quote:
I am very impressed with your distribution of Puppy. How close is it to Barry's 4.1.2 puppy? What is different? Can I use the official puppy repository and test directory for apps for Lighthouse?
Thank you, Lighthouse is a custom build of Puppy4.1.2, with Xorg 7.4 and k2.6.28.5 from Newyearspup by MU. It has numerous modifications and additions, notably Gslapt Package Manager and LXDE from Slackware. Most 4.x series pets should work, except for Xorg-related, kernel-specific ones and Pwidgets. I think the test directory is generally only for newer Alpha/Beta Puppies.
Quote:
Does anyone know where I can get a gnucash 2.2.4 or greater sfs file for lighthouse. That is the only piece missing for me to convert to this from Ubuntu 8.0.4.
Gslapt has 2.2.9, disregard the alsa conflict message. I haven't tried Gnucash myself, though there could be some missing dependencies. Often Gslapt will have those if needed.
Quote:
Also, how do I change the default for the apps on the top icon menus? Change the icons shown on this menu? Add or remove apps/icons?
Which WM are you asking about? Do you mean the desktop icons or categories in the menus? Changing the menus in most WMs involves editing configuration files. KDE has kappfinder and kmenuedit GUIs but changing the icon order is very hard.

Oh, it just occurred to me that the wbar launcher may be what you mean. For that, edit '/root/.wbar', then right-click on wbar to refresh it.
Quote:
I would also like to automount some partitions/drives and not others. In Ubuntu I edit mtab and fstab, but they use other apps than puppy does.
Add a line for each drive you want mounted to '/etc/rc.d/rc.local' like this:
Code:
mount /dev/sda2 /mnt/sda2
mount /dev/sda3 /mnt/sda3
replacing the 2s and 3s with appropriate values from Pmount.
Quote:
I am still very very impressed with Lighthouse Puppy 442d!!!!!
Great work!!!!

-bruce.
Thank you Bruce, I appreciate your support and comments.
-TazOC

_________________
lhpup.org Lighthouse 64 6.02
Back to top
View user's profile Send private message Visit poster's website 
OTRhound


Joined: 30 Aug 2009
Posts: 8
Location: california

PostPosted: Sat 12 Sep 2009, 19:27    Post subject: false alarm re nVIdia 173  

hi again folks,
been super super busy, so Huge apologies for having not got back to my betatesting efforts-- given that my bug report has now turned out to be baseless, I feel somwhat bad about that and hope to make it up to you as time permits going forward.
I tried a fresh go with the 442-d iso, and I had downloaded and put in place all the goodies (mariner, kde, voyager) this time.. when the video driver selection dialogs came up this time, I noticed the tremendously helpful texts mentioning a detail along the lines of "IF you have Marinier installed [these nvidia drivers can be selected]"..
so what I'm thinking is that last time I hadnt put the mariner.sfs in the right place before, and didnt notice that detail in the dialogs. So maybe a check as to whether the user is prepared to go ahead with selecting the nVidia drivers, before letting her.

Thanks again for your tremendous efforts tazoc, i tried out kde and it looks good.. everything went smoothly. A couple little snags, but I'll take some time to write them up in concise detail when I get the chance..
peace!
Back to top
View user's profile Send private message 
Bruce_n_Duane

Joined: 01 Nov 2005
Posts: 68
Location: Washington State

PostPosted: Sat 12 Sep 2009, 20:28    Post subject: Window Manager
Subject description: Using JWM
 

Hello Tazoc:

I am using the JWM window manager.

I will look at getting gnucash next week when I have faster wifi.
I will also download the devx, vala, and genie codes at that time.
The wifi I have today is good for about 2-4k bits/sec == slow.
The libraries are good for 600k-1500k bits/second == fast!!!

Thanks for the help on the mount command and wbar.

I found out what was happening to cause the windows to disappear. If the mouse is on the top title bar and you scroll the mouse wheel, the window will shade or unshade.

Now, how do I remove this feature?

I grabbed the bibletime files from ubuntu 8.04 from /usr/share/sword
and put them in a new directory in LHP /home then created link files
for mods.d and modules directories into LHP's /usr/share/sword and
I left the locales.d directory alone.
BibleTime works like a champ and is faster than in Ubuntu in my opinion.

I continue to test out LHP.

The areas left for me are:
Build the vala and genine, development environment with IDEs
Wine to get more bible study guides working (Bible Ultimate)
Wine to run my Delorme Topo, Streetmaps and National Geo Topo
And get gnucash 2.2.4 or greater working

Does underdog work in LHP?

The final destination of LHP will be on a hard disk that has Ubuntu 8.04
with Gnucash in another partition.

Keep up the great work on LHP!!!
-bruce.
Back to top
View user's profile Send private message 
Barburo


Joined: 14 Jun 2007
Posts: 283

PostPosted: Mon 14 Sep 2009, 12:50    Post subject: rt2870sta driver  

Hi TazOC,
I have also posted this problem in hardware/wireless but have received no replies yet.

Briefly , I purchased a Buffalo WLI-UC-GN USB dongle for my HP Tx1000 notebook because the internal Broadcomm card ceased to function.

Windows recognizes it and configures it from the supplied CD

Lighthouse Pup 4.1.2 Final doesn't see the dongle. Not sure why. Pupscan shows
Quote:
Manufacturer=Ralink
Product=802.11 n WLAN
SerialNumber=1.0
VendorID=0411 ProductID=015d KERNEL-MODULE=(none)

I looked through /var/log/messages but saw no warnings or error messages.

I googled around and found that this dongle uses the Ralink RT2870 chipset.

I tried to load rt2870sta driver through the connection wizard and got a "not found" (see pic).

From reading the forum this module should auto load in al 4.xx puppys.

Any idea why 4.1.2f doesn't load it?

B.
image.gif
 Description   
 Filesize   16.92 KB
 Viewed   1565 Time(s)

image.gif

Back to top
View user's profile Send private message 
tazoc


Joined: 11 Dec 2006
Posts: 1157
Location: Lower Columbia Basin WA US

PostPosted: Mon 14 Sep 2009, 14:31    Post subject:  

@Bruce,
I don't know how to change the titlebar behavior in JWM. I usually use KDE or LXDE. Not sure about underdog, I've never tried it. Thanks for your comments.

@Barburo,
I tried loading the same module in LHP 412f and got the same error you did. Must be something wrong with that firmware or maybe it is incompatible with the k2.6.28.5 kernel? We should try Puppy 412 and see if it's any different. I will try it and update this post shortly. The firmware is at '/lib/modules/all-firmware/rt2870sta-fw.tar.gz'.
[Update: I tried loading the firmware in Puppy 412 and it works. I don't know why it doesn't work in LHP. I'm working on LHP443 with Barry's new k2.6.30.5 and I'll try it on that.]

-TazOC

_________________
lhpup.org Lighthouse 64 6.02
Back to top
View user's profile Send private message Visit poster's website 
tazoc


Joined: 11 Dec 2006
Posts: 1157
Location: Lower Columbia Basin WA US

PostPosted: Thu 17 Sep 2009, 17:15    Post subject: Translations and keymaps for KDE 4.2.4  

KDE-4.2.4-l10n_442.sfs Regions & languages for KDE 4.2.4 (non-US only)
* Translations and keymaps for KDE 4.2.4 only

* Use with International keyboard layout fix

* Not needed for US English locale

_________________
lhpup.org Lighthouse 64 6.02
Back to top
View user's profile Send private message Visit poster's website 
Bruce_n_Duane

Joined: 01 Nov 2005
Posts: 68
Location: Washington State

PostPosted: Fri 18 Sep 2009, 17:39    Post subject: KDE and Mariner Question
Subject description: Startup screens still appearing
 

Hello Tazoc:

I am using Lighthouse Puppy 4.4.2d with the JWM window manager and 6 additional sfs file loaded at boot (Opera, KDE, Mariner, Bibletime, OpenOffice, and Google Earth) that I downloaded September 3rd.

I just built a copy of Lighthouse without Opera for a fellow camper at the resort I am at. She was using windows and sold her on switching to Puppy. Put it on a 4GB Kingston Traveler Flash. Works great. I would love to tell her how to get Mariner and KDE to stop asking to be installed on startup.

I have tried myself, answering yes to all screens and still get the startup screen.
If I select Uninstall for both, I still get asked at startup. If I delete the entries for KDE and Mariner in /Autostart and /Startup, the entries get put back when I boot my computer the next time. Is there a way to get this to stop?

Also, How do I get rid of gkrellm on startup without breaking the system. I would prefer the pwidgets display of Puppy 4.2.1. Is it possible to use pwidgets in JWM on Lighthouse Puppy 422d?

I tried "underdog" to run gnucash in a quick test. It failed. I will try again next week to get this to work. I now have two flash drives with Lighthouse Puppy installed. One for testing and one to use all the time. I am switching to Lighthouse Puppy as my main Linux.

I have modified the /root/.wbar file to have the icons and applications that I like.

The only application I added is mc=Midnight Commander. I have been using this filebrowser since 2005 and love the ability to view and edit files with this tool and have two directories to copy, compare, link, and view on the same screen.

I see that Barry has released 430 and tuuxxx has released 431 already. Are you going to build a version of Lighthouse Puppy based on this? Just a question!
Yes or No are equal answers to me!!!!!

-bruce.
Back to top
View user's profile Send private message 
tazoc


Joined: 11 Dec 2006
Posts: 1157
Location: Lower Columbia Basin WA US

PostPosted: Fri 18 Sep 2009, 19:13    Post subject:  

Hi Bruce,
I'm testing LHP443 with the kernel from Puppy 4.3. Will probably wait for the next release or two before doing a complete re-build of LHP from Puppy 4.3x.

I want you to use ROX-Filer to check for 'MarinerSetup' scripts in both /Autostart and /Startup. Move both into the accompanying folder, DisabledItems. Same for gkrellm if desired. Then open '/usr/local/bin/', right-click on 'MarinerSetup' | Permissions and change the drop-down to 'a-x(Make non-executable)'. You can do the same for 'KDE-Setup'.

Then save your session if your pup_save.2fs is on a flash drive by typing '/usr/sbin/save2flash' in terminal. Wait until it finishes, then reboot.

If that doesn't make the prompts go away I don't know what will...

I couldn't get Pwidgets to work properly in LHP. Have you tried Conky in the Desktop or System Menu? Pwidgets opens several instances of conky, with unique configurations.
-TazOC

_________________
lhpup.org Lighthouse 64 6.02
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 21 of 23 [345 Posts]   Goto page: Previous 1, 2, 3, ..., 19, 20, 21, 22, 23 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1244s ][ Queries: 12 (0.0086s) ][ GZIP on ]