Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 22 Oct 2014, 17:50
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
cups1.4b2-i486 pet (2.46MB) reworked for lpt & usb printers
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post new topic   Reply to topic View previous topic :: View next topic
Page 3 of 4 [54 Posts]   Goto page: Previous 1, 2, 3, 4 Next
Author Message
Patriot


Joined: 15 Jan 2009
Posts: 734

PostPosted: Wed 04 Feb 2009, 03:32    Post subject:  

Hmmm .....

Quote:
I cannot find an option to delete a printer if one screws up.

If you're used to the previous web interface then the new web interface layout needs some time to getting used to ... from what i read, that's how all cups from 1.4 onwards will be ...

The option to delete is now placed 'deeper' into individual printer menu. As edoc mentioned, you'll have to click on the 'screwed up' printer name and proceed from there .....

Quote:

Quote:
Quote:
403 Forbidden

I have done the chmod 0666 /dev/lp0 several times but no effect. Not sure what is happening.


edoc, could you kindly elaborate a little more ? From what I can tell, if you're getting a 403 in the web-interface then it could be a browser cache issue ... cups will ask for login info if an administrative function is called ... I've also read somewhere that cups can sometimes timed-out due to the ssl key creation during logins ... I've not encounter a 403 as yet, so a little more detailed spec may help me pin point the issue ...

Perhaps you may need to flush (delete) the bareview cache before using cups web interface ... It's in /root/.TestGtkEmbed/TestGtkEmbed/Cache/ ... This is also done in the updated pet postinstall ... Alternatively, if you use the default browser then clear the cache before pointing to http://localhost:631

I'd like to briefly explain about the chmod 0666 /dev/lp0 ... this permission will give read & write access for /dev/lp0 to owner + group + world ... (puppy's "on-demand-mod-loading" default is 0660)

Without it, cups cannot access any printer assigned to /dev/lp0 as cups also no longer runs as root (attempting to run as root will make cups switch to user nobody) ... using any other userid won't make much difference either as puppy is root owned by default ...

This issue have been resolved in the newly updated cups_std pet ... I have added udev rules to ensure all /dev/lp# and /dev/usb/lp# are world accessible ... the /dev/lp# permission denied errors should no longer be an issue ...

Quote:
Brief info on my tests so far ...


During my tests, I found that I'm unable to use both lpt and usb printers at the same time .... they both were pointing to /dev/lp# ..... so I'm placing usb printers back to /dev/usb/lp# ... this is done in accordance to what I understand from :

http://www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html
-and-
http://www.linuxjournal.com/article/7316

I've requested a friend of mine with multiple usb printers to test puppy + cups on his system and have just received a positive reply that multiple usb printers does work properly and cups can print to both usb printers simultaneously ... On my part, I'm able to print to one usb and one lpt printer simultaneuosly ...

At this point, my concern is to be able to print thru cups either using built-in ppd or raw. Next, I'll need to confirm samba -> cups printing is not broken ...

I've yet to start looking into gutenprint compatibility (as requested by ttuuxxx) as I have real world matters to deal with at the moment ... it may take a little while longer before I can resume ...

Rgds
Back to top
View user's profile Send private message 
edoc


Joined: 07 Aug 2005
Posts: 4379
Location: Southeast Georgia, USA

PostPosted: Wed 04 Feb 2009, 13:00    Post subject:  

OK, I think I have spotted the local problem here - CUPS on one computer is conflicting with CUPS on another.

When I made changes to the setup of the printer on the desktop printer from my laptop it got all confused. Perhaps a user needs to be warned when making a remote change that may cause problems?

I reset the printer connected to the desktop from CUPS on the desktop and it is working fine from both the desktop and my laptop now.

I have CUPS 1.4b2 on that desktop but it is not your version, yours is on my laptop - I will change that one to yours and see if that removes the conflict that is preventing the HP printer connected to my laptop from working.

A more prominent warning as to the interaction of CUPS on a network may be in order - my computers are in a very common configuration - a shared wired/wireless router.

WDYT?

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send private message Visit poster's website 
edoc


Joined: 07 Aug 2005
Posts: 4379
Location: Southeast Georgia, USA

PostPosted: Wed 04 Feb 2009, 14:27    Post subject:  

Just observed different behavior between Print Test Page and Print Self-Test Page,
Print Test Page fails with an error:
Quote:
hp_officejet_4200_series-28 Test Page anonymous 1k Unknown stopped "/usr/lib/cups/filter/foomatic-rip-hplip failed"


Print Self-Test Page cycle for a while then produces the inaccurate message:
Quote:
Print Self-Test Page On hp_officejet_4200_series
Printer command job completed


Print Self-Test Page prints nothing, the job and output just vanish.

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send private message Visit poster's website 
Patriot


Joined: 15 Jan 2009
Posts: 734

PostPosted: Thu 05 Feb 2009, 09:03    Post subject:  

Hmmm .....

I'm sorry edoc ... I wish I could help troubleshoot hplip/foomatic stuffs ... frankly, I'm not using it as yet and haven't a clue what's going on ... I'm willing to put it onto a list of stuff to do together with gutenprint tests ... that'll probably be sometime next week ...

I'm already under a ton of stuffs to clear right now ... I hope I can get back to messing with puppy soon ...

Rgds
Back to top
View user's profile Send private message 
Patriot


Joined: 15 Jan 2009
Posts: 734

PostPosted: Thu 05 Feb 2009, 09:09    Post subject:  

Hmmm .....

I was having some coffe, wrecking my brains figuring how to settle some real life issues ..... then out of nowhere, a flash came to mind on cups usb printer detection ...

I took a quick look at the cups backend sources and whipped up a usb printer backend based on the parallel sources ... I've only made some quick tests and found it working for me ... I need some testers to tell me how it goes ...

Look at my first post for the addon and place the module usblpp into /usr/lib/cups/backend ... No cups restart or reboot required ... If you need to remove it, just delete it and reconfigure your printer URI to parallel:/dev/usb/lp# again ...

This allows usb printers to be detected by model at usb# ... The URI upon detection will be usblpp:/dev/usb/lp# ... It is deemed to be an experimental addon ...

Please post some feedbacks ...

Rgds
Back to top
View user's profile Send private message 
edoc


Joined: 07 Aug 2005
Posts: 4379
Location: Southeast Georgia, USA

PostPosted: Thu 05 Feb 2009, 12:08    Post subject:  

So, are you saying that I just need to download and run this?

Quote:
cups-1.4b2-usblp-addon.tar.gz
Description usb printer backend addon : put into /usr/lib/cups/backend


Or is there also an additional manual edit I need to do?

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send private message Visit poster's website 
Patriot


Joined: 15 Jan 2009
Posts: 734

PostPosted: Thu 05 Feb 2009, 23:23    Post subject:  

Hmmm .....

Quote:
..... Or is there also an additional manual edit I need to do?

Does not require any editing to any conf file ... Click on the file and extract somewhere ... then copy/move the usblpp file to /usr/lib/cups/backend ... then open cups web interface, click add printer (or find new printer) and any usb printer(s) on /dev/usb/lp# should be presented on the printer selection list ... if its not then its probably already on the configured list ...

Since its still experimental and requires field test reports, it should be excluded from the std pet package ... if its stable enough then the final source and binary will be added in ...

Rgds
Back to top
View user's profile Send private message 
edoc


Joined: 07 Aug 2005
Posts: 4379
Location: Southeast Georgia, USA

PostPosted: Sat 07 Feb 2009, 23:50    Post subject:  

Followed all of the steps, no joy, get the same old error when I try to print a Test Page:

Quote:
hp_officejet_4200_series-61 Test Page root 1k Unknown stopped
"/usr/lib/cups/filter/foomatic-rip-hplip failed"


I will reboot and try again ... just in case.

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send private message Visit poster's website 
edoc


Joined: 07 Aug 2005
Posts: 4379
Location: Southeast Georgia, USA

PostPosted: Sun 08 Feb 2009, 10:35    Post subject:  

Just occurred to me that I may need to install your addon on both computers ... will do so little later after church and report back.

Reboot on my laptop made no difference for the failur of the HP printer.

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send private message Visit poster's website 
Josef

Joined: 09 Feb 2009
Posts: 20

PostPosted: Thu 12 Feb 2009, 04:00    Post subject:  

ttuuxxx wrote:

http://www.puppylinux.asia/tpp/ttuuxxx/programs/documents/cups-1.4b2-i386-v2.pet


Hi ttuuxxx!
The link is down, would you check it please?

Thx!
Back to top
View user's profile Send private message 
jakobcornelis


Joined: 06 Nov 2007
Posts: 117
Location: Elliot Lake, Ontario

PostPosted: Sat 07 Mar 2009, 20:08    Post subject:  

Patriot wrote:


All these pesky little things can annoy users and users don't like to be annoyed by stuffs that just works everywhere else ...

Rgds


I'll say.

This thing seems outright bizarre to a newbie like me. I shouldn't even be in a thread like this - I am way out of my league. But, hey, that cups_std-1.4b2-i486.pet got my printer going where nothing else would. Mind you, when I reboot it's gone again. I tried to add

modprobe parport
modprobe parport_pc
modprobe lp
chmod 0666 /dev/lp0

but that did not do any good (I put that just ahead of the init.d part just past the last fi. I just try to do what you guys tell me.)

For the record, I run Puppy 4.1.2 on an old Toshiba Satellite 1500, with a Canon BJC 2000 printer (parallel port). I've also tried a HP Deskjet 3915 usb printer, but I never got that to go at all.

Now if I can only get my printer working after reboot, even by adding some code, I'll be ahead of the game; right now the only way to accomplish this seems to be to uninstall cups and reinstall it .

Meanwhile, thanks for the reworked cups. That made my day.

jc
Back to top
View user's profile Send private message 
edoc


Joined: 07 Aug 2005
Posts: 4379
Location: Southeast Georgia, USA

PostPosted: Sat 07 Mar 2009, 20:51    Post subject:  

Josef wrote:
ttuuxxx wrote:

http://www.puppylinux.asia/tpp/ttuuxxx/programs/documents/cups-1.4b2-i386-v2.pet


Hi ttuuxxx!
The link is down, would you check it please?

Thx!


Just tried it now and got this error:
Quote:

Authorization Required

This server could not verify that you are authorized to access the document requested. Either you supplied the wrong credentials (e.g., bad password), or your browser doesn't understand how to supply the credentials required.

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send private message Visit poster's website 
WhoDo


Joined: 11 Jul 2006
Posts: 4441
Location: Lake Macquarie NSW Australia

PostPosted: Sat 07 Mar 2009, 21:13    Post subject:  

edoc wrote:
Just tried it now and got this error:
Quote:

Authorization Required

This server could not verify that you are authorized to access the document requested. Either you supplied the wrong credentials (e.g., bad password), or your browser doesn't understand how to supply the credentials required.

All of our main mirror sites now require a UserID (puppy) and Password (linux) to access downloads. The end product of sharing a network with spammers and hackers unfortunately.

Hope that helps

_________________
Actions speak louder than words ... and they usually work when words don't!
SIP:whodo@proxy01.sipphone.com; whodo@realsip.com
Back to top
View user's profile Send private message 
jakobcornelis


Joined: 06 Nov 2007
Posts: 117
Location: Elliot Lake, Ontario

PostPosted: Sat 07 Mar 2009, 21:17    Post subject:  

Patriot wrote:


3. I've posted the cups 1.4b2 standard (full) pet reworked with the above fixes. This pet package will make some cleanups during installation and now have automatic "postinstall" install. I did not make any changes to the cups source. Full source is available from www.cups.org btw ...




Posted where, please?

jc
Back to top
View user's profile Send private message 
edoc


Joined: 07 Aug 2005
Posts: 4379
Location: Southeast Georgia, USA

PostPosted: Sat 07 Mar 2009, 21:59    Post subject:  

Quote:
Not Found

The requested URL /tpp/ttuuxxx/programs/documents/cups-1.4b2-i386-v2.pet was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 3 of 4 [54 Posts]   Goto page: Previous 1, 2, 3, 4 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0969s ][ Queries: 12 (0.0043s) ][ GZIP on ]