Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 21 Dec 2014, 12:51
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Integration of 3G Wireless Modem Detection - 4.1.2 & 4.2.1
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 21 of 37 Posts_count   Goto page: Previous 1, 2, 3, ..., 19, 20, 21, 22, 23, ..., 35, 36, 37 Next
Author Message
alix_board

Joined: 14 Aug 2009
Posts: 64
Location: Austria

PostPosted: Fri 04 Sep 2009, 05:05    Post_subject:  resolv.conf  

Hi @ all,

no it works great!

I create resolv.conf with the DNS of A1 and saved it in /etc --> that was the conclusion Smile !
Back to top
View user's profile Send_private_message 
Aitch


Joined: 04 Apr 2007
Posts: 6825
Location: Chatham, Kent, UK

PostPosted: Fri 04 Sep 2009, 07:15    Post_subject:  

Rich,

followed alix here Smile

see warpinwolf's post

http://www.murga-linux.com/puppy/viewtopic.php?p=338292#338292

apologies if you're already aware of this

Aitch Smile
Back to top
View user's profile Send_private_message 
kultex

Joined: 17 Nov 2007
Posts: 39

PostPosted: Fri 04 Sep 2009, 12:28    Post_subject:  

@alix_board,

strange - which puppy version did you take? - I tested all Austrian operators - except A1 (but with bob, who is using the same net as A1) with puppy, Huawei E220 and I had no problems with DNS - and I installed one laptop with fluxflux-sl and A1 and there also was no need for DNS entries.
Back to top
View user's profile Send_private_message 
alix_board

Joined: 14 Aug 2009
Posts: 64
Location: Austria

PostPosted: Mon 07 Sep 2009, 01:36    Post_subject:  

Hi kultex,

i use Puppy Version 4.2.1-k2.6.25.16 !

@ my DNS Problem: Before i install the 2 drivers 3G_pupdial-wireless-12.pet and usb_modeswitch-1.0.2.pet i don not have problems with DNS. But after that, i had also problems with normal Ethernet Connection to the Internet. So, after i have configure resolv.conf it works!
Back to top
View user's profile Send_private_message 
mcalex

Joined: 23 Apr 2006
Posts: 78
Location: Perth, WA

PostPosted: Tue 08 Sep 2009, 07:56    Post_subject:  

hiya richard, still lurking.

just tried to change /etc/wvdial.conf as you suggested to alix_board (ie uncommenting init8 and init9).

Like alix_board, I seem to have the problem where pupdial re-comments the lines before running, hence no output in the connection status log.

Am i editing the right file? is there a user-level wvdial.conf that has settings that overwrite the file in /etc?

apart from that, i'm still stuck, but then I haven't worked really hard at it. have been thinking a bit, and wondering if there is any chance it's coz i've got an athlon instead of an intel chip? that seems to be the cause of a few of my linux problems.

anyway, if you can let me know if i'm editing the correct wvdial.conf (or tell me why pupdial is recommenting) that'd be great.

<edit>
the things you find when you read. Just trawled through the user guide. looks like Virgin's apn is: virginbroadband (all lowercase). can't remember whether i've tried that, but will have a shot
-chap in /etc/ppp/options looks worth a shot too.
. . . <edit2>
. . . nope, and nope
. . . </edit2>
</edit>

cheers
mcalex
Back to top
View user's profile Send_private_message 
rerwin


Joined: 24 Aug 2005
Posts: 1551
Location: Maine, USA

PostPosted: Wed 09 Sep 2009, 23:03    Post_subject:  

mcalex, alix_board,
Regarding your difficulty in editing wvdial.conf and having it remain when pupdial runs: My design intent some time ago was for pupdial to allow users to edit the more exotic options into the file and for pupdial to keep them there and use them when connecting. But the constraint was to be that you edit the file only when pupdial is NOT running. While running, it rewrites the file. I thought I put in logic to read and rewrite the Init6-9 section as is -- however the user wants it.

I just now got around to trying that myself. But it not only destroys the data if entered when pupdial is running, but also if edited with pupdial not running. I will look into it tomorrow, to get it right for 4.3!

Thanks for prompting me to check it.
Richard
Back to top
View user's profile Send_private_message 
kultex

Joined: 17 Nov 2007
Posts: 39

PostPosted: Thu 10 Sep 2009, 10:48    Post_subject:  

alix_board wrote:

@ my DNS Problem: Before i install the 2 drivers 3G_pupdial-wireless-12.pet and usb_modeswitch-1.0.2.pet i don not have problems with DNS. But after that, i had also problems with normal Ethernet Connection to the Internet. So, after i have configure resolv.conf it works!


I think, that is not a problem with rerwins pets, it is a problem of puppy - it starts, as soon, as you open seamonkey, without having an internet connection - it is also happens, when you boot from CD, open seamonkey without connection to the net by lan - then connect - ifconfig tells you, you are connected, but in seamonkey no website opens....
Back to top
View user's profile Send_private_message 
mcalex

Joined: 23 Apr 2006
Posts: 78
Location: Perth, WA

PostPosted: Fri 11 Sep 2009, 12:34    Post_subject: working in 4.3 (4.2.4?)  

hi rerwin,

can happily report that i can get (and am now) online using 3G_pupdial-wireless-12.pet and usb_modeswitch-1.0.2.pet in puppy 4.2.4 but only with pupdial working in stupid mode and after playing with config settings in seamonkey. woo-hoo!

only problem is, puppy can't seem to find my soundcard anymore Sad i'm off searching for audio posts
<edit>
just noticed a post of yours at the beginning of the 4.3 beta2 bug thread which i'm trawling through. do you want my copy of the three files you requested there or have i missed that boat? I have a creative labs card that 4.21 found the emu10k (i think) driver for. in 4.2.4 alsa wants to probe ISA devices!
</edit>

great work, for some reason i've not managed to get online with linux (tried redhat, fedora, mandrake) or freebsd before, so this is a first for me. nearly au revoir windows!

cheers
mcalex
Back to top
View user's profile Send_private_message 
rerwin


Joined: 24 Aug 2005
Posts: 1551
Location: Maine, USA

PostPosted: Fri 11 Sep 2009, 15:33    Post_subject: Pupdial correction to retain edited wvdial.conf Init6-9  

kultex,
Thanks for analyzing the DNS issue. Is the problem something you and I could work out a remedy for?

mcalex,
Glad to hear you resolved your connection issue.

And alix_board,
I have now fixed pupdial so you can edit the wvdial.conf Init6-9 lines and have them be retained by pupdial. The patch is in the 4.3beta2 Bugs thread here: http://www.murga-linux.com/puppy/viewtopic.php?p=340321#340321
I am also updating 3G_pupdial...-12 with it, for new downloaders.
Richard
Back to top
View user's profile Send_private_message 
kultex

Joined: 17 Nov 2007
Posts: 39

PostPosted: Fri 11 Sep 2009, 17:38    Post_subject:  

the very quick remedy is I think the resolv.conf - the rest has to wait in my case until the end of October, because until 20.10 I am absolutely occupied with work and just can do very little things.....sorry
Back to top
View user's profile Send_private_message 
01micko


Joined: 11 Oct 2008
Posts: 7841
Location: qld

PostPosted: Tue 15 Sep 2009, 09:56    Post_subject:  

wow!

Thankyou Richard and Barry. Online via my huwei (I'll never spell that right) e169 over VirginBroadband Au running 4.3 beta 3. (Did that -chap thing in /etc/ppp/options). Took only seconds. On the eee pc 701sd with a sd card installed via BootFlash usb installer.

If you need logs let me know, I spose good logs are as helpful as bad logs Smile

Cheers and thanks.

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
rerwin


Joined: 24 Aug 2005
Posts: 1551
Location: Maine, USA

PostPosted: Tue 15 Sep 2009, 14:21    Post_subject:  

01micko,
Thanks for your positive report on a device that was tricky to get going. Although my first thought was that I did not need them, since you succeeded, but I would like to see how it all worked, because of that trickiness. Thanks for offering.

kultex: Thanks for that gem of a chart, and the details for part of Europe. I have added a pointer to your posting from a new item 7 in the main page.
Richard
Back to top
View user's profile Send_private_message 
01micko


Joined: 11 Oct 2008
Posts: 7841
Location: qld

PostPosted: Wed 16 Sep 2009, 01:29    Post_subject:  

hello Richard

here is what I did (much the same as previous)

-Modem was detected at boot and recognised as /dev/ttyUSB0
-Carrier check, Dialtone check, Busy check All unchecked
-Stupid mode, Auto Reconnect Both checked
-left Initialisation strings and Max speed alone
-I have no SIM PIN, so left it blank
-inserted ISP phone number *99#
-my username
-left password but I think any old thing should be there
-Inserted Wireless APN "VirginBroadband" (without quotes)
-added "-chap" option to /etc/ppp/options

Here's /tmp/pup_event_module_devpath_log
Code:
MODULE=processor DEVPATH=/devices/LNXSYSTM:00/ACPI_CPU:00
MODULE=ac DEVPATH=/devices/LNXSYSTM:00/device:00/PNP0A08:00/ACPI0003:00
MODULE=button DEVPATH=/devices/LNXSYSTM:00/LNXPWRBN:00
MODULE=eeepc_laptop DEVPATH=/devices/LNXSYSTM:00/device:00/ASUS010:00
MODULE=evdev DEVPATH=/devices/virtual/input/input6
MODULE=thermal DEVPATH=/devices/LNXSYSTM:00/LNXTHERM:00
MODULE=battery DEVPATH=/devices/LNXSYSTM:00/device:00/PNP0A08:00/PNP0C0A:00
MODULE=video DEVPATH=/devices/LNXSYSTM:00/device:00/PNP0A08:00/device:16
MODULE=intel_agp DEVPATH=/devices/pci0000:00/0000:00:00.0
MODULE=shpchp DEVPATH=/devices/pci0000:00/0000:00:1c.0
MODULE=snd_hda_intel DEVPATH=/devices/pci0000:00/0000:00:1b.0
MODULE=shpchp DEVPATH=/devices/pci0000:00/0000:00:1c.1
MODULE=shpchp DEVPATH=/devices/pci0000:00/0000:00:1c.2
MODULE=uhci_hcd DEVPATH=/devices/pci0000:00/0000:00:1d.0
MODULE=uhci_hcd DEVPATH=/devices/pci0000:00/0000:00:1d.1
MODULE=uhci_hcd DEVPATH=/devices/pci0000:00/0000:00:1d.2
MODULE=uhci_hcd DEVPATH=/devices/pci0000:00/0000:00:1d.3
MODULE=ehci_hcd DEVPATH=/devices/pci0000:00/0000:00:1d.7
MODULE=i2c_i801 DEVPATH=/devices/pci0000:00/0000:00:1f.3
MODULE=atl1e DEVPATH=/devices/pci0000:00/0000:00:1c.1/0000:03:00.0
MODULE=pcspkr DEVPATH=/devices/platform/pcspkr
MODULE=serio_raw DEVPATH=/devices/platform/i8042/serio0
MODULE=serio_raw DEVPATH=/devices/platform/i8042/serio1
MODULE=usbcore DEVPATH=/devices/pci0000:00/0000:00:1d.7/usb1/1-0:1.0
MODULE=usb_storage DEVPATH=/devices/pci0000:00/0000:00:1d.7/usb1/1-5/1-5:1.0
MODULE=option DEVPATH=/devices/pci0000:00/0000:00:1d.0/usb2/2-2/2-2:1.0
MODULE=option DEVPATH=/devices/pci0000:00/0000:00:1d.0/usb2/2-2/2-2:1.1
MODULE=option DEVPATH=/devices/pci0000:00/0000:00:1d.0/usb2/2-2/2-2:1.2

/tmp/udevtrace-modem.log
Code:
usb_v1d6b_p0002_d0206_dc09_ic09_usb_interface_Linux 2.6.30.5 ehci_hcd_EHCI Host Controller_
usb_v1d6b_p0001_d0206_dc09_ic09_usb_interface_Linux 2.6.30.5 uhci_hcd_UHCI Host Controller_
usb_v058f_p6335_d0105_dc00_ic08_usb_interface_Generic_Mass Storage Device_
usb_v12d1_p1001_d0000_dc00_ic08_usb_interface_____________________HUAWEI Mobile_
module_usbserial
usb_v1d6b_p0001_d0206_dc09_ic09_usb_interface_Linux 2.6.30.5 uhci_hcd_UHCI Host Controller_
usb_v1d6b_p0001_d0206_dc09_ic09_usb_interface_Linux 2.6.30.5 uhci_hcd_UHCI Host Controller_
module_option
usb_v1d6b_p0001_d0206_dc09_ic09_usb_interface_Linux 2.6.30.5 uhci_hcd_UHCI Host Controller_
usb_v12d1_p1001_d0000_dc00_icff_usb_interface_____________________HUAWEI Mobile_
usb_v12d1_p1001_d0000_dc00_icff_usb_interface_____________________HUAWEI Mobile_
usb_v12d1_p1001_d0000_dc00_icff_usb_interface_____________________HUAWEI Mobile_
usb_v1d6b_p0002_d0206_dc09_ic09_usb_interface_Linux 2.6.30.5 ehci_hcd_EHCI Host Controller_
usb_v058f_p6335_d0105_dc00_ic08_usb_interface_Generic_Mass Storage Device_
usb_v1d6b_p0001_d0206_dc09_ic09_usb_interface_Linux 2.6.30.5 uhci_hcd_UHCI Host Controller_
usb_v12d1_p1001_d0000_dc00_icff_usb_interface_____________________HUAWEI Mobile_
usb_v12d1_p1001_d0000_dc00_icff_usb_interface_____________________HUAWEI Mobile_
usb_v12d1_p1001_d0000_dc00_icff_usb_interface_____________________HUAWEI Mobile_
usb_v1d6b_p0001_d0206_dc09_ic09_usb_interface_Linux 2.6.30.5 uhci_hcd_UHCI Host Controller_
usb_v12d1_p1001_d0000_dc00_ic08_usb_interface_____________________HUAWEI Mobile_
usb_v1d6b_p0001_d0206_dc09_ic09_usb_interface_Linux 2.6.30.5 uhci_hcd_UHCI Host Controller_
usb_v1d6b_p0001_d0206_dc09_ic09_usb_interface_Linux 2.6.30.5 uhci_hcd_UHCI Host Controller_


Other logs as attached

Thanks Smile

Mick
logs.tar.gz
Description 
gz

 Download 
Filename  logs.tar.gz 
Filesize  3.14 KB 
Downloaded  419 Time(s) 

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
01micko


Joined: 11 Oct 2008
Posts: 7841
Location: qld

PostPosted: Fri 18 Sep 2009, 01:40    Post_subject:  

Hello again Richard

Working great on my main box too in 4.3 Cool . Just as well too because I've blown my download limit for the month... still 10 days to go!

Two minor niggles.

1. I always check 'stupid mode' but pupdial does not remember my choice. Is that possible to implement?

2. I definitely need the '-chap' option in /etc/ppp/options (just inadvertantly tried without it Laughing ) or else the modem will not negotiate a connection. I recall you said you might try to squeeze that checkbox in the pupdial gui.

Are there other ISPees needing that option?

Cheers

Mick

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
alix_board

Joined: 14 Aug 2009
Posts: 64
Location: Austria

PostPosted: Mon 21 Sep 2009, 08:32    Post_subject: Re: Pupdial correction to retain edited wvdial.conf Init6-9  

rerwin wrote:
kultex,
And alix_board,
I have now fixed pupdial so you can edit the wvdial.conf Init6-9 lines and have them be retained by pupdial. The patch is in the 4.3beta2 Bugs thread here: http://www.murga-linux.com/puppy/viewtopic.php?p=340321#340321
I am also updating 3G_pupdial...-12 with it, for new downloaders.
Richard


Allright! Now i am back from holiday and i will try the new one a soon as possible!
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 21 of 37 Posts_count   Goto page: Previous 1, 2, 3, ..., 19, 20, 21, 22, 23, ..., 35, 36, 37 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1005s ][ Queries: 12 (0.0092s) ][ GZIP on ]