Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 02 Sep 2014, 22:18
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Boot/GRUB problem (error 2)
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 3 of 3 [33 Posts]   Goto page: Previous 1, 2, 3
Author Message
bushybill

Joined: 02 Nov 2005
Posts: 10
Location: Western Colorado

PostPosted: Sun 03 Jan 2010, 22:38    Post subject: grub errors
Subject description: wrong inode size
 

Thank you rcrsn51!
I have been trying to dual boot Puppy 431 and Windows 7 with not much luck and much frustration. I installed EasyBCD in windoz 7 but kept getting error messages. Searching the forums I found your post about the wrong inode size. I used GParted in Puppy 431 to partition the hard drive. Sure enough, the inode size was 256. Using mkfs.ext3 -I 128 /dev/sda3 cured the problem and now dual booting works fine.

Thanks Again
Bushy Bill
Back to top
View user's profile Send private message 
danneauxs

Joined: 14 Oct 2008
Posts: 92

PostPosted: Tue 26 Jan 2010, 06:36    Post subject:  

rcrsn51 wrote:
When you installed Ubuntu, it would have reformatted the drive as ext2 or ext3. Unfortunately, the recent releases of some Linux's contain formatting tools that are not compatible with Puppy's version of GRUB. Here is how to check:

Boot off the Puppy Live CD, go to a console and type this command:

Code:
tune2fs -l /dev/sda1   (with a lower case ell)


Identify the value of "Inode Size". If it's 256, you have the problem.


Could this be a problem with puppy also?

I just booted from puppy 4.3 live cd, ran gparted, deleted all partitions and reformatted to ext2. Ran the puppy universal installer, installed grub and got grub error 2. Rebooted with live cd, found this post, and ran your code - returned inode256. It was all done with puppy but the indoe was still 256????

There was an old swap file there from last year (when I last ran laptop) from DCL puppy but I couldn't turn it off with gparted so I ran pdisk to get rid of it, created new partition and formatted to ext2 but still showed 256. Used pdisk to do it all over again and still 256. Over and over using both tools to delete old partition, make a new one and format it (tried ext2, ext3 & ext4) still 256. Tried your command for mkfst.ext3 and it worked.

Why couldn't I get it right with gparted or pdisk. Could it be the harddrive? Old gateway solo 2500

Well using your manual format command worked like a charm. I even then went into gparted and resized the partition (it was the whole drive) and created a swap file. Instlled puppy and grub, rebooted and it worked. This is something I'm gonna print out !!

thanks!
Danneauxs
Back to top
View user's profile Send private message 
jahmon


Joined: 23 Jan 2009
Posts: 5
Location: Queensland

PostPosted: Fri 29 Jun 2012, 22:32    Post subject: Inode size 256
Subject description: puppy won't start after frugal install to hard drive (solved)
 

Bruce B wrote:
rcrsn51 wrote:
Thanks for replying. This problem first appeared in the Linux world in the spring of 2008, and it's finally started to filter down to Puppy. There have been four episodes in the last few weeks.


Your post doesn't specify what problem. In context with other posts, I take it you refer to GRUB and inode sizes?

I find the subject interesting as you can well imagine. Frankly, I've never had such a problem, not now or ever. I only encounter it in forum postings.

Do you have an idea why?


Thanks to rcrsn51 for providing the solution to this pervasive problem.
The offending <inode=256>-partition was created using gparted from a macpup528 live-cd. Manually re-created partition using capitalized 'I" - beautiful MacPup happily co-exists (now) with xp.

Ben

_________________
Wink Be kind!
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 3 of 3 [33 Posts]   Goto page: Previous 1, 2, 3
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0549s ][ Queries: 11 (0.0043s) ][ GZIP on ]