Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 17 Oct 2018, 23:31
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
Print job sent from Puppy gets stuck in XP print queue
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [4 Posts]  
Author Message

Joined: 21 Sep 2008
Posts: 3489
Location: Worcestershire, UK

PostPosted: Tue 30 Dec 2008, 14:29    Post subject:  Print job sent from Puppy gets stuck in XP print queue
Subject description: Problem: unable to actually print from Puppy to a printer on Windows XP

I've searched dozens of forums and sites and am unable to find a solution to this perplexing problem - if anyone can help I will be very grateful. It maybe a Windows XP rather than a Puppy problem.............

My setup:

Windows XP Home SP3 PC hard wired to Belkin Wifi Router inc. DHCP server

HP Deskjet 3920 connected to USB port on the Windows PC

Thinkpad 600 running Puppy 4.1 Retro Kernel with PCMCIA Wifi adaptor

I have applied the "missing link" patch to enable CUPS to offer the "Windows Printer via Samba" option

I have installed the HPIJS .pet and can configure CUPS to print to the HP Deskjet 3920

I have confirmed that the Deskjet when directly connected to the Thinkpad/Puppy USB port works and can print the CUPS test page and sample prints from applications

I have set both file and printer sharing on the Windows PC and can successfully detect and mount and access the shared files on Puppy using PNetHood

I can apparently send print jobs from Puppy to the Windows PC - when the print is requested, the print job appears very quickly in the Windows PC printer properties display. I have sent print jobs from CUPS Admin, from SMBClient and by printing to Default from Geany.

Then the problem starts - the Deskjet makes a couple of "I'm getting ready to start to print" noises but then goes silent and no printout appears. The print job cannot be deleted from the XP print queue by normal means.

I have tried various user accounts on XP both with and without passwords and various forms of the DeviceURI in /etc/cups/printers.conf - smb://computer_name/printer_name but in all cases the XP print queue shows the job owner as Guest

So I'm flummoxed and need some help please?
Is the problem an incompatibility between the Deskjet printer drivers on Puppy and XP ?? (how do the 2 printer drivers interact over Samba? I'm unsure.........).
Is the problem some sort of access permission problem on XP ??
Should I abandon HPIJS and try the rather complicated generic postscript solution given at http://puppylinux.org/wiki/how-tos/general/genericsharedpostscriptprinteronwindows ??

Many thanks in anticipation
Back to top
View user's profile Send private message Visit poster's website 

Joined: 05 Sep 2006
Posts: 12324
Location: Stratford, Ontario

PostPosted: Tue 30 Dec 2008, 14:57    Post subject:  

Network printing from Puppy has always been an adventure. If it works, it works perfectly. If it doesn't work, there never seems to be a solution. There are three possible culprits:

1. Puppy. Other Linux's seem to do a better job.
2. Wireless / wired networking, routers, firewalls, etc.
3. The printer. I suspect that some printers only work if they are physically connected to their host computer.

By any chance, could you get a Windows laptop and try to print wireless from it? That would help to eliminate some sources of the problem.

Also, it would be interesting to see what happens if you turn things around and print from Windows to Puppy using this method.
Back to top
View user's profile Send private message 

Joined: 21 Sep 2008
Posts: 3489
Location: Worcestershire, UK

PostPosted: Wed 31 Dec 2008, 13:25    Post subject: some progress
Subject description: but now a different problem - "Can not get the ticket cache for root"

Many thanks for the advice..........

Unfortunately I don't have another Wifi laptop to try with Windows XP.

I did try the mirror image configuration and that didn't work either with HP drivers in both client and server.

So I've tried (with some effort) the generic postscript solution described in http://www.puppylinux.org/wiki/how-tos/general/genericsharedpostscriptprinteronwindows
and this WORKS - to an extent.

I am able to remote print successfuly from Abiword, Gnumeric, PDF Viewer and Seamonkey

however if I print from Geany or other applications which only seem to print to the default printer I get the "Can not get the ticket cache for root" error reported in:
http://www.murga-linux.com/puppy/viewtopic.php?t=26565&start=15 where I've posted some log information

So I think this proves that my original problem wasn't a wifi or networking or router problem nor an XP problem but some sort of problem between the 2 types of HP driver on the client and server.

I now seem to have a different problem - to get the badly behaved applications to print - anybody got any suggestions??

Printing is acceptably speedy BTW even though my Thinkpad 600 is pretty old and slow, my wifi is 802.11b and there's obviously quite a bit of software that gets involved in all the different translations.

Back to top
View user's profile Send private message Visit poster's website 

Joined: 26 Jul 2007
Posts: 986
Location: England

PostPosted: Sun 04 Jan 2009, 13:03    Post subject:  

I've struggled with Puppy printing for 18 mnths, ever since I started with Puppy. As rcrsn51 says- if it works, then it works; if it doesn't, then it doesn't.

One thing I've found is: If the application gives only a "Generic Postscript" choice at print time, and your printer is not a generic postscript printer, then you will never print. YOUR printer has to show up on the printer menu.

My printer is connected to an XP machine, but connection is via a wired network. Sometimes it works, sometimes it doesn't. I've checked firewalls, permissions, sharing, samba, and so on, but never managed to get a set-up that worked consistently, except 4.1.2 retro. That works if I make sure that the XP machine is on, the printer is on, and I then use PNethood to connect Print$ with the "use cifs" box checked before starting work.

I've also found that if printing will not work, then file sharing usually does. Next time I get trouble, I intend to copy the file that I want to print into a Windows share folder, then try printing it using Word. Could be informative.

And, sshh...... Debian works, no bother. Too big and slow for my old crock of a machine, and all the "you are not allowed to do that" password stuff.....

Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [4 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0395s ][ Queries: 11 (0.0067s) ][ GZIP on ]