Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 22 Jul 2014, 07:31
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
FAILURE TO CREATE RAM DISK - POSSIBLE ADDRESS CONFLICT?
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [4 Posts]  
Author Message
NWS

Joined: 10 Nov 2005
Posts: 2
Location: Houston

PostPosted: Fri 11 Nov 2005, 11:52    Post subject:  FAILURE TO CREATE RAM DISK - POSSIBLE ADDRESS CONFLICT?  

For the past few days I have been trying unsuccessfully to run Puppy Windows for Windows 98 (vers. 1.0.5).

Even though my computer, a Dell Inspiron 7000 P2 300Mhz laptop, has 192 MB of RAM on board, it appears that for
some reason a sufficiently large RAM disk cannot be created. I believe that the reason COULD be due to the fact that I have
the computer's BIOS configured for "maximum performance" i.e. RAM shadowing of the system's video and system ROM. There COULD
be an address conflict between the RAM that the BIOS uses for system and video BIOS shadowing and the RAM that the PupWIn98
utility is trying to address in order to create the RAM disk to run Linux. I will
disable the computer's "maximum performance" option in BIOS and try again to see if this is indeed the case.

The following is the screen output of my computer after I double click on the penguin on my Windows 98 desktop. All of the following
was generated by the computer, except for my comments, which are enclosed in {{ }} brackets.

Has anyone had a similar experience?

NWS


---------START OF PUPWIN98 START UP SEQUENCE -------------------------
>>

Dell Inspiron 7000 300LT Bios Rev. A15
CPU=Pentium II, 300 MHz
0640K System RAM Passed
0191M Extended RAM Passed
0512K cache SRAM Passed
System BIOS Shadowed
Video BIOS Shadowed
UMB upper limit segment address: EB90
Mouse initialized

{{ The startup sequence next goes on to
initialize the 8 GB HDD, and the Matsushita CD/DVD ROM drive. }}

The amount of system memory has changed,
or the suspend to disk file, is absent.
See "Suspend to Disk File", in the on-line
users guide for instructions.

{{ The computer has 64MB installed on the motherboard.
When I ordered it from Dell, I had another 128MB installed,
for a total of 192 MB RAM. Presumably that expolains the statement about the amount of system memory having changed. The "suspend" option on the BIOS is
either "Suspend to Disk" or "Suspend to RAM". Initially it
was set to "Suspend to RAM".I thought that this could have an address
conflict with the RAM
disk, so I changed the BIOS setting to "Suspend to Disk".
It made no difference.}}

{{ A BIOS settings screen flashes up briefly, and the start-up
process continues. The BIOS settings are as follows: }}

Windows 98 is now starting your MS-DOS based program.

System cannot determine what configuration your system is in.

Select one of the following:

1. Docked Configuration
2. Backup Configuration (similar to docked)
3. Backup Configuration (similar to undocked)
4. None of the above

Enter your choice: <<

{{ I enter "1"}}

<<

Windows Expanded Memory driver, version 4.95
{{ Copyright, etc.}}

EMM386 not installed - unable to set page frame base address

Press any key when ready ...

EMM386 successfully installed

Expanded memory services unavailable

Total upper memory available: 54 KB {{ KB - not MB !}}
Largest upper memory block available: 54KB
Upper memory starting address: CF00 H

EMM386 active

Puppy Linux (PUPPY/PUPLINUX.BAT) 2005 0513 1225

Without entry, will start Lin ux after 30 Seconds


! !
! !
Ready to run Linux or Windows Press L or W

Gujin1, Gujin2++ go! v(0.9) Etienne LORRAIN 2004
Loading Kernel "PUPPY/VLINUZ"
Loading initial RAM disk "PUPPY/IMAGE.GZ"

{{ At this point the screen goes blank, and the
process starts from the beginning in an infinite loop.
Presumably the RAM that seems to be available to
create the RAM Disk is only 54KB (not MB).
Since my machine has 192 MB of RAM on board,
it appears that the availabled RAM is not being
recognized for some reason.}}

<<
-------------END OF PUPWIN98 START UP SEQUENCE--------------------

OBSERVATIONS:

When I initially encountered this problem,
I been running without an active config.sys utility on my
hard disk, since I normally use this machine for Win98 only,
and have a rescue disk with all of the necessary DOS programs.
My initial respones to the problem was to
insert a config.sys utility with the himem.sys and emm386
statments into the start-up sequence. Since it made no difference,
I concluded that the RAM disk is being created entirely by the
utilities provided with PupLin98, and I removed the config.sys
file from my HDD again. The statements in the start-up sequence appear to support this supposition.

The only other possibilitiy
that I can think of which might be responsible for this problem
is that the computer is set for "maximum performance"
in the BIOS. This means that BOTH SYSTEM AND VIDEO BIOS
SHADOWING IN RAM ARE ENABLED. The system has 8 MB of video RAM,
but I'm not certain of the size of the video ROM. I'm also not
certain of the size of the system ROM, although I can probably
poke around and find out.

Could it be that the RAM reserved by
the system BIOS for shadowing both the system and video ROM has
an address conflict with the RAM disk that the PupWin98 startup
utility is trying to create? Has anyone encountered a similar problem?

When try again, I will disable the "maximum performance" feature in
the BIOS and presumably the computer will operate more slowly due to
the absence of both video and system BIOS shadowing in RAM. However,
if this does work, then slowing a computer with 192 MB of RAM on board
down to create a significantly smaller RAM disk will not be the most elegant solution.

Any "thoughtful thoughts" or comments about similar experiences would be appreciated.

NWS
Back to top
View user's profile Send private message 
Bruce B


Joined: 18 May 2005
Posts: 11080
Location: The Peoples Republic of California

PostPosted: Fri 11 Nov 2005, 17:58    Post subject:  

If I read your post correctly and I'm almost certain I didn't. I'd say you cannot run Puppy in a DOS RAM drive.

The main purpose of DOS in this scenario is to serve as the platform to run the DOS based bootloader, tiny.exe.

The RAM drive is created by a DOS driver. In the beginning of the Puppy boot process the RAM drive and associated drive letter exist.

A few sequences later DOS gets kicked out of the picture, the DOS drivers are removed, the RAM drive disappears from existence.

Puppy does not run on top of DOS, on the contrary - it removes it.

Puppy can and does make use of the DOS filesystem, but not to be confused with the DOS operating system.

The RAM drive is of course a DOS filesystem and Puppy can use it as long as it exists, which isn't very long because the boot process gets rid of DOS and the driver that supports the RAM disk filesystem.
Back to top
View user's profile Send private message 
NWS

Joined: 10 Nov 2005
Posts: 2
Location: Houston

PostPosted: Fri 11 Nov 2005, 20:21    Post subject:  

>> I'd say you cannot run Puppy in a DOS RAM drive. <<

Thanks for your comments.

I believe that what you say is correct, with the qualification that I can't START Puppy in a DOS RAM drive. For some reason the temporary DOS RAM Drive appears to be being created with an upper limit of 54KB. I read another post somewhere that the Dell Inspiron 7000 has some type of problem with EMM386 - so I tried to run a CD version of Feather Linux. I believe that it also uses a temporary DOS Ram drive to get started, although I believe that it then continues to rely on the CD for the Linux OS. The result was the same. Caught in an infinite failed startup loop. I then decided to try the Feather Linux CD on my Dell Inspiron 9100 P4 which normally runs Windows XP. I got to the Feather Linux startup screen the same way that I did on the Pentium 2, and then got into an infinite failed start up loop again.

It almost seems to me that there may be something to the old post about Dell Inspiron laptop computers (not only the Inspiron 7000) having a problem with EMM386.

I tried to turn off the Shadow ROM feature in the BIOS for the Inspiron 7000 in case there was an address conflict with the RAM disk, but discovered that it was not user controllable through the BIOS.

I've fiddled with it enough for one day!

NWS
Back to top
View user's profile Send private message 
Bruce B


Joined: 18 May 2005
Posts: 11080
Location: The Peoples Republic of California

PostPosted: Mon 14 Nov 2005, 22:37    Post subject:  

I can see I didn't understand the question the first time around.

Here's what's happening with your computer and the Puppy for Windows98 release:

When you click on the icon on the desktop, it kills windows and starts you running in 'real' DOS mode.

The .pif file you clicked on has instructions to load himem.sys and emm386.exe and load DOS high,umb

I cannot make sense of why it has these instructions.

1) DOS will not reallocate itself after it has booted. If you want DOS to use UMBs then it must be done on the initial boot.

2) The default is for DOS to load high, so it already is.

3) Himem.sys is already running when you boot from Windows to REAL DOS mode.

4) Emm386.exe is an EMS manager for DOS applications that require or can use EMS. It can also be used for making UMB available and loading TSRs and Devices in the UMB. But in this case it's not used that way.

5) Tiny.exe does not require EMS nor can it use it. Furthermore Tiny.exe does use extended memory either. It runs in conventional base memory.

The RAM disks that get created on Puppy's boot are Linux created disks.

Workaround: Right click on the desktop icon, edit the properties and remove the places that say to load DOS=HIGH,UMB, himem.sys and emm386.exe
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [4 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0629s ][ Queries: 11 (0.0034s) ][ GZIP on ]