Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 25 Oct 2014, 16:02
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Networking » Wireless
Sirra Wireless Aircard 881U up and running
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
ThreeD

Joined: 22 Nov 2008
Posts: 1

PostPosted: Sun 23 Nov 2008, 16:44    Post_subject:  Sirra Wireless Aircard 881U up and running  

I'm writing to share my experience with Puppy and broadband wireless using the Sierra Wireless Aircard 881U. I've been using Puppy on and off for the last couple years. Recently I had the need to connect to the Internet during the day while I'm away on the road. I signed up for broadband wireless through ATT and chose USB hardware as I could use it on multiple laptop computers, since some of them no longer have a pcmcia slot.

My main computer that I am using Puppy (version 4.1.1) is on a Dell D630 booting from a USB memory stick. I've made no changes to Puppy, straight download from the website and then installed to a USB stick. I am not an experienced Linux user. I know just enough to get around.

These are the steps I performed to get this card working:

1. Using HardInfo within Puppy I examined the entries under USB. I saw my Sierra Wireless 881U card as a USB MMC Storage Device, not as a aircard. This concerned me somewhat, but I thought let's keep going. The information you'll need is the vendor id and product id. For my 881U the vendor id=0x1199 and product id=0xfff.

2. Using PGPRS Modem Setup I filled in the data based on other articles I had read on the Puppy user forum and other Internet sites concerning GSM wireless broadband hardware:

APN: isp.cingular
Username: gprsuser (default entry)
Password: CINGULAR1
Phone number: *99#
Phone PIN: I left this blank (I also put my cell phone number in, either worked.)

3. I should have a Serial Modem Device File similar to /dev/ttyUSB0 or /dev/usb/ttyUSB0. Under PGPRS Modem Setup I used the Probe command and found only /dev/ttyS0. Pressing OK I tried to connect without success.

4. Use modprobe to set the /dev/ttyUSB device. The command is:

modprobe usbserial vendor=0x1199 product=0xfff

Running PGPRS Modem Setup now detected /dev/ttyUSB0 and /dev/usb/ttyUSB0 as well as the original /dev/ttyS0. I chose /dev/ttyUSB0 but this gave an "unrecognized error" from PGRS Connect. Choosing /dev/usb/ttyUSB0 got a response from the 881U.

This is where things got interesting. When I plug the aircard into a USB port the PWR light always comes on, but sometimes when I plugged the aircard in the Data light on it would blink a few times and then go off. Other times when I plugged it in the Data light would stay on solid. I mention this because if the Data light does not stay on and you initiate a connection, PGRS Connect either errors with "Defining PDP context, connect script failed" or it would appear to negotiate, but have no addresses assigned to the DNS servers and the 881U would have the wrong TCPIP address assigned to it. The solution to this problem is to unplug the 881 and then after a second or two plug it back in. Sometimes I would have to do this two or three times for the 881U Data light to constantly stay on.

Once connected I have never had problems with terminating my Internet connection and connecting again by just restarting PGPRS Connect. While I'm connected I've never had the connection terminate unexpectedly. I have not had the opportunity to try 3G yet since I have not visited a area that has it. My connect speeds have been from 160 kbaud download and 90 kbaud upload.

So while the above is not optimal it does consistently work.

If anyone wants me to go into further detail on the errors I get to improve how the 881U works under Puppy let me know. I'd be willing to send screen dumps of all the info that PGPRS Modem Connect displays as well as try a thing or two.

I wish to say thanks to all who have put effort into making Puppy what it is, a great nimble and powerful OS! Very Happy
Back to top
View user's profile Send_private_message 
gamfa

Joined: 26 Oct 2005
Posts: 113
Location: So. Central Indiana, USA

PostPosted: Wed 21 Jan 2009, 20:06    Post_subject:  

It appears from Sierra site the 881 is in the same series as the 875s which I use. Those modems need 3 usb devices. If /dev/usb/ttyUSB0 works for you create /dev/usb/ttyUSB1 and ttyUSB2 manually if they do not exist. I had problems on my 875s and this thread might help

http://www.murga-linux.com/puppy/viewtopic.php?t=17969&search_id=968841589

This Serria link also is good stuff

http://www.sierrawireless.com/faq/ShowFAQ.aspx?ID=602

_________________
"Don't tell my cattle that I have leather seats in my truck"

"I don't let my schooling get in the way of my education"...Mark Twain
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Networking » Wireless
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0543s ][ Queries: 11 (0.0036s) ][ GZIP on ]