Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 14 Dec 2018, 18:37
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Macpup 4.1.1
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 5 of 5 [68 Posts]   Goto page: Previous 1, 2, 3, 4, 5
Author Message
prit1


Joined: 03 Jan 2008
Posts: 538
Location: Los Angeles

PostPosted: Wed 07 Jan 2009, 18:48    Post subject:  

Yes, you can definitely install Macpup on this machine.

With 128 MB RAM, you might have to create a swap partition (around 500 MB) or do a full install instead of frugal install.

You can search the forum to understand full vs frugal install if required. The below link will let you do a google search of the forum.
http://wellminded.com/puppy/pupsearch.html

_________________
Macpup - The beauty of linux | Pritlog - Simple blog app
Back to top
View user's profile Send private message 
_MegadetH_

Joined: 28 Sep 2008
Posts: 221
Location: Italy

PostPosted: Wed 14 Jan 2009, 13:46    Post subject:  

Hi! I don't know if I have to post this here or in vlc thread. anyway, when I watch vlc videos in fullscreen mode the upper bar still stands there. How can I hide it in fullscreen mode?
Back to top
View user's profile Send private message 
CatDude


Joined: 03 Jan 2007
Posts: 1573
Location: UK

PostPosted: Wed 14 Jan 2009, 16:31    Post subject:  

Hello _MegadetH_

That upper bar as you call it, is the IceWM Taskbar
what you need to do is AutoHide it.

Have a look at this file: /root/.icewm/preferences (note that .icewm is a hidden directory)
In that file look for this:
Code:

#  Auto hide task bar after delay
TaskBarAutoHide=0 # 0/1

and change it to this:
Code:

#  Auto hide task bar after delay
TaskBarAutoHide=1 # 0/1

Then restart icewm: Menu > Shutdown > Restart IceWM (this may be different in Macpup)
To see the Taskbar, move the mouse cursor to the top of the screen.

CatDude
.

_________________

Back to top
View user's profile Send private message 
_MegadetH_

Joined: 28 Sep 2008
Posts: 221
Location: Italy

PostPosted: Wed 14 Jan 2009, 18:02    Post subject:  

CatDude wrote:
Hello _MegadetH_

That upper bar as you call it, is the IceWM Taskbar
what you need to do is AutoHide it.

Have a look at this file: /root/.icewm/preferences (note that .icewm is a hidden directory)
In that file look for this:
Code:

#  Auto hide task bar after delay
TaskBarAutoHide=0 # 0/1

and change it to this:
Code:

#  Auto hide task bar after delay
TaskBarAutoHide=1 # 0/1

Then restart icewm: Menu > Shutdown > Restart IceWM (this may be different in Macpup)
To see the Taskbar, move the mouse cursor to the top of the screen.

CatDude
.


Hello Catdude! thanks for the support! Smile I tried and it works. I'd prefer the bar autohide only when vlc fullscreen is on and not always, but maybe it isn't possible.
Back to top
View user's profile Send private message 
_MegadetH_

Joined: 28 Sep 2008
Posts: 221
Location: Italy

PostPosted: Sat 14 Feb 2009, 14:06    Post subject:  

Hi! I have a problem again
After booting when the desktop is ready, it appears a little window on the upper left corner. I think it's a wbar window and I cannot close it. Restarting X server or clicking on workspace:2 or if it disappear. Look at attached image to understand what I mean.
Do I have to change something in icewm preferences to remove that window?
Thanks
Back to top
View user's profile Send private message 
runtt21


Joined: 07 Jun 2008
Posts: 1651
Location: BigD Texas

PostPosted: Sat 14 Feb 2009, 16:30    Post subject:  

megadeth ,
Try editing /root/.xinitrc (this is a hidden file, press Ctrl-H in rox to show this). Change the line that has wbar:

it should have a sleep 3 && wbar .....

change it to:

sleep 5 && wbar.

If the result is the same, try increasing the sleep timing.
Back to top
View user's profile Send private message Visit poster's website 
CatDude


Joined: 03 Jan 2007
Posts: 1573
Location: UK

PostPosted: Sat 14 Feb 2009, 18:56    Post subject:  

Hi

I don't think that is to do with wbar.

Go to: /root/.icewm/startup
and try increasing the sleep time for freememapplet-tray and/or blinky

It has happened to me on various occassions and increasing the sleep time sorted it out.

CatDude
.

_________________

Back to top
View user's profile Send private message 
_MegadetH_

Joined: 28 Sep 2008
Posts: 221
Location: Italy

PostPosted: Sun 15 Feb 2009, 06:20    Post subject:  

Thank you! Very Happy

I tried changing the number of blinky and freememapplet-tray in /root/.icewm/startup. After some reboots I found the right combination:

killall blinky
sleep 3 && /root/my-applications/blinky-0.8-icewm/src/blinky -bg "#49437a" &

killall freememapplet-tray
sleep 3 && /root/my-applications/freememapplet_tray_puppy215ce/freememapplet-tray &

Now that window disappeared! It was very annoying Smile
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 5 of 5 [68 Posts]   Goto page: Previous 1, 2, 3, 4, 5
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1566s ][ Queries: 12 (0.0526s) ][ GZIP on ]