Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 02 Sep 2014, 18:11
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Video
gspca problem with trust webcam [solved]
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [2 Posts]  
Author Message
liberomureddu

Joined: 21 Jun 2008
Posts: 48
Location: Milano - Italy / Helsinki - Finland

PostPosted: Tue 30 Sep 2008, 09:51    Post subject:  gspca problem with trust webcam [solved]  

Hi, I posted this also on the puppy 4.1 bugs section with no result, maybe it's better to post it here. I have a Trust WB-1400T webcam, it works in ubuntu using gspca, but the only way to improve its fps rate is to turn the autoexpo parameter off.
However, setting this parameter in puppy doesn't produce any result, while gamma or the colors parameters change. The result is that with skype the webcam is almost unusable.
Is there any solution to fix this? I can reproduce this on puppy 4.0 until the last rc1.
Thanks a lot,
Libero

Last edited by liberomureddu on Fri 17 Oct 2008, 10:39; edited 1 time in total
Back to top
View user's profile Send private message 
liberomureddu

Joined: 21 Jun 2008
Posts: 48
Location: Milano - Italy / Helsinki - Finland

PostPosted: Fri 17 Oct 2008, 10:38    Post subject: solved  

Solved, following the instructions here:
http://forum.skype.com/index.php?s=8fd6c29f61a7b442ab66f1d14a11308b&showtopic=221601
For some reason, in order to change the value of autoexpo, one has to first remove the module gspca and then add the module back with the new value. In ubuntu I could modify this parameter on the fly without removing the module:

Code:

rmmod gspca
modprobe gspca autoexpo=0


Now my Trust Wb 1400 works under skype without any problem.
Turning off the autoexpo, it's good to raise a little the gamma parameter.
I have good settings with gamma=5

ciao
Libero
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [2 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Video
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0415s ][ Queries: 11 (0.0076s) ][ GZIP on ]