Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 17 Dec 2014, 16:04
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Business
Siag office 3.5.5
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 2 Posts_count   Goto page: 1, 2 Next
Author Message
106498

Joined: 18 Nov 2007
Posts: 250
Location: NZ

PostPosted: Wed 27 Aug 2008, 04:23    Post_subject:  Siag office 3.5.5
Sub_title: a small office suite.
 

I made a .pet package for siag office because the only one I could find was an old
dotpup. All the programs are there but there are no icons in the menu. Siag "sucks
less" and is a simple office suite for old hardware. More info at http://siag.nu/.

EDIT: I have removed the .PET as it was reported to do some undesirable stuff. A new one to download has been posted further down in this thread.

_________________
An expert is just a beginner with experience.
Shamelessly representing TdeM!

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
playdayz


Joined: 25 Apr 2008
Posts: 3789

PostPosted: Wed 27 Aug 2008, 12:39    Post_subject: Thanks  

Thanks, I had been wanting to take a look at it--you made it easy.
Back to top
View user's profile Send_private_message 
106498

Joined: 18 Nov 2007
Posts: 250
Location: NZ

PostPosted: Wed 27 Aug 2008, 21:32    Post_subject:  

Glad I could help Smile
_________________
An expert is just a beginner with experience.
Shamelessly representing TdeM!
Back to top
View user's profile Send_private_message Visit_website 
redandwhitestripes

Joined: 02 Jan 2009
Posts: 124

PostPosted: Thu 10 Dec 2009, 10:12    Post_subject:  

Thank you very much for this. I've been wanting to try Siag for a while.

Any way to get the spell check working in PW? It's not a big problem as I can use aspell from the console and PW even allows the user to open the console from within the programme, but I'm still curious.

EDIT: Answered my own question. I consulted the online documentation and discovered SIAG uses ispell. I had aspell installed instead, so as per the documentation I symlinked to ispell like this
ln -s `which aspell` /usr/local/bin/ispell

and the spell checker works fine Smile
Back to top
View user's profile Send_private_message 
DMcCunney

Joined: 02 Feb 2009
Posts: 897

PostPosted: Fri 11 Dec 2009, 19:31    Post_subject: Re: Siag office 3.5.5
Sub_title: a small office suite.
 

106498 wrote:
I made a .pet package for siag office because the only one I could find was an old
dotpup. All the programs are there but there are no icons in the menu. Siag "sucks
less" and is a simple office suite for old hardware. More info at http://siag.nu/.

Major annoyance.

Installing from the PET, among other things, reset a symlink. /usr/lib/libtermcap.so.2, which is supposed to be a symlink to /usr/lib/termcap.so.2.0.8, gets reset to be a symlink to a private copy in Siag Office's directory hierarchy.

This renders the system unusable, as lots of things want libtermcap.so.2 and can't find it after this is done. (Reboot, and login goes into an endless error loop complaining about not finding libtermcap.so.2.)

I had to boot Puppy from CD with pfix=ram, manually mount the Puppy partition (since I use a full install), and open a console window to go in and fix the symlink, then reboot.

I suggest not trying to install this pet until that behavior is neutered...
______
Dennis
Back to top
View user's profile Send_private_message 
harii4


Joined: 30 Jan 2009
Posts: 444
Location: La Porte City, IA , U.S.A.

PostPosted: Thu 12 Aug 2010, 20:56    Post_subject:  

the .pet is no longer there.
Shame, i've been wanting to try Siag for a while too.
Back to top
View user's profile Send_private_message Visit_website 
sc0ttman


Joined: 16 Sep 2009
Posts: 2386
Location: UK

PostPosted: Tue 24 Aug 2010, 01:57    Post_subject:  

I made a package and uploaded here:

http://ppm.scottjarvis.com/office/suites/siag-3.5.5.pet

_________________
Akita Linux, VLC-GTK, Pup Search, Pup File Search
Back to top
View user's profile Send_private_message 
ceaualbi

Joined: 19 Jan 2011
Posts: 1

PostPosted: Wed 19 Jan 2011, 10:41    Post_subject:  Thanks
Sub_title: Your upload is superb!
 

Many thanks, I downloaded the file using your link (sc0ttman).

I'ts running under puppy linux (saved session on HD) and it works perfectly!

I have a question, though, is there any .deb for testing it under a very old desktop, I think it's under kubuntu 4...

Many, many thanks!
Back to top
View user's profile Send_private_message 
ttuuxxx


Joined: 05 May 2007
Posts: 10843
Location: Ontario Canada,Sydney Australia

PostPosted: Wed 19 Jan 2011, 11:41    Post_subject:  

Just rename it in puppy from siag-3.5.5.pet to siag-3.5.5.tar.gz
then click on it, xarchive should open it then just extract to anywhere and copy the files to same directory on your other OS. It will give you an error when extract it, but just ignore it, xarchive always gives that error when extracting renamed pets. It doesn't actually produce an error in the extraction process.
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send_private_message Visit_website 
scsijon

Joined: 23 May 2007
Posts: 1052
Location: the australian mallee

PostPosted: Mon 24 Jan 2011, 02:24    Post_subject:  

for: 106498

It seems the Animator module is not working at present, just a blue screen.

Also current version is 3.6.1.

can you check please it's working ok for you, maybe I need a nonlisted lib.

I'm planning to use it on my puppyrunt, replacing gnumeric, abiword, etc. as it seems to be a selfcontained system and total size is smaller as it's about 2.25meg.

I will build in some "spare time" before the alpha becomes public, if there is such a thing, playdayz, 01micko, ttuuxxx and other builders would know about that.

good find though.

thanks
scsijon
Back to top
View user's profile Send_private_message Visit_website 
amigo

Joined: 02 Apr 2007
Posts: 2287

PostPosted: Mon 24 Jan 2011, 04:07    Post_subject:  

siag is very old and no longer maintained. A while back I hacked around on it quite a bit -I had also found that the Animator wouldn't start. IIRC, you have to revert to version 3.4.? to have it working. There are several versions in between 3.4.9 and 3.6.1, but the amount of changes was fairly small, so it's pretty easy to 'backport' any useful changes from later versions into 3.4.10
Back to top
View user's profile Send_private_message 
scsijon

Joined: 23 May 2007
Posts: 1052
Location: the australian mallee

PostPosted: Fri 28 Jan 2011, 18:23    Post_subject:  

sorted out siag 355 problem, was made when XawM was v6, we now use v7. You need to make a set of links back to v6, and it all seems to work.

Note that he put the animator structure backwards, when you first start it, move the blue screen over to see it's control page.

regards
scsijon
damn typos

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
KusaNoKaito


Joined: 19 Feb 2010
Posts: 99
Location: Florida

PostPosted: Sun 30 Jan 2011, 20:09    Post_subject:  

Is there a presentation program with this. Question
_________________
Puppy Packages
My Website
Back to top
View user's profile Send_private_message Visit_website 
scsijon

Joined: 23 May 2007
Posts: 1052
Location: the australian mallee

PostPosted: Mon 07 Feb 2011, 20:09    Post_subject:  

just a note,
siag 355 is working correctly with wary5. edit:and puppy5.2

I may just build the latest next week and see what happens.

edit1:(ongoing dependancy yuck! due to age)

edit 2: playdayz has added 355 to the ppm as it's actually a good package, but be warned that it doesn't work properly with anything earlier than above puppy series.
I have failed to get 361 egon working at all so am steping back through the three earlier releases too see where it collapsed. The whole packages size also expands seriously with 3.6 series as there is now a lot of external libs puppy doesn't use added. It may become not worth the work and I shall add if so add a note here and the 3.6.1 thread (unsorted area).
regards
scsijon
Back to top
View user's profile Send_private_message Visit_website 
amigo

Joined: 02 Apr 2007
Posts: 2287

PostPosted: Sat 05 Mar 2011, 11:29    Post_subject:  

I got 3.6.0 working a long time ago -but not the animator:
http://distro.ibiblio.org/pub/linux/distributions/amigolinux/download/XApps/siag-3.6.0/

I was able to put together a 3.4-ish version where the animator would at least run. All that code is so old and nasty to work with -but I too had high hopes (or wishes) for siag. Only someone who really badly wanted such a thing would put so much work into that...
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 2 Posts_count   Goto page: 1, 2 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Business
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0783s ][ Queries: 11 (0.0034s) ][ GZIP on ]