Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 16 Dec 2018, 20:36
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Networking » Wireless
solved: wpc11v4 AND pcmcia AND wep PROBLEMS
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 2 [16 Posts]   Goto page: Previous 1, 2
Author Message
mothraman

Joined: 24 Aug 2008
Posts: 36

PostPosted: Sat 30 Aug 2008, 12:02    Post subject: Solved: wpc11v4, pcmcia, and wep problems  

I am new to Linux, but have been a software developer for over 30 years. I found this whole thing to be a challenge. I am posting the results of my success here for anyone who may benefit from them. Good luck! Thanks to all who helped (actively and passively).

Details:
IBM Thinkpad i1200 series 1167-210, purchased new in 2000, with Windows 98 (just background, since I wiped the hd and only have Puppy running now).
160MB RAM, 6GB hd, 500mhz intel celeron processor
Linksys WPC11v4 PCMCIA wifi card
Router has WEP security--I had WPA-PSK, but when I wanted to resurrect this laptop, I discovered from Linksys tech support and from this forum that the card does not support it.
SSID broadcast disabled on router.
Puppy 4.0, full install to hard drive

Challenge 1:
Get the PCMCIA card recognized. The symptom was that the power light on the card did not turn on. With the help of experts here, I discovered that I need to load yenta_socket.
Solution 1: open a console window and type "modprobe yenta_socket." I later added this to the rd.local script, below, but this was the first step. The power light came on. With a little research, I learned that yenta_socket bridges from the card bus to PCI--and I've now told more than I know.

Challenge 2:
I followed the instructions found in the wireless section to use ndiswrapper to load my windows driver. Result: "Invalid driver!"
Solution 2:
I googled "WPC11v4 chipset" to find that it uses the Realtek R8180 chipset. After some forum searching I found that the R8180 driver in the network wizard ("connect" icon--lower left of my screen) was the one to use, so I did.
NOTE: I had the network wizard save this, so it loads at boot--that's why it's not in the script below.

Next step was to connect. I continued with the network wizard. The card was found, I clicked the wlan button, then wireless, where I entered the details of my connection: WEP, managed, open, gave my SSID and key. Then clicked the auto dhcp button to get an ip address. The link light on the wifi card came on.

Challenge 3:
I could not connect. "Blinky"--the network icon to the right of the speaker icon at the bottom of the screen--told me it could see the network but could not connect. I opened a console window and ran dmesg. I found a msg that rtl_ieee80211_crypt_wep was not found and that I should load it. With some searching, I found out that there are two problems:
1. that's a typo: the module name is ieee80211_crypt_wep-rtl
2. the module should have been in /lib/modules/2.6.21.7/r8180 but it wasn't, that's why it wasn't being loaded with the driver (as I understand the situation)
Solution 3:
The module, plus some others that may be needed, were in /zdrv_400.sfs (as I learned from this forum). I opened a file window, then clicked on zdrv_400.sfs it to mount it, then navigated to /mnt/+zdrv_400.sfs/lib/modules/2.6.21.7/r8180 where I found the module, and copied the entire contents of the directory to the proper location (cited above). I unloaded the driver (modprobe -r r8180) then went through the network connect, including loading the driver, again. Viola!

Challenge 4:
I wanted to have network connectivity when I boot, and not have to go through the steps above every time I re-boot.
Solution 4:
/etc/rd/rc_local is a script that is executed at boot before X starts (I am told). I used the advice on this forum to find a combination that works. There may be other combinations that also work and this combination may not work for others, but it's a start.
NOTE: one of the suggestions I found said to remove some files--
rm -f /var/lib/dpcpd/*.pid
rm -f /var/run/*.pid
before the dhcpcd command in the last executable line. I ran those from the command line when I was experimenting, before I wrote the script. The script works without them, either because they worked the 1st time or because they don't matter. Try them if this doesn't work.
ALSO: I have done a (very) little research into the dhcpcd command to see what all the options mean. Evidently "puppypc" is the puppy client name and wlan0 is the interface (could be eth0 or something else in your confguration) but I can't find anything else that applies (yet). If anyone knows, please post an answer or a link to an answer here.


#/etc/rc.d/rc_local.sh
#=lines already there===
#this file called from rc.local0
#you can edit this file
#When firewall is installed, will append lines to this file...
#===end lines already there===
#===lines added by mothraman===
#enable PCMCIA 20080829 0945
modprobe yenta_socket
sleep 5s
# Bring up the wifi 20080829 2130
ifconfig wlan0 up
# provide wep ssid and key
iwconfig wlan0 essid <your ssid here without the brackets>
#remember: mothtraman's wep is open, managed--your options in the next two lines may be different
iwconfig wlan0 key <your wep key here without the brackets> open
iwconfig wlan0 mode managed
# use dhcp to get an ip address
dhcpcd -t 30 -h puppypc -d wlan0
#done
#===end lines added by mothraman===
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 2 [16 Posts]   Goto page: Previous 1, 2
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Networking » Wireless
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0299s ][ Queries: 11 (0.0056s) ][ GZIP on ]