Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 30 Jul 2014, 23:25
All times are UTC - 4
 Forum index » House Training » HOWTO ( Solutions )
Install and run bubbles, gemgame and tuxtype2 in puppy4.0
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [2 Posts]  
Author Message
jrb


Joined: 11 Dec 2007
Posts: 1030
Location: Smithers, BC, Canada

PostPosted: Thu 07 Aug 2008, 15:20    Post subject:  Install and run bubbles, gemgame and tuxtype2 in puppy4.0  

Recently I switched from puppy2.17.1 to puppy4.0. While there are many advances I missed bubbles, gemgame and tuxtype2.

To run bubbles and gemgame simply install:
http://www.puppylinux.ca/puppyfiles/pet_packages-3/bubbles-1.0.2a.pet
http://www.puppylinux.ca/puppyfiles/pet_packages-3/gemgame-2003.pet
http://www.puppylinux.ca/puppyfiles/pet_packages-3/tcl-8.5a4nothreads.pet
http://www.puppylinux.ca/puppyfiles/pet_packages-3/tk-8.5a4nothreads.pet

To run tuxtype2 you need to install:
http://www.puppylinux.ca/tpp/bugs/tuxtype2-1.5.3.pet

and several sdl libraries and the 3.01 version of libfreetype.so which I have put together into the attached .pet.

I don't know whether using the older libfreetype.so will mess up any other programs. I haven't seen any problems yet but let me know if you do.
tuxtype2_libs.pet
Description  sdl and freetype libs to run tuxtype2 in puppy 4.0
pet

 Download 
Filename  tuxtype2_libs.pet 
Filesize  662.78 KB 
Downloaded  501 Time(s) 
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Thu 02 Oct 2008, 23:14    Post subject:  

the following pet can be used, if you don't want to risk to break existing libraries.

It assumes, that you already have installed libSDL with petget, or have a puplet, that already includes libSDL.

In Muppy 0084 libSDL is included, but tuxtype2 crashes.
This seems to be related to the combination of Muppys libSDL_ttf.so and libfreetype.so.6.

This pet now installs these files from tuxtype2_libs.pet:

/usr/local/lib-tuxtype2/libfreetype.so.6.3.15
/usr/local/lib-tuxtype2/libSDL_ttf-2.0.so.0
/usr/local/lib-tuxtype2/libfreetype.so.6
/usr/local/lib-tuxtype2/libSDL_ttf.so
/usr/local/lib-tuxtype2/libSDL_ttf-2.0.so.0.6.1
/usr/local/bin/tuxtype2
/usr/local/bin/tuxtype2.bin

So the working libs are installed to a new folder, so that they do not overwrite existing ones.

tuxtype2 is replaced with a script, that includes this new folder.
It then runs tuxtype2.bin (the old tuxtype2).

Mark
tuxtype2-1.5.3-i386-1-crash-fix.pet
Description 
pet

 Download 
Filename  tuxtype2-1.5.3-i386-1-crash-fix.pet 
Filesize  280.12 KB 
Downloaded  436 Time(s) 

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 1 [2 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » HOWTO ( Solutions )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0462s ][ Queries: 12 (0.0078s) ][ GZIP on ]