Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 26 Nov 2014, 06:02
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
python 2.5.2 slackware 12.2 compatible IDLE GUI
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 3 of 3 Posts_count   Goto page: Previous 1, 2, 3
Author Message
moogsydodong


Joined: 16 Mar 2009
Posts: 81
Location: Tagum City, Davao del Norte, Mindanao, Philippines

PostPosted: Fri 16 Oct 2009, 01:07    Post_subject:  

hi there neurino,

welcome to puppy...
for compiling apps in puppy see this:
http://www.puppylinux.com/development/compileapps.htm

hope it helps...if you can manage to compile python 2.6.x or python 3.x please post the pet for it I,m learning python and I want to try the latest build

_________________
...SHUT UP AND LISTEN!!!...In a battle there is only ONE COMMANDER!!!
Back to top
View user's profile Send_private_message 
neurino


Joined: 15 Oct 2009
Posts: 360

PostPosted: Fri 16 Oct 2009, 05:08    Post_subject:  

Thank, I'll give a try but consider I'm a total newbie in Linux enviornment...

Where can I find devx_430.sfs ???
Not here:
http://distro.ibiblio.org/pub/linux/distributions/puppylinux/sfs_modules-4/

the last is devx_421.sfs is it valid anyway?
Back to top
View user's profile Send_private_message 
big_bass

Joined: 13 Aug 2007
Posts: 1747

PostPosted: Fri 16 Oct 2009, 10:03    Post_subject: Re: python 2.5.2 slackware 12 compatible IDLE GUI
Sub_title: version 3.01+ 4.00 + and 4.1 now xwPython too!!
 

neurino wrote:
big_bass wrote:
all 3 are needed
http://www.puppylinux.ca/tpp/big_bass/libdb-4.4.pet
http://www.puppylinux.ca/tpp/big_bass/TclTk-patched4py-8.4.pet
http://www.puppylinux.ca/tpp/big_bass/python-2.5.2.pet



I'm a Python developer so I'd like to have the same packages I have on Windows. I tried the pet above but only the python-2.5.2 installed (and works from console) the other 2 failed.

Thanks for your support
Renzo



Quote:

the other 2 failed.


Hey Renzo

welcome, there's always a lot of work for developers

failed how? were you missing dependencies?

I first built this on puppy 3.01 then tested on 4.00 and 4.12 versions of puppy

if you are missing any depends let me know you could post the list


if you need a development environment ASAP
you could install an official puppy 4.12 or derivative of 4.12

I just downloaded the three packages and installed them on slaxer-pup 4.12
note: the python pet takes a long time to install because of the dependency checking in petget so be patient but it works


keep me posted I'll be glad to help


Joe
python on slaxer-pup.png
 Description   
 Filesize   15.72 KB
 Viewed   2336 Time(s)

python on slaxer-pup.png


Edited_times_total
Back to top
View user's profile Send_private_message 
neurino


Joined: 15 Oct 2009
Posts: 360

PostPosted: Fri 16 Oct 2009, 10:28    Post_subject:  

Hi Joe,

thanks for your support,

when I try to install TclTk and libdb I both get the same error from Package Manager:

"Error, package (name of the package) failed to install".
_____________

I have no real urge to use Linux since I already use Windows on my desktop pc for all.
But I put hands on a 256MB ram P4 notebook and was delighted how powerful is Puppy! (and linux in a general meaning)

So I wish I could have a free development station also when I (rarely) travel or to test my apps on linux too.

I posted some of the python packages I often use (forgot matplotlib too!) and I know I won't find 'em all in .pets so if devx_430.sfs is about to come in a week or 2 I'll wait, otherwise I'll consider passing to Puppy 4.12 (or 4.21???)
Back to top
View user's profile Send_private_message 
neurino


Joined: 15 Oct 2009
Posts: 360

PostPosted: Sun 18 Oct 2009, 09:34    Post_subject:  

Hey there,

I stumbled across this page: http://distro.ibiblio.org/pub/linux/distributions/puppylinux/puppy-4.3.1/ and saw pup-431.iso and devx_431.sfs so I'll try to compile python and his packages as soon as I can.

I'll keep you updated...
Back to top
View user's profile Send_private_message 
big_bass

Joined: 13 Aug 2007
Posts: 1747

PostPosted: Sun 18 Oct 2009, 10:07    Post_subject:  

neurino wrote:
Hey there,

I stumbled across this page: http://distro.ibiblio.org/pub/linux/distributions/puppylinux/puppy-4.3.1/ and saw pup-431.iso and devx_431.sfs so I'll try to compile python and his packages as soon as I can.

I'll keep you updated...


Since you'll compile for a new build of puppy
recompile tcl/ tk to the latest version it will be easier than patching
trying to keep it compatible with the older versions
of puppy that have tcl/ tk pre installed


UPDATED
well, I recompiled everything with the newer versions and patches
I'll upload it tomorrow
Joe

_________________
debian wheezy ,linux mint, slackware I use them all and they all have good points
Mint would be best for general users though
Back to top
View user's profile Send_private_message 
krsmith28p

Joined: 22 Nov 2008
Posts: 6

PostPosted: Wed 21 Oct 2009, 16:08    Post_subject:  

I am having a similar problem to neutrino. I am pretty sure I have successfully installed libdb-4.4 and tk/tcl on earlier versions of Puppy, but am getting the same "failed to install this package" message, on 4.3, and on 4.3.1 . Is there a more command line method to do the install that might be more verbose in its error reporting?
Did you upload a newer version, yet bbass? - the directory still lists the date as Dec 08.

I have successfully installed python, wxpython, and also wxglade.
I may have a go at installing tcl/tk from sources, but I know it is a big package, and I am not a bright enough linux user to know what is required to patch it successfully for python.
In case it comes across otherwise - guys, I am really grateful your efforts mean I can get this far!
K

edit - ah, actually I think you are saying the latest version of tcl/tk wont need patching.
Back to top
View user's profile Send_private_message 
big_bass

Joined: 13 Aug 2007
Posts: 1747

PostPosted: Thu 22 Oct 2009, 11:12    Post_subject:  

krsmith28p wrote:


Did you upload a newer version, yet bbass? - the directory still lists the date as Dec 08.



edit - ah, actually I think you are saying the latest version of tcl/tk wont need patching.



I have recompiled everything from source this time



* I am still working on wxpython
its not needed for python to work but some apps need it
its an add on

the reason for the error is in the changes in petget to PPM
so the packages just need to be reformatted to the appease
the new package management

in fact I by passed all mis-haps with that and built all the latest packages as *tgz's the same format slackware uses
from there you shouldn't have problems I have not tested any of the packages on 430+ but if you want them they are already built here
keep me posted if you need something else


http://www.murga-linux.com/puppy/viewtopic.php?t=41298&start=317
http://www.murga-linux.com/puppy/viewtopic.php?t=41298&start=318

Joe

_________________
debian wheezy ,linux mint, slackware I use them all and they all have good points
Mint would be best for general users though
Back to top
View user's profile Send_private_message 
neurino


Joined: 15 Oct 2009
Posts: 360

PostPosted: Sun 15 Nov 2009, 18:38    Post_subject:  

I compiled wxPython from source a couple of days ago.

First as a standalone with --prefix in an external drive then, once it worked good, with --prefix=/usr, some trouble but it worked that way too.

Now I'm looking at the standalone folder: 282 MB!!!.

Looking into it I see the lib subfolder contains more than 275MB, I'm a noob but every file in it is repeated 3 times, with the same size and just some extra extension appended like this:

Code:

libwx_gtk2ud-2.8.so           89403KB
libwx_gtk2ud-2.8.so.0        89403KB
libwx_gtk2ud-2.8.so.0.6.0   89403KB


Is it some I messed up in my (numerous) tries or is it normal?

Note: also I made python setup.py install both for python 2.5 and 2.6... double trouble, double the files?

Please help....
Back to top
View user's profile Send_private_message 
ITAmember

Joined: 13 Sep 2009
Posts: 168
Location: The middle of a cornfield

PostPosted: Sun 15 Nov 2009, 19:06    Post_subject:  

Those first two files are supposed to be symbolic links to the third file. A symbolic link is the linux equivalent of a shortcut in windows. So the first two files should only be a handful of bytes in size. Smile If you have no problems with recompiling cd to the source directory and run these commands

Code:
make clean
./configure --prefix=/usr
make
make install DESTDIR=/path/to/some/dir/


/path/to/some/dir is where the installed files should go. In this case after the compile finished you would run

Code:
dir2pet /path/to/some/dir/


to make a pet package.
Back to top
View user's profile Send_private_message 
asl3210

Joined: 15 Nov 2009
Posts: 1

PostPosted: Sun 15 Nov 2009, 22:41    Post_subject:  

sir why cant i download the python packages on the first page. it is asking for username and password. im very interested with python and i want to use it with my puppy. thanks.
Back to top
View user's profile Send_private_message 
ITAmember

Joined: 13 Sep 2009
Posts: 168
Location: The middle of a cornfield

PostPosted: Sun 15 Nov 2009, 23:30    Post_subject:  

Username: puppy
Password: linux
Back to top
View user's profile Send_private_message 
neurino


Joined: 15 Oct 2009
Posts: 360

PostPosted: Mon 16 Nov 2009, 05:22    Post_subject:  

ITAmember wrote:
Those first two files are supposed to be symbolic links to the third file

but why links to a file in the same folder???

I can recompile but already have a wx dir on a usb key with all the wxwidgets files in it (with bin, lib, share subfolders etc) but after make install the process is not ended, you have to call python setup.py install (with appropriate flags).
That requires as much time as make so I think I cannot use dir2pet like I did when I compiled python itself.

At the moment I'm not bored of the whole compile from source thread.
All I'd like is know how I can get rid of libwx_gtk2ud-2.8.so.0.6.0 90 Megs links

Thank you
Renzo
Back to top
View user's profile Send_private_message 
charlie6


Joined: 30 Jun 2008
Posts: 1022
Location: South of Belgium

PostPosted: Mon 01 Mar 2010, 14:42    Post_subject:  

Hi bigbass !
many thanks for those pets
I'd like to install python and wxPython on Puppy4.3.1.
Unfortunatelly, the page 1 links do not work anylonger: I get the following message:
Code:
Cannot read /mnt/w1011/d39/s12/b02d8349/www/puppylinux.asia/tpp/big_bass/.htaccess

Although other puppylinux.asia/tpp/members directories are well reachable ..?
Where could I find those pets?
Thanks in advance for any reply.
Cheers
Charlie
Back to top
View user's profile Send_private_message 
big_bass

Joined: 13 Aug 2007
Posts: 1747

PostPosted: Fri 05 Mar 2010, 13:43    Post_subject:  

Hey charlie6

check my post in this thead dated
Posted: Thu Oct 22, 2009 11:12 am

for more info and the links

Joe

_________________
debian wheezy ,linux mint, slackware I use them all and they all have good points
Mint would be best for general users though
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 3 of 3 Posts_count   Goto page: Previous 1, 2, 3
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1000s ][ Queries: 12 (0.0118s) ][ GZIP on ]