Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 21 Oct 2014, 14:31
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Usuarios de habla Hispana
Error al instalar programas Debian
Moderators: rarsa
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
scifictn

Joined: 12 Jul 2008
Posts: 83

PostPosted: Tue 15 Jul 2008, 01:11    Post_subject:  Error al instalar programas Debian  

Hola a todos los foristas.
Tengo instalado la version 4.0 de PuppyLinux en una maquina de bajos recursos y el desempeño ha sido excelente. Pero me he encontrado con un problema. He estado intentando instalar programas para Debian, y leyendo en el manual de PuppyLinux veo que hay que tener instalados los programas Dillo y pb-debianintaller, los cuales ya han sido instalados.
Siguiendo las instrucciones se menciona que una vez bajado el programa para Debian con extension ".deb", en una terminal hay que teclear el siguiente comando: pb-debianinstaler, despues de lo cual se inicia el programa Dillo desplegando una pagina especial para la instalacion. Pero al teclear este comando recibo en consola el siguiente mensaje; sh: line 0: cd: /tmp/PB-Debianinstall: No such file or directory.
Igualmente me aparece en otra ventana aparte y titulada como xmessage el siguiente mensaje; Widget needs Webserver, start it?. A esta pregunta respondo Yes, y en la terminal me aparece otro mensaje cuyo texto es el siguiente: /usr/local/bin/pb-debianinstaller: line 53: ./httpd: No such file or directory.
Tambien me aparece otra ventana xmessage mostrando el siguiente texto; Ghttpd could not be started, exiting... Respondo con un OK y todo termina sin permitirme instalar el programa

¿Que pudiera estar pasando, y que puedo hacer para solucionarlo?.

Gracias por la atencion prestada a esta consulta.

Saludos.
Back to top
View user's profile Send_private_message 
caka

Joined: 07 Dec 2006
Posts: 202

PostPosted: Tue 15 Jul 2008, 04:14    Post_subject:  

Bienvenido a Puppy.

Eso mismo que te pasa a tí me paso a mí hace ya algún tiempo en mi Puppy 2.12. La diferencia es que a mí me funcionaba perfectamente y despues de usarlo durante bastante tiempo me empezó a dar ese error. Hice una pregunta en el foro y no obtuve respuesta:

http://www.murga-linux.com/puppy/viewtopic.php?search_id=1564594757&t=14704

Pero la grna diferencia es que el debianinstaller se creo para utilizarse con versiones anteriores de Puppy y como el Puppy 4.0 que tu usas es totalmente compatible con slackware pues los creadores de Puppy dejaron de lado el debianinstaller ya que todos los programas que necestites los puedes encontrar en slackware.

Así que lo que recomienda MU (gran guru ed Puppy Very Happy ) es que te olvides del debianinstaller e intentes buscar el programa que necesites como paquete slackware. Si no sabes instalar paquetes slackware es muy fácil: te bajas el archivo, abres la consola donde lo hayas guardado y lo conviertes en un paquete pet con el comando:

Code:
tgz2pet nombredelarchivo


o también hacer lo que recomienda MU en este post en inglés:

http://www.murga-linux.com/puppy/viewtopic.php?p=189277&search_id=1564594757#189277

Si tienes problemas dí exactamente cual es el programa que quieres instalar para ver si te podemos ayudar a compilarlo y orientarte sobre como instalarlo.

Suerte.
Back to top
View user's profile Send_private_message 
scifictn

Joined: 12 Jul 2008
Posts: 83

PostPosted: Tue 15 Jul 2008, 13:44    Post_subject:  

Gracias por responder a mi pregunta y por la orientacion que me has dado. Eres muy amable.

Respondiendo puntualmente a tu pregunta. El programa que deseo instalar es el navegador Opera en su ultima version 9.51, y realmente no creo que dentro de la paqueteria de Slackware pueda encontrar dicho programa.
Ya he bajado el archivo del programa Opera a mi disco duro y este archivo tiene la extension .deb, asi que pensè que con la instruccion pb-debianinstaller se podia instalar el programa.
Viendo el problema que me explicas con relacion a pb-debianinstaller, ¿como pudiera instalar el programa que te comento?.

Gracias de nuevo por la ayuda.

Saludos desde Hermosillo Sonora Mexico!!
Back to top
View user's profile Send_private_message 
olovram

Joined: 07 Mar 2008
Posts: 107

PostPosted: Tue 15 Jul 2008, 20:18    Post_subject:  

lo mas facil es bajandote undeb, que creo que viene con unrpm.

una ves instalado, navega desde consola a la carpeta donde tengas el .deb
luego teclea
Code:

undeb "nombre del archivo.deb"


eso te dara un directorio con todos los archivos del paquete

pegalo a / o conviertelo a .pet y ya quedo Wink

pd:

el comando SIN las comillas
Back to top
View user's profile Send_private_message 
scifictn

Joined: 12 Jul 2008
Posts: 83

PostPosted: Wed 16 Jul 2008, 01:11    Post_subject: SOLUCIONADO!!....Error al instalar programas Debian  

Antes que nada debo agradecer mucho a las dos personas que tuvieron la amablidad de responder a mi pregunta. Estas personas son: CAKA y OLOVRAM.

Como dice el titulo de este post el problema ya ha sido solucionado. Para las personas que pudieran pasar por el mismo problema he de explicar como fue que lo solucione, obviamente con ayuda de mis dos amigos!!.
Basicamente queria instalar el navegador Opera en su ultima version ya que en los repositorios que aparecen en "Puppy Package Manager" aprece la version 9.23 y la ultima es la 9.51.
Ya habia bajado a mi HD el archivo Opera(.deb) de la pagina oficial de Opera(www.opera.com) pero la instalacion no funciono via pb-debianinstaller. CAKA en su post me menciono que pb-debianinstaller ya no era soportada por la version de Puppy 4.0 y que buscara el paquete compatible con Slackware y que utilizara el comando tgz2pet para hacer la conversion del paquete a PuppyLinux. Yo dudaba que puediera existir una version de Opera para Slackware, pero navegando en la pagina oficial de Opera me di cuenta de que si habia una version para Slackware.
Baje ese archivo y procedi a hacer la conversion via el comando tgz2pet sin presentarse problemas. Luego, utilizando ROX-FILER me ubique en donde habia bajado dicho archivo y al darle click aparecio una ventana preguntando si procedia con la instalacion. Al darle click me arrojo una pequeña ventana de error donde decia que la descompresion habia fallado y que buscara informacion en la carpet .packages . Investigando dentro de la carpeta .packages me di cuenta de que se habia credo una nueva carpeta llamada Opera9.51, ingrese a esa carpeta y me encontre con un archivo llamado INSTALL.SH. Se me ocurrio correrlo asi.... ./install.sh y listo.....el procedimiento de instalacion empezo a correr. Me hizo algunas preguntas porque ya tenia una version instalada de opera(9.23) y me preguntaba si queria re-escribir algunos archivos, le respondi que si, y todo concluyo sin problemas.

Agradesco nuevamente a CAKA por la sugerencia de utilizar tgz2pet para hacer la conversion de Slackware a .pet. Esa fue la principal solucion!!.
No he de olvidar tambien a OLOVRAM por las sugerencias que me dio, que aunque en esta ocacion no fue necesario utilizarlas no dudo que en un tiempo mas me seran de gran ayuda porque hay que tener en cuenta que no todos los programas puden tener su version en Slackware y si en Debian, que en su caso me seran de mucha utilidad!!.

Gracias a los dos!!

Saludos desde Hermosillo Sonora Mexico!!
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars ) » Usuarios de habla Hispana
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0619s ][ Queries: 11 (0.0075s) ][ GZIP on ]