Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 02 Jul 2015, 08:57
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Audio
Toshiba Satellite 1730CDT no sound
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message

Joined: 09 Jul 2008
Posts: 4
Location: Melbourne, Australia

PostPosted: Wed 09 Jul 2008, 23:51    Post_subject:  Toshiba Satellite 1730CDT no sound  

Fairly new to Puppy but have 'played around' with computers for the last 30 years.

Alsaconfig says it finds the sound card, Cirrus Logic CS4281, and configures it OK but I still get no sound (I have tried both loudspeakers and earphones). Also neither AlsaMixer nor sGmixer run - they just return nothing when run.

What to now - any thoughts please?


John, Melbourne
Back to top
View user's profile Send_private_message 

Joined: 20 Jan 2006
Posts: 6698
Location: lisbon

PostPosted: Thu 10 Jul 2008, 22:19    Post_subject:  

Hi John,

same model toshiba I used to have when I first tried puppy. Which puppy version are you running, and how are you running it...frugal/CD/full?

If you enter lsmod is there any mention of cs4281? If not try running modprobe cs4281. If you're sound works after running this, you can add this command to /etc/rc.d/rc.local so that it will be run on booting.

Or you could try running alsaconf -a.
Back to top
View user's profile Send_private_message 

Joined: 18 Aug 2008
Posts: 1

PostPosted: Mon 18 Aug 2008, 17:38    Post_subject: re Toshiba Satellite 1730CDT no sound  

Hello! I'm more of a kubuntu chap myself, but damn, I'm impressed by puppy.

Anyways, I dug out my out toshiba 1700-300 after I killed my music laptop and I'm experiencing the same issue.

lsmod brings up a whole load of crap (stop me if I'm getting to technical here) it does mention SND_CS4281 and it's used by 1
also, SND is used by SND_CS4281 (what is lsmod looking at here?)

I tried modprobe cs4281 but that gave me a FATAL: module cs4281 not found.

alsaconf -a went through without complaining, seemed to run fine

I'm using the latest version of puppy, puppy dingo 4 I think and I did the full hard drive install

any ideas?

/edit, I've gone into alsamixer and unmuted everything and turned all the volumes up. The only thing that makes a difference is the external amplifier, when it's on I hear silence, when it's muted I hear slight interference in the headphones
Back to top
View user's profile Send_private_message 

Joined: 29 Jan 2006
Posts: 3630
Location: Sydney Australia

PostPosted: Tue 19 Aug 2008, 01:07    Post_subject:  


Check out this post and other links in it.

Good luck.....Chris.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Audio
Jump to:  

You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0438s ][ Queries: 11 (0.0035s) ][ GZIP on ]