Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 31 Oct 2014, 16:16
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Video
Strange, now works, but why?
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [3 Posts]  
Author Message
KF6SNJ

Joined: 19 Jun 2007
Posts: 698
Location: Distressed States of Amerika

PostPosted: Fri 04 Jul 2008, 21:07    Post subject:  Strange, now works, but why?
Subject description: Dell Inspiron 4000 Laptop
 

My pastor gave me a Dell Inspiron 4000 laptop in which the monitor had apparently gone bad. There were odd lines jetting off from just about every graphic and letter. Basically, it was almost unreadable. I decided to look at the BIOS settings. It was set to run from LCD and not from an external monitor. I tried playing with the display settings, but that only seemed to make it worse. Finally, I did something I had not thought to ever do on any computer, I disabled COM1. Suddenly the display was crystal clear. The OS, WinME, complained about COM1 being disabled, but everything looked great. It was perfectly readable. I booted up MacPup on (using the IDE=NODMA option) and everything was absolutely perfect. Here is what I don't get:

How is it that disabling COM1 would cause the display to suddenly work correctly?

I already wrote to my pastor about it, of course he may now want his old laptop back, but if so, I don't mind. I thanked him for giving me the opportunity to fix this.
Back to top
View user's profile Send private message Visit poster's website Yahoo Messenger 
WhoDo


Joined: 11 Jul 2006
Posts: 4441
Location: Lake Macquarie NSW Australia

PostPosted: Sat 05 Jul 2008, 01:47    Post subject: Re: Strange, now works, but why?
Subject description: Dell Inspiron 4000 Laptop
 

KF6SNJ wrote:
How is it that disabling COM1 would cause the display to suddenly work correctly?

Shared memory address for the COM and Video drivers. Look at the address that COM1 is using, change it to another acceptable address and re-enable. Is the video still ok? Just a thought.

Cheers

_________________
Actions speak louder than words ... and they usually work when words don't!
SIP:whodo@proxy01.sipphone.com; whodo@realsip.com
Back to top
View user's profile Send private message 
KF6SNJ

Joined: 19 Jun 2007
Posts: 698
Location: Distressed States of Amerika

PostPosted: Sat 05 Jul 2008, 23:28    Post subject:  

COM1 is supposed to be the serial port. I found that setting it to COM4 also works fine. My only other problem with it is that the "Fn" key isn't working right and I have to use it to type certain letters. Still, that is not too big of a hiccup overall.

Note: My pastor has told me I can keep the computer. He simply says congrats on fixing it.
Back to top
View user's profile Send private message Visit poster's website Yahoo Messenger 
Display posts from previous:   Sort by:   
Page 1 of 1 [3 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Video
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0444s ][ Queries: 11 (0.0059s) ][ GZIP on ]