Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 31 Jul 2014, 17:59
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Puppy 4 frugal install not saving session.
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [20 Posts]   Goto page: 1, 2 Next
Author Message
kagashe

Joined: 22 Jul 2007
Posts: 21

PostPosted: Sun 29 Jun 2008, 10:16    Post subject:  Puppy 4 frugal install not saving session.  

Hi,

Although, I am not a beginner Puppy 4 is making me feel like one. I have done frugal install of Puppy 4 by copying vmlinuz initrd.gz pup_400.sfs and zdrv_400.sfs to one of the partitions on hard disc.

When I shutdown/reboot Puppy is not asking where to create save file and exciting by giving a message session not saved.

This never happened in earlier versions. I don't have any save file from previous versions.

Please help.

kagashe
Back to top
View user's profile Send private message 
dm6257

Joined: 27 Jun 2008
Posts: 10
Location: Columbia, MD USA

PostPosted: Sun 29 Jun 2008, 10:48    Post subject: Puppy 4 install not asked to save
Subject description: New installation on USB flash drive doesn't ask for save option at shutdown
 

I posted a similiar topic a few days ago with the same issue. I tried a new installation technique where I used Vista to format my 2 GB USB flash drive to FAT32 and used Win32 Syslinux to add a MBR. The Puppy installation worked great but when I shutdown Puppy 4 it immediately goes to Session Not Saved. I have tried the ComboFormat method with the identical results.

Any ideas?

dm6257
Back to top
View user's profile Send private message 
dm6257

Joined: 27 Jun 2008
Posts: 10
Location: Columbia, MD USA

PostPosted: Sun 29 Jun 2008, 19:42    Post subject: Puppy 4 not saving session
Subject description: Puppy 4 does not ask to save session with USB flash, Puppy 3.01 does
 

After reading the comment of the thread initiator I downloaded Puppy 3.01 and installed on my 2 GB USB flash drive. It worked perfectly and after the first shutdown it walked through a procedure to create a save file.

Puppy 4 did not do this. Is there a glitch in the new release?

Thanks,
dm6257
Back to top
View user's profile Send private message 
ken_cat

Joined: 05 Dec 2007
Posts: 40
Location: Ontario, Canada

PostPosted: Sun 29 Jun 2008, 21:31    Post subject:  

Nothing wrong with Puppy 4.00. I just did a frugal install onto the hard drive. On first reboot it asked to create the pup_save.2fs file and it put it into the /pup400 folder.

I had to follow the instructions in the 4.0 manual found on the website. Getting Grub set-up was a little rough, but the iinstructions are good.

Dig out the manual and try er agin Smile
Back to top
View user's profile Send private message 
kagashe

Joined: 22 Jul 2007
Posts: 21

PostPosted: Mon 30 Jun 2008, 00:21    Post subject:  

ken_cat wrote:
Nothing wrong with Puppy 4.00. I just did a frugal install onto the hard drive. On first reboot it asked to create the pup_save.2fs file and it put it into the /pup400 folder.

I had to follow the instructions in the 4.0 manual found on the website. Getting Grub set-up was a little rough, but the iinstructions are good.

Dig out the manual and try er agin Smile
Thanks. The manual suggests to create a directory /puppy400 and put the 4 files in it and write the grub/menu.lst line as follows:
title Puppy Linux 4.00 frugal
rootnoverify (hd0,X)
kernel /puppy400/vmlinuz pmedia=idehd psubdir=puppy400
initrd /puppy400/initrd.gz

It works.

When I shutdown/reboot for the first time Puppy asks to save to the file or use entire partition. Initially, I selected the entire partition since it is a dedicated partition to Puppy. Although, Puppy added some folders to the partition (etc initrd lib root usr) it failed to create pup_save.2fs file and the configurations were not saved.

Second time I selected the option save to the file and it saved in /puppy400 folder.

The option to use the entire partition seems to be new but it is not working to save configurations. Why?

kagashe
Back to top
View user's profile Send private message 
dm6257

Joined: 27 Jun 2008
Posts: 10
Location: Columbia, MD USA

PostPosted: Mon 30 Jun 2008, 11:23    Post subject: Puppy 4 frugal install not saving session
Subject description: Install to USB flash drive does not request session save.
 

Thanks for the suggestion regarding the manual. The installer for a USB flashdrive uses Syslinux as the bootloader and creates a virtual ext2 file within the FAT32 partition. I don't see any mention of this in the manual and was never asked by the installer whether I wanted to save to a file or a partition.

So for now it looks like for Puppy 3.01 for USB flash drive users.

Thanks again,
dm6257
Back to top
View user's profile Send private message 
Py

Joined: 12 Aug 2005
Posts: 70

PostPosted: Tue 01 Jul 2008, 13:50    Post subject:  

Even with the above advice I have managed to get into a pickle with this type of frugal install of Puppy4.

With my current Puppy 2.16 I installed it by following exactly the post quoted below from GuestToo.

Would anyone care to modify this so that it is now applicable to Puppy4?

Quote:
if you have copied the files from the cd to hda1 ... Puppy is installed on the hard drive

now you need to install a boot loader to start Puppy, if you don't have one installed

make a directory (folder) on hda1 called boot

make a directory in /boot called grub

make a file in /boot/grub called menu.lst (that's LST,not one-st)

put something like this in menu.lst:

title Puppy
root (hd0,0)
kernel /vmlinuz root=/dev/ram0 PMEDIA=idehd
initrd /initrd.gz

your Grub boot loader is now configured

if you boot Windows too, you also would want to put this in the menu.lst file:

title Windows
rootnoverify (hd0,0)
chainloader +1

you can install Grub by copying the files in /usr/lib/grub/i386-pc to the /boot/grub directory ... /boot/grub will probably be in /mnt/home ... you actually only need the stage1 and stage2 files, and the stage1_5 file for the file system that /boot/grub is on ... but you might as well copy them all ... though stage2_eltorito is definitely not needed

now, to actually install the Grub boot loader to the mbr (first sector of the hard drive) you would type this in an rxvt console window:

grub
root (hd0,0)
setup (hd0)
quit

Grub (Grand Unified Boot loader) should now be installed and configured

so basically, to install Puppy to the hard drive, you copy 4 files from the cd to the hard drive

to install Grub, you copy a few files from the cd to the hard drive and make a text file telling Grub how to boot Puppy ... to install the Grub program, you run grub and type setup

and that's about it


From: http://www.murga-linux.com/puppy/viewtopic.php?t=16954
Back to top
View user's profile Send private message 
ICPUG

Joined: 24 Jul 2005
Posts: 1289
Location: UK

PostPosted: Wed 02 Jul 2008, 07:33    Post subject:  

Py,

May I suggest replacing this secton:

make a file in /boot/grub called menu.lst (that's LST,not one-st)

put something like this in menu.lst:

title Puppy
root (hd0,0)
kernel /vmlinuz root=/dev/ram0 PMEDIA=idehd
initrd /initrd.gz

with the following:

make a directory (folder) on hda1 called puppy400

Copy the following files from the CD to the folder puppy400:

vmlinuz
initrd.gz
pup_400.sfs
zdrv_400.sfs

make a file in /boot/grub called menu.lst (that's LST,not one-st)

put this in menu.lst:

title Puppy Linux 4.00 frugal
rootnoverify (hd0,0)
kernel /puppy400/vmlinuz pmedia=idehd psubdir=puppy400
initrd /puppy400/initrd.gz
boot

The rest of the instructions remain the same.

Please note that I am not knowledgable of installing grub on a linux partition but I assume you have got that right from your 2.16 install anyway.

ICPUG
Back to top
View user's profile Send private message 
Bruce B


Joined: 18 May 2005
Posts: 11080
Location: The Peoples Republic of California

PostPosted: Wed 02 Jul 2008, 08:47    Post subject:  

ICPUG,

In one example you have this:

kernel /vmlinuz root=/dev/ram0 PMEDIA=idehd

In the other sample you have this:

kernel /puppy400/vmlinuz pmedia=idehd psubdir=puppy400

I wonder if there was a change in versions where arguments like
pmedia went from UPPERCASE to lowercase?

I've seen so many examples of both text cases.

Does case matter?

--------------

Can you shed any light on this for us (me)?

TIA

Bruce
Back to top
View user's profile Send private message 
Py

Joined: 12 Aug 2005
Posts: 70

PostPosted: Wed 02 Jul 2008, 23:11    Post subject:  

Thanks ICPUG. I'll give it a go.
Back to top
View user's profile Send private message 
davidA


Joined: 15 Jun 2008
Posts: 64
Location: Location: Location:

PostPosted: Thu 03 Jul 2008, 00:21    Post subject:  

I need to research this some more, after doing a frugal install (today) I am saving to a file in a dedicated puppy partition (which is not what I expected) I was expecting to be able to use the whole partition for puppy (not to just be able to save to a 1.25 GB file)

Note: I used the universal installer (and started from scratch) on a newly partitioned hard drive (with nothing else on it) but was never offered the option to save to a whole partition (just a file of max size 1.25 GB)

Should I have selected the 'don't save' option (when I exited and rebooted) ?
Back to top
View user's profile Send private message 
ICPUG

Joined: 24 Jul 2005
Posts: 1289
Location: UK

PostPosted: Thu 03 Jul 2008, 08:22    Post subject:  

Bruce,

Actually, Puppy likes to have its parameters PMEDIA, PDEV1 and PSUBDIR in upper case.

However, after a certain version of Puppy (which I cannot now remember) the startup script for Puppy added these lines:

[ $pmedia ] && PMEDIA=$pmedia
[ $pdev1 ] && PDEV1=$pdev1
[ &psubdir ] && PSUBDIR=$psubdir

In natural language the first line means:
If pmedia exists then set PMEDIA equal to the contents of pmedia
Similarly for the other 2 lines.


This has the effect that if it finds any parameter name in lower case it passes its contents into the parameter with upper case name.

The result is that in recent Puppies you can provide these three parameter names in upper OR lower case.

In my post above I just copied bits from previous posts without thinking of the confusion I might cause!

Sorry,

ICPUG
Back to top
View user's profile Send private message 
erikson


Joined: 27 Feb 2008
Posts: 735
Location: Ghent, Belgium

PostPosted: Thu 03 Jul 2008, 11:12    Post subject:  

Edit: Arghhh, I wrote below post before reading the full thread (and ICPUGs answer). I'm pleased that his and my answers are compatible.

---

Bruce B wrote:
I wonder if there was a change in versions where arguments like pmedia went from UPPERCASE to lowercase?

I've seen so many examples of both text cases.

Does case matter?

--------------

Can you shed any light on this for us (me)?

This question pops up regularly on the forum, so let's address it once and for all Wink

PMEDIA, PDEV1, PSUBDIR, LAYERFS and LOGLEVEL are environment variables for the root-level shell, that are read from the kernel line in grub's menu.lst, and that are used in the init script in initrd.gz to steer its behavior.

Now this init script (from Puppy 3.01 vanilla) contains following lines:
Code:
[ $layerfs ] && LAYERFS=$layerfs
(...)
[ $loglevel ] && LOGLEVEL=$loglevel #v2.22
(...)
[ $pmedia ] && PMEDIA=$pmedia #boot parameter, broad category of boot media. ex: cd.
[ $pdev1 ] && PDEV1=$pdev1    #boot parameter, partition have booted off. ex: hda3
[ $psubdir ] && PSUBDIR=$psubdir #boot parameter, directory for puppy files. ex: puppy220

So, if the variable names on the kernel line are in lower case, the corresponding uppercase variables are set to the same value. The comment appears to suggest that this lowercase/uppercase translation was introduced in version 2.22 (at least for LOGLEVEL, I don't know for the other ones).

Anyway, the variables used in init are the uppercase ones. You're always safe, irrespective of exact Puppy version, when using the UPPERCASE names in the grub menu.

The init script does not translate case for the given values. The values for PMEDIA, PDEV1, and LAYERFS must always be given in lowercase. The value for PSUBDIR must always correspond in case to the name of the subdirectory.

_________________
If it ain't broke, don't fix it. --- erikson
hp/compaq nx9030 (1.6GHz/480MB/37.2GB), ADSL, Linksys wireless router
http://www.desonville.net/
Puppy page: http://www.desonville.net/en/joere.puppy.htm

Back to top
View user's profile Send private message Visit poster's website 
moritzes

Joined: 11 Aug 2005
Posts: 20
Location: Akron, OH

PostPosted: Sat 26 Jul 2008, 13:32    Post subject: "session not saved" msg at frugal Puppy 4 shutdown  

I didn't have any luck with the suggestions in this thread, but did find another way to make my frugal Puppy 4 save.

I edited the /etc/rc.d/PUPSTATE to add an entry for PUPSAVE (no arrows or hyphens in actual file...):

Code:
PUPMODE=12
PDEV1='hda5'
DEV1FS='ext3'
PUPSFS='hda5,ext3,/puppy400/pup_400.sfs'

--->>> PUPSAVE='hda5,ext3,/puppy400/pup_save.2fs'  <<<---

PMEDIA='idehd'
SATADRIVES=''
#these directories are unionfs layers in /initrd...
SAVE_LAYER='/pup_rw'
PUP_LAYER='/pup_ro2'
#The partition that has the pup_save file is mounted here...
PUP_HOME='/mnt/dev_save'
#(in /initrd) ...note, /mnt/home is a link to it.
#this file has extra kernel drivers and firmware...
ZDRV='hda5,ext3,/puppy400/zdrv_400.sfs'
PSWAPFILE=''
PSAVEMARK=''


After that, Puppy saved at my next shutdown. Not sure why Puppy is not picking this up, but for those of you who are hunting it down, the other package on this Dell Latitude laptop is Ubuntu 8.04 (which is a fine distro, but it's a slow pig on this thing). As you see from above, I'm on the hda5 partition, which is the same partition as the Ubuntu. Hope this helps someone.
Back to top
View user's profile Send private message 
carolus

Joined: 14 Feb 2007
Posts: 129

PostPosted: Thu 08 Apr 2010, 11:07    Post subject:
Subject description: "session not saved" with Puppy 4.1.2
 

Instead of the usual query about saving the session, on shutdown I just get the message "session not saved".

This is when booting Puppy 4.1.2 on my desktop computer using Windows XP bootloader with grub4dos, a configuration that works fine on my laptop.
(With vmlinuz and initrd on the system hard drive, pup*.sfs on USB flash). On the desktop computer, Puppy 4.1.2 works normally when booting from a multisession CD; only when using grub4dos is there a problem. On the desktop, but not the laptop, I have a USB hard drive as well as the USB flash, but Puppy seemed to correctly find and mount the flash drive.

Any explanation or suggestions?

This is not exactly a "frugal install" as I understand it, but it is close enough to perhaps fit into this thread.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 2 [20 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0967s ][ Queries: 11 (0.0039s) ][ GZIP on ]