Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 25 Oct 2014, 23:26
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Audio
Sound Works on Toshiba Tecra750DVD But Not Saved after Boot
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
ken_cat

Joined: 05 Dec 2007
Posts: 40
Location: Ontario, Canada

PostPosted: Wed 25 Jun 2008, 01:35    Post_subject:  Sound Works on Toshiba Tecra750DVD But Not Saved after Boot
Sub_title: MP3 playback. <SOLVED>
 

Thought I'ld post a success for anyone searching.

Toshiba Tecra750DVD laptop with Yamaha OPL3-SA3 sound harware.

The ALSA Wizard initially failed to recognize a Pnp or current card, but going thru the legacy search it came up with a list to try. First up was OPL3SA2, so I chose that even though it was an SA3 in the machine. ALSAMixer reports Yamaha OPL3-SA23 so it was a good choice.

Anyway, I have sound. The Gxine Media Player sucked as the MP3 playback was cutting up with any mouse movement or activity. Made for big CPU I guess (only a 233 Mhz in the little Tosh). Downloaded Xfmedia and it works purrfectly.

edit: listening with an old set of Yamaha HP-3 Orthodynamic Headphones.......Very sweet indeed Cool

Edited_time_total
Back to top
View user's profile Send_private_message 
ken_cat

Joined: 05 Dec 2007
Posts: 40
Location: Ontario, Canada

PostPosted: Wed 25 Jun 2008, 23:18    Post_subject:  

I have changed the thread title to reflect an issue I discovered tonight.

I shut the computer down last night and have done a few reboots today after restarting the computer. Went to play some MP3's tonight and had no sound. The two mixers reported the yamaha sound card in their gui.

Just for the heck of it , I reran the ALSA Sound Wizard and loaded up the Yamaha modules again....VOILA......sound. And I did answer yes to saving the configuration for the next boot.

Is there a bug where the configuration is not saved?
Back to top
View user's profile Send_private_message 
ken_cat

Joined: 05 Dec 2007
Posts: 40
Location: Ontario, Canada

PostPosted: Thu 26 Jun 2008, 20:19    Post_subject:  

I should update that it has happened again tonight. Starting from a computer shutdown, there is no sound; however, looking at lsmod output, there are plenty of sound related modules loaded. This is a full harddrive install of Puppy 4/00.

I'm looking at the mixers and the xfmedia player for muting controls and don't see that the computer is muted.

Anyone experience the same thing, or have any tips?
Back to top
View user's profile Send_private_message 
ken_cat

Joined: 05 Dec 2007
Posts: 40
Location: Ontario, Canada

PostPosted: Fri 27 Jun 2008, 23:46    Post_subject:  

I installed Puppy 3.01 in HD full install (wiped out 4.00).

This sound issue is the same. No sound after reboot. Have to rerun ALSA wizard to get sound re-established.

No one here listen to music????????
Back to top
View user's profile Send_private_message 
shroomy_bee


Joined: 28 Jun 2008
Posts: 666

PostPosted: Sat 28 Jun 2008, 15:12    Post_subject:  

I had (sort of still have) a similar problem with the sound, but I got it working -

http://www.murga-linux.com/puppy/viewtopic.php?t=30790

I rebooted the liveCD and compared the 'modprobe.conf' file with the same file on the full install, to see what was different on it & stopping the sound from working.

You can do this from the console (command line), but it should work using the gui/desktop icons too:

First I found a line in the hdd installation version of modprobe.conf that refered to my 'HD intel audio' - that wasn't in the liveCD version (in my case, because I installed Puppy on a different machine to the one I was going to use it in) - so I deleted that line, and deleted the space it left behind, and saved that.


But deleting that didn't work - so I went back into the /etc/ (where the modprobe.conf is located) to see what else might be different -

found a file that is called 'asound.state', which is not present on the liveCD version, it's a text-file icon (all the writing on the icon) - just click on it, and you'll see loads of code about configurations for the audio player, volume settings and so forth.

So - when you find that file, delete it, then reboot the machine - and your sound should work.

- but maybe save a copy of it first, on say a USB drive, so you can put it back on again if it doesn't work for you.

It worked for me - but I still can't get the startup-barks going.

But - I notice that it is back again in /etc/ after rebooting.......but it is no longer in bold font.

( to get into /etc/ - click the 'file' icon (the first one, the house) on the desktop, and click the green arrow on the left - that takes you into the root proper, and /etc/ is in there ).
Back to top
View user's profile Send_private_message Visit_website 
ken_cat

Joined: 05 Dec 2007
Posts: 40
Location: Ontario, Canada

PostPosted: Sat 28 Jun 2008, 19:37    Post_subject:  

My problem is solved. Can't believe it. Its been around since ver 2.16.

See here and follow the link:
http://www.murga-linux.com/puppy/viewtopic.php?t=21315

Or go direct: http://www.murga-linux.com/puppy/viewtopic.php?t=20788
See post by Sasito-linux.

Or copied direct for the impatient:

"I think this will help anyone having this problem:

Edit /etc/modprobe.conf

In the ALSA section you will find this line:

isapnp=0

Just change it to:

isapnp=1 "

http://www.murga-linux.com/puppy/viewtopic.php?mode=attach&id=10498

Notice the DO NOT EDIT warnings Laughing
modprobe.conf_PNP.jpg
 Description   
 Filesize   73.04 KB
 Viewed   742 Time(s)

modprobe.conf_PNP.jpg

Back to top
View user's profile Send_private_message 
exProphecy


Joined: 05 Nov 2007
Posts: 336
Location: Bay Area, California

PostPosted: Mon 14 Jul 2008, 11:23    Post_subject:  

I'm having the same "sound card not saved after boot" problem but I tried looking for isapnp=0 in modprobe.conf and I didn't see it there.
_________________
Puppy 4.3.1 + Sansa Express MP3 Player + 10GB USB Flash Drive = My triple threat OS. Wink
I consider myself a Turritopsis Nutricula.
http://www.wellminded.com/puppy/pupsearch.html
http://www.esnips.com/web/exprophecypets
Back to top
View user's profile Send_private_message AIM 
exProphecy


Joined: 05 Nov 2007
Posts: 336
Location: Bay Area, California

PostPosted: Wed 16 Jul 2008, 07:20    Post_subject:  

I looked at my modprobe.conf and I have this at the sound card part:

# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF verion 1.0.8 ---
alias snd-card-0 snd-emu10k1
alias sound-slot-0 snd-emu10k1
# --- END: Generated by ALSACONF, do not edit. ---

I don't even have an "options" section after the aliases. =/ Any clue on what to do to make it load my sound card load after reboot?

_________________
Puppy 4.3.1 + Sansa Express MP3 Player + 10GB USB Flash Drive = My triple threat OS. Wink
I consider myself a Turritopsis Nutricula.
http://www.wellminded.com/puppy/pupsearch.html
http://www.esnips.com/web/exprophecypets
Back to top
View user's profile Send_private_message AIM 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Audio
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0620s ][ Queries: 12 (0.0059s) ][ GZIP on ]