Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 19 Sep 2014, 18:08
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
boost-1.36.0.pet C++ Libraries
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [13 Posts]  
Author Message
big_bass

Joined: 13 Aug 2007
Posts: 1747

PostPosted: Tue 17 Jun 2008, 15:19    Post subject:  boost-1.36.0.pet C++ Libraries
Subject description: boost-1.35.0.sfs also
 

...one of the most highly regarded and expertly designed C++ library projects in the world.” — Herb Sutter and Andrei Alexandrescu, C++ Coding Standards

latest you only need this

had to make a pet kept getting download permission errors
http://www.puppylinux.ca/tpp/big_bass/boost-1.3.6.0.pet

older if you need it
http://www.puppylinux.ca/tpp/big_bass/boost-1.35.0.sfs

info only
http://www.boost.org/
http://www.boost.org/doc/


while working with Ardour one of the requirements was to have boost headers present
so I saw the size and thought no....way then said well an SFS could be mounted then removed Wink

so I converted it to a sfs

I got around this problem doing something else anyway but since I made it a sfs
it can be used in puppy if needed or if another project requires it
its the latest boost 1.35.0

***if you need any help using this you will need to read the manual
I am offering this as a required package only without technical support of use ***


********************************************************
this is why I did this
For the Ardour 2.0 series

* glib 2.10 or above (libglib2, libglib2.0, libglib2.0-0)
* GTK+ 2.8 or above (plus other GTK requirements like Pango, ATK, Cairo) (libgtk2, libgtk2.0, libgtk2.0-0)
* libgnomecanvas (libgnomecanvas2, libgnomecanvas2-0)
* liblo (liblo, liblo0) (a lightweight Open Sound Control (OSC) library)
* boost (libboost (note: ardour is not linked against boost, but it does require the header files to be present)
* FFTW v3. Note that you will need both the double-precision version ("fftw3") and the single-precision ("fftw3f") version installed.

***************************************************************


big_bass at ------------>http://www.puppylinux.ca/tpp/big_bass/
boost.png
 Description   
 Filesize   6.16 KB
 Viewed   2693 Time(s)

boost.png


Last edited by big_bass on Tue 11 Nov 2008, 00:03; edited 7 times in total
Back to top
View user's profile Send private message 
rockym93


Joined: 04 Jul 2006
Posts: 21
Location: Australia

PostPosted: Mon 14 Jul 2008, 03:26    Post subject:  

Thanks for posting these!

I spent ages trying to figure these out- I need them to compile Wesnoth. Couldn't get them to compile.

_________________

Back to top
View user's profile Send private message Visit poster's website 
big_bass

Joined: 13 Aug 2007
Posts: 1747

PostPosted: Mon 14 Jul 2008, 11:27    Post subject:  

rockym93 wrote:
Thanks for posting these!

I spent ages trying to figure these out- I need them to compile Wesnoth. Couldn't get them to compile.



Prerequisites

You need to have the development packages of these libraries and a compiler (such as gcc) installed to build Wesnoth. You will also need the runtime packages to actually run Wesnoth.

* libsdl1.2 ( http://www.libsdl.org ) (SDL >= 1.2.7 strongly recommended)
* libsdl-image1.2 (with PNG support) ( http://www.libsdl.org/projects/SDL_image )
* libsdl-mixer1.2 (with Vorbis support) ( http://www.libsdl.org/projects/SDL_mixer )
* libsdl-net ( http://www.libsdl.org/projects/SDL_net )
* libintl (and other libraries found in gettext package) ( http://www.gnu.org/software/gettext/gettext.html )
* (newer than Wesnoth 1.3) python >= 2.4 ( rather optional but highly recommended, http://www.python.org )
* (newer than Wesnoth 1.3.12) libboost ( currently only libboost-iostreams, http://www.boost.org )
* (newer than Wesnoth 1.3.12) zlib ( in theory already needed for libsdl-image, http://www.zlib.org )
* scons (Development version only)

If you attempt to build from the stable branch from svn you will also need those packages:

* autoconf >= 2.60
* automake >= 1.9

The various SDL libraries can be found at http://www.libsdl.org



good luck and PM me when you get it working
I like to hear and post in this tread too

big_bass
Back to top
View user's profile Send private message 
ags

Joined: 28 Jul 2006
Posts: 14
Location: Norway

PostPosted: Tue 15 Jul 2008, 05:29    Post subject: boost and gpsdrive  

Hi Big_Bass!

I have downloaded a .deb-package of the last Gpsdrive version and installed it on my Dingo test drive (VirtualBox), but I'm struggling to satisfy dependencies to run it. One of them was related to boost (libboost_filesystem-gcc42-mt-1_34_1.so.1.34) and two others to:
Mapnik (libmapnik.so.0.5) and
Libgda (libgda-3.0.so.3).
I made a libgda pet and was going to install Mapnik when I found another dependency problem (libfreetype2 - ) I would really like to have Gpsdrive running, but it seems that many have problems when they try to compile and install. Would you consider making a package?
Back to top
View user's profile Send private message 
disciple

Joined: 20 May 2006
Posts: 6435
Location: Auckland, New Zealand

PostPosted: Sun 02 Nov 2008, 18:16    Post subject:  

I can't mount this. Does anyone know if the problem could be that it was made with an LZMA enabled puppy, which I don't have?
_________________
DEATH TO SPREADSHEETS
- - -
Classic Puppy quotes
- - -
Beware the demented serfers!
Back to top
View user's profile Send private message 
big_bass

Joined: 13 Aug 2007
Posts: 1747

PostPosted: Sun 02 Nov 2008, 19:23    Post subject:  

disciple wrote:
I can't mount this. Does anyone know if the problem could be that it was made with an LZMA enabled puppy, which I don't have?


disciple
It was made on version 3.01 puppylinux

open a console and check your version
#mksquashfs -version 3.2-r2 (2007/01/15)

I can make a new one for you what version are you using ?


big_bass

Last edited by big_bass on Tue 11 Nov 2008, 12:20; edited 1 time in total
Back to top
View user's profile Send private message 
disciple

Joined: 20 May 2006
Posts: 6435
Location: Auckland, New Zealand

PostPosted: Mon 03 Nov 2008, 17:06    Post subject:  

I've got version 3.3 in Puppy 4.00
The release notes for 3.00/3.01 don't say anything about LZMA, so maybe I've just got a corrupt download. I'll try the new one this afternoon.

_________________
DEATH TO SPREADSHEETS
- - -
Classic Puppy quotes
- - -
Beware the demented serfers!
Back to top
View user's profile Send private message 
disciple

Joined: 20 May 2006
Posts: 6435
Location: Auckland, New Zealand

PostPosted: Tue 04 Nov 2008, 00:05    Post subject:  

Dude, I'm redownloading the old version to try again, but the link for the new version just tells me the website won't allow me access to the page...
_________________
DEATH TO SPREADSHEETS
- - -
Classic Puppy quotes
- - -
Beware the demented serfers!
Back to top
View user's profile Send private message 
ttuuxxx


Joined: 05 May 2007
Posts: 10750
Location: Ontario Canada,Sydney Australia

PostPosted: Tue 04 Nov 2008, 03:46    Post subject:  

disciple wrote:
Dude, I'm redownloading the old version to try again, but the link for the new version just tells me the website won't allow me access to the page...


you can try one I compiled up awhile ago
http://www.puppylinux.ca/tpp/ttuuxxx/programs/compile/libboost-iostreams1.34.1.pet
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile

Back to top
View user's profile Send private message Visit poster's website 
pgs843

Joined: 26 Feb 2008
Posts: 3

PostPosted: Mon 10 Nov 2008, 21:14    Post subject:  

same problem here. i cant mount the sfs on puppy 411 with sfs version 3.3.

also, ive been trying to make boost work for awhile. ive compiled it, recompiled it, and put it in about every directory in the filesystem, and it(the headers) still cant be found. how did you make it work?
Back to top
View user's profile Send private message 
big_bass

Joined: 13 Aug 2007
Posts: 1747

PostPosted: Tue 11 Nov 2008, 00:08    Post subject:  

pgs843 wrote:
same problem here. i cant mount the sfs on puppy 411 with sfs version 3.3.

also, ive been trying to make boost work for awhile. ive compiled it, recompiled it, and put it in about every directory in the filesystem, and it(the headers) still cant be found. how did you make it work?




I made a pet instead it will install to the correct locations
http://www.puppylinux.ca/tpp/big_bass/boost-1.3.6.0.pet

and no fuss with different sfs versions
sorry for the delay I tried uploading several times
ver 3.3 squashfs gave me permissions errors on downloads Shocked



big_bass
Back to top
View user's profile Send private message 
pgs843

Joined: 26 Feb 2008
Posts: 3

PostPosted: Tue 11 Nov 2008, 20:12    Post subject:  

awesome, thanks Smile all of them worked except libboost_thread. it couldnt find the thread library
Back to top
View user's profile Send private message 
big_bass

Joined: 13 Aug 2007
Posts: 1747

PostPosted: Wed 12 Nov 2008, 13:34    Post subject:  

pgs843 wrote:
awesome, thanks Smile all of them worked except libboost_thread. it couldnt find the thread library


if you can paste the exact error it would help me fix the problem
faster

I found this in /usr/lib
libboost_thread-mt.so

you may just need to symlink to it

Quote:

Code: type this this the console

ln -s /usr/lib/libboost_thread-mt.so /usr/lib/libboost_thread.so




is all working for you now?

if using the symlink fixes it I will patch the pet

big_bass
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [13 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0809s ][ Queries: 12 (0.0042s) ][ GZIP on ]