Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 18 Dec 2014, 16:16
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
How to get Spanish accents with U.S keyboard DINGO (SOLVED!)
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [14 Posts]  
Author Message
jplagarde

Joined: 04 Jun 2008
Posts: 31

PostPosted: Sun 15 Jun 2008, 21:54    Post subject:  How to get Spanish accents with U.S keyboard DINGO (SOLVED!)  

I need to figure out how to type Spanish accents on Dingo! Especially when using abiword!! I'm on my MAC right now i need these éáñ etc .. on the mac you simply type option while holding e then the next key stroke will be accented ..

anyway to do this?

Thanks!!

Last edited by jplagarde on Tue 17 Jun 2008, 16:08; edited 1 time in total
Back to top
View user's profile Send private message 
erikson


Joined: 27 Feb 2008
Posts: 735
Location: Ghent, Belgium

PostPosted: Tue 17 Jun 2008, 10:10    Post subject: Re: How to get spanish accents (abiword) w/ US Keyboard - Di
Subject description: Please help!!
 

jplagarde wrote:
I need to figure out how to type Spanish accents on Dingo! (...) anyway to do this?

Yes, sure.

I assume you have a standard US keyboard. Now configure US-international keyboard (named br-latin1-us in Puppy's mouse/keyboard setup wizard, only heaven knows why) and buy one. Or keep the standard keyboard and memorize the location of special characters and dead-key symbols, or draw them on the appropriate keys with a felt-tip permanent marker.

The layout is found on wikipedia: Keyboard layout

_________________
If it ain't broke, don't fix it. --- erikson
hp/compaq nx9030 (1.6GHz/480MB/37.2GB), ADSL, Linksys wireless router
http://www.desonville.net/
Puppy page: http://www.desonville.net/en/joere.puppy.htm

Back to top
View user's profile Send private message Visit poster's website 
jplagarde

Joined: 04 Jun 2008
Posts: 31

PostPosted: Tue 17 Jun 2008, 11:08    Post subject:  

The problem is that i don't know the keystrokes to get these special characters no matter what keyboard layout I'm using. If i hit alt in abiwork it thinks i want the top menu. Where can i find the keystrokes for the various layouts. I have seen the wikipedia site but it doesn't spell out how you actually make the characters.

Thanks!
Back to top
View user's profile Send private message 
erikson


Joined: 27 Feb 2008
Posts: 735
Location: Ghent, Belgium

PostPosted: Tue 17 Jun 2008, 12:08    Post subject:  

jplagarde wrote:
I have seen the wikipedia site but it doesn't spell out how you actually make the characters.

Excerpt:
Quote:
The US keyboard layout can be configured to type accents efficiently. This is known as the US-International layout. Using the same layout as the US keyboard, accented characters can be typed by pressing the appropriate accent key, then the letter on the keyboard in its unaccented form. Accent keys share the same key as ', `, ", ^ and ~.

Accent keys are activated by pressing it (without holding it), and next pressing the letter that requires an accent. After the two strokes, the single accented character would appear on the screen. Note that only vowels can have accents in this way. If one wishes to use the normal single quotation mark, caret and so on, one would press the accent key followed by the spacebar. Accented characters can be typed with the following combinations:

* ' the letter (é)
* ` the letter (è)
* " the letter (ë)
* ^ the letter (ê)
* ~ the letter (ñ)

Thus, in this sense, the keys ', `, ", ^ and ~ are dead keys when first depressed, then become normal keys functioning in the same way as keys on the US keyboard if the spacebar is pressed.


But it only works when US-international is configured, i.e. as br-lat1-us from Menu > Setup > Mouse/keyboard wizard.

_________________
If it ain't broke, don't fix it. --- erikson
hp/compaq nx9030 (1.6GHz/480MB/37.2GB), ADSL, Linksys wireless router
http://www.desonville.net/
Puppy page: http://www.desonville.net/en/joere.puppy.htm

Back to top
View user's profile Send private message Visit poster's website 
jplagarde

Joined: 04 Jun 2008
Posts: 31

PostPosted: Tue 17 Jun 2008, 13:07    Post subject:  

So frustrating because i've set it, using the keyboard/mouse wizard, to br-lat1-us, rebooted, and it still does not work. when I hit the( ' ) key to cause the action (its supposed to be a dead key till the second hit) and it doesn't work. I just prints the ' rather than waiting for the second key stroke.

Thanks for you help though ...
Back to top
View user's profile Send private message 
erikson


Joined: 27 Feb 2008
Posts: 735
Location: Ghent, Belgium

PostPosted: Tue 17 Jun 2008, 13:43    Post subject:  

jplagarde wrote:
... when I hit the( ' ) key to cause the action (its supposed to be a dead key till the second hit) and it doesn't work. I just prints the ' rather than waiting for the second key stroke

Maybe it only behaves as dead-key when pressed together with Shift or Alt or AltGr (e.g. press AltGr and keep it depressed, press and release ', release AltGr, and then press-release the vowel). Some experimenting should show.

I have a Belgian keyboard, which has similar tricks for dead-keys. For the dead-key tilde, I have to do AltGr+~ on that one, and it works a treat (following it with n indeed gives the tilded ñ). Likewise AltGr with comma, followed by c, gives cedilla ç.

Good luck!

_________________
If it ain't broke, don't fix it. --- erikson
hp/compaq nx9030 (1.6GHz/480MB/37.2GB), ADSL, Linksys wireless router
http://www.desonville.net/
Puppy page: http://www.desonville.net/en/joere.puppy.htm

Back to top
View user's profile Send private message Visit poster's website 
erikson


Joined: 27 Feb 2008
Posts: 735
Location: Ghent, Belgium

PostPosted: Tue 17 Jun 2008, 14:45    Post subject:  

Okay... now I tested myself, by simulating a US-international keyboard.

After a couple of failed attempts, I ultimately did the following:

(1) Run Menu > Setup > Mouse/keyboard wizard and select br-latin1-us
(2) Run Menu > Setup > Xorg Video Wizard and click XorgWizard. This aborts X and brings up the video definition screen; redefine video resolution (in my case 1024x768, 24-bit color). This rebuilds file /etc/X11/xorg.conf that has the keyboard config parameter that is used in X.
(3) Test: I identified the key corresponding to the '/" key on US international. Press AltGr, keep it depressed, press-release '/" key, release AltGr. This is the US-international dead-key combination for accents. Then press a vowel, e.g. a, and this forms á. Same technique for é, í, ó, ú.
(4) Reboot and retest gives same results.

So step (2) was missing in my previous instructions. This means that in X the keyboard was still reset to standard US after reboot --- whatever the mouse/keyboard wizard might have said. Consider this as a mild bug in Puppy.

_________________
If it ain't broke, don't fix it. --- erikson
hp/compaq nx9030 (1.6GHz/480MB/37.2GB), ADSL, Linksys wireless router
http://www.desonville.net/
Puppy page: http://www.desonville.net/en/joere.puppy.htm

Back to top
View user's profile Send private message Visit poster's website 
jplagarde

Joined: 04 Jun 2008
Posts: 31

PostPosted: Tue 17 Jun 2008, 16:06    Post subject:  

Erickson!

Well done! I have been struggling with this for days! What a great help you have been! I was beginning to wonder what was going on. How weird that you need to rerun the xvideowizard to get the other settings to stick.

I tried the keyboard layout you suggested but ultimately found ES - the straight spanish keyboard easier to manage!

Thanks so much again!!

JP

I'll edit the thread and put solved !
Back to top
View user's profile Send private message 
erikson


Joined: 27 Feb 2008
Posts: 735
Location: Ghent, Belgium

PostPosted: Wed 18 Jun 2008, 06:42    Post subject:  

jplagarde wrote:
Thanks so much again!!

You're welcome. De nada, como se dice en castellano Smile

Wrap-up summary

(1) Below comments apply for Xorg (I don't know about Xvesa). They apply for Puppy 3.01, and probably also for most or for all other versions (I didn't check).

(2) Puppy keeps keyboard layout type in two files, namely in /etc/keymap and (along with other settings) in /etc/X11/xorg.conf. If both files correspond, the setting is reliably effective after restarting X or rebooting. Otherwise the effective setting may unexpectedly be wrong, and/or it may unexpectedly change by restarting X, and/or it may unexpectedly change by rebooting.

(3) Both files are properly configured using my two-step procedure of earlier post, with the mouse/keyboard wizard (setting keymap) and with the Xorg video wizard (setting xorg.conf). Alternatively, both files may also be suitably adapted by hand-editing, followed by restarting X or rebooting to make the settings effective.

_________________
If it ain't broke, don't fix it. --- erikson
hp/compaq nx9030 (1.6GHz/480MB/37.2GB), ADSL, Linksys wireless router
http://www.desonville.net/
Puppy page: http://www.desonville.net/en/joere.puppy.htm

Back to top
View user's profile Send private message Visit poster's website 
frefel

Joined: 26 Feb 2009
Posts: 178
Location: Eugene, Ore., US

PostPosted: Mon 20 Apr 2009, 03:04    Post subject:  

I was eagerly expecting to use these well researched findings to change my Puppy 4.2 keyboard to be able to type Spanish accented characters but, lo and behold, there is no "br-latin1-us" option on my keyboard menu.

Any suggestions on how to accomplish this with my present Puppy version?

Thanks.
Back to top
View user's profile Send private message AIM Address 
frefel

Joined: 26 Feb 2009
Posts: 178
Location: Eugene, Ore., US

PostPosted: Tue 21 Apr 2009, 22:34    Post subject:  

Isn't there anyone using Puppy 4.2 with international characters that could explain how to set it up? Or is that not an option anymore?
Ayudame por favor (fijate en la falta de signos de acento ortografico)

.
Back to top
View user's profile Send private message AIM Address 
disciple

Joined: 20 May 2006
Posts: 6463
Location: Auckland, New Zealand

PostPosted: Sun 28 Jun 2009, 09:48    Post subject:  

I guess this is probably too late for you now Sad

Personally I don't like the deadkeys system. What I do is:
- not change the type of keyboard
- use xmodmap to make a key I wouldn't otherwise use a multi key (often called a compose key). This means to enter an accented character I press compose, then the accent, then the letter.

I'm afraid I don't have the time right now to explain properly, but basically to do it this way you need to:
1. run xev (I think these days it is in a package of Xorg extras in petget, or you can get it from http://www.murga-linux.com/puppy/viewtopic.php?p=244431#244431) and find out the keycode of the key you want to make the multi key. Some people like to use the right Windows key. I think my keyboard actually has the print screen key as a multi key by default - if you already have a multi key and you don't want to change it these instructions are kind of pointless Smile.
2. map it with xmodmap. Do some research to find out the syntax if you want to run the command to test Smile For it to automatically be mapped at startup, put code something like this in ~/.Xmodmap
Code:
keycode 111 = Multi_key

_________________
DEATH TO SPREADSHEETS
- - -
Classic Puppy quotes
- - -
Beware the demented serfers!
Back to top
View user's profile Send private message 
Shep

Joined: 08 Nov 2008
Posts: 851
Location: GIRT-BY-SEA

PostPosted: Sun 17 Jan 2010, 23:03    Post subject:  

erikson wrote:
Excerpt:
Quote:
The US keyboard layout can be configured to type accents efficiently. This is known as the US-International layout. Using the same layout as the US keyboard, accented characters can be typed by pressing the appropriate accent key, then the letter on the keyboard in its unaccented form. Accent keys share the same key as ', `, ", ^ and ~.

Accent keys are activated by pressing it (without holding it), and next pressing the letter that requires an accent. After the two strokes, the single accented character would appear on the screen. Note that only vowels can have accents in this way. If one wishes to use the normal single quotation mark, caret and so on, one would press the accent key followed by the spacebar. Accented characters can be typed with the following combinations:

* ' the letter (é)
* ` the letter (è)
* " the letter (ë)
* ^ the letter (ê)
* ~ the letter (ñ)

Thus, in this sense, the keys ', `, ", ^ and ~ are dead keys when first depressed, then become normal keys functioning in the same way as keys on the US keyboard if the spacebar is pressed.


But it only works when US-international is configured, i.e. as br-lat1-us from Menu > Setup > Mouse/keyboard wizard.
All very good, as far as it goes. But with this setup, how to get c cedila?? (i.e., c with a comma underneath it.
Back to top
View user's profile Send private message 
Shep

Joined: 08 Nov 2008
Posts: 851
Location: GIRT-BY-SEA

PostPosted: Tue 19 Jan 2010, 00:04    Post subject:  

For customising the keyboard for your own language,
erikson advises a 2 step procedure where he wrote:
(1) Run Menu > Setup > Mouse/keyboard wizard and select br-latin1-us
(2) Run Menu > Setup > Xorg Video Wizard and click XorgWizard. This aborts X and brings up the video definition screen; redefine video resolution (in my case 1024x768, 24-bit color). This rebuilds file /etc/X11/xorg.conf that has the keyboard config parameter that is used in X.

May I supplement step 1 with

(1b) as well as selecting your keyboard, at this stage if you are using Xorg then in the Mouse/Keyboard Wizard select Advanced Xorg keyboard configuration and from the Options tab select how you want certain keys to behave, including CONTROL and SHIFT keys, and setting the Third Level Chooser if your language employs a keyboard with three or more characters on some of the keys (esp. the digit keys). Here, you can also set the EURO character to be on a key. Now proceed to step 2.

I hope this will generalise the procedure, to make it applicable to all languages.

Am grateful to Erikson for posting this discovery; Puppy's instructions should be modified to include these corrections.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [14 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0938s ][ Queries: 11 (0.0045s) ][ GZIP on ]