Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 23 Oct 2014, 05:05
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Für deutschsprachige Anhänger
muppy xorg S3 Graphics Inc. SavageIX black screen
Moderators: MU
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [11 Posts]  
Author Message
vati


Joined: 31 Aug 2006
Posts: 27
Location: Germany

PostPosted: Thu 12 Jun 2008, 11:40    Post subject:  muppy xorg S3 Graphics Inc. SavageIX black screen
Subject description: puppy vs. muppy xorg
 

Meine Hardware:
IMB Thinkpad 20 700mhz 256 M Ram, Video S3 Graphics Inc. SavageIX + externer Monitor 17'' TFT

Installation:
Muppy 0083.E Standard Frugal Installation auf Festplatte

Grub menue.lst:
title MuppyLinux 008.3 hd
rootnoverify (hd0,6)
kernel /muppy0083/vmlinuz pmedia=idehd layerfs=aufs psubdir=muppy0083
initrd /muppy0083/initrd.gz

Problem:
Xorg unter Muppy bringt BLACK SCREEN ; xvesa ok.

Zustandsbeschreibung:
Obwohl ich unter Puppy alt und neu ( 2.17 / 4.0) stets ohne Probleme den Xorg Server laden kann, habe ich mit Muppy ständig Schwierigkeiten. Die Notlösung XVESA spielt meine Videos nicht im Fullscreen Modus ab bzw. bringt Ruckelvideos. Das ist der Hauptgrund, unbedingt den Xorg Server zu benutzen.

FAZIT:
Obwohl Muppy die exquisite Softwareausstattung incl. dt. Sprache überhaupt hat, halten mich solche grundsätzlichen Dinge wie mangelhafte Videotreiber von der Nutzung ab. Mit XVESA gebe ich mich nicht zufrieden wg. der Multimedianutzung.

FRAGE:
Wer hat noch solche Probleme?
Wieso konnte bisher immer Puppy mit dieser Videohardware umgehen, aber nicht Muppy?
Was muss ich nachladen, damit diese Hardware von Xorg unter Muppy verstanden wird?

Ich probiere jetzt schon 2 Tage ohne Erfolg!
Einmal konnte ich Xorg mit Normalauflösung einrichten und starten.
Alles war OK.
Als ich den externen Monitor abschaltete, hatte ich wieder Black Screen.
Und so drehe ich mich ständig im Kreis und sehe keinen Zusammenhang.
Bin für jede Hilfe sehr dankbar.
Herzliche Grüsse
-Jörg aus Dresden

_________________
Precise Puppy on EEEPC Asus 1005p frugal SD-Card without pupsave
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Thu 12 Jun 2008, 18:38    Post subject:  

Hallo,

bitte zippen und beifügen:
/var/log/Xorg.0.log (von Muppy)
/etc/X11/xorg.conf (von Muppy UND Puppy 2)

Muppy (Puppy3) verwendet Xorg 7.2, Puppy 2+4 andere Versionen.
Zudem gibt es ständig Änderungen am xorgwizard.

Ein schwarzer Schirm könnte verursacht werden durch falsche Monitor-Frequenzen.
Ich hatte das kürzlich bei Experimenten mit einer Ati-Karte.
Ich hab dann die Werte für vsync/hsync testweise reduziert in xorg.conf, bis es ging.

Ein Vergleich von xorg.conf von Muppy und Puppy 2 zeigt hier eventuell Unterschiede.

Ich habe ein fast identisches Notebook, T21 mit S3 Savage, P 800 mit 256 MB.
3D läuft mit Software-OpenGL bei Quake2 (original), Quake2-Versionen die GLX nutzen, stürzen ab, oder haben teilweise weisse Texturen und sind so nicht spielbar.
Da die Savage nur 8 MB hat, geht Hardware-Beschleunigung (DRI) auch nur bis max. 1024x768 Punkte, man sieht sonst Fehler (DRI disabled) wegen zuwenig Video-Ram im Xorg.0.log.

Mein internes Display ist inzwischen kaputt, es hatte immer häufiger Aussetzer, die sich Anfangs noch durch Bewegen des Displays beheben liessen.
Inzwischen bleibt der Bildschirm schwarz, und ich nutze dieses Laptop nur noch mit externem Monitor (1400x1050).
Auch ohne DRI bei dieser Auflösung laufen Videos flüssig mit "xv" als Ausgabetreiber für MPlayer.

Daher würde es Dir leider nichts nutzen, wenn ich meine xorg.conf als Vorlage beifügen würde.

Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
vati


Joined: 31 Aug 2006
Posts: 27
Location: Germany

PostPosted: Thu 12 Jun 2008, 19:41    Post subject: muppy xorg S3 Graphics Inc. SavageIX black screen
Subject description: Xorg Vergleich Puppy 2.17.1 Muppy 0083.E
 

Danke Mark für die schnelle Info.
Übrigens habe ich gerade per Zufall Xorg mit 1024x768 mit dem externen Monitor am Laufen. Aber wenn ich den externen Monitor NICHT anschliesse ,habe ich wieder BLACK SCREEN ohne Korrekturmöglichkeit, d.h. ich kann nur elektrisch wieder booten (Strom aus). Kurios, da Puppy Original (jede Version) keine Probleme macht, egal ob mit oder ohne externen Monitor?!
Da ich gern speziell Deine Distribution unter die Leute bringen will, muss ich zunächst selber klar kommen.
Liebe Grüsse von
-Jörg aus Dresden
xorg.puppy.muppy.tar.gz
Description  muppy xorg.conf , puppy xorg.conf, Xorg.0.log Muppy 008.E Standard
gz

 Download 
Filename  xorg.puppy.muppy.tar.gz 
Filesize  12.38 KB 
Downloaded  495 Time(s) 

_________________
Precise Puppy on EEEPC Asus 1005p frugal SD-Card without pupsave
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Thu 12 Jun 2008, 20:05    Post subject:  

Also,
die beiden xorg.conf sind bis auf 1 Zeile identisch:
Load "dri"

Dies ist in Puppy 2 nicht vorhanden.
Es aktiviert die 3D Beschleunigung, die dann auch problemlos weiteraktiviert wird (glx).
Das Log sieht gut aus.
Du könntest die Zeile probehalber mit einem "#" am Anfang deaktivieren.

Zum Vergleich bräuchte ich die Xorg.0.log des nichtlaufenden Systems.
Also starten,und beim schwarzen Bildschirm ausschalten.
Dann landest Du beim Neustart vermutlich in der Konsole.
Hier tippen:

tar -czvf /root/log.tgz /var/log/Xorg.0.log
sync

Das sollte das Log mit den Fehlern packen, sofern es noch auf die Platte geschrieben werden konnte.

Wenn es nix mit DRI zu tun hat, bin ich im Moment ratlos, da beide xorg.conf sonst identisch sind.
Es liegt dann offenbar ein Fehler in Xorg vor, sofern es auch in Puppy 3 auftritt.
Der Unterschied Puppy 3 / Muppy ist eigentlich nur, daß Muppy schon von vornherein DRI-Treiber mitbringt (/usr/X11R7/lib/xorg/modules/dri/savage_dri.so).
In Puppy 3 müsste man die erst als PET (Xorg-DRI) installieren.

Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
vati


Joined: 31 Aug 2006
Posts: 27
Location: Germany

PostPosted: Thu 12 Jun 2008, 21:07    Post subject: muppy xorg S3 Graphics Inc. SavageIX black screen
Subject description: Xorg Black screen Xvesa OK
 

Das müsste dann ein Fehler in Xorg innerhalb Muppy sein, denn soeben bin ich nur mit dem XVESA Videotreiber aktiv, weil ich den externen Monitor 1024x768 TFT abgeklemmt habe. Die Folge war wie gehabt, BLACK SCREEN bis ich die Gelegenheit hatte, auf XVESA umzustellen. Die DRI Zeile hatte ich vorher deaktiviert. Es muss einen versteckten Unterschied zwischen Muppy/Puppy bzgl. Xorg geben?! Ich kann mir jedenfalls keinen Reim darauf machen Confused
Teilen wir die Ratlosigkeit und ich gebe diesbezüglich auf!
Trotzdem Danke für Deine Mühe!
-Jörg
Xorg.0.log.tar.bz2
Description  Xorg Logdatei bei Black Screen
bz2

 Download 
Filename  Xorg.0.log.tar.bz2 
Filesize  7.59 KB 
Downloaded  485 Time(s) 

_________________
Precise Puppy on EEEPC Asus 1005p frugal SD-Card without pupsave
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Thu 12 Jun 2008, 21:14    Post subject:  

Quote:
(II) AIGLX: Loaded and initialized /usr/lib/xorg/modules/dri/savage_dri.so


Das DRI-Modul wird also immer noch geladen.
Du könntest diese Datei mal umbenennen, damit sie nicht gefunden wird.
Sonst bin ich im Moment ratlos.

Ich bin von heute bis Montag offline, kann daher nicht mehr antworten bis dahin.
Wünsche Dir viel Glück...
Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
srbo

Joined: 16 Nov 2007
Posts: 28
Location: Melle, Germany

PostPosted: Fri 13 Jun 2008, 11:34    Post subject: muppy xorg S3 Graphics Inc. SavageIX black screen  

Hallo Jörg,
bitte einmal zu meinem Verständnis:

Unter Puppy 2 und Puppy 4 treten die von Dir beschriebenen Probleme nicht auf.
Hattest Du unter Puppy 3 bzw. Puppy 3.01 ebenfalls Probleme oder hast Du das nicht getestet gehabt?

Mir war bereits aufgefallen, dass ich mit einigen Anwendungen unter Puppy 2.14 bis 2.17 keine Probleme hatte, mit 3.01 und (leider) auch mit Muppy bis zur aktuellen Fassung traten gelegentlich Schwierigkeiten in Bezug auf Graphic Anwendungen auf. Doom stürzte ins Nirvana, Blender3d lief zwar im grafischen Bereich ordentlich, liess sich Aufgrund nicht sichtbarer Buttons nur sehr schwer bedienen.

Stefan
Back to top
View user's profile Send private message 
vati


Joined: 31 Aug 2006
Posts: 27
Location: Germany

PostPosted: Fri 13 Jun 2008, 14:43    Post subject: Re: muppy xorg S3 Graphics Inc. SavageIX black screen  

Hallo Stefan,
srbo wrote:

Hattest Du unter Puppy 3 bzw. Puppy 3.01 ebenfalls Probleme oder hast Du das nicht getestet gehabt?
Ich habe soeben eine frische puppy 3.01 Frugal ohne pup_save.2fs gebootet. Wie erwartet hatte ich mit Xorg keine Probleme.
Ich bestätigte nur, was xorgwizard vorschlägt 1024x768x16 und X startet einwandfrei. Nicht so mit Muppy Confused . Auch ältere Muppys ließen mir nur den XVESA zur Wahl. Ich hatte schon Phantasien, daß es vielleicht mit dem abweichenden Windowsmanager zu tun ICWM statt JWM Confused
Ich weiss es einfach nicht.
Selbst ein Backup der msy_save stellt nicht automatisch den letzten funktionieren Xorg ohne schwarzen Bildschirm wieder her, was ich völlig kurios finde.
Den letzten Xorg-Zugang per Muppy OHNE SCHWARZEN BS habe so erreicht:
Xorg zwar gestartet, aber gleich wieder geschlossen.
mp /etc/X11/xorg.conf
Dort dri mittels # deaktiviert.
Horizontale und vertikale Frequenz von 80 auf 60 geändert.
xwin gestartet und X startete diesmal mit Xorg.
Aber normal ist das ja nicht, oder Confused
Ich sehe keine Regel in diesem Verhalten.
Gruss
-Jörg

_________________
Precise Puppy on EEEPC Asus 1005p frugal SD-Card without pupsave
Back to top
View user's profile Send private message Visit poster's website 
srbo

Joined: 16 Nov 2007
Posts: 28
Location: Melle, Germany

PostPosted: Sun 15 Jun 2008, 09:58    Post subject: muppy xorg S3 Graphics Inc. SavageIX black screen  

Hallo Jörg,
danke für Deine Infos. Vermutlich wird das Problem weniger in Xorg direkt sondern in der PNP Behandlung liegen.

Bin derzeit kräftig am Testen (externer Monitor rein / raus / ein- ausschalten ...) und komme da auf die variantenreichsten Ergebnisse unter Muppy.

Könntest Du vielleicht noch etwas zu den Reihenfolgen schreiben bzw. der Konstellation an welchem Display (externer/interner TFT) zu welchem Zeit- und Betriebspunkt der "Blackscreen" auftrat? Würde mir sehr helfen da etwas Licht ins Dunkel zu bringen. Danke.

Gruß,
Stefan
Back to top
View user's profile Send private message 
vati


Joined: 31 Aug 2006
Posts: 27
Location: Germany

PostPosted: Mon 23 Jun 2008, 05:36    Post subject: Re: muppy xorg S3 Graphics Inc. SavageIX black screen
Subject description: Loesung DRI Modul Deaktivierung
 

Hallo Stefan und Mark,
konnte leider nicht eher antworten Embarassed
Um das Thema mal abzuschliessen, verweise ich auf Marks Lösung:
http://www.murga-linux.com/puppy/viewtopic.php?p=206260#206260
Die Black Screen Ursache ist definitiv diese Zeile in der /etc/X11/xorg.conf:
Code:
Load       "dri"

in der Zeile 25. Ich muss diese manuell auf der Konsole deaktivieren:
mp /etc/X11/xorg.conf
Vorher xorgwizard gestartet und EXIT an der Stelle, wo die Bildschirmauflösung ausgewählt werden kann und die OK - TEST - EXIT Optionen in der Dialogmaske erscheinen.
Nach der Änderung der xorg.conf zu:
#Load "dri"
startet der Xorg Server mittels xwin bei einer Bildschirmauflösung von 800x600.
Das ändere ich manuell wieder in der xorg.conf auf 1024x768.
X Neustart bringt das gewünschte Ergebnis:
Grafikserver Xorg für Muppy mit guter Auflösung ohne Black Screen.
Ich darf also bei meiner Hardware nicht den xorgwizard abschließen, weil OK oder TEST immer mit Black Screen enden ohne Rückkehrmöglichkeit zur Konsole.
Die Ursache bei den HF Frequenzen zu suchen, war für meine Hardware ein Irrtum. Diese Eintragungen konnte ich unverändert so lassen (im Gegensatz zu meinem Beitrag weiter oben).
Die Deaktivierung der DRI Module MUSS auf der Konsole NACH "xorgwizard mit Abbruch" und VOR xwin mittels Konsoleneditor stattfinden. Jeder Start des xorgwizard (auch mit Abbruch) überschreibt die alte xorg.conf , aktiviert die DRI-Module erneut und führt wieder zu Black-Screen nach dem xwin Befehl.
Entschuldige Mark, dass ich Dir genau deshalb, nicht schon vor einer Woche eine positive Rückmeldung geben konnte Embarassed
Danke für eure Suche nach einer Lösung!
Herzliche Grüsse
-Jörg

_________________
Precise Puppy on EEEPC Asus 1005p frugal SD-Card without pupsave
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Mon 23 Jun 2008, 15:54    Post subject:  

Danke für Deine Lösung.

Ich werde wohl etwas wie einen Konolenbefehl "setup" einführen müssen.
Der würde dann Spezialfälle abhandeln, die sich nicht automatisiert lösen lassen.
Ein Menüpunkt wäre zum Beispiel "Grafik-Hardware-Beschleunigung abschalten", was den DRI-Eintrag entfernen würde (ohne xorgwizard zu starten).

Grüße, Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 1 [11 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Für deutschsprachige Anhänger
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0874s ][ Queries: 12 (0.0090s) ][ GZIP on ]