Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 10 Dec 2018, 18:10
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
Which LAMP package to use???
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 3 of 3 [43 Posts]   Goto page: Previous 1, 2, 3
Author Message
growler


Joined: 24 Mar 2008
Posts: 209
Location: Kapiti - New Zealand

PostPosted: Mon 29 Dec 2008, 00:12    Post subject: gd support with 3.01  

I got this php from slackware 12.0 it is possible there is some other slackware package with the php-gd libraries but googling I see there are other folks with slackware that have had issues getting gd going. It was resolved with 12.1
Easiest I reckon to upgrade to 4.1.2 and use the new .pet
Back to top
View user's profile Send private message 
noobie

Joined: 18 Dec 2008
Posts: 11

PostPosted: Mon 29 Dec 2008, 03:08    Post subject:  GD Problem  

Thanks again for your quick response.

Looks like I'll have to wait until 4.xx does a suitable combo of software & hardware for me.

Until then, what would be involved in installing the latest gd into that .sfs file? Would such a thing be possible? Would it help?
Back to top
View user's profile Send private message 
Evil20071


Joined: 07 Jun 2008
Posts: 490
Location: Piedmont, SC,.United States

PostPosted: Mon 29 Dec 2008, 03:14    Post subject: Re: GD Problem  

noobie wrote:
Thanks again for your quick response.

Looks like I'll have to wait until 4.xx does a suitable combo of software & hardware for me.

...


Working on that. It's my #3 project.

1: OOo 3.0.0.pet
2: Puppy Chihuahua
3: Puppy: Web Server Edition
4 and up are non-puppy related.

_________________
TotalElectronics.us
Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger MSN Messenger 
ICQ Number 
growler


Joined: 24 Mar 2008
Posts: 209
Location: Kapiti - New Zealand

PostPosted: Mon 29 Dec 2008, 05:34    Post subject:  

Is 4.1.2 not suitable for your hardware?

The mysql-5.0.067-php-5.2.6-i686.pet makes puppy 4.1.2 into a mysql/php/hiawatha web-server. it includes gd support and all the components are compiled on puppy for puppy.

I have been playing with gray's puppy-NOP and I must say I think xfce/thunar does have some benefits over jwm/rox
Back to top
View user's profile Send private message 
noobie

Joined: 18 Dec 2008
Posts: 11

PostPosted: Mon 29 Dec 2008, 21:32    Post subject:  Hardware support & software mix
Subject description: 3.01 tigerpup rocks
 

I run older kit and the two workstations I use both like tigerpup and the easy compiz setup therein.

I tried 4.1.2 and had there were problems on my gforce 440mx single screen setup.

Dual screen ati 7000ve never works in dual mode so use xp on that one at the mo.

So I've decided to wait and see : )
Back to top
View user's profile Send private message 
growler


Joined: 24 Mar 2008
Posts: 209
Location: Kapiti - New Zealand

PostPosted: Sun 29 Mar 2009, 02:05    Post subject: New LAMP pet  

I've updated all applications in my LAMP pet

now with
mysql 5.1.31
php 5.2.8
hiawatha 6.11
phpMyAdmin 3.1.3.1

see

http://www.puppylinux.org/wiki/how-tos/networking/lamp-vs-plhmp-php-and-mysql-with-hiawatha
Back to top
View user's profile Send private message 
growler


Joined: 24 Mar 2008
Posts: 209
Location: Kapiti - New Zealand

PostPosted: Sat 06 Jun 2009, 22:32    Post subject: Another update  

I recompiled the latest offerings of

Hiawatha - 6.14
mysql -5.1.34
php - 5.2.9
phpMyAdmin - 3.1.5

and made a new .pet

I moved the wiki page explaining the rationale of choices made and the download link to http://www.weberp.org/PuppyLinux
Back to top
View user's profile Send private message 
ottod

Joined: 21 Sep 2006
Posts: 14

PostPosted: Mon 08 Jun 2009, 02:50    Post subject: Where to download?  

Where can I download mysql-5.0.067-php-5.2.6-i686.pet?
This is for Puppy 4.1.2. I know there is a new one with an upgraded Hiawatha but I am interested in this simpler and smaller version but servage.net is "empty".
Back to top
View user's profile Send private message 
growler


Joined: 24 Mar 2008
Posts: 209
Location: Kapiti - New Zealand

PostPosted: Tue 09 Jun 2009, 00:17    Post subject:  

Sadly the servage link files destroyed by some baddie. MU offerred some other space where later files are located. I don't have copies of these old archives which are really superseeded by the later ones anyway.

The mysql-php .pet was only for 4.1 since hiawatha was dropped for 4.2 I have now bundled it in the .pet - even if you are on earlier versions this later version of hiawatha is tiny (around 130k I think) and a drop in the 11 Meg bucket - most of the bundle is mysql. Some of the settings have been tweaked for hiawatha config too following feedback to the wiki page. GD support is now fixed with the jpeg code in too. Innodb table engine also included in mysql. Also this .pet includes phpMyAdmin 3.1.5 which wasn't in the mysql-php pet - and you will want it really anyway.

The saving in space is minimal relative to the advantages explained above by having the full suite of applications in the latest .pet
Back to top
View user's profile Send private message 
aarf

Joined: 30 Aug 2007
Posts: 3613
Location: around the bend

PostPosted: Sat 13 Jun 2009, 06:39    Post subject:  

strange things are happening growler.
installed current pet into 4.2.1.
just the begining:
file://localhost/root/my-documents/

is the url to my-documents in my browsers!
i.e file://localhost/root/ is the browser url to root, my whole computer is accessible in localhost!
this is also occurring when booting other puplets that the current pet was not even installed into!
this is all still occurring even after uninstalling the current pet!

Edit:
Quote:
this is also occurring when booting other puplets that the current pet was not even installed into!
i am not absolutely certain I didnt install to the other puplet during a late night encounter. however the lamp.pet is not in either of the installed pets in the pet manager now.
_________________

ASUS EeePC Flare series 1025C 4x Intel Atom N2800 @ 1.86GHz RAM 2063MB 800x600p ATA 320G
_-¤-_

<º))))><.¸¸.•´¯`•.#.•´¯`•.¸¸. ><((((º>
Back to top
View user's profile Send private message Visit poster's website 
growler


Joined: 24 Mar 2008
Posts: 209
Location: Kapiti - New Zealand

PostPosted: Sat 13 Jun 2009, 18:08    Post subject:  

@aarf - which .pet did you install? I have been working with the hiawatha based LAMP packages. My install using LAMP-6.14-5.1.34-5.2.9.pet

Hiawatha - 6.14
Mysql - 5.1.34
PHP 5.2.9

Certainly doesn't expose /root or /root/my-documents!!

The web-root was compiled as /root/httpd/hiawatha
Back to top
View user's profile Send private message 
aarf

Joined: 30 Aug 2007
Posts: 3613
Location: around the bend

PostPosted: Sat 13 Jun 2009, 21:18    Post subject:  

growler wrote:
@aarf - which .pet did you install? I have been working with the hiawatha based LAMP packages. My install using LAMP-6.14-5.1.34-5.2.9.pet

Hiawatha - 6.14
Mysql - 5.1.34
PHP 5.2.9

Certainly doesn't expose /root or /root/my-documents!!

The web-root was compiled as /root/httpd/hiawatha


i downloadd it from http://dotpups.de/puppy4/dotpups/Internet/LAMP-6.14-5.1.34-5.2.9.pet
however i deleted it so dont have the exact one.it was recent but before your post of : Tue Jun 09, 2009 12:17 am. but after your post of Sat Jun 06, 2009 10:32 pm.
not sure that it is a problem because although
file://localhost/root/my-documents/
will give access,
http://localhost/root/my-documents/
will not.
still find file://localhost/root/my-documents/ as highly unusual as i haven't encountered this before. i am using opera10 beta and that is the url i get when i load files from my-documents.

_________________

ASUS EeePC Flare series 1025C 4x Intel Atom N2800 @ 1.86GHz RAM 2063MB 800x600p ATA 320G
_-¤-_

<º))))><.¸¸.•´¯`•.#.•´¯`•.¸¸. ><((((º>
Back to top
View user's profile Send private message Visit poster's website 
growler


Joined: 24 Mar 2008
Posts: 209
Location: Kapiti - New Zealand

PostPosted: Sat 13 Jun 2009, 22:16    Post subject:  

Quote:

file://localhost/root/my-documents/
will give access,


This is normal with most browsers where you are using the browser as the user root as we do with puppy - this will not work remotely of course since localhost will resolve to the computer you are working on. No problem with any of this.

Quote:

http://localhost/root/my-documents/
will not.

Perfect then .. all good! you are only using hiawatha when you attempt to use http:// .... sounds like hiawatha is working ok.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 3 of 3 [43 Posts]   Goto page: Previous 1, 2, 3
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1570s ][ Queries: 13 (0.0302s) ][ GZIP on ]