Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 30 Jul 2014, 11:35
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Puppy 4 DINGO
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 15 of 17 [248 Posts]   Goto page: Previous 1, 2, 3, ..., 13, 14, 15, 16, 17 Next
Author Message
JustGreg

Joined: 24 May 2005
Posts: 666
Location: Connecticut USA

PostPosted: Mon 16 Jun 2008, 16:23    Post subject:
Subject description: Puppy 4.0 ffmpeg does not do video capture.
 

I have been trying to get web camera on the 2goPC to work. Puppy 4.0 ffmpeg does not support video capture. The version (
Code:
version SVRN-rUNKNOWN
) does not have -vd oprtion and most of the video capture formats. Puppy 3.01 ffmpeg (version SVRN-r79072) works perfectly fine and will do video capture from a web camera.
_________________
Enjoy life, Just Greg
Live Well, Laugh Often, Love Much
Back to top
View user's profile Send private message 
attawan

Joined: 30 Jun 2008
Posts: 2

PostPosted: Mon 30 Jun 2008, 02:59    Post subject: mplayer
Subject description: mplayer doesn't work in puppy 4.0 - solved
 

BarryK wrote:
ttuuxxx wrote:
But then I installed mplayer via petget and it had a missing "divx" file, doesn't say which version or anything useful. So i figure the mplayer full codec pack should fix that, nope still missing "divx" so I figured why not just try mplayer, so I click the icon and it 2 boxes came up, 1 black and 1 white. Then my pc froze, which it never does and I had to press ctrl+Backspace to exitx and then startx to get back,

Actually, it says a missing "xvid" -- but that's a false alarm. That is an incorrect dependency in the packages.txt file. I've fixed it.

I installed Mplayer PET package (the official one from ibiblio), and I also got two empty boxes when I started it from the menu. I hit CTRL-ALT-BACKSPACE to kill X, restarted X, then Mplayer worked. Dunno why.

I had heaps of trouble with Mplayer before, behaving really odd, some of which I documented in my blog. That's why I dumped it in favour of Gxine.


The same problem here....restart X doesn't help....found roundabout:

Just don't use the link in menu, but find mplayershell instead and click on it - works perfect!!! ( in /usr/bin ). Can also drag on desktop to make a link. B.t.w. uses much less CPU then Gxine.
Back to top
View user's profile Send private message 
ledo

Joined: 29 Jun 2008
Posts: 30

PostPosted: Wed 02 Jul 2008, 10:33    Post subject:  

I noticed and i report:

CF to IDE type installation with universall installer doesn't work on my old toshiba laptop with puppy DINGO.

It works like it should for now with version 3.01

When i try to install with DINGO i get usual setup menus but when i press last button yust before installation begins nothing happens.
Back to top
View user's profile Send private message 
gray


Joined: 23 Feb 2007
Posts: 313
Location: Adelaide - South Australia

PostPosted: Sun 06 Jul 2008, 03:02    Post subject: Abiword spell check  

The spell check in Dingo Abiword does not work.

This is because Enchant is not configured correctly. There needs to be a /usr/lib/enchant directory containing an object file that is a gateway to the desired spell checker. Abiword in Dingo has the Ispell dictionary so the libenchant_ispell.so file needs to be in the above directory. Unfortunately there is a bug in enchant regarding where it expects to find the dictionary files - it only looks in the path /usr/share/enchant/ispell as far as I can tell, so I added a symlink for american.hash in there to the usr/share/abiword-2.6/dictionary/LittleEndian32.american.hash file to get it to work.
Dingo_Ispell_fix.pet
Description 
pet

 Download 
Filename  Dingo_Ispell_fix.pet 
Filesize  22.24 KB 
Downloaded  480 Time(s) 
Back to top
View user's profile Send private message 
Sit Heel Speak


Joined: 30 Mar 2006
Posts: 2595
Location: downwind

PostPosted: Tue 08 Jul 2008, 01:52    Post subject:  

Tests of Puppy 4.00 with both kernels, k2.6.25 and k2.6.21.7.

This is on a vintage-2003 dual-Xeon equipped with both UDMA5 (ATA100) and SCSI disks.

Both Dingo versions are frugal installs, each on its own 3.3G partition of a single 10GB UDMA5 disk at sda1 (in k2.6.25) and hda2 (in k2.6.21.7), booted from GRUB installed from k2.6.25 in the default position (root superblock).

Program startup is noticeably snappier under Dingo 4.00 k2.6.21.7 than k2.6.25, even though in theory the SMP-capable k2.6.25 should be faster on this dualie machine.

Five or six problems manifest. Numbers 1 and 2 are show-stoppers:

1. On k2.6.25 (but not on 2.6.21.7), an error, screenshot here, of "Hard link count is wrong" when PFind is started. PFind is thereby unuseable.

e2fsck'ing the .sfs file and fsck'ing the (ext3) sda1 partition it's on (the [e2]fsck'ing was done from Lobster's tmxxine-alpha-4 version of Dingo, running pfix=ram from live-CD) does not cure this "Hard link count is wrong" error. This same problem is seen also with k2.6.25 on another system, a vintage-1999 dual-P3.

2. PETget still takes a lo-oooo-ong time, like three minutes on Dingo k2.6.25 and one minute on k2.6.21.7 (and about 30 seconds on Puppy 2.16CE), to initialize its wget. Yes, wgetrc proxies are configured correctly.

3. Having problems with PNethood (I didn't realize there is a version .063--been away, catching up), so I downloaded the old SMB mounter LinNeighborhood through the PET manager. After getting LinNeighborhood's dependency gtk-1.2.10 (and its own dependencies), LinNeighborhood works OK in both k2.6.25 and k2.6.21.7--except for the conversion error message shown here which appears when a drive on the Win98 machine is mounted in Puppy. Despite the error message, LinNeighborhood does work OK on both kernels.

PNethood displays a similar horde of conversion-error messages when started from the command line.

4. Dingo 4.00-k2.6.25 can't mount .iso image files. k2.6.21.7 can.

5. The problem ttuuxx wrote about in this thread on May 21, concerning file-copying (or moving) to a USB stick formatted vfat, afflicts k2.6.25 but not k2.6.21.7. On k2.6.25 it also afflicts a file moved from across the network, i.e. from a Win98 machine to a local USB stick formatted vfat, i.e.

cp '~/mnt/SUBOTAI/SUBOTAI_D/PUPPY/Puppy 4.00 2.6.21.7 kernel official/boot.images' /mnt/sdc1

gives the error message

cp: preserving permissions for `/mnt/sdc1/boot.images/no_emul.00': Operation not permitted
Failed to copy /root/mnt/SUBOTAI/SUBOTAI_D/PUPPY/Puppy 4.00 2.6.21.7 kernel official/boot.images as /mnt/sdc1/boot.images

on k2.6.25 but this error does not occur on k2.6.21.7. Nevertheless, even on k2.6.25 /boot.images is there on the destination USB stick, with contents.

On to try the alpha of 4.1...
SHS

PS: 6. While I'm at it: expandtarballs.sh on the Puppy 4 Unleashed kit, doesn't work. (sigh...time to learn bash, so I don't need to come here crying for help...) (yeah, I know, I was saying that a year ago too...)

Last edited by Sit Heel Speak on Thu 17 Jul 2008, 22:33; edited 3 times in total
Back to top
View user's profile Send private message 
linuxcbon

Joined: 09 Aug 2007
Posts: 749

PostPosted: Fri 11 Jul 2008, 12:25    Post subject:  

Dingo full disk install with seamonkey, with many many big web sites open at same time, the hard disk gets active and pc freezes. No swap file setup. RAM is 512M.
Back to top
View user's profile Send private message 
tlchost

Joined: 05 Aug 2007
Posts: 1670
Location: Baltimore, Maryland USA

PostPosted: Sat 12 Jul 2008, 03:53    Post subject:  

sixten wrote:

ISO: puppy-4.00-k2.6.21.7-seamonkey.iso

Sound isn't working (intel-hda). l


Same problem with a Dell 5150.

Alsa 1.0.8 in version 3.x works fine.
Back to top
View user's profile Send private message Visit poster's website 
2beta

Joined: 12 Jul 2008
Posts: 7

PostPosted: Sat 12 Jul 2008, 13:11    Post subject:  

ledo wrote:
I noticed and i report:

CF to IDE type installation with universall installer doesn't work on my old toshiba laptop with puppy DINGO.

It works like it should for now with version 3.01

When i try to install with DINGO i get usual setup menus but when i press last button yust before


Same problem as Ledo.

Installation to CF card is impossible with Puppy universall installer
-USB CF adaptater later to IDE,
and
-CF in IDE adapter
are not working.
Back to top
View user's profile Send private message 
Sit Heel Speak


Joined: 30 Mar 2006
Posts: 2595
Location: downwind

PostPosted: Sun 13 Jul 2008, 22:35    Post subject:  

In the k2.6.25 Puppy 4...I get this screen after a failed install of Yoper Linux 3.1-beta to sdd2.

I used GPartEd to wipe both partitions from sdd and put fresh ones on.

Then, rebooted.

Still, Hotpup continues to mistakenly detect that there exists the (nonexistent) sdd3.

Anyone have any idea how I get rid of it? This isn't Boot Manager's fault, I'm not bypassing the checks. Rebooting into Puppy 4 k2.6.21.7, the phantom drive is gone (and the drive is sdb). Rebooting back into k2.6.25, it's back. Turning Hotpup off, restarting X, turning it back on, restarting X again, does not get rid of sdd3.

Side note: Hotpup disk detection (though erroneous) happens in under three seconds in Puppy 4.00 k2.6.25, but it takes several minutes (but shows correct results) in k2.6.21.7.

***EDITED if I turn off "no probing" in the Boot Manager (i.e., yes, do probing), k2.6.21.7 Hotpup produces the drive icons in the same swift 3 seconds as k2.6.25***

Last edited by Sit Heel Speak on Thu 17 Jul 2008, 22:13; edited 1 time in total
Back to top
View user's profile Send private message 
edoc


Joined: 07 Aug 2005
Posts: 4341
Location: Southeast Georgia, USA

PostPosted: Wed 16 Jul 2008, 22:19    Post subject:  

When will 4.1alpha2 be released, please?

Just did a FRUGAL load of Puppy 4.00/Dingo 2.6.21.7 to my Panasonic Toughbook CF-28 with 766MB RAM and 1.95G Swap.

xorg would not work but xvesa did.

GRUB made a nuisance of itself (for a Frugal load) as usual, I ended up with the following successful menu.lst:

Code:
timeout 3
color light-gray/blue black/light-gray
title Puppy Linux 4.00
rootnoverify (hd0,0)
kernel /puppy400/vmlinuz PMEDIA=idehd psubdir=puppy400
initrd /puppy400/initrd.gz


From a cold boot the load of my pup_save file slows things a bit, not certain why.

GXINE (default version 0.5.9) cannot handle a .rm video file. Per a Forum thread elsewhere I tried the mplayer_codecs_full PET without success. drv.so appears to be absent so only the audio is handled. The PET package repository shows an older gxine and a newer one - the newer is flagged as crashing - does that mean that there is no solution short of loading mplayer? (I read on another Forum thread that mplayer has to be booted directly and not from the Menu.)

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send private message Visit poster's website 
edoc


Joined: 07 Aug 2005
Posts: 4341
Location: Southeast Georgia, USA

PostPosted: Thu 17 Jul 2008, 19:41    Post subject:  

Just loaded the realplayer11 PET to a fresh load of Puppy Linux 4.00/Dingo and so far it appears to function flawlessly.

See this thread re realplayer:
http://www.murga-linux.com/puppy/viewtopic.php?search_id=1755233265&t=28022

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send private message Visit poster's website 
edoc


Joined: 07 Aug 2005
Posts: 4341
Location: Southeast Georgia, USA

PostPosted: Sun 20 Jul 2008, 16:59    Post subject: Hardinfo - Devices Broken  

This may have already been reported but in Frugal on my Panasonic CF-28 Hardinfo Devices reports nothing - it doesn't even display categories of hardware.

Summary does but not Devices.

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send private message Visit poster's website 
edoc


Joined: 07 Aug 2005
Posts: 4341
Location: Southeast Georgia, USA

PostPosted: Wed 23 Jul 2008, 22:48    Post subject:  

Don't know what I did ... surely it was not intentional ... but Devices is now working!

New challenge.

When I do a warm reboot my "personal file" loads then is followed by purple text saying that hda1 file integrity is being checked and it takes a while.

Is this normal?

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send private message Visit poster's website 
edoc


Joined: 07 Aug 2005
Posts: 4341
Location: Southeast Georgia, USA

PostPosted: Wed 23 Jul 2008, 22:57    Post subject:  

Don't know what I did ... surely it was not intentional ... but Devices is now working!

New challenge.

When I do a warm reboot my "personal file" loads then is followed by purple text saying that hda1 filesystem check ....... and it takes a while.

Is this normal?

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send private message Visit poster's website 
brucedp


Joined: 17 Jun 2006
Posts: 2

PostPosted: Tue 29 Jul 2008, 03:41    Post subject: Puppy version 4 issues  

Though quite satisfied with Puppy 3.01, I decided to try 4.00
I tried both the released 4.0 version and the experimental version ( puppy-4.00-k2.6.25-seamonkey.iso ) with the newer kernel.

-As already posted, the sound did not work. Both 4.00 versions had sound problems.

-I found the new 4.00 dropped direct support for .pup files. Though an error pop up message states a pet-manager tool has to be installed to install a .pup application file. After the installation, the installed pup app did not work (i.e.: puppy2-xawtv-3.95.pup ).

I suppose support for the experimental version of the 4.00 version was dropped for lack of support and that the newer kernel is to be used in a future Puppy version (it is no longer available for down load off the http://www.puppylinux.org/downloads/official-releases site but still available as a torrent elsewhere). Oddly the http://www.puppylinux.com/download/index.html page still talks about the experimental version (?).

I assume because it had the newer kernel is why the experimental version saw my dual core processor, saw my Intel DG33FB motherboard's integrated (Maxwell) pata channel, and saw the pata/eide hard drive hanging off it. The standard 4.00 and previous versions of Puppy saw did not see them.

IMHO: I am going to revert back to 3.01 . It works without bugs on all PC hardware I have (old to new). I am surprised 4.00 was released, the support team did test it first right?
A big issue for me is lack of applications that now have to use the .pet file format. I assume there is some advantage to switching to .pet but I find it is a hardship to not have all the .pups converted to .pet and tested before thrusting a .pet only version of Puppy out there. Especially when the pet-manager that is supposed to help install pups does not work (not all installed pups work on 4.00 ).
I will wait until a newer version of Puppy has what I need before I'll consider upgrading.
-Bruce
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 15 of 17 [248 Posts]   Goto page: Previous 1, 2, 3, ..., 13, 14, 15, 16, 17 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1009s ][ Queries: 12 (0.0071s) ][ GZIP on ]