Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 20 Oct 2014, 00:48
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Graphics
Pencil animation/drawing software QT4
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 3 [35 Posts]   Goto page: Previous 1, 2, 3 Next
Author Message
swiatmar


Joined: 09 Aug 2008
Posts: 241
Location: Danube, AT

PostPosted: Tue 07 Oct 2008, 18:31    Post subject:  

Wow Smile

pencil is a very nice animation tool. very simple and has everything what I need for simple animation instead flash.

There is only one problem in my pencil. everytime i try to save new animation as .swf the program is crashing. and I am losing everything Sad

Has any one the same problem? and an idea how to fix it?

mar
Back to top
View user's profile Send private message Visit poster's website 
ttuuxxx


Joined: 05 May 2007
Posts: 10821
Location: Ontario Canada,Sydney Australia

PostPosted: Wed 08 Oct 2008, 01:52    Post subject:  

swiatmar wrote:
Wow Smile

pencil is a very nice animation tool. very simple and has everything what I need for simple animation instead flash.

There is only one problem in my pencil. everytime i try to save new animation as .swf the program is crashing. and I am losing everything Sad

Has any one the same problem? and an idea how to fix it?

mar


well we all had that problem, and wasn't able to fix it, I haven't looked at it lately, but I'll try to compile it again when a newer less buggy release is released Smile
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send private message Visit poster's website 
vovchik


Joined: 23 Oct 2006
Posts: 1285
Location: Ukraine

PostPosted: Wed 08 Oct 2008, 06:41    Post subject:  

Dear Puppians,

I compiled the new pencil - 0.4.4.b - on Puppy 3.01 with qt 4.4.1 without problems. Unlike my earlier version, this one started mangling the swf output, doing something wrong in the rendering of bitmaps. I had wanted to install the new version because the former one would not produce sound on my system. After noticing the newly mangled swfs, I installed the latest ming package (libs and executables) from the Slackware 12.0 repo. Still no luck. I think there are bugs in the latest pencil, as ttuuxxx has suggested. We will probably have to wait a bit until they fix them. Apart from that, pencil is indeed a nice program.

With kind regards,
vovchik
Back to top
View user's profile Send private message 
battleshooter


Joined: 14 May 2008
Posts: 1095
Location: Australia

PostPosted: Tue 13 Jul 2010, 02:00    Post subject:  

I'm with everyone, Pencil's awesome, thanks for the pet Ttuuxxx, but I can't seem to use the export movie function. Using it on Quirky. It's no big deal, just thought I'd mention it after playing with it a bit. Fun program!

Battleshooter

_________________
LMMS 1.0.2, Ardour 3.5.389, Kdenlive 0.9.8
Back to top
View user's profile Send private message 
vovchik


Joined: 23 Oct 2006
Posts: 1285
Location: Ukraine

PostPosted: Tue 13 Jul 2010, 16:40    Post subject:  

Dear Puppians,

I seem to recall that I figured out why the new version crashed. Everything was fine when libming was 0.3:

Code:

/usr/lib/libming.so -> libming.so.0
 /usr/lib/libming.so.0 -> libming.so.0.3.0


Things get dicey in pencil with libming.so.1.4.x. When I restored those old libming links, pencil was able to export.

With kind regards,
vovchik
Back to top
View user's profile Send private message 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Sun 15 Aug 2010, 01:20    Post subject:  

Quote:
Qt4 library
http://www.puppylinux.ca/pet4/qt4-4.3.2.pet


Where is this now?
Has pencil been petted for Lucid?

_________________
Puppy WIKI
Back to top
View user's profile Send private message Visit poster's website 
paulhomebus


Joined: 21 Jan 2010
Posts: 120
Location: New Zealand

PostPosted: Sun 15 Aug 2010, 02:43    Post subject:  

It's here....

Pencil for Lupu.... please test!
(includes Ming libs, QT4OpenGL etc, etc)

http://www.4shared.com/file/edSHD6pI/_2__Pencil-04-Lucid.html
Back to top
View user's profile Send private message Visit poster's website AIM Address 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Mon 16 Aug 2010, 00:47    Post subject:  

Quote:
It's here....


many thanks
Where Shocked

How do I run it to test?
pencil from console not working . . .

_________________
Puppy WIKI
Back to top
View user's profile Send private message Visit poster's website 
ttuuxxx


Joined: 05 May 2007
Posts: 10821
Location: Ontario Canada,Sydney Australia

PostPosted: Mon 16 Aug 2010, 03:02    Post subject:  

Lobster wrote:
Quote:
It's here....


many thanks
Where Shocked

How do I run it to test?
pencil from console not working . . .

lobster did you install the qt pet for lucid also? It needs libQtXml.so.4 libQtGui.so.4 libQtCore.so.4
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send private message Visit poster's website 
paulhomebus


Joined: 21 Jan 2010
Posts: 120
Location: New Zealand

PostPosted: Mon 16 Aug 2010, 04:43    Post subject:  

Lobster

You should find it under Graphics > Graphics Processing.

Hope that helps.
Paul

btw - I'll check dependencies on a clean Lupu LIVE-CD...
Back to top
View user's profile Send private message Visit poster's website AIM Address 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Mon 16 Aug 2010, 05:15    Post subject:  

Quote:
lobster did you install the qt pet for lucid also?


No where is that?

Looked here and all the usual places could not find - thought the package was inclusive?
http://puppylinux.org/wikka/LucidPuppyQuickpet

thanks guys Smile

_________________
Puppy WIKI
Back to top
View user's profile Send private message Visit poster's website 
ttuuxxx


Joined: 05 May 2007
Posts: 10821
Location: Ontario Canada,Sydney Australia

PostPosted: Mon 16 Aug 2010, 06:24    Post subject:  

Lobster wrote:
Quote:
lobster did you install the qt pet for lucid also?


No where is that?

Looked here and all the usual places could not find - thought the package was inclusive?
http://puppylinux.org/wikka/LucidPuppyQuickpet

thanks guys Smile


naaa lobster QT is never inclusive in a 1.6MB pet Smile
Barry usually splits up the QT packages, some in the devx and some in another pet package.
The missing files you need you can get from Ubuntu, there are 4 of them
http://mirrors.kernel.org/ubuntu/pool/main/q/qt4-x11/libqtcore4_4.6.2-0ubuntu5_i386.deb

http://mirrors.kernel.org/ubuntu/pool/main/q/qt4-x11/libqtgui4_4.6.2-0ubuntu5_i386.deb

http://mirrors.kernel.org/ubuntu/pool/main/q/qt4-x11/libqt4-xml_4.6.2-0ubuntu5_i386.deb

http://mirrors.kernel.org/ubuntu/pool/main/n/nas/libaudio2_1.9.2-3_i386.deb
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send private message Visit poster's website 
paulhomebus


Joined: 21 Jan 2010
Posts: 120
Location: New Zealand

PostPosted: Mon 16 Aug 2010, 06:41    Post subject:  

Sorry Lobster, yeah my bad, qt4 wasn't included..

This one has....
http://www.4shared.com/file/T1kgosyE/Pencil-04-Lucid.html

7.4Mb tho!

Or just use the QT4 deb's from ttuuxxx with this one.
http://www.4shared.com/file/LPaxiJ8S/Pencil-04-Lucid.html

BTW - all the Pencil's uploaded are v0.4.4b - the latest.
Back to top
View user's profile Send private message Visit poster's website AIM Address 
maans

Joined: 07 Jan 2010
Posts: 83
Location: Denmark

PostPosted: Fri 15 Oct 2010, 10:30    Post subject:  

paulhomebus wrote:
Sorry Lobster, yeah my bad, qt4 wasn't included..
This one has....
http://www.4shared.com/file/T1kgosyE/Pencil-04-Lucid.html
7.4Mb tho!
I realize this is an "old" thread, however with this pet Pencil shuts down abruptly when saving as a flashfile. (Lupo 5.1.0) is there any cure for this?
paulhomebus wrote:
Or just use the QT4 deb's from ttuuxxx with this one.
http://www.4shared.com/file/LPaxiJ8S/Pencil-04-Lucid.htmlBTW - all the Pencil's uploaded are v0.4.4b - the latest.
Would this be the better choice?

Cheers Måns Mårtensson
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 3331
Location: Ontario

PostPosted: Mon 18 Oct 2010, 14:37    Post subject: original qt  

This is ttuxx's original qt

http://puppylinux.ca/tpp/ttuuxxx/programs/compile/qt-4.4.1.pet
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 3 [35 Posts]   Goto page: Previous 1, 2, 3 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Graphics
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0877s ][ Queries: 12 (0.0043s) ][ GZIP on ]