Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 20 Sep 2014, 12:05
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
How to use Canon FB630P parallel scanner?
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [20 Posts]   Goto page: 1, 2 Next
Author Message
Master_wrong

Joined: 19 Mar 2008
Posts: 456

PostPosted: Tue 22 Apr 2008, 10:45    Post subject:  How to use Canon FB630P parallel scanner?  

I saw this website claiming that they can use parallel scanner into linux
such as:
FB320P, FB620P, FB630P, FB330P, N340P, N640P, and N640P ex scanners
75, 150, 300 and 600dpi scan resolutions
Post-scan CCD gain correction (calibration)
Nibble or ECP mode parallel port support
SANE Backend (integrated into main SANE-backends package,

http://canon-fb330p.sourceforge.net/

http://www.buzzard.me.uk/jonathan/scanners.html

http://sourceforge.net/project/showfiles.php?group_id=26508

http://cyberelk.net/tim/data/libieee1284/stable/

I hope this is true as I myself are using it...
anyone can help me install their program (libieee and driver) ?

how they able to create the driver here :
http://canon-fb330p.sourceforge.net/reverse.html


thank you
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6687
Location: lisbon

PostPosted: Tue 22 Apr 2008, 19:35    Post subject:  

Master_wrong,

I think the driver for your scanner is already in the available sane .pet package. Which pupversion are you using? (I'm asking as I think there were some problems with scanners under pup3x, & I think ttuuxxx has recently uploaded a complete sane package for 3x).

Also one thing to check, (for parallel canon scanners), is to open the file /etc/sane.d/dll.conf in a text editor, & remove the comment from the line with #canon_pp.
Back to top
View user's profile Send private message 
ttuuxxx


Joined: 05 May 2007
Posts: 10753
Location: Ontario Canada,Sydney Australia

PostPosted: Tue 22 Apr 2008, 20:21    Post subject:  

first install this http://www.puppylinux.ca/ttuuxxx/programs/office/X-sane-Scanner-v1.0.pet
and try it out. I read that the The beta code from this project was integrated into SANE 1.0.8 (released on 27th May 2002) and development at this end has since stopped. So basically it should be in the package I made up. ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send private message Visit poster's website 
Master_wrong

Joined: 19 Mar 2008
Posts: 456

PostPosted: Thu 24 Apr 2008, 09:22    Post subject:  

Thank you ttuuxxx,muggins, I try edit the file you mentioned with no luck...

my installed pet :
gimp 2.2.15
libgphoto 2.1.6
qt-3.3.8
sane 1.0.18
xsane 0.994
sane backend 1.0.17

I still downloading... slowly at my connection...
do I need anything else to change ?

thank you.
Back to top
View user's profile Send private message 
ttuuxxx


Joined: 05 May 2007
Posts: 10753
Location: Ontario Canada,Sydney Australia

PostPosted: Thu 24 Apr 2008, 10:00    Post subject:  

Hi does this mean you installed my package and it didn't work?
http://www.puppylinux.ca/ttuuxxx/programs/office/X-sane-Scanner-v1.0.pet
sorry but I wasn't sure.
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send private message Visit poster's website 
Master_wrong

Joined: 19 Mar 2008
Posts: 456

PostPosted: Thu 24 Apr 2008, 12:23    Post subject:  

thank you ttuuxxx, I download and install U_scanner pack.zip(pet inside) before i download your pet,
I install your pet, it is installed but not changing anything and the messages "no device available" when i try xsane.... could it because i installed u_scanner pack?
should I uninstall all pet from the u_scanner pack before install your pet?

btw my puppy is 301 seamonkey.
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6687
Location: lisbon

PostPosted: Thu 24 Apr 2008, 22:13    Post subject:  

Master_wrong,

I would uninstall all scanner .pets, then try ttuuxxx's version. I've got a parallel canon N640P scanner so, since your 630 is using the same sane driver, can't see why we can't get it working.

Besides making sure that canon_pp is uncommented in /etc/sane.d/dll.conf, I just remembered another oddity. For some reason the .pet I installed didn't have libsane-canon_pp.so in /usr/lib/sane, do if you also don't have this library file, you can get it here.

Just extract the package to /, and libsane-canon_pp.so will end up in /usr/lib/sane.
Back to top
View user's profile Send private message 
Master_wrong

Joined: 19 Mar 2008
Posts: 456

PostPosted: Fri 23 May 2008, 09:48    Post subject:  

sorry, I tried with no luck here, i've tried the puppy 4 too.

But... I tried teenpup 2008, (I think 214) with kde andd kooka, my FB630P work! after open the file /etc/sane.d/dll.conf in a text editor, & remove the comment from the line with #canon_pp.

the scan quality isn't too bright however...

thank you.
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6687
Location: lisbon

PostPosted: Sat 24 May 2008, 20:24    Post subject:  

With the pupversions where it didn't work, did /usr/lib/sane have the file libsane-canon_pp.so? Regarding brightness, doesn't xsane allow you to alter this?
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6687
Location: lisbon

PostPosted: Sat 24 May 2008, 21:11    Post subject:  

Ok, these are the exact steps I followed to get a canon-640Pex flatbed parallel scanner recognised on pup2.16.

I installed sane_backends-1.0.17.pet

The package manager then generated a message about a missing libgphoto library, & because I was on the .net, the manager then downloaded & installed libgphoto-2.1.6.pet. I then installed xsane-0.991.pet, changed the line, in /etc/sane.d/dll.conf, from #canon_pp to canon_pp, then restarted the window manager.

When I tried running Xsane, it doesn't see my scanner! Download libsane-canon_pp.so package, and extract to /, retry Xsane, & bingo! a working scanner.

The same general procedure should work for you, and any pupversion, with the caveat that the sane version for pup3 was missing substantial elements & it's better to go with the version compiled by ttuuxxx.

N.B. Regarding brightness, on the sane-canon_pp site, they say:

Quote:
Brightness and Contrast
These are not implemented, and probably never will be. These appear to be implemented entirely in software. Use GIMP or
a similar program if you need these features.


And yet when I run xsane, it does have a slider for brightness, and this did brighten the scanned image.
Back to top
View user's profile Send private message 
Master_wrong

Joined: 19 Mar 2008
Posts: 456

PostPosted: Sun 25 May 2008, 12:07    Post subject:  

ok

Thanks muggins.
Back to top
View user's profile Send private message 
Master_wrong

Joined: 19 Mar 2008
Posts: 456

PostPosted: Sat 31 May 2008, 10:57    Post subject:
Subject description: Problem SOLVED
 

thank muggins, I have tried again and FB630p work nicely on puppy 301.
Back to top
View user's profile Send private message 
battleshooter


Joined: 14 May 2008
Posts: 1075
Location: Australia

PostPosted: Mon 04 Aug 2008, 16:59    Post subject:  

Just as a side note, I found I needed sane (used petget) to get Muggins steps to work, which he didn't mention. But other than that, using his instructions my CanoScan N676U works, not flawlessly yet, needs some tweaking, but it works Smile
_________________
LMMS 1.0.2, Ardour 3.5.389, Kdenlive 0.9.8
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6687
Location: lisbon

PostPosted: Mon 04 Aug 2008, 20:39    Post subject:  

Battleshooter,

glad to hear you're scanner is working but, before the Spanish Inquisition arrives at my front door:

Quote:
I installed sane_backends-1.0.17.pet
Back to top
View user's profile Send private message 
battleshooter


Joined: 14 May 2008
Posts: 1075
Location: Australia

PostPosted: Tue 05 Aug 2008, 04:26    Post subject:  

Sorry Muggins the Spanish Inquisition is back Smile

I don't know what it was, but for me, when I installed just the sane_backends-1.0.17.pet it didn't create /etc/sane.d for me, it was only when I installed the individual sane package that I could get my scanner alive. Maybe it was just a odd thing for me, cause no one else reported it.

Sorry to be so seemingly belligerent Embarassed I am appreciative of this walkthrough you put up concerning the scanner

_________________
LMMS 1.0.2, Ardour 3.5.389, Kdenlive 0.9.8
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 2 [20 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0717s ][ Queries: 11 (0.0033s) ][ GZIP on ]