Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 14 Dec 2018, 01:32
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
XFCE 4.4.2 for Puppy 4.0 - Dingo
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 4 [48 Posts]   Goto page: 1, 2, 3, 4 Next
Author Message
JB4x4

Joined: 30 Jul 2006
Posts: 256

PostPosted: Tue 08 Apr 2008, 19:29    Post subject:  XFCE 4.4.2 for Puppy 4.0 - Dingo  

Here is an XFCE pet and sfs for Dingo. This was compiled in Dingo 3.98 beta and will not work in earlier versions of Puppy.

Size:

PET - 21 meg download - 50.4 meg installed
SFS - 17.2 meg download

Added features:

-XFCE Taskmanager is opened when clicking on the CPU graph
-XFCE Battery Monitor (not enabled by default) is included and can be added to the panel
-The mixer was compiled for ALSA support, but should work without
-Locales where extracted for a "slightly" smaller download

Links:

http://www.puppylinux.ca/tpp/jb4x4/XFCE/XFCE-442-Dingo.pet
md5sum: e3cf7cf7454005c20a6a12b56a6465a9 XFCE-442-Dingo.pet

http://www.puppylinux.ca/tpp/jb4x4/XFCE/XFCE-442-Dingo.sfs
md5sum: 710aa8934886de6b56f19e41f4345a30 XFCE-442-Dingo.sfs

http://www.puppylinux.ca/tpp/jb4x4/XFCE/XFCE-442-Dingo-locale.pet

To use, install PET package, exit to prompt, and run "xwin startxfce4"

Additional Plugins:

Clipman:

Clipman allows you to keep several clipboard selections in memory which you can then use to toggle. It can pull the clips from both the default (Ctrl+C) and/or primary (mouse selection) clipboards, prevent an empty clipboard, and restore your clipboard on login.

http://www.puppylinux.ca/tpp/jb4x4/XFCE/xfce4-clipman-plugin-0.8.1-i486.pet

Places:

This plugin is a menu with quick access to folders, documents, and removable media. The places plugin brings much of the functionality of GNOME’s Places menu to Xfce.

http://www.puppylinux.ca/tpp/jb4x4/XFCE/xfce4-places-plugin-1.0.0-i486.pet


Have Fun
JB

Revisions:

20080412 - Added SFS file

Last edited by JB4x4 on Sat 12 Apr 2008, 10:47; edited 4 times in total
Back to top
View user's profile Send private message Yahoo Messenger 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15239
Location: Paradox Realm

PostPosted: Wed 09 Apr 2008, 01:03    Post subject: Re: XFCE 4.4.2 for Puppy 4.0 - Dingo  

JB4x4 wrote:

To use, install PET package, exit to prompt, and run "xwin startxfce4"

Have Fun
JB


Smile Did that - it installed (big download) and seems to be taking about 100MB aprox once unpacked?

before "xwin startxfce4" make sure you reboot Wink

Using xfce now . . .
Working fine - gonna play - many thanks

_________________
YinYana AI Buddhism
Back to top
View user's profile Send private message Visit poster's website 
JB4x4

Joined: 30 Jul 2006
Posts: 256

PostPosted: Wed 09 Apr 2008, 06:29    Post subject:  

Edited original post, 21 meg download, 50.4 meg installed

JB
Back to top
View user's profile Send private message Yahoo Messenger 
floborg


Joined: 25 Oct 2007
Posts: 194
Location: Fort Worth, TX

PostPosted: Wed 09 Apr 2008, 20:38    Post subject:  

Any idea how to get a context menu when right-clicking on the desktop? Xubuntu has this feature.
Back to top
View user's profile Send private message 
Turpin


Joined: 16 May 2007
Posts: 120

PostPosted: Sat 12 Apr 2008, 08:35    Post subject:  

I don't understand. I've tried installing XFCE befoe with different pets and I tried it now with this pet in a fresh Puppy 3.98, and all of those times, I get this same result. It looks exactly the same. Nothing different. Like XFCE isn't even installed. Am I mssing something? Something that isn't covered in this thread? I mean, I installed the pet, it completed successfully. I rebooted. It booted fully into Puppy's default window manager. I shutdown to prompt. I type in xwin startxfce4 and I'm back in Puppy, nothing's changed. Please help. I'm going crazy. Been at this trying to get a good Puppy foundation to build on for a week. I'm not working. Everyone thinks I'm crazy. I take your word that this is easy, but I must be missing some step that everyone else knows about.
Back to top
View user's profile Send private message 
JB4x4

Joined: 30 Jul 2006
Posts: 256

PostPosted: Sat 12 Apr 2008, 09:40    Post subject:  

Well, I guess to start, how are you running your puppy? Full install, Frugal, Live-CD with pupsave file, etc.

One thing, you should not have to reboot after installing the PET.

JB
Back to top
View user's profile Send private message Yahoo Messenger 
Béèm


Joined: 21 Nov 2006
Posts: 11775
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Sat 12 Apr 2008, 10:24    Post subject:  

Would there be a sfs version in the future?
_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send private message 
magerlab

Joined: 08 Jul 2007
Posts: 737

PostPosted: Sat 12 Apr 2008, 10:44    Post subject:  

is it posiible to request for a cut -off version of xfce4 ithpet(or sfs) without locales and with only one or two themes ?
it will save a lot of space and needed themes could be added later
Back to top
View user's profile Send private message 
JB4x4

Joined: 30 Jul 2006
Posts: 256

PostPosted: Sat 12 Apr 2008, 10:45    Post subject:  

@Beem - An SFS is now provided, please see first post. If you could, please test an report back.
Back to top
View user's profile Send private message Yahoo Messenger 
Turpin


Joined: 16 May 2007
Posts: 120

PostPosted: Sat 12 Apr 2008, 13:25    Post subject:  

Sorry, I'm using the DVD to boot with my save sfs files on the hard drive. I'll try that sfs. Do you think the pet may be missing something that the sfs has? I forgot to mention. I didn't install the locales add-on, but I think that's primarily for the clock, based on my experience using NOP, which has XFCE.
Really, isn't there something I might be missing? Has everyone but me using Puppy 3.98 (4 beta) been able to use XCFE from this pet, on a fresh install with no potential dependencies added first? This makes no sense to me. I'm not an idiot, but circumstances have a way of making it seem so.
Back to top
View user's profile Send private message 
JB4x4

Joined: 30 Jul 2006
Posts: 256

PostPosted: Sat 12 Apr 2008, 14:15    Post subject:  

The themes directory only amounted to 800k compressed - 4.7 meg installed. I figured it wasn't much difference.

@Turpin, I'm not sure what to tell you. The SFS contains the same files as the PET, just packaged differently. You should not need any extra dependencies or the locales package. When I test my packages, I boot with "pfix=ram", install the PET, exit to Prompt, and started XFCE with "xwin startxfce4".

Just curious, have you tried booting off of your DVD with the boot code "pfix=ram", and try installing XFCE without creating a savefile.

JB
Back to top
View user's profile Send private message Yahoo Messenger 
Turpin


Joined: 16 May 2007
Posts: 120

PostPosted: Sat 12 Apr 2008, 14:27    Post subject:  

No. haven't tried those things with this particular xfce pet. I was following the instructions that seemed to be working for everyone else. But I'll try that. Thanks for your help.
UPDATE: The sfs file being loaded in my config did the trick. I've exhausted my curiosity and patience or I'd make extra time to figure out what was was wrong with just installing the pet.
Now I finally have a solid brand spanking new foundation to build up something on. Thanks for all the help. And sorry for any aggravation I've caused.
Not to throw this too far off course, but it seems the sfs form of pet distribution works really well. It's saved me on two different occasions including this one.
Back to top
View user's profile Send private message 
Béèm


Joined: 21 Nov 2006
Posts: 11775
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Sat 12 Apr 2008, 17:52    Post subject:  

JB4x4 wrote:
@Beem - An SFS is now provided, please see first post. If you could, please test an report back.
Just downloaded and will try.
_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send private message 
Béèm


Joined: 21 Nov 2006
Posts: 11775
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Sat 12 Apr 2008, 19:05    Post subject:  

Béèm wrote:
JB4x4 wrote:
@Beem - An SFS is now provided, please see first post. If you could, please test an report back.
Just downloaded and will try.
Up and running.
First impressions.
Tips & Tricks is empty.
I get an impression of speed.
I would say SeaMonkey performs quicker then under JWM.
On the other hand, I didn't get a correct IP with the network wizard.
The IP obtained is something like 169.254........ (apipa)
With Pwireless I succeeded to have an IP, so I can go on the internet.
Forgot how to change to a 24 hour clock. Didn't find it in a xfce menu function, so should be done in a jwm file.
I attached OOo 2.4 and that was ok also, altho OOo didn't run very fast, but this is due to OOo itself, I think.
As with beta 1, for ayttm the service types had to be installed first.
This is it so far.

EDIT:
I installed Pidgin and had missing libs.
I found a first set, libxcb-xlib.so (3 files) and downloaded them.
The problem I have now, that I have to transform 2 of the files to links to point to the third one.
I tried to do this in Thunar, but I don't see how it can be done.
Any idea?

EDIT again
OK I had to revert to JWM to do the job of creating symlinks.
Pidgin 2.4 is up and running now in xfce.

Edit once more
As I like realplayer, I installed the RealPlayer 11
(found in additional software)
Installed and worked fine.

Still I would like to know how to create symlink using Thunar.

_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch

Last edited by Béèm on Sun 13 Apr 2008, 05:21; edited 2 times in total
Back to top
View user's profile Send private message 
JB4x4

Joined: 30 Jul 2006
Posts: 256

PostPosted: Sat 12 Apr 2008, 21:08    Post subject:  

@Beem, Thank You for testing!!

I have made a package for the Tips and Tricks. It also adds Fortunes (run "fortunes" from the command line). You can download it here:

http://www.puppylinux.ca/tpp/jb4x4/XFCE/XFCE4-Tips_Fortunes.pet
(1.5 meg)

Speaking of Tips and Tricks.... run the command "xfhelp4" from the command line, and it will open your browser with the XFCE4 manual

JB
Back to top
View user's profile Send private message Yahoo Messenger 
Display posts from previous:   Sort by:   
Page 1 of 4 [48 Posts]   Goto page: 1, 2, 3, 4 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0620s ][ Queries: 12 (0.0097s) ][ GZIP on ]