Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 23 Apr 2014, 20:47
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Trouble installing SCIM m17n in Puppy 3.01
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 39 of 41 [610 Posts]   Goto page: Previous 1, 2, 3, ..., 37, 38, 39, 40, 41 Next
Author Message
levian

Joined: 06 Aug 2009
Posts: 36

PostPosted: Mon 10 Aug 2009, 20:54    Post subject:  

hi Irihapeti,

thanks for the kind reply.

Quote:
http://www.puppylinux.org/wiki/localization/technical-how-tos/setting-puppy-multi-lingual-operation-beginner-friendly-method
http://www.puppylinux.org/wiki/multi-lingual-puppy/technical-how-tos/getting-scim-working-after-its-installed


these are the also among the instructions that i followed, which later resulted to searching for answer through the forum. i still get a Dependency missing for libscim-1.0.so.8 when installing the bridge though. i did include the gtk-2.12.1-xinput package while installing the 3 packages previously.

as for the font installation, i followed the instructions listed in the INSTALL file, n got stuck at the stage 5 - "test". i get "no such file or directory" when typing /usr/X11R6/bin/x1sfonts | grep 'wenquanyi', i repeated the steps twice n still get a "no such file or directory". what did i miss?
font.png
Description 
png

 Download 
Filename  font.png 
Filesize  27.56 KB 
Downloaded  440 Time(s) 
Back to top
View user's profile Send private message Visit poster's website 
Irihapeti
Guest


PostPosted: Tue 11 Aug 2009, 06:37    Post subject:  

levian:

You only need to make sure that the wenquanyi folder is in /usr/share/fonts and then reboot or restart the x-server. At least, that's all I've ever done.

If you got a missing dependency error when installing scim-bridge, check that you are not using a version of scim compiled by someone else. That's the only reason I can think of for the error.
Back to top
levian

Joined: 06 Aug 2009
Posts: 36

PostPosted: Tue 11 Aug 2009, 21:11    Post subject:  

hi Irihapeti,

thanks for the kind reply. i placed my wenquanyi under /usr/share/fonts/wenquanyi/wqy-bitmapfont/. when i opened up geany's font, i can see WenQuanYi Bitmap Song n WenQuanYi Zen Hei, but under the previews are all english ABCs. is that how it is supposed to be?

i downloaded these packages from /members/Irihapeti/

scim-1.4.7-i486.pet
scim-bridge-0.4.15-i486.pet
scim-pinyin-0.5.91-i486.pet
gtk-2.12.1-xinput

i continued n installed the rest of these packages too yesterday,

m17n-db-1.5.1-i486.pet
m17n-lib-1.5.1-i486.pet
scim-tables-0.5.8-i486.pet

n also another chinese localization package from http://dotpups.de/puppy4/dotpups/Localization/Chinese/

zh_e-400.pet

for the bridge error, first i tried - scim-bridge-qt4-p4.pet n received the error of missing library files for: libQtGui.so.4 libQtyCore.so.4. then i tried scim-bridge-0.4.16-i486.pet n received the error of missing dependencies: libscim-1.0.so.8.


updates:
i managed to get it working after reinstalling a fresh copy of puppy. there were still missing dependencies error but so far everything is working fine. i can read n input chinese characters now. thank you so much, Irihapeti!! Very Happy
Back to top
View user's profile Send private message Visit poster's website 
Irihapeti
Guest


PostPosted: Wed 12 Aug 2009, 06:56    Post subject:  

levian:
The missing files when you install scim-bridge-qt4 are in qt4-4.3.4-p2.pet

You will need that package only if you are going to run qt4 applications.

Anyway, I'm glad it's working.
Back to top
levian

Joined: 06 Aug 2009
Posts: 36

PostPosted: Wed 12 Aug 2009, 22:05    Post subject:  

hi Irihapeti,

should i install qt4-4.3.4-p2.pet after it is working now?
i have installed so much packages that it stuck at "If X failed to start, type "xorgwizard" to setup X" error during start up, therefore i ended up reinstalling my puppy instead.

all that is left is having my printer install.
do you happen to know anyone who can help me with it? sorry for so much trouble, i am not literate with linux. most of the time, it is try n error for me. hehe.
Back to top
View user's profile Send private message Visit poster's website 
Irihapeti
Guest


PostPosted: Wed 12 Aug 2009, 22:59    Post subject:  

levian wrote:
hi Irihapeti,

should i install qt4-4.3.4-p2.pet after it is working now?
i have installed so much packages that it stuck at "If X failed to start, type "xorgwizard" to setup X" error during start up, therefore i ended up reinstalling my puppy instead.

all that is left is having my printer install.
do you happen to know anyone who can help me with it? sorry for so much trouble, i am not literate with linux. most of the time, it is try n error for me. hehe.


You only need to install qt4-4.3.4-p2.pet if you are going to be using qt4 programs. If everything is working without it, then I would say that you don't need it.

Printers: sorry, can't really help. You could try leaving a message in the Advanced Topics -> Hardware subforum.

Trial and error is a great way to learn. I knew nothing about Linux two years ago. The number of things I've broken and reinstalled would be huge. Fortunately, Linux makes reinstalling easy (well, much easier than Windows).
Back to top
levian

Joined: 06 Aug 2009
Posts: 36

PostPosted: Wed 12 Aug 2009, 23:23    Post subject:  

hi Irihapeti,

i already posted under the hardware section.
it's true, all it takes is the experience to make us grow accustom to it.
thanks for your assist for the past few days! Very Happy
Back to top
View user's profile Send private message Visit poster's website 
kensuguro

Joined: 21 Aug 2009
Posts: 2

PostPosted: Fri 21 Aug 2009, 01:28    Post subject:  

any hints for scim-anthy on puppy 4.2.1?
I installed everything, and it all seems to be working.
I can call up scim with ctrl-space, and get anthy to show up, actually type and see hiragana.. except, when I press space to convert to kanji, nothing happens. I can also press enter to commit the hiragana..
Is this a known issue?

I've installed:
anthy-9100e
all the gtk+ packages
scim-1.4.7
scim-anthy-1.2.6
scim-bridge-0.4.15

seems it's extremely close to working.. just no kanji.. any help appreciated.
Back to top
View user's profile Send private message 
Irihapeti
Guest


PostPosted: Fri 21 Aug 2009, 04:27    Post subject:  

kensuguro:

You need one more package: gconv4dingo.pet

I knew it was needed for scim-canna in Puppy 4. I didn't realise it was also needed for scim-anthy.

I've updated the new wiki page to include this information.
Back to top
Irihapeti
Guest


PostPosted: Tue 25 Aug 2009, 16:32    Post subject:  

For those who are interested, I've uploaded the latest versions of the m17n database and libraries, plus the anthy server. They are available from the usual download locations.
Back to top
Irihapeti
Guest


PostPosted: Thu 03 Sep 2009, 01:33    Post subject:  

Another addition to the range of input methods for SCIM:

scim-chewing-0.3.3-i486.pet and its associated library, libchewing-0.3.2-i486.pet

These are for Traditional Chinese input.

They are available from puppylinux.asia and should be available from puppylinux.ca in a day or so (Caneri has to move them to the public download area).
Back to top
kjoe

Joined: 25 Jul 2007
Posts: 27
Location: Austria

PostPosted: Fri 25 Sep 2009, 16:32    Post subject: Skype using SCIM? (in puppy 4.30)  

Hello all,
using the SCIM packages in Puppy 4.30 according to the instructions by Irihapeti works perfectly well for most applications (Geany, OpenOffice, Mozilla,...)
I just could not get Skype to use SCIM. Ctrl + Enter does not switch the input method. I've installed:

anthy-9100h-i486
canna-3.7p3-i486
gconv4dingo
gtk+-2.12.1-xinput
libGLU-1.3
libqt4_4.4.3-1
m17n-db-1.5.5-i486
m17n-lib-1.5.5-i486
qt4-4.3.2
qt4-4.3.4-p2
scim-1.4.9-i486
scim-anthy-1.2.6-i486
scim-bridge-0.4.16-i486
scim-bridge-qt4-p4
scim-canna-1.0.1-i486
scim-m17n-0.2.3-i486
scim-pinyin-0.5.91-i486
scim-tables-0.5.9-i486
wxGTK-2.8.8-i486

Am I missing anything?
Has anyone got Skype to work with SCIM?

Any suggestions are welcome - thanks in advance.

kjoe
Back to top
View user's profile Send private message 
Irihapeti
Guest


PostPosted: Fri 25 Sep 2009, 19:43    Post subject:  

There is a set of programs that fall outside of the scope of the Scim GTK and QT modules.

Java programs belong to this group, and I read just the other day that Skype does as well.

I've had no luck in getting Java programs to work with Scim in Puppy, although they do in other Linux distros.

Maybe I need to look at Puppy 4.3 to see if it's now possible.

And, of course, if anyone else knows how to get these non-GTK, non-QT programs working with scim, please let us know.

Edit: Sorry, the problem with Java is still there in Puppy 4.30
Back to top
Aitch


Joined: 04 Apr 2007
Posts: 6825
Location: Chatham, Kent, UK

PostPosted: Sat 26 Sep 2009, 10:24    Post subject:  

Hi Irihapeti

Quote:
And, of course, if anyone else knows how to get these non-GTK, non-QT programs working with scim, please let us know.


Sounds like a job for ttuuxxx, maybe - he enjoys tracking inconsistencies/problems with dependencies/libs down

btw, nice avatar; what is it saying, in what language?

Aitch Smile
Back to top
View user's profile Send private message 
kjoe

Joined: 25 Jul 2007
Posts: 27
Location: Austria

PostPosted: Sat 26 Sep 2009, 14:30    Post subject:  

Hi Irihapeti,
thank you for your quick response. I always thought, that Skype was a QT-based program, because the actual Linux version requires Qt 4.2.1+.

So I tried to find a solution and at least found it. There was a missing package "scim-bridge-client-qt4". I downloaded it from debian server:

http://ftp.ie.debian.org/debian/pool/main/s/scim-bridge/scim-bridge-client-qt4_0.4.14-1_i386.deb

I am really excited. Although its working in Skype now, it still does not in Java (tested using jedit).

kjoe
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 39 of 41 [610 Posts]   Goto page: Previous 1, 2, 3, ..., 37, 38, 39, 40, 41 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0803s ][ Queries: 12 (0.0138s) ][ GZIP on ]