Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 27 Nov 2014, 05:43
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Sylpheed 2.4.8 with GPG-signatures
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Tue 08 Apr 2008, 04:23    Post_subject:  Sylpheed 2.4.8 with GPG-signatures  

Compiled in Muppy 008.3 (Puppy 3.0.1 with addons).

Compiled-in features: IPv6 iconv GnuPG OpenSSL GtkSpell

GnuPG lets you encrypt your mails.
When you create a new mail, you have checkboxes to activate this.

What GPG-Keys are and such?
Learn more by reading HowTos:
Deutsch · English · Español · Français · Italiano
http://www.gnupg.org/documentation/howtos.en.html

Download:
http://dotpups.de/puppy3/dotpups/Internet/Sylpheed-2.4.8-GPG/

mirror:

http://puppyfiles.ca/dotpupsde/puppy3/dotpups/Internet/Sylpheed-2.4.8-GPG/

The DOC packages are not needed.
The DEV packages are not needed.
The NLS packages are needed only, if you use another language than english.

If your Puppy has no GtkSpell, install it with PetGet, or from:
http://puppyfiles.ca/dotpupsde/dotpups/Office/sylpheed-2.2.6/
There is a version with the required Library only,
one with english dictionary in addition,
and one with german dictionary in addition.

Mark

_________________
my recommended links
Back to top
View user's profile Send_private_message Visit_website 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Tue 08 Apr 2008, 05:26    Post_subject:  

Triggered by a discussion I have. And somewhat Off Track.
Is it useful to have GnuPG in a newsreader?
If yes, what is the rationale for this?

_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send_private_message 
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Tue 08 Apr 2008, 05:35    Post_subject:  

sorry, can't help you, Bernard.
I have not read the HowTos yet Laughing
GPG always was too complicated for me Embarassed
I just made these packages, because I wanted to upgrade Sylpheed for Muppy, and had requests for better encryption support in Muppy.
So this time I compiled GPG, too.

I hope, someone has can give you a more informative answer.

Mark

_________________
my recommended links
Back to top
View user's profile Send_private_message Visit_website 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Tue 08 Apr 2008, 05:38    Post_subject:  

No problemo Mark.
I did read a bit in the GnuPG site, but still don't see very much the utility to use it. Maybe for mail.
Bernard

_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send_private_message 
DreamsToGo


Joined: 27 Jan 2006
Posts: 117
Location: Castelnaudary, south France, World Capital of Cassoulet

PostPosted: Fri 30 May 2008, 11:36    Post_subject:  

Mark, I installed the Sylpheed 2.4.8 .pet, rebooted Puppy and when I start Sylpheed, I'm still in 2.4.7.

I am using Puppy 4 official.

I notice that I now have two Sylpheed entries in the menu, but they both start version 2.4.7.

Any ideas?
Back to top
View user's profile Send_private_message 
Henry

Joined: 29 Jul 2006
Posts: 829
Location: Oregon USA

PostPosted: Sun 01 Feb 2009, 12:36    Post_subject: Re: Sylpheed 2.4.8 with GPG-signatures  

Quote:
GnuPG lets you encrypt your mails.
When you create a new mail, you have checkboxes to activate this.

What GPG-Keys are and such?
Learn more by reading HowTos:
Deutsch · English · Español · Français · Italiano
http://www.gnupg.org/documentation/howtos.en.html

Download:
http://dotpups.de/puppy3/dotpups/Internet/Sylpheed-2.4.8-GPG/


Mark, thanks for this. Sylpheed is excellent, but has been usually compiled for puppy without gnupg. This meant I had to decrypt incoming shopping cart orders by CLI gnupg.

However, these orders are inline so an additional step is required in Sylpheed to decrypt them. One has to create an "Action" thus:
Decrypt: * gpg --no-tty --command-fd 0 --passphrase-fd 0 --decrypt %p |

Then to decrypt: Tools|Actions|Decrypt and enter the passphrase.
Reference: http://home.subnet.at/~max/mail/sylpheed.php
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0548s ][ Queries: 11 (0.0036s) ][ GZIP on ]