Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Oct 2014, 17:48
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Cannot install 400alpha7 in Toshiba Portege 7010CT [SOLVED]
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
bde

Joined: 29 Mar 2008
Posts: 25

PostPosted: Tue 01 Apr 2008, 22:18    Post_subject:  Cannot install 400alpha7 in Toshiba Portege 7010CT [SOLVED]  

Using FreeDOS boot disk, I successfully booted to X using puppy-400alpha7-397-k2.6.21.7-seamonkey. What I did not succeed was installing on /dev/hda1. Briefly, I don't have MS Windows (wiped NT out). Wiped it clean using DBAN. Used a FreeDOS bootfloppy to boot. I have an IDE hard disk (/dev/hda) and an USB DVD-ROM to put the puppy CDROM (that comes out as C drive when FreeDOS is booted). The RAM size is 96 M. I also have linld on the floppy (A). I went to C drive, and issued the command:
Quote:
a:\linld image=vmlinuz initrd=initrd.gz "cl=root=/var/ram pfix=noram,nox"


This booted to shell environment. Ran xorgwizard, chose 1024x768x24 mode. After coming back to shell environment, ran xwin that loaded the X successfully. The responsiveness in X was exceptionally good, and was very surprised knowing that I only have 96 M of RAM.

The next thing was installing on ide internal harddisk. Ran Menu/Setup/Puppy universal installer. This led me to gparted. Created /dev/hda1 as main disk (ext3, boot flag), and /dev/hda2 (256 M size) as linux-swap disk and completed the partition by applying it. fdisk -l command shows all these two partitions from command shell. Rebooted the computer to make sure that the hard disk partitions were read back. Next, ran Menu/Setup/Puppy universal installer again, chose internal (IDE or SATA) hard drive on first screen, OKed hda selected, saw "Puppy Universal Installer" window with Install Puppy to hda1 choice on the top part. I clicked on the icon for this hda1 install, confirmed the install in the next window [You have chosen to install Puppy to partition /dev/hda1, which has a ext3 filesystem and the size is etc. etc... ] by pressing OK. But, nothing happended after that.

To troubleshoot, I next opened a command shell, issued command puppyinstaller, chose Internal (IDE or SATA) hard drive on first screen, chose hda again from the next screen. At this point found the error message in the command shell:
Quote:
ls: cannot access /mnt/hda1/pup_[0-9][0-9][0-9].sfs: No such file or directory


Next, clicked icon next to Install Puppy to hda1 in the next screen on the top (Puppy Universal Installer), confirmed install on /dev/hda1 in the following screen, and found the same error message again in the command shell as above. And, the puppyinstaller exited.

So, it was unsuccessful. I tried a few more things to install puppy on /dev/hda1 without success. Don't know how to get around the access error. Don't want to do frugal install, but a full install on hard disk. Would appreciate any help very much.

Edited_time_total
Back to top
View user's profile Send_private_message 
Bruce B


Joined: 18 May 2005
Posts: 11130
Location: The Peoples Republic of California

PostPosted: Tue 01 Apr 2008, 23:11    Post_subject:  

Sounds like you know what you do.

I've not played with Dingo at all. As I'm sure you know it's a testing release.

I think, but I'm not sure, based on something I maybe read or dreamed that Dingo doesn't have /dev/hd?? devices.

That what would have been an hd* device is now an sd* device.

Example

replace /dev/hda1 with maybe /dev/sda1

Most important - if you can look in the /dev directory and see if there are any /dev/hd*, if so than it didn't switch to only sd* devices.

Hoping I helped more than harmed, as you already know more about Dingo than I do :)
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9203
Location: Stratford, Ontario

PostPosted: Wed 02 Apr 2008, 02:03    Post_subject:  

You might want to go over to the Bugs section and read the Dingo Alpha 7 thread at the top. It contains a discussion about bugs in the Universal Installer that sounds like your problem. BarryK also supplies a patch.
Back to top
View user's profile Send_private_message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Wed 02 Apr 2008, 02:18    Post_subject:  

Yes, the bug you describe was fixed. Now, I can't recall if it was before or after the release of alpha7 -- must have been after. I have probably mentioned it on my developer news page http://www/puppylinux.com/blog or in the alpha7 feedback thread in the bugs section of this forum.
_________________
http://bkhome.org/news/
Back to top
View user's profile Send_private_message Visit_website 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Wed 02 Apr 2008, 03:38    Post_subject:  

As of alpha 7 ide drives are hd* again and not sd*
Maybe the bug has to do with some scripts not adapted for this.

_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send_private_message 
bde

Joined: 29 Mar 2008
Posts: 25

PostPosted: Wed 02 Apr 2008, 22:09    Post_subject:  Finally successful installing on internal ide hard disk
Sub_title: on /dev/hda2 in Toshiba Portege 7010CT with 96 M RAM
 

I have finally been successful following your advice. Thank you all for your input. I repartitioned and reformatted hard disk (/dev/hda) having linux-swap, /dev/hda2 (boot) and /dev/hda3 with the later two formatted as ext3. Next, edited /usr/sbin/puppyinstaller using an editor (e3vi), went to line 1138 and added idehd and satahd as mentioned in http://www.puppylinux.com/news/news400a7-400b.htm under "Full hard drive install fixed." Installed grub in /dev/hda. After rebooting, had to do Ctrl-C. Ran xorgwizard and xwin. Shutting down from xwindows and rebooting to xwindows are now hasslefree. Another computer converted from Windows NT to Linux.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0607s ][ Queries: 11 (0.0067s) ][ GZIP on ]