Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 01 Aug 2014, 10:12
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
TEENpup 2008 Problem Booting
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [6 Posts]  
Author Message
Hawkeye_52

Joined: 25 Mar 2008
Posts: 2

PostPosted: Tue 25 Mar 2008, 06:04    Post subject:  TEENpup 2008 Problem Booting
Subject description: hangs up with error message while booting
 

Hi,

I am trying to get a feel for TEENpup 2008, but can not get it to load.

I got a good download (MD5 checked out). I burned my copy at the lowest allowable speed of 16x on an HP Lightscribe CD.

My computer is a new HP Slimline with an Athlon Dual Core 64 bit processor using 2 GB of ram. My video processor is an nVidia GeForce 6150SE with 512 MB of ram. My hard drive has 500 GB, with a 3 GB swap and an / directory and home directory of approximately equal amounts taking up the rest of the space. I have a CD/DVD burner with Lightscribe capabilities.

Hoping that I have provided enough information, when I try to boot TEENpup, I get an error message: 'cannot find Puppy on idecd boot media'. Since I am not sure what the files should look like on a Puppy live CD, I don't know how to try and solve this one on my own.

Any help would be appreciated....

Hawkeye

P. S.

The files on the CD are:

boot.cat = 2.0 KB
boot.msg = 957 B
initrd.gz = 1.2 MB
isolinux.bin = 10.4 KB
isolinux.cfg = 141 B
pup_214.sfs = 478.7 MB
vmlinuz = 1.7 MB
zdrv_214.sfs = 16.9 MB

TOTAL = 498.5 MB

Does it look as if I am missing something, or that one of the files might be corrupted? I am trying to get this to work for my grand-niece (teenager) who will be running it on a 'legacy' 386 machine, but I wanted to be able to take it for a test drive and familiarize myself with the way it works, so I could help her get up and running.

Again, any help would be appreciated....
Back to top
View user's profile Send private message 
john biles


Joined: 17 Sep 2006
Posts: 1401
Location: Australia

PostPosted: Wed 26 Mar 2008, 17:32    Post subject:  

Hello Hawkeye_52,
Normally I burn all my Linux iso's to CD at 4x
Have you tried to bootup TEENpup on another PC?
Do other versions of Linux bootup on your PC?

I have 5 test PC's I use to test TEENpup 2008 ranging from a Pentium III 350mhz PC to a duo core 1.7ghz laptop and they all work?

Can anyone help Hawkeye_52

_________________
Legacy OS 2.1 LTS Released! Install me on a new! EXT2 Partition with 500Mb of swap and I'll be happy. Razz
Legacy OS 4 Released! Install to newer legacy hardware / early EeePC's Very Happy
Back to top
View user's profile Send private message Visit poster's website 
HairyWill


Joined: 26 May 2006
Posts: 2949
Location: Southampton, UK

PostPosted: Wed 26 Mar 2008, 18:32    Post subject: Re: TEENpup 2008 Problem Booting
Subject description: hangs up with error message while booting
 

Hawkeye_52 wrote:
I am trying to get this to work for my grand-niece (teenager) who will be running it on a 'legacy' 386 machine
Give up now. You will not get it to work on a 386, flat.

Getting TeenPup to boot on your machine might be solvable. While TeenPup has got a shed load of great applications it is based on a fairly old puppy core. Recent developments in puppy have included better compatibility for newer hardware. For a while SATA disks were a problem. You might want to test the disk in a different machine and investigate the bootparms here
http://puppylinux.org/wikka/BootParms

_________________
Will
contribute: community website, screenshots, puplets, wiki, rss
Back to top
View user's profile Send private message 
cthisbear

Joined: 29 Jan 2006
Posts: 3399
Location: Sydney Australia

PostPosted: Wed 26 Mar 2008, 18:36    Post subject:  

Type in some of these commands or the lot.

As soon as you type p the boot will stop until you hit enter.

Puppy has problems with booting on certain laptops and desktops.
Hardware issues....like the old days when you had to keep 4 or 5 different
spanners...because the tolerance of the nuts were different....
so you had to be careful or you could strip your nuts.
Painful!

A Rudypup download would be interesting to see if Puppy worked.
Rudy has special commands.
Compaq can be a dog, some HP and Sony Vaio laptops, and other
brands refuse to boot with some Puppy versions.
Irritating....but not always in our control.

Rudypup Commands.
Type puppy only once....then the commands default of Rudy Puppy.
Add a space between commands.

EG: puppy acpi=strict acpi=noirq pci=biosirq etc etc.

puppy acpi=strict
acpi=noirq
pci=biosirq
pci=nosort
irqpoll routeirq
display boot.msg
prompt 1
label puppy
kernel vmlinuz
append root=/dev/ram0 initrd=initrd.gz loglevel=3 PMEDIA=idecd
timeout 50

Other commands:

puppy pnpbios=off
puppy ide1=0x180,0x386 nopcmcia acpi=off
apci=on /=off =/force
apci=force

////////////////////////////////
I really wish all the developers would have a problem boot option
in their versions with all the commands built in....
say( puppy solve=boot ).
Preferably with no typing for this last one...Hit Tab or something.

If we can get people to the desktop, then the hope is that
the majority will stay on.

Like getting in a great new car and it refuses to start.

All the time in the world spent on fonts...looks...apps...function is wasted.
Of course I know that hardware providers are the issue.
No criticism of your great work otherwise John.
I posted the install fix on your Teenpup 2008 review.....
which someone kindly posted to the forum.

Surely this issue can be fixed for future Puppies.
Sage has his SCSI theme....and this is mine.
I love to stir him up...but once again it needs a fix.

Get more people to the desktop....more people that may help with answers.

Reegards to all.......Chris.
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 8938
Location: Stratford, Ontario

PostPosted: Wed 26 Mar 2008, 18:45    Post subject:  

Since this is a new machine, the optical drive may be SATA. This would explain why Puppy cannot find itself on "idecd". The easiest workaround is to get a flash drive and copy the four core files off the CD - vmlinuz, initrd.gz, pupxxx.sfs and zdrvxxx.sfs. Then boot again off the CD. At the short initial pause, type:

puppy PMEDIA=usbflash

Puppy should launch off the flash drive. Your "legacy" 386 probably has about 4 MB of memory. Don't bother trying.
Back to top
View user's profile Send private message 
Hawkeye_52

Joined: 25 Mar 2008
Posts: 2

PostPosted: Thu 27 Mar 2008, 11:07    Post subject: TEENpup 2008 Problem Booting  

Thanks for all your helpful responses. I had continued to 'fiddle' around with the boot options to see if I could get it to go on my machine. I believe it may have something to do with what 'rcrsn51' mentioned about a SATA drive. We have 3 fairly new computers at home, my wife has a little bit older HP desktop running XP with a wireless USB stub; TEENpup booted right up on hers, but I couldn't connect to the internet Embarassed . My desktop -- you've read my woes already; no love on that one. I also have a new HP laptop; got 'kernel panic' with that one.

If anyone is interested in the hardware specifics on either of my 'problem' machines, let me know. This spin of the Puppy distro has such promise, I want to keep watching to see if the updates will serve my machines better. It may say 'TEENpup' but it looks like a very nice general use distro.

I hear and understand 'HairyWill', and will give up that idea now. At the price of used computers, I can pick something up a little newer dirt cheap, and still give her a great Linux introduction.

Thanks again, everyone. I will be following Puppy and its forums regularly. It seems like a great community....

Hawkeye
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [6 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0707s ][ Queries: 11 (0.0126s) ][ GZIP on ]